Table of Contents

1 INTRODUCTION ......................................................................................................... 5
   1.1 About this Document ........................................................................................... 5
      1.1.1 Description of the Contents .......................................................................... 5
      1.1.2 List of Revisions ......................................................................................... 6
      1.1.3 Conventions in this Manual .......................................................................... 7
      1.1.4 Reference to Devices, Firmware and Software Versions ............................... 8
   1.2 Documentation Overview ..................................................................................... 9
      1.2.1 Basic documents .......................................................................................... 9
      1.2.2 Protocol-specific Documents ..................................................................... 10
      1.2.3 Online Help ............................................................................................... 12
   1.3 Legal Notes ......................................................................................................... 13
   1.4 Registered Trademarks ....................................................................................... 16

2 DESCRIPTION ........................................................................................................... 17

3 REQUIREMENTS FOR CONFIGURING THE NETHOST ........................................ 18
   3.1 Required Software ............................................................................................ 18
   3.2 System Requirements PC/Notebook .................................................................... 21

4 GETTING STARTED .................................................................................................. 22

5 ASSIGNING TEMPORARY IP ADDRESS TO NETHOST DEVICE .......................... 24
   5.1 Prerequisites ..................................................................................................... 24
   5.2 Step-By-Step Instructions ................................................................................. 25

6 NHST-T100-EN: DOWNLOADING FIRMWARE TO THE DEVICE WITH SYCON.NET ............................................................................................................. 27
   6.1 Prerequisites ..................................................................................................... 27
   6.2 Step-By-Step Instructions ................................................................................. 28
   6.3 Ordering and Downloading License to NHST-T100-EN with SYCON.net ............ 36
      6.3.1 Prerequisites ............................................................................................. 36
      6.3.2 Instructions ............................................................................................... 36

7 CONFIGURING THE NETHOST STEP-BY-STEP .................................................... 49
   7.1 Overview ........................................................................................................... 49
   7.2 Configuring netHOST for Fieldbus Systems with SYCON.net: NHST-T100-DP/DPM Example .................................................................................................................. 49
      7.2.1 Prerequisites ............................................................................................. 49
      7.2.2 Step-By-Step Instructions ........................................................................... 50
   7.3 Configuring netHOST for RTE Systems with SYCON.net: NHST-T100-EN/PNM Example .................................................................................................................. 64
      7.3.1 Prerequisites ............................................................................................. 64
      7.3.2 Step-By-Step Instructions ........................................................................... 64

8 TESTING COMMUNICATION STEP-BY-STEP ........................................................ 80
   8.1 Testing Communication of netHOST for Fieldbus: NHST-T100-DP/DPM Example 80
      8.1.1 Prerequisites ............................................................................................. 80
8.1.2 Step-By-Step Instructions ................................................................. 80
8.2 Testing Communication of netHOST for RTE Systems: NHST-T100-EN/PNM Example ......................................................... 86
   8.2.1 Prerequisites .................................................................................. 86
   8.2.2 Step-By-Step Instructions ................................................................. 86

9 IMPORTING DEVICE DESCRIPTION FILES INTO SYCON.NET ...................... 95

10 UPDATING FIRMWARE WITH SYCON.NET .................................................. 96
   10.1 Overview ......................................................................................... 96
   10.2 Prerequisites for Updating Firmware with SYCON.net ..................... 96
   10.3 Step-By-Step Instructions for Updating Firmware with SYCON.net .... 97

11 USING SD MEMORY CARD TO COPY CONFIGURATION DATA INTO SPARE NETHOST DEVICES ......................................................... 103
   11.1 Overview ......................................................................................... 103
   11.2 Prerequisites ................................................................................... 103
   11.3 Step-By-Step Instructions ................................................................. 103

12 DESCRIPTION OF THE NETHOST DTM ...................................................... 108
   12.1 Overview ......................................................................................... 108
   12.2 Description of the GUI ..................................................................... 108
   12.3 Dialog Windows of the “Settings” Group .......................................... 112
      12.3.1 Overview ................................................................................... 112
      12.3.2 Driver Dialog Window ............................................................... 113
      12.3.3 netX Driver Dialog Window ...................................................... 114
      12.3.4 Device Assignment Dialog Window ......................................... 116
   12.4 Dialog Windows of the “Configuration” Group .................................... 118
      12.4.1 Overview ................................................................................... 118
      12.4.2 Settings Dialog Window ............................................................ 119
      12.4.3 Memory Card Management Dialog Window ................................ 121
      12.4.4 Licensing Dialog Window .......................................................... 123
   12.5 Windows of the “Diagnosis” Group .................................................... 124
      12.5.1 Overview ................................................................................... 124
      12.5.2 General Diagnosis Window ....................................................... 125
      12.5.3 Firmware Diagnosis Window .................................................... 127
   12.6 Establishing Online Connection ....................................................... 128

13 BRIEF INSTRUCTIONS FOR CONFIGURING NETHOST MASTER DEVICES ... 130
   13.1 netHOST as Master for Fieldbus Systems ............................................. 130
      13.1.1 CANopen Master: NHST-T100-CO/COM .................................... 130
      13.1.2 DeviceNet Master: NHST-T100-DN/DNM ................................... 131
      13.1.3 PROFIBUS DP Master: NHST-T100-DP/DPM .............................. 132
   13.2 netHOST as Master for Real-Time Ethernet Systems .......................... 133
      13.2.1 EtherCAT Master: NHST-T100-EN/ECM .................................... 133
      13.2.2 EtherNet/IP Scanner: NHST-T100-EN/EIM ............................... 134
      13.2.3 PROFINET IO Controller: NHST-T100-EN/PNM ...................... 135

14 ERROR CODES ........................................................................................... 136
   14.1 Error Code Definitions ...................................................................... 136
<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>14.2</td>
<td>Overview Error Codes</td>
<td>137</td>
</tr>
<tr>
<td>14.3</td>
<td>General Hardware Error Codes</td>
<td>138</td>
</tr>
<tr>
<td>14.3.1</td>
<td>RCX General Task Errors</td>
<td>138</td>
</tr>
<tr>
<td>14.3.2</td>
<td>RCX Common Status &amp; Errors Codes</td>
<td>139</td>
</tr>
<tr>
<td>14.3.3</td>
<td>RCX Status &amp; Error Codes</td>
<td>140</td>
</tr>
<tr>
<td>14.4</td>
<td>ODM Error Codes</td>
<td>141</td>
</tr>
<tr>
<td>14.4.1</td>
<td>General ODM Error Codes</td>
<td>141</td>
</tr>
<tr>
<td>14.4.2</td>
<td>General ODM Driver Error Codes</td>
<td>142</td>
</tr>
<tr>
<td>14.4.3</td>
<td>cifX Driver Specific ODM Error Codes</td>
<td>143</td>
</tr>
<tr>
<td>14.5</td>
<td>Error Codes cifX Device Driver and netX Driver</td>
<td>146</td>
</tr>
<tr>
<td>14.5.1</td>
<td>Generic Error Codes</td>
<td>146</td>
</tr>
<tr>
<td>14.5.2</td>
<td>Generic Driver Error Codes</td>
<td>147</td>
</tr>
<tr>
<td>14.5.3</td>
<td>Generic Device Error Codes</td>
<td>148</td>
</tr>
<tr>
<td>14.6</td>
<td>Error Codes netX Driver</td>
<td>149</td>
</tr>
<tr>
<td>14.6.1</td>
<td>CIFX API Transport Error Codes</td>
<td>149</td>
</tr>
<tr>
<td>14.6.2</td>
<td>CIFX API Transport Header State Error Codes</td>
<td>149</td>
</tr>
<tr>
<td>14.7</td>
<td>ODM Error Codes DBM V4</td>
<td>150</td>
</tr>
</tbody>
</table>

15 APPENDIX | 155  |
| 15.1    | User Rights for the netHOST DTM | 155  |
| 15.2    | List of Figures | 156  |
| 15.3    | List of Tables | 159  |
| 15.4    | Contacts | 160  |
1 Introduction

1.1 About this Document

1.1.1 Description of the Contents

This Operating Instruction Manual describes how to use the SYCON.net configuration software installed on a Windows PC to configure the following LAN controlled netHOST devices as master devices in the corresponding Fieldbus or Real-Time Ethernet system:

- **NHST-T100-DP/DPM** for PROFIBUS DP (order no.: 1890.410/DPM)
- **NHST-T100-CO/COM** for CANopen (order no.: 1890.500/COM)
- **NHST-T100-DN/DNM** for DeviceNet (order no.: 1890.510/DNM)
- **NHST-T100-EN/PNM** for PROFINET IO (order no.: 1890.840/PNM)
- **NHST-T100-EN/ECM** for EtherCAT (order no.: 1890.110/ECM)
- **NHST-T100-EN/EIM** for EtherNet/IP (order no.: 1890.820/EIM)
- **NHST-T100-EN** for PROFINET IO, EtherCAT or EtherNet/IP (order no.: 1890.800; hardware and performance are identical to the NHST-T100-EN/PNM/ECM/EIM devices, but firmware has to be loaded into the device by the customer)

This document provides step-by-step instructions for configuring a netHOST, using the **NHST-T100-DP/DPM** (PROFIBUS DP Master) and the **NHST-T100-EN/PNM** (PROFINET IO Controller) devices as examples. Here, you will also find descriptions of the graphical user interface and the dialog windows of the netHOST Device Type Manager (netHOST-DTM), which is used in SYCON.net to configure and diagnose a netHOST device.

If you are using the **NHST-T100-EN** (which is shipped without pre-installed firmware), you will here find instructions on how to install the firmware with SYCON.net.

The testing of reading and writing of Fieldbus or Real-Time Ethernet data via the netHOST is also described in this document. For this, the netHOST Device Test Application running on a Windows PC is being used.

How to update firmware and how to use an SD Memory Card to copy configuration data of the netHOST is also described here.
### 1.1.2 List of Revisions

<table>
<thead>
<tr>
<th>Index</th>
<th>Date</th>
<th>Chapter</th>
<th>Revisions</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2013-08-05</td>
<td>All</td>
<td>Created</td>
</tr>
<tr>
<td>2</td>
<td>2014-12-05</td>
<td>Title</td>
<td>Title of document changed from &quot;Configuration of Fieldbus Devices with Remote Access&quot; to &quot;Configuration of LAN controlled master devices&quot;.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>All Document completely revised, netHOST devices for Real-Time Ethernet added.</td>
</tr>
<tr>
<td>3</td>
<td>2015-07-13</td>
<td>All 6</td>
<td>Document revised, netHOST device NHST-T100-EN added. Chapter NHST-T100-EN: Downloading Firmware to the Device with SYCON.net added.</td>
</tr>
<tr>
<td>4</td>
<td>2015-07-22</td>
<td>1.1.4.1</td>
<td>Firmware version in section Hardware and firmware updated to version ≥ v1.7</td>
</tr>
<tr>
<td>5</td>
<td>2017-02-27</td>
<td>3.2</td>
<td>Section System Requirements PC/Notebook, Internet access added, Windows 8.1 and Windwos 10 added.</td>
</tr>
</tbody>
</table>

*Table 1: List of Revisions*
1.1.3 Conventions in this Manual

Notes, operation instructions and results of operation steps are marked as follows:

Notes

Important: <important note you must follow to avoid malfunction>

Note: <general note>

<note, where to find further information>

Operation Instructions

1. <instruction>

2. <instruction>

or

➢ <instruction>

Results

➢ <result>
1.1.4 Reference to Devices, Firmware and Software Versions

1.1.4.1 Hardware and firmware

This document relates to the following versions of hardware and firmware:

### Devices with preloaded firmware

<table>
<thead>
<tr>
<th>Order no.</th>
<th>Hardware revision</th>
<th>Protocol</th>
<th>Firmware file</th>
<th>Firmware version</th>
</tr>
</thead>
<tbody>
<tr>
<td>NHST-T100-DP/DPM</td>
<td>1890.410/DPM 4</td>
<td>PROFIBUS DP Master</td>
<td>FT20V010.NXF</td>
<td>1.7.x.x</td>
</tr>
<tr>
<td>NHST-T100-CO/COM</td>
<td>1890.500/COM 4</td>
<td>CANopen Master</td>
<td>FT20V040.NXF</td>
<td>1.7.x.x</td>
</tr>
<tr>
<td>NHST-T100-DN/DNM</td>
<td>1890.510/DNM 4</td>
<td>DeviceNet Master</td>
<td>FT20V060.NXF</td>
<td>1.7.x.x</td>
</tr>
<tr>
<td>NHST-T100-EN/PNM</td>
<td>1890.840/PNM 2</td>
<td>PROFINET IO Controller</td>
<td>FT20C0V0.NXF</td>
<td>1.7.x.x</td>
</tr>
<tr>
<td>NHST-T100-EN/ECM</td>
<td>1890.110/ECM 2</td>
<td>EtherCAT Master</td>
<td>FT20E0V0.NXF</td>
<td>1.7.x.x</td>
</tr>
<tr>
<td>NHST-T100-EN/EIM</td>
<td>1890.820/EIM 2</td>
<td>EtherNet/IP Scanner</td>
<td>FT20G0V0.NXF</td>
<td>1.7.x.x</td>
</tr>
</tbody>
</table>

Table 2: Reference to devices with preloaded firmware

### Device for loadable firmware

(Firmware not loaded in state of delivery of device)

<table>
<thead>
<tr>
<th>Order no.</th>
<th>Hardware revision</th>
<th>Supported protocols</th>
<th>Loadable firmware file</th>
<th>Firmware version</th>
</tr>
</thead>
<tbody>
<tr>
<td>NHST-T100-EN</td>
<td>1890.800 2</td>
<td>PROFINET IO Controller</td>
<td>FT20C0V0.NXF</td>
<td>1.7.x.x</td>
</tr>
<tr>
<td></td>
<td></td>
<td>EtherCAT Master</td>
<td>FT20E0V0.NXF</td>
<td>1.7.x.x</td>
</tr>
<tr>
<td></td>
<td></td>
<td>EtherNet/IP Scanner</td>
<td>FT20G0V0.NXF</td>
<td>1.7.x.x</td>
</tr>
</tbody>
</table>

Table 3: Reference to devices for loadable firmware

**Note:** The device For acting as master device, the **NHST-T100-EN** requires the **NXLIC-Master** license (order no.: **8211.000**). Make sure to order the NHST-T100-EN device together with the master license, so that it will be delivered with the license already loaded.

If necessary, a master license can also be ordered and installed belatedly; instructions for this are provided in section **Ordering and Downloading License to NHST-T100-EN with SYCON.net** on page 36.

1.1.4.2 Software

This document refers to the following software versions:

<table>
<thead>
<tr>
<th>Software</th>
<th>Version</th>
<th>File name</th>
<th>Path on netHOST Solutions DVD</th>
</tr>
</thead>
<tbody>
<tr>
<td>SYCON.net</td>
<td>1.380.x.x</td>
<td>SYCONnet.netX setup.exe</td>
<td>Setups &amp; Drivers\SYCON.net</td>
</tr>
<tr>
<td>Ethernet Device</td>
<td>1.501.x.x</td>
<td>EnDevConfigTool.msi</td>
<td>Setups &amp; Drivers\Ethernet Device Setup Utility</td>
</tr>
<tr>
<td>Configuration Tool</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>netHOST Device Test</td>
<td>1.0.x.x</td>
<td>netHOST.exe</td>
<td>Setups &amp; Drivers\netHOST Test</td>
</tr>
</tbody>
</table>

Table 4: Software
1.2 Documentation Overview

This section lists documents that are relevant to the user of the netHOST device.

Note, that the netHOST Solutions DVD also provides special documentation for developers in the Documentation\english\3.For Programmers directory. These special documents are not listed in this section.

1.2.1 Basic documents

<table>
<thead>
<tr>
<th>Title</th>
<th>Contents</th>
<th>Document ID</th>
<th>Path on the netHOST Solutions DVD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating Instruction Manual</td>
<td>Configuring, testing, diagnosing and updating firmware of the netHOST devices</td>
<td>DOC130402OIxxEN</td>
<td>Documentation\english\1.Software\SYCON.net Configuration Software\Configuration of netHOST-Devices OI xx EN.pdf</td>
</tr>
<tr>
<td>User Manual netHOST NHST-T100 – LAN controlled master devices for Fieldbus and Real-Time Ethernet Systems</td>
<td>Installation, commissioning and hardware description of the netHOST devices</td>
<td>DOC130401UMxxEN</td>
<td>Documentation\english\2.Hardware\netHOST, Model NHST-T100-xx\netHOST NHST-T100 - Remote Fieldbus Device UM xx EN.pdf</td>
</tr>
<tr>
<td>User Manual Software Installation netHOST Devices</td>
<td>Instructions for installing the netHOST software</td>
<td>DOC130501UMxxEN</td>
<td>Documentation\english\4.Installation Instructions\netHOST - Software Installation UM XX EN.pdf</td>
</tr>
<tr>
<td>User Manual Wiring Instructions</td>
<td>Wiring instructions (cable characteristics) for fieldbus protocols</td>
<td>DOC120208UMxxEN</td>
<td>Documentation\english\4.Installation Instructions\Wiring Instructions UM XX EN.pdf</td>
</tr>
<tr>
<td>Operating Instruction Manual Ethernet Device Configuration</td>
<td>Instruction on how to assign an IP address to Hilscher devices</td>
<td>DOC050402OIxxEN</td>
<td>Documentation\english\1.Software\Ether net Device Setup Utility\Ethernet Device Configuration OI XX EN.pdf</td>
</tr>
</tbody>
</table>

Table 5: Basic Documentation for netHOST
1.2.2 Protocol-specific Documents

**netHOST as PROFINET IO Master**
You also need the following documents if you are using an NHST-T100-DP/DPM netHOST device:

<table>
<thead>
<tr>
<th>Title</th>
<th>Contents</th>
<th>Document ID</th>
<th>Path on the netHOST Solutions DVD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating Instruction Manual DTM for Hilscher-PROFINET IO Master Devices</td>
<td>Description of the device type manager for PROFINET IO master devices</td>
<td>DOC070401O1xxEN</td>
<td>Documentation\english\1. Software\SYCON.net Configuration Software\Master Configuration\PROFINET IO Master DTM OI xx EN.pdf</td>
</tr>
</tbody>
</table>

**netHOST as CANopen Master**
You also need the following documents if you are using an NHST-T100-CO/COM netHOST device:

<table>
<thead>
<tr>
<th>Title</th>
<th>Contents</th>
<th>Document ID</th>
<th>Path on the netHOST Solutions DVD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating Instruction Manual DTM for Hilscher-CANopen Master Devices</td>
<td>Description of the device type manager for CANopen master devices</td>
<td>DOC070402O1xxEN</td>
<td>Documentation\english\1. Software\SYCON.net Configuration Software\Master Configuration\CANopen Master\CANopen Master DTM OI xx EN.pdf</td>
</tr>
<tr>
<td>Operating Instruction Manual Generic Slave DTM for CANopen Slave Devices</td>
<td>Description of the device type manager for generic CANopen slave devices</td>
<td>DOC060203O1xxEN</td>
<td>Documentation\english\1. Software\SYCON.net Configuration Software\Master Configuration\CANopen Master\Slave Configuration\CANopen Generic Slave DTM OI xx EN.pdf</td>
</tr>
</tbody>
</table>

**netHOST as DeviceNet Master**
You also need the following documents if you are using an NHST-T100-DN/DNM netHOST device:

<table>
<thead>
<tr>
<th>Title</th>
<th>Contents</th>
<th>Document ID</th>
<th>Path on the netHOST Solutions DVD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating Instruction Manual DTM for Hilscher-DeviceNet Master Devices</td>
<td>Description of the device type manager for DeviceNet master devices</td>
<td>DOC070403O1xxEN</td>
<td>Documentation\english\1. Software\SYCON.net Configuration Software\Master Configuration\DeviceNet Master\DeviceNet Master DTM OI xx EN.pdf</td>
</tr>
<tr>
<td>Operating Instruction Manual Generic Slave DTM for DeviceNet Slave Devices</td>
<td>Description of the device type manager for generic DeviceNet slave devices</td>
<td>DOC041201O1xxEN</td>
<td>Documentation\english\1. Software\SYCON.net Configuration Software\Master Configuration\DeviceNet Master\Slave Configuration\DeviceNet Generic Slave DTM OI xx EN.pdf</td>
</tr>
</tbody>
</table>

Table 6: Additional Documentation for netHOST as PROFIBUS DP Master

Table 7: Additional Documentation for netHOST as CANopen Master

Table 8: Additional Documentation for netHOST as DeviceNet Master
### netHOST as PROFINET IO Controller

You also need the following documents if you are using an NHST-T100-EN/PNM, respectively NHST-T100-EN device with loaded PROFINET IO Controller firmware:

<table>
<thead>
<tr>
<th>Title</th>
<th>Contents</th>
<th>Document ID</th>
<th>Path on the netHOST Solutions DVD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating Instruction Manual</td>
<td>Description of the device type manager for PROFINET IO Controller devices</td>
<td>DOC060302OlxEN</td>
<td>Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\PROFINET IO Controller\PROFINET IO Controller DTM OI xx EN.pdf</td>
</tr>
<tr>
<td>Operating Instruction Manual</td>
<td>Description of the device type manager for generic PROFINET IO devices</td>
<td>DOC060305OlxEN</td>
<td>Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\PROFINET IO Controller \IO Device Configuration\PROFINET IO Generic Device DTM OI xx EN.pdf</td>
</tr>
</tbody>
</table>

Table 9: Additional Documentation for netHOST as PROFINET IO Controller

### netHOST as EtherCAT Master

You also need the following documents if you are using an NHST-T100-EN/ECM, respectively NHST-T100-EN device with loaded EtherCAT Master firmware:

<table>
<thead>
<tr>
<th>Title</th>
<th>Contents</th>
<th>Document ID</th>
<th>Path on the netHOST Solutions DVD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating Instruction Manual</td>
<td>Description of the device type manager for EtherCAT Master devices</td>
<td>DOC080404OlxEN</td>
<td>Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\EtherCAT Master\EtherCAT Master DTM OI xx EN.pdf</td>
</tr>
<tr>
<td>Operating Instruction Manual</td>
<td>Description of the device type manager for generic EtherCAT slave devices</td>
<td>DOC071202OlxEN</td>
<td>Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\EtherCAT Master\Slave Configuration\EtherCAT Generic Slave DTM OI xx EN.pdf</td>
</tr>
<tr>
<td>User Manual</td>
<td>Wiring instructions for EtherCAT networks</td>
<td>DOC121104UMxEN</td>
<td>Documentation\english\4.Installation Instructions\Wiring Instructions UM xx EN.pdf</td>
</tr>
</tbody>
</table>

Table 10: Additional Documentation for netHOST as EtherCAT Master
netHOST as EtherNet/IP Scanner

You also need the following documents if you are using an NHST-T100-EN/EIM, respectively NHST-T100-EN device with loaded EtherNet/IP Scanner firmware:

<table>
<thead>
<tr>
<th>Title</th>
<th>Contents</th>
<th>Document ID</th>
<th>Path on the netHOST Solutions DVD</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating Instruction Manual DTM for EtherNet/IP Scanner Devices</td>
<td>Description of the device type manager for EtherNet/IP Scanner devices</td>
<td>DOC061201OlxEN</td>
<td>Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\EtherNetIP Scanner\EtherNetIP Scanner DTM OI xx EN.pdf</td>
</tr>
<tr>
<td>Operating Instruction Manual Generic, Modular Generic DTM from EDS File for non-modular and modular EtherNet/IP Adapter Devices</td>
<td>Description of the generic, modular generic device type manager from EDS file for non-modular EtherNet/IP Adapter devices and modular EtherNet/IP Adapter devices</td>
<td>DOC100221OlxEN</td>
<td>Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\EtherNetIP Scanner\Adapter Configuration\EtherNetIP Generic Adapter DTM EDS OI xx EN.pdf</td>
</tr>
<tr>
<td>Operating Instruction Manual Generic DTM for EtherNet/IP Adapter Devices and Modular Generic DTM for modular EtherNet/IP Adapter Devices</td>
<td>Description of the generic device type manager for EtherNet/IP Adapter devices and modular EtherNet/IP Adapter devices</td>
<td>DOC070203OlxEN</td>
<td>Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\EtherNetIP Scanner\Adapter Configuration\EtherNetIP Generic Adapter DTM OI xx EN.pdf</td>
</tr>
</tbody>
</table>

Table 11: Additional Documentation for netHOST as EtherNet/IP Scanner

1.2.3 Online Help

The SYCON.net configuration software provides an online help.

- To open the online help of the SYCON.net netFrame application, choose **Help > Content and Index** in the menu bar of SYCON.net or press **F1** key on your keyboard.
- If you have opened a netHOST configuration dialog in SYCON.net (i.e. if you have opened the netHOST DTM), you can call-up a context-sensitive online help (featuring parts of this operating manual) by clicking the **Help** button in the dialog window or by pressing the **F1** key on your keyboard.
1.3 Legal Notes

Copyright
© Hilscher Gesellschaft für Systemautomation mbH
All rights reserved.
The images, photographs and texts in the accompanying materials (in the form of a user's manual, operator's manual, Statement of Work document and all other document types, support texts, documentation, etc.) are protected by German and international copyright and by international trade and protective provisions. Without the prior written consent, you do not have permission to duplicate them either in full or in part using technical or mechanical methods (print, photocopy or any other method), to edit them using electronic systems or to transfer them. You are not permitted to make changes to copyright notices, markings, trademarks or ownership declarations. Illustrations are provided without taking the patent situation into account. Any company names and product designations provided in this document may be brands or trademarks by the corresponding owner and may be protected under trademark, brand or patent law. Any form of further use shall require the express consent from the relevant owner of the rights.

Important notes
Utmost care was/is given in the preparation of the documentation at hand consisting of a user's manual, operating manual and any other document type and accompanying texts. However, errors cannot be ruled out. Therefore, we cannot assume any guarantee or legal responsibility for erroneous information or liability of any kind. You are hereby made aware that descriptions found in the user's manual, the accompanying texts and the documentation neither represent a guarantee nor any indication on proper use as stipulated in the agreement or a promised attribute. It cannot be ruled out that the user's manual, the accompanying texts and the documentation do not completely match the described attributes, standards or any other data for the delivered product. A warranty or guarantee with respect to the correctness or accuracy of the information is not assumed.

We reserve the right to modify our products and the specifications for such as well as the corresponding documentation in the form of a user's manual, operating manual and/or any other document types and accompanying texts at any time and without notice without being required to notify of said modification. Changes shall be taken into account in future manuals and do not represent an obligation of any kind, in particular there shall be no right to have delivered documents revised. The manual delivered with the product shall apply.

Under no circumstances shall Hilscher Gesellschaft für Systemautomation mbH be liable for direct, indirect, ancillary or subsequent damage, or for any loss of income, which may arise after use of the information contained herein.

Liability disclaimer
The hardware and/or software was created and tested by Hilscher Gesellschaft für Systemautomation mbH with utmost care and is made available as is. No warranty can be assumed for the performance or flawlessness of the hardware and/or software under all application conditions and scenarios and the work results achieved by the user when using the hardware and/or software. Liability for any damage that may have
occurred as a result of using the hardware and/or software or the corresponding documents shall be limited to an event involving willful intent or a grossly negligent violation of a fundamental contractual obligation. However, the right to assert damages due to a violation of a fundamental contractual obligation shall be limited to contract-typical foreseeable damage.

It is hereby expressly agreed upon in particular that any use or utilization of the hardware and/or software in connection with

- Flight control systems in aviation and aerospace;
- Nuclear fusion processes in nuclear power plants;
- Medical devices used for life support and
- Vehicle control systems used in passenger transport

shall be excluded. Use of the hardware and/or software in any of the following areas is strictly prohibited:

- For military purposes or in weaponry;
- For designing, engineering, maintaining or operating nuclear systems;
- In flight safety systems, aviation and flight telecommunications systems;
- In life-support systems;
- In systems in which any malfunction in the hardware and/or software may result in physical injuries or fatalities.

You are hereby made aware that the hardware and/or software was not created for use in hazardous environments, which require fail-safe control mechanisms. Use of the hardware and/or software in this kind of environment shall be at your own risk; any liability for damage or loss due to impermissible use shall be excluded.

Warranty

Hilscher Gesellschaft für Systemautomation mbH hereby guarantees that the software shall run without errors in accordance with the requirements listed in the specifications and that there were no defects on the date of acceptance. The warranty period shall be 12 months commencing as of the date of acceptance or purchase (with express declaration or implied, by customer's conclusive behavior, e.g. putting into operation permanently).

The warranty obligation for equipment (hardware) we produce is 36 months, calculated as of the date of delivery ex works. The aforementioned provisions shall not apply if longer warranty periods are mandatory by law pursuant to Section 438 (1.2) BGB, Section 479 (1) BGB and Section 634a (1) BGB [Bürgerliches Gesetzbuch; German Civil Code] If, despite of all due care taken, the delivered product should have a defect, which already existed at the time of the transfer of risk, it shall be at our discretion to either repair the product or to deliver a replacement product, subject to timely notification of defect.

The warranty obligation shall not apply if the notification of defect is not asserted promptly, if the purchaser or third party has tampered with the products, if the defect is the result of natural wear, was caused by unfavorable operating conditions or is due to violations against our operating regulations or against rules of good electrical engineering practice, or if our request to return the defective object is not promptly complied with.
Costs of support, maintenance, customization and product care
Please be advised that any subsequent improvement shall only be free of charge if a defect is found. Any form of technical support, maintenance and customization is not a warranty service, but instead shall be charged extra.

Additional guarantees
Although the hardware and software was developed and tested in-depth with greatest care, Hilscher Gesellschaft für Systemautomation mbH shall not assume any guarantee for the suitability thereof for any purpose that was not confirmed in writing. No guarantee can be granted whereby the hardware and software satisfies your requirements, or the use of the hardware and/or software is uninterruptable or the hardware and/or software is fault-free.
It cannot be guaranteed that patents and/or ownership privileges have not been infringed upon or violated or that the products are free from third-party influence. No additional guarantees or promises shall be made as to whether the product is market current, free from deficiency in title, or can be integrated or is usable for specific purposes, unless such guarantees or promises are required under existing law and cannot be restricted.

Confidentiality
The customer hereby expressly acknowledges that this document contains trade secrets, information protected by copyright and other patent and ownership privileges as well as any related rights of Hilscher Gesellschaft für Systemautomation mbH. The customer agrees to treat as confidential all of the information made available to customer by Hilscher Gesellschaft für Systemautomation mbH and rights, which were disclosed by Hilscher Gesellschaft für Systemautomation mbH and that were made accessible as well as the terms and conditions of this agreement itself.
The parties hereby agree to one another that the information that each party receives from the other party respectively is and shall remain the intellectual property of said other party, unless provided for otherwise in a contractual agreement.
The customer must not allow any third party to become knowledgeable of this expertise and shall only provide knowledge thereof to authorized users as appropriate and necessary. Companies associated with the customer shall not be deemed third parties. The customer must obligate authorized users to confidentiality. The customer should only use the confidential information in connection with the performances specified in this agreement.
The customer must not use this confidential information to his own advantage or for his own purposes or rather to the advantage or for the purpose of a third party, nor must it be used for commercial purposes and this confidential information must only be used to the extent provided for in this agreement or otherwise to the extent as expressly authorized by the disclosing party in written form. The customer has the right, subject to the obligation to confidentiality, to disclose the terms and conditions of this agreement directly to his legal and financial consultants as would be required for the customer's normal business operation.

Export provisions
The delivered product (including technical data) is subject to the legal export and/or import laws as well as any associated regulations of various countries, especially such laws applicable in Germany and in the United States. The products / hardware / software must not be exported into such
countries for which export is prohibited under US American export control
laws and its supplementary provisions. You hereby agree to strictly follow
the regulations and to yourself be responsible for observing them. You are
hereby made aware that you may be required to obtain governmental
approval to export, reexport or import the product.

1.4 Registered Trademarks

Adobe Reader® is a registered trademark of the Adobe Systems
Incorporated.

CANopen® is a registered trademark of CAN in AUTOMATION -
International Users and Manufacturers Group e.V. (CiA), Nürnberg.

DeviceNet™ and EtherNet/IP™ are trademarks of ODVA (Open DeviceNet
Vendor Association, Inc).

EtherCAT® is a registered trademark and a patented technology of
Beckhoff Automation GmbH, Verl, Germany, formerly Elektro Beckhoff
GmbH.

PROFIBUS® and PROFINET® are registered trademarks of PROFIBUS
International, Karlsruhe.

Windows® XP, Windows® Vista, Windows® 7, Windows® 8, Windows® 8.1
and Windows® 10 are registered trademarks of Microsoft Corporation.

All other mentioned trademarks are property of their respective legal
owners.
2 Description

The netHOST device allows you to access data of a fieldbus or Real-Time Ethernet network from your PC, terminal or other host system via TCP/IP (Ethernet LAN). The netHOST device thus serves as a gateway (respectively programming interface) between your PC/terminal/host system and the Fieldbus or Real-Time Ethernet network.

Once configured, the netHOST device operates the Fieldbus or RTE network on its own. An appropriate application program establishes the TCP/IP connection to the device and accesses the data of the secondary network.

Access to the netHOST device takes place according to the “Ethernet Marshalling” procedures, by which locally generated service requests of an initiator (i.e. the host application) are being transmitted to a receiver (i.e. the netHOST device) by an appropriate method (i.e. coded/decoded in Ethernet telegrams). The service requests are then called and executed “by remote” on the netHOST device.

The host system can be based on a Windows operating system, but is, however, not restricted to Windows only. For Windows developers, the netHOST Solutions DVD provides the code with the Ethernet Marshalling function both as C++ source code and as Windows DLL (netXTransport.dll). For developers of embedded systems, the DVD provides a C source code which is independent from any specific type of operating system.

Important: The Ethernet connection to the netHOST device is not protected by password or encryption. Protection against unauthorized access by external networks has to be ensured by using adequate measures!

The following figure illustrates the data flow of “Ethernet Marshalling” with the netHOST:

![Figure 1: Data Flow of LAN Controlled netHOST Device](image)
3 Requirements for Configuring the netHOST

3.1 Required Software

Software components needed on a PC or host system under Windows to configure or test the netHOST device, or to download/update its firmware, are provided on the netHOST Solutions DVD.

These are:

- **Ethernet Device Configuration Tool**
  This tool is needed to assign a temporary IP address to the netHOST device (by default/factory setting, the IP address of the netHOST is 0.0.0.0), so that SYCON.net can access the netHOST and download the configuration (and in case of an NHST-T100-EN the initial firmware) via LAN.
  The tool is included in the SYCON.net installation, but can also be installed separately on a Windows PC or notebook. The installation program for separate installation is called EnDevConfigTool.msi and can be found in the Setups & Drivers\Ethernet Device Setup Utility directory of the netHOST Solutions DVD.

- **SYCON.net**
  To configure the netHOST device, you need to install the configuration and diagnosis software SYCON.net, version 1.360.x.x or higher, on your Windows PC or notebook. From version 1.360.x.x upwards, SYCON.net contains the appropriate Device Type Manager (netHOST-DTM) for configuring and diagnosing the netHOST device.
  You also need SYCON.net in order to download/update firmware files.
  You can start the installation program for SYCON.net in the menu of the start screen of the netHOST Solutions DVD. You can also start the installation by double-clicking the SYCONnet netX setup.exe file in the Setups & Drivers\SYCON.net directory of the DVD.

Detailed instructions on how to install SYCON.net are provided in the user manual Software Installation netHOST Devices, DOC130501UMxxEN.

- **netHOST Device Test Application**
  This application is needed to test the remote access and to read and write data of the secondary network, in case you don’t have an own application program for this purpose.
  This application does not need to be installed on your Windows PC or notebook. It can be started by clicking Run Windows Test Application in the menu of the start screen of the netHOST Solutions DVD. You can also execute the application by double-clicking the netHOST.exe file in the Setups & Drivers\netHOST Test directory of the DVD.
Requirements for Configuring the netHOST

- **netXTransport.dll**
  The netXTransport.dll contains the Ethernet Marshalling functionality. It is needed on the Windows PC or accessing host system for communicating with the netHOST device via TCP/IP (Ethernet LAN). The DLL is included in the SYCON.net installation, but can also be installed separately on a Windows PC or notebook. The separate netXTransport.dll for Windows can be found on the netHOST Solutions DVD in the directory Supplements & Examples\netXTransport Protocol DLL – Win32 Test Application with Source Code.

  **Note:** Windows developers will find C++ source code containing the Ethernet marshalling functionality in the Programming & Development\Developing own remote accessing Applications\netXTransport Protocol DLL\Source Codes directory of the netHOST Solutions DVD.

  For host systems not based on Windows, C source code containing the Ethernet marshalling functionality is available in the Programming & Development\Developing own remote accessing Applications\netXTransport Protocol C-Toolkit directory.

- **USB driver**
  The USB driver is needed on the Windows PC or notebook only in the exceptional case of having to reset the netHOST device to its “factory settings” (firmware recovery via USB). This can be necessary if, e. g., the firmware file of the device is corrupted. When performing a recovery via USB, a fresh firmware file is reloaded into the device with the ComProX tool.

  Instructions on how to reset the netHOST device to its factory settings can be found in the user manual netHOST NHST-T100 – LAN controlled master devices for Fieldbus and Real-Time Ethernet systems, DOC130401UMxxEN, in the Firmware recovery chapter.

  Instructions on how to install the USB driver under Windows are provided in the user manual Software Installation netHOST Devices, DOC130501UMxxEN.
The figure below depicts the interaction of the required software components and the data flow.

**Figure 2: Data Flow and Software Components for Configuration and Testing**

1. **SYCON.net with netHOST-DTM**: Configuration, diagnosis and downloading/updating firmware of the netHOST device via TCP/IP.
2. **netHOST Device Test Application**: Allows testing the communication.
3. **Online Data Manager (ODM)**: Connects the application layer (SYCON.net) to the communication layer (netX Driver). The ODM is included in the SYCON.net installation.
4. **netX Driver**: Windows driver for communication between SYCON.net and the netHOST device. The netX Driver is included in the SYCON.net installation.
5. **cifX Application Interface (API)**: Enables an application program to access the fieldbus/RTE network via netHOST.
6. **netXTransport.DLL for Windows**: Integrates the commands of the application program into an Ethernet protocol and sends the data to the netHOST device. Contains the Marshalling function of the host. The DLL is included in the SYCON.net installation, but can also be installed separately.
7. **Ethernet Device Configuration Tool**: Assigns a temporary IP address to the netHOST device. The tool is included in the SYCON.net installation.
8. **netHOST firmware**: Contains the protocol stack and the Marshalling function of the device.
3.2 System Requirements PC/Notebook

For installing and using the SYCON.net configuration software, you need a PC or notebook with:

- PC with 1 GHz processor or higher
- Windows® XP SP3,
  Windows® Vista (32 bit) SP2,
  Windows® 7 (32 bit und 64-Bit) SP1,
  Windows® 8 (32-Bit und 64-Bit),
  Windows® 8.1 (32-Bit und 64-Bit),
  Windows® 10 (32-Bit und 64-Bit)
- Administrator privilege required for installation
- Internet Explorer 5.5 or higher
- RAM: min. 512 MByte, recommended 1024 MByte
- Graphic resolution: min. 1024 x 768 pixel
- Keyboard and Mouse
- Restriction: Touch screen is not supported.

**Note:** If the project file is used on another PC,
- the other PC must also comply to these system requirements,
- the device description files of the devices used in the project must be imported to the configuration software SYCON.net on the other PC,
- respectively the DTMs of the devices used in the project must be installed on the other PC.
# Getting Started

**netHOST Devices with preloaded firmware**

The subsequent table provides an overview of the steps which need to be performed in order to configure and test the netHOST devices:

| NHST-T100-DP/DPM | NHST-T100-CO/COM | NHST-T100-DN/DNM | NHST-T100-EN/PNM | NHST-T100-EN/ECM | NHST-T100-EN/EIM |

<table>
<thead>
<tr>
<th>#</th>
<th>Step</th>
<th>For details, refer to</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Install netHOST</td>
<td>User Manual netHOST NHST-T100 – LAN controlled master devices for Fieldbus and Real-Time Ethernet networks</td>
</tr>
<tr>
<td></td>
<td>- Mount netHOST device.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Connect the netHOST device to the LAN network (primary network)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Connect the netHOST device to the fieldbus or Real-Time Ethernet</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Connect the netHOST device to a voltage supply.</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Install SYCON.net configuration software on configuration PC.</td>
<td>User Manual Software Installation netHOST Devices</td>
</tr>
<tr>
<td>3</td>
<td>Use Ethernet Device Configuration tool to assign a temporary IP address to the netHOST device.</td>
<td>Section Assigning Temporary IP Address to netHOST Device on page 24</td>
</tr>
<tr>
<td>4</td>
<td>Configure netHOST with SYCON.net.</td>
<td>Section Configuring netHOST for Fieldbus Systems with SYCON.net: NHST-T100-DP/DPM Example on page 49 or section Configuring netHOST for RTE Systems with SYCON.net: NHST-T100-EN/PNM Example on page 64</td>
</tr>
<tr>
<td>5</td>
<td>Test Communication</td>
<td>Section Testing Communication of netHOST for Fieldbus: NHST-T100-DP/DPM Example on page 80 or section Testing Communication of netHOST for RTE Systems: NHST-T100-EN/PNM Example on page 86</td>
</tr>
</tbody>
</table>

*Table 12: Overview Configuration and Testing of netHOST with Preloaded Firmware*
**NHST-T100-EN (device without preloaded firmware)**

The subsequent table provides an overview of the steps which need to be performed in order to commission, configure and test the **NHST-T100-EN**

<table>
<thead>
<tr>
<th>#</th>
<th>Step</th>
<th>For details, refer to</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Install NHST-T100-EN</td>
<td>User Manual netHOST NHST-T100 — LAN controlled master devices for Fieldbus and Real-Time Ethernet networks</td>
</tr>
<tr>
<td></td>
<td>- Mount netHOST device.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Connect the netHOST device to the LAN network (primary network)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Connect the netHOST device to the fieldbus or Real-Time Ethernet</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Connect the netHOST device to a voltage supply.</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Install SYCON.net configuration software on configuration PC</td>
<td>User Manual Software Installation netHOST Devices</td>
</tr>
<tr>
<td>3</td>
<td>Use Ethernet Device Configuration tool to assign a temporary IP address to the NHST-T100-EN device</td>
<td>Section Assigning Temporary IP Address to netHOST Device on page 24</td>
</tr>
<tr>
<td>4</td>
<td>Download firmware to NHST-T100-EN device</td>
<td>Section NHST-T100-EN: Downloading Firmware to the Device with SYCON.net on page 27</td>
</tr>
<tr>
<td>5</td>
<td>Configure netHOST with SYCON.net.</td>
<td>Section Configuring netHOST for RTE Systems with SYCON.net: NHST-T100-EN/PNM Example on page 64</td>
</tr>
<tr>
<td>6</td>
<td>Test Communication</td>
<td>Section Testing Communication of netHOST for RTE Systems: NHST-T100-EN/PNM Example on page 86</td>
</tr>
</tbody>
</table>

*Table 13: Overview Configuration and Testing of NHST-T100-EN*
5 Assigning Temporary IP Address to netHOST Device

In its state of delivery, the netHOST device has the IP address 0.0.0.0. Also, the DHCP option (i.e. the option of the netHOST receiving its IP address dynamically from a DHCP server) at first is deactivated by default in the firmware (if required, you can activate the DHCP server option in SYCON.net later). Because the netHOST is configured via Ethernet LAN and SYCON.net, you first need to assign a valid temporary IP address to the netHOST, in order to enable SYCON.net to establish an Ethernet connection to the device in the first place (the initial firmware download for the NHST-T100-EN is also done via Ethernet LAN and SYCON.net and thus also requires the assignment of a temporary IP address). You can use the Hilscher Ethernet Device Configuration Tool to assign this temporary IP address from your configuration PC.

The Ethernet Device Configuration Tool is described in the operating instructions manual Ethernet Device Configuration, DOC050402OIxxEN, which is stored on the netHOST Solutions DVD in the Documentation\english\1.Softwarr\Ethernet Device Setup Utility directory.

5.1 Prerequisites

- You have installed the Hilscher Ethernet Device Configuration Tool on your configuration PC (is included in the SYCON.net installation).
- The netHOST device is connected to a voltage supply.
- The configuration PC and the netHOST device are connected to the same local Ethernet network.

Note: When using netHOST devices for Fieldbus systems (i.e. NHST-T100-DP/DPM, NHST-T100-CO/COM or NHST-T100-DN/DNM), plug-in the Ethernet LAN cable into one of the two RJ45 sockets on the left side of the device (X2 interface). When using netHOST devices for RTE systems (i.e. NHST-T100-EN, NHST-T100-EN/PNM, NHST-T100-EN/ECM or NHST-T100-EN/EIM), plug-in the Ethernet LAN cable into the single RJ45 socket on the right side of the device (X3 interface).
5.2 Step-By-Step Instructions

1. **Start Ethernet Device Configuration tool** on your PC.

   ➢ In the Windows **Start** menu, choose **Start > All Programs > SYCON.net System Configurator > Ethernet Device Setup**.

   (If you haven’t installed SYCON.net on your PC and have installed the **Ethernet Device Configuration** tool separately, then choose **Start > All Programs > Hilscher GmbH > Ethernet Device Configuration > Ethernet Device Configuration**.)

   ➢ The tool starts:

   ![Ethernet Device Configuration Tool (1)](image1)

2. Search for Hilscher devices in the IP network.

   ➢ **Click Search Devices** to identify connected Hilscher devices.

   ➢ All found devices are listed:

   ![Ethernet Device Configuration Tool (2)](image2)
3. Assign IP address.
   - Select the line featuring the netHOST device.
   - Click **Configure**, then choose **Set IP Address...** from the menu.
   - The **IP Configuration** dialog opens:

   ![Image of IP Configuration dialog]

   **Figure 5: Ethernet Device Configuration Tool (3)**

   - Enter the IP address by which the netHOST device shall be reached in your local IP network. The IP address must be in the same sub net as the later to be used configuration PC.
   - Click **OK**.
   - The netHOST device receives the entered IP address.

   **Note:** The IP address assigned by the **Ethernet Device Configuration Tool** is kept by the netHOST device only until next power-on cycle or device reset, or until a permanent IP address has been configured and downloaded with SYCON.net.
6 NHST-T100-EN: Downloading Firmware to the Device with SYCON.net

This chapter is relevant only to users of the NHST-T100-EN device (order no.: 1890.800), which – unlike all other netHOST devices – is shipped with its firmware not yet loaded. The user thus has to perform the download of the firmware file himself.

One of the following master protocols can be loaded to the NHST-T100-EN:

<table>
<thead>
<tr>
<th>Supported protocol</th>
<th>Loadable firmware file</th>
</tr>
</thead>
<tbody>
<tr>
<td>PROFINET IO Controller</td>
<td>FT20C0V0.NXF</td>
</tr>
<tr>
<td>EtherCAT Master</td>
<td>FT20E0V0.NXF</td>
</tr>
<tr>
<td>EtherNet/IP Scanner</td>
<td>FT20G0V0.NXF</td>
</tr>
</tbody>
</table>

Table 14: Loadable firmware for NHST-T100-EN

The firmware files are stored on the product DVD in the Firmware\netHOST folder.

A netHOST acting as master device requires the NXLIC-Master license. If you have ordered the NHST-T100-EN device together with the NXLIC-Master license (order no. 8211.000), the device was delivered with an already installed and activated master license, and you therefore only have to download the desired firmware file.

If your NHST-T100-EN device is not yet equipped with the master license for any reason, you can use SYCON.net to order the license from Hilscher and then download the license to the device. Instructions for this are provided in section Ordering and Downloading License to NHST-T100-EN with SYCON.net on page 36). Note that you have to download the firmware first.

The following section describes how to download the PROFINET IO Controller firmware to the NHST-T100-EN device. The procedure for the EtherCAT master and EtherNet/IP Scanner firmware is the same.

6.1 Prerequisites

- You have installed SYCON.net on your configuration PC.
- You have inserted the netHOST Solutions DVD into your local DVD drive or have access to the firmware file intended for download (e.g. you have stored the file on your configuration PC).
- The configuration PC and the NHST-T100-EN device are connected to the same local Ethernet network.
- The NHST-T100-EN device is connected to a voltage supply.
- You have assigned a suitable temporary IP address to the netHOST device (see section Assigning Temporary IP Address to netHOST Device on page 24).
6.2 Step-By-Step Instructions

1. Start SYCON.net configuration software.
   - In the Windows Start menu, select All Programs > SYCON.net System Configurator > SYCON.net.
   - A login dialog appears:

   ![SYCON.net User Login](image1.png)

   Figure 6: SYCON.net Login

   - Enter your password, then click OK.
   - SYCON.net opens with a new empty project:

   ![Empty Project in SYCON.net](image2.png)

   Figure 7: Empty Project in SYCON.net
2. Create a new project.
   - In the Vendor tab of the Device Catalog (right window), open folder Hilscher GmbH > Master. Then select the netHOST DTM symbol corresponding to the protocol of your firmware and drag & drop it onto the bus configuration line in the middle window.

   Use the following netHOST-DTMs:
   - for PROFINET IO Controller: NHST-T100-EN/PNM
   - for EtherCAT Master: NHST-T100-EN/ECM
   - for EtherNet/IP Scanner: NHST-T100-EN/EIM

   ![Figure 8: Select NHST-T100-EN DTM](image)

3. Open the netHOST configuration window (i.e. the netHOST DTM).
   - Double-click the netHOST symbol in the bus configuration line, or select the netHOST symbol and choose Configuration > Main Settings from the context menu (to open context menu, right-click on the netHOST symbol).
The netHOST DTM opens with the **Device Assignment** dialog window. SYCON.net automatically starts to search for connected devices.

![Figure 9: Scanning for Devices in SYCON.net](image)

Because the netX Driver (which enables the Ethernet LAN connection to the netHOST device) is not yet acquainted with the IP address of the device, the netHOST is not found for the time being. You therefore first have to enter the IP address in the driver configuration dialog.

4. Select driver.
   - In the **Navigation Area**, select **Settings > Driver**.
   - The **Driver** dialog window opens. It lists all available drivers:

![Figure 10: Select Driver](image)

- Make sure the **netX Driver** is selected (check box must be activated).
### Note: In the netHOST DTM, the netX Driver usually is already selected by default. If this is not the case, activate the check box in front of the netX driver.

- Click **OK** or **Apply**.

5. Set IP address of netHOST in netX Driver.
   - In the **Navigation Area**, select **Settings > Driver > netX Driver**.
   - The **netX Driver** dialog window opens.
   - Select **TCP Connection** tab:

   ![Set IP Address in netX Driver](image)

   **Figure 11: Set IP Address in netX Driver**

   - Make sure the **Enable TCP Connector** option is selected (check box must be activated).
   - Click on button next to the **Select IP Range** drop-down list.
   - In the **IP Address** field, enter the IP address which you have assigned to the netHOST device with the **Ethernet Device Configuration Tool** (see **Assigning Temporary IP Address to netHOST Device** section on page 24).

   **Note:** You will find a detailed description of this dialog in the **netX Driver Dialog Window** section on page 114.

- Click **Save**.
6. Assign netHOST device.
   - In the Navigation Area, select **Settings > Device Assignment**.
   - The **Device Assignment** dialog window opens.
   - In the **Device selection** drop-down list, choose **suitable only** entry.
   - Click **Scan**.
   - If all prerequisites are fulfilled (see **Prerequisites** section on page 49) and the IP address has been properly set in the netX Driver, the NHST-T100-EN device will now be found and displayed in the list.

![Device Assignment Window](image.png)

**Figure 12: Select Device**

   - Activate the check box in front of the netHOST device.
   - Click **Apply**.

   - In the **Navigation Area**, select **Configuration > Settings**.
The **Settings** dialog window opens:

![Figure 13: Settings Dialog](image1)

- Click **Browse** button next to the **Available Firmware** field in order to search for the appropriate firmware file.

- The **Select Firmware File** dialog opens:

![Figure 14: Select Firmware File Dialog in SYCON.net](image2)
Navigate to the directory where the firmware file is stored. Firmware files are stored on the netHOST Solutions DVD in the `Firmware\netHOST` directory.

The subsequent table indicates which file belongs to which protocol:

<table>
<thead>
<tr>
<th>Protocol</th>
<th>Firmware file</th>
</tr>
</thead>
<tbody>
<tr>
<td>PROFINET IO Controller</td>
<td>FT20C0V0.NXF</td>
</tr>
<tr>
<td>EtherCAT Master</td>
<td>FT20E0V0.NXF</td>
</tr>
<tr>
<td>EtherNet/IP Scanner</td>
<td>FT20G0V0.NXF</td>
</tr>
</tbody>
</table>

Table 15: Protocol/Firmware for NHST-T100-EN

Select the appropriate firmware file, then click **Open**.

Back in the **Settings** dialog window, the selected firmware file is now displayed in the **Available Firmware** field:

![Firmware Download in SYCON.net](image)

**Figure 15: Firmware Download in SYCON.net**

8. Download firmware to netHOST device.

- In the **Available Firmware** field, select the firmware file.
- Class and version of the software are displayed.
- Check whether you have selected the appropriate firmware file.
Hazard of device damage by disruption of voltage supply during firmware update!
Do not interrupt the voltage supply while downloading the firmware to the netHOST. Power failure during a writing process in the file system can cause severe malfunctioning of the device.

- If you have selected the appropriate firmware file, click Download, to start downloading the file to the netHOST device.
- The following security question pops up:

![Security Question Firmware Download]

Figure 16: Security Question Firmware Download

**Note:** The existing firmware netHOST BFW, which is to be overwritten, is a so-called “base firmware” which is present in each NHST-T100-EN device in its state of delivery. The purpose of the base firmware is to enable access to the device via LAN and SYCON.net, so that the initial firmware download can be done by the customer. When downloading the “full” firmware, the base firmware is not needed any longer in the device and can thus be overwritten.

- The firmware is downloaded to the netHOST.

**Note:** The temporary IP address assigned to the netHOST device by the Ethernet Device Configuration Tool will be erased by the firmware download. The device falls back to its default 0.0.0.0 address, therefore you have to re-assign an IP address to the netHOST afterwards with the Ethernet Device Configuration Tool. Instructions for this can be found in the Assigning Temporary IP Address to netHOST Device section on page 24.
A permanent IP address can be assigned to the netHOST during configuration of the “Ethernet Marshalling”, see section Configuring Ethernet Marshalling on page 70.

- To close the netHOST DTM, click OK or Cancel.
- You have downloaded the firmware to the NHST-T100-EN device. If you did order the device together with the NXLIC-Master license (this is usually the case), the device was delivered with an activated license, and you can now proceed to configure your device. If your NHST-T100-EN device has not yet been endowed with a master license, you must now proceed to order and download the license as described in the following section.
6.3 Ordering and Downloading License to NHST-T100-EN with SYCON.net

This section describes how to order and download a master license to the NHST-T100-EN with SYCON.net. This is only necessary in the unusual case that the device had not been ordered together with an NXLIC-Master license, and has thus been delivered without the license already installed.

6.3.1 Prerequisites

- The configuration PC and the NHST-T100-EN device are connected to the same local TCP/IP (Ethernet LAN) network.
- The device is connected to a voltage supply.
- You have successfully downloaded the firmware to the NHST-T100-EN.
- You have re-assigned a suitable temporary IP address to the netHOST device after firmware download (the device loses its temporary IP address after firmware download and subsequent device reset). For instructions, see section Assigning Temporary IP Address to netHOST Device on page 24.
- You have opened the SYCON.net project of your NHST-T100-EN device.
- You have access to the internet (for downloading the license file from the Hilscher web site)

6.3.2 Instructions

6.3.2.1 Open License Dialog

1. Open the configuration dialog.
   ➢ Double-click the netHOST symbol in the bus configuration line, or select the netHOST symbol and choose Configuration > Main Settings from the context menu (to open context menu, right-click on the netHOST symbol).
   ➢ The configuration dialog opens.

2. Open license dialog
   ➢ Select in the navigation area under the folder Configuration the entry Licensing.
   ➢ The license dialog opens.
6.3.2.2 License Dialog

In the License pane you can:
- check, which licenses for Master protocols or Utilities are present in the device (Position 1 in the figure below),
- order licenses (Positions to 11),
- transfer licenses to the device 12.

Note: To display further entries under License Type, move the scroll box downwards or upwards. To display further entries under Request Form, please fill out, move the scroll box downwards or upwards.

1 The title bar contains the notation of the device description: Symbolic Name [Device Description] <Station Address> (#Network ID).
6.3.2.3 Which Licenses are present in the Device?

Check, which licenses are present in the device.

How to proceed:
- Open the License pane as described under section Open License Dialog on page 36.
  
  ![License Pane - License Type](image1.png)
  
  Figure 18: License Pane - License Type
  
  - Under License Type click [+] at Master protocols.
  - The Master protocols overview opens:

  ![License Pane - License Type / Master protocols](image2.png)
  
  Figure 19: License Pane – License Type / Master protocols
  
  - Or click [+] at Utilities.
  - The Utilities overview opens:

  ![License Pane - License Type / Utilities](image3.png)
  
  Figure 20: License Pane – License Type / Utilities
  
  - The column Existing indicates which licenses are present in the device.
    
    Yes = License is present in the device.
    
    No = License is not present in the device.

  Note: In newer versions of the present configuration software under License Type may be displayed additional licenses or other protocols that can be ordered later.
License for Master Protocols

One General Master License:
On the device maximally 1 communication protocol with master function can be implemented.

Two General Master Licenses:
On the device maximally 2 communication protocols with master function can be implemented.

The license includes the following Master protocols:
- AS-Interface Master
- CANopen Master
- DeviceNet Master
- EtherCat Master
- EtherNet/IP Scanner
- PROFIBUS Master
- PROFINET IO RT Controller
- Sercos Master

License for Utilities

- SYCON.net
- OPC Server
- QVis Minimum Size
- QVis Standard Size
- QVis Maximum Size
- CoDeSys Minimum Size
- CoDeSys Standard Size
- CoDeSys Maximum Size

For the utilities QVis and CoDeSys, only one license each may be chosen alternatively as:
- Minimum Size,
- Standard Size or
- Maximum Size.
6.3.2.4 How to order a License

To order a license, proceed as follows:

<table>
<thead>
<tr>
<th>Refer to Section:</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Open the license dialog.</td>
<td>Open License Dialog</td>
</tr>
<tr>
<td>2. Select the required licenses.</td>
<td>Selecting License</td>
</tr>
<tr>
<td>3. Enter the ordering data.</td>
<td>Ordering Data</td>
</tr>
<tr>
<td>4. Place your order.</td>
<td>Ordering the License</td>
</tr>
</tbody>
</table>

6.3.2.5 Selecting License(s)

You can select licenses for Master protocols and/or utilities.

1. Selecting license(s) for Master protocol(s):

- Under **License Type** click **Master protocols** in the **License** pane.
- Under **Order** check as many licenses must run simultaneously on your device:
  - *One General Master License*
  - *Two General Master Licenses.*

2. And/or select license(s) for utility(utilities):

- In the **License** pane under **License Type** click **Utilities**.
- Under **Order** check the required utility(utilities) *(single or several)*:
  - SYCON.net
  - OPC Server
  - QVis Minimum Size*
  - QVis Standard Size*
  - QVis Maximum Size*
  - CoDeSys Minimum Size**
  - CoDeSys Standard Size**
  - CoDeSys Maximum Size**

2. For *) and **) minimum size, standard size or maximum size can be selected only as an alternative.
6.3.2.6 Ordering Data

1. Device Information

   The *Device Information* required for the order are read from the device and automatically filled in the order.

2. Ordering Data

   Enter the *Ordering Data* into the *License* pane.

   - Enter the *Data to manage the Order* (therefore refer to section *Data to manage the Order (License Information)* on page 42).

**Device Information (Ordering data read from the Device)**

The following ordering data are read from the device and displayed in the *License* pane:

- Manufacturer
- Device number
- Serial number
- Chiptype
- Step (chip revision)
- Romcode revision
- Checksum (checksum of the device data)

The gray fields under *Request Form, please fill out* contain the ordering data read from the device:

<table>
<thead>
<tr>
<th>Name</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manufacturer*</td>
<td>0x0001</td>
</tr>
<tr>
<td>Article number*</td>
<td>1251130</td>
</tr>
<tr>
<td>Serial number*</td>
<td>20007</td>
</tr>
<tr>
<td>Chiptype*</td>
<td>0x0000000001</td>
</tr>
<tr>
<td>Step*</td>
<td>0x0000000000</td>
</tr>
<tr>
<td>Romcode revision*</td>
<td>0x0000000000</td>
</tr>
<tr>
<td>Checksum*</td>
<td>G</td>
</tr>
</tbody>
</table>

*Fields marked with * are mandatory.*

*Figure 21: License Pane - Request Form, please fill out / Device Information*

These ordering data read out from the device are displayed automatically from the device.
Data to manage the Order (License Information)

For your order you must enter the following data to the License pane:

1. **License Type (User Single Device License).**

   ![License Pane - Request Form, please fill out / License Type](image)

   - Select the license type under **Request Form, please fill out > Value**, (for future application, currently only *User Single Device License* can be selected).

2. **Mandatory data** to the order request (editable fields):
   - First Name
   - Surname
   - E Mail (address, to which the license download link shall be send.)
   - Telephone
   - Company
   - Address
   - Country
   - City, State, Zip

   ![License Pane - Request Form, please fill out / Mandatory data](image)

   - Enter all mandatory fields under **Request Form, please fill out > Value** (marked with *).

3. **Additional order data, not mandatory** (editable fields):
   - Fax
   - Customer Number
   - Order Number
   - Value added tax identification number
   - Under **Request Form, please fill out > Value** enter all fields for the additional data, which are not mandatory.
### 6.3.2.7 Ordering the License

Place your order in the License pane. Therefore:

1. Select the **Subsidiary** (4), to which the order shall be send.
2. Place the order:

   - **by E-Mail** (5),
   - **or by Fax** (6)
   - **or by Telephone** (7),
   - **or in a File** (8).

Refer to Section:

- **Ordering the License by E Mail** 44
- **Ordering the License by Fax or by Telephone** 45
- **Exporting License Request to a File** 47

The **Contact Data** of the selected subsidiary are displayed under Position (9), (10) and (11).
Ordering the License by E Mail

You can place your order by e-mail.

Figure 25: License Pane – placing the order by E-mail

- Click E-mail… ⑤.
- The order E-mail License request opens:

  Figure 26: Example: Order E-Mail License request

- The order e-mail License request contains:
  - the E-mail… of the selected subsidiary ③,
  - the automatically generated XML file ⑥ EmailOrderRequest_- [Devicenumber]_[Serialnumber].xml with a summary info of the order information,
  - the Order Address ④,
  - the License Information ⑤,
  - the License Type ⑥,
  - the Device Data ⑦,
  - the ordered Licenses ⑧.

- Send the order e-mail License request.
- The order process is complete.
Ordering the License **by Fax or by Telephone**

You can place your order by Fax or by Telephone.

![Print Fax Form](image1)

![Telephone](image2)

Figure 27: License Pane - placing the order by Fax or by Telephone

- Click **Print Fax Form** or **Telephone…**.
- The summary of the ordering data *PrintOrderRequest_[Devicenumber]_[Serialnumber].html* is opened in a browser window.

**Note:** If your browser does not display the order data or the window **Move Element** or **Copy Element** are displayed, check the safety settings of your system.

---

### netX License Order Form

**Doc Example LTD**

2000th Rd

NY 11417

U.S.

Tel: +122344-100

**Licensee Information**

- **First Name:** John
- **Surname:** Doe
- **e-Mail:** Licensee@doe.com
- **Telephone:** 0911221544-55
- **Fax:** 0911225414-100
- **Customer No.:** 123456789
- **Company:** Doc Example LTD
- **Address:** 2000th Rd
- **Country:** U.S.
- **City Zip:** NY 11417
- **Order Number:** 987654321
- **Tax Ident. Number:**

**License Type**

*User Single Device License*

**Device Information**

- **Manufacturer:** 0x0001
- **Device Number:** 1251100
- **Serial Number:** 20007
- **Chip Type:** 0x00000001
- **Step:** 0x00000000
- **Remote Revision:** 0x00000000
- **License Flags 1:** 0x7f
- **License Flags 2:** 0x0

**Ordered Licenses**

- **Master Protocols**
  - One General Master License
  - SerCon III Master

- **Utilities**
  - SYCON.net

**Date:** __________________________  **Signature:** __________________________

---

Figure 28: Example: Order Data Form PrintOrderRequest
The order data form contains:

- the **Order Address**
- the **License Information**
- the **License Type**
- the **Device Data**
- the **ordered Licenses**

- Print the order data form, sign it and send it by Fax.

  ![Print Fax Form](image)

  *Figure 29: License Pane – Fax Number of the selected Subsidiary*

- Use the Fax number, which is displayed after the subsidiary was selected in the **License** pane.

  Or:

- Keep ready the order data form and communicate the order data via telephone.

  ![Telephone](image)

  *Figure 30: License Pane – Telephone Number of the selected Subsidiary*

- Use the telephone number, which is displayed after the subsidiary was selected in the **License** pane.

- The order process is complete.
6.3.2.8 **Exporting License Request to a File**

If you are working on a process computer without an e-mail client, you can export your order information to a file, save the file to a removable disk and place your order manually via e-mail from a different PC.

![Export License Request](image)

Figure 31: License Pane - Ordering by exported File and E-Mail

- Click **Export License Request...**.
- The window **Browse For Folder** is displayed.
- Choose for or create a new folder on a removable disk.
- Save the automatically generated **XML file EmailOrderRequest - [Devicenumber]_[Serialnumber].xml** with a summary info of the **order information** to this folder.
- Send this file from a PC with an e-mail client manually via e-mail.
- Therefore use an e-mail address, which is displayed after the subsidiary was selected in the **License** pane (see Position Figure License Pane on page 37).
- The order process is complete.
6.3.2.9 How to get the License and transfer it to the Device

**Note:** License files can only be delivered via e-mail. The e-mail contains a link to download the license file.

According to the license you ordered, you will receive an e-mail containing a **Link to download the License File**. This leads to a server PC on which the license file is provided. Using the received link you will have to save the license file on your PC and then transfer the license to your device. If your e-mail client is on another PC as your device, you must save your license file e.g. to an USB stick.

**Steps how to proceed**

1. Save the license file to a PC or a disk.
   - Click to the **Link to download the License File** in the e-mail.
   - Save the license file *.nxl* to a PC or a removable disk.

2. Download the license file to the device.
   - Respectively connect the removable disk with the license file to the PC, which is connected to your device.
   - Click **Download License** in the **License** pane in the configuration software.

   ![Figure 32: License Pane - Download License](image)

   - The File selection window **Open** is displayed.
   - Therein select the license file **netX License Files (*.nxl)**.
   - Click **Open**.
   - The license file is transferred to the device.
   - After this the license is present in the device and is activated with the next device reset.

3. Activate Device Reset

   **Hint:** To activate the license in the first device, a device reset is required.

   - To check whether the license has been activated, follow the steps in section **Which Licenses are present in the Device?** on page 38.
7 Configuring the netHOST Step-By-Step

7.1 Overview

This chapter provides exemplary step-by-step instructions on how to configure a NHST-T100-DP/DPM netHOST as PROFIBUS DP master and how to configure a NHST-T100-EN/PNM as PROFINET IO Controller by using the SYCON.net configuration software provided by Hilscher. The configuration of the netHOST devices for DeviceNet, CANopen, EtherCAT and EtherNet/IP can, in principle, be carried out as described for the PROFIBUS DP and PROFINET IO examples in this chapter — except, of course, for the specific settings of the individual fieldbus/RTE protocols.

Details of the parameters which have to be set for each individual fieldbus or RTE protocol can be found in the operating instruction manuals for the DTM s of the corresponding protocols. These DTM manuals are stored on the netHOST Solutions DVD in the directory Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\[protocol].

During configuration in SYCON.net, you can also open a context-sensitive online help by clicking the Help button in the opened dialog window of the DTM, or by pressing the F1 key on your keyboard.

7.2 Configuring netHOST for Fieldbus Systems with SYCON.net: NHST-T100-DP/DPM Example

In this example for PROFIBUS DP, a pre-configured Hilscher CB-AB32-DPS IO test board serves as Fieldbus slave device.

7.2.1 Prerequisites

- You have installed SYCON.net on your configuration PC.
- You have the user right Maintenance, Planning Engineer or Administrator in SYCON.net.
- The slave devices have been configured properly and you know the required configuration parameters of the slaves. In this example for PROFIBUS DP, you must know the number of bytes of the input/output modules.
- If the slave devices you want to add to the Fieldbus are missing in the device catalog of SYCON.net, you first have to import the device description files of these devices into SYCON.net. Instructions for this can be found in the Importing Device Description Files into SYCON.net chapter on page 95.
- You have assigned a suitable temporary IP address to the netHOST device (see section Assigning Temporary IP Address to netHOST Device on page 24).
- The netHOST device is connected to a voltage supply.
- The configuration PC and the netHOST device are connected to the same local TCP/IP (Ethernet LAN) network.
7.2.2 Step-By-Step Instructions
7.2.2.1 Creating New netHOST Project in SYCON.net

1. Start SYCON.net configuration software.
   ➢ In the Windows Start menu, select All Programs > SYCON.net System Configurator > SYCON.net.
   ➢ A login dialog appears:

   ![Login dialog](image1.png)

   Figure 33: SYCON.net Login

   ➢ Enter your password, then click OK.
   ➢ SYCON.net opens with a new empty project:

   ![Empty project](image2.png)

   Figure 34: Empty Project in SYCON.net
2. Add netHOST device to the configuration project.
   - In the Vendor tab of the Device Catalog (right window), open folder Hilscher GmbH > Master.
   - Then select NHST-T100-DP/DPM device and drag & drop it onto the bus configuration line in the configuration window (middle window):

   ![Figure 35: Add netHOST Device in Configuration Project](image)

   The gateway device appears in the project:

   ![Figure 36: netHOST Device in Configuration Project](image)
3. Save project.
   ➢ In the menu, choose File > Save As to save the netHOST configuration project.

7.2.2.2 Assigning Device to Driver and Configuring Driver

1. Open the netHOST configuration window (i.e. the netHOST DTM).
   ➢ Double-click the netHOST symbol in the bus configuration line or select the netHOST symbol and choose Configuration > Main Settings from the context menu (to open context menu, right-click on the netHOST symbol).
   ➢ The netHOST DTM opens with the Device Assignment dialog window. SYCON.net automatically starts to search for connected devices.

![Device Assignment Dialog](image)

Because the netX Driver (which enables the Ethernet LAN connection to the netHOST device) is not yet acquainted with the IP address of the device, the netHOST is not found for the time being.

2. Select driver.
   ➢ In the Navigation Area, select Settings > Driver.
The **Driver** dialog window opens. It lists all available drivers:

- Make sure the **netX Driver** is selected (check box must be activated).

**Note:** In the netHOST DTM, the netX Driver usually is already selected by default. If this is not the case, activate the check box in front of the netX driver.

- Click **OK** or **Apply**.

3. Set IP address of netHOST in netX Driver.
   - In the **Navigation Area**, select **Settings > Driver > netX Driver**.
   - The **netX Driver** dialog window opens.
   - Select the **TCP Connection** tab:

![Figure 38: Select Driver](image)

![Figure 39: Set IP Address in netX Driver](image)
- Make sure the **Enable TCP Connector** option is selected (check box must be activated).
- Click on **button next to the Select IP Range** drop-down list.
- In the **IP Address** field, enter the IP address which you have assigned to the netHOST device with the **Ethernet Device Configuration Tool** (see Assigning Temporary IP Address to netHOST Device section on page 24).

**Note:** You will find a detailed description of this dialog in the netX Driver Dialog Window section on page 114.

- Click **Save**.

4. Assign netHOST device.
- In the Navigation Area, select **Settings > Device Assignment**.
- The **Device Assignment** dialog window opens.
- In the **Device selection** drop-down list, choose **suitable only** entry.
- Click **Scan**.
- If all prerequisites are fulfilled (see Prerequisites section on page 49) and the IP address has been properly set in the netX Driver, the netHOST device will now be found and displayed in the list.

![Figure 40: Select Device](image)

- Activate the check box in front of the netHOST device.
- Click **Apply**.
Note: You can create and edit a configuration project for the netHOST device without being actually connected to the device via Ethernet LAN. In this case, no netHOST device will be found in the Device Assignment dialog window. For downloading the configuration, however, you eventually need an Ethernet LAN connection to the netHOST device, and then you also need to assign the device in this dialog window.

7.2.2.3 Configuring Ethernet Marshalling

1. Open the configuration window for the Ethernet Marshalling.
   ➢ Select the netHOST symbol, then choose Configuration > Ethernet Marshalling from the context menu (to open context menu, right-click on the netHOST symbol).

![Figure 41: Open Configuration Dialog for Primary Network](image-url)
The General dialog of the **Ethernet Marshalling** configuration opens:

![Figure 42: Setting IP Address (1)](image1)

2. Set IP parameters.

   - In the **Extras** section, uncheck the DHCP option to deactivate the assignment of the IP address by DHCP server. This enables you to set the address parameters manually.
   - The **Enable** check boxes can now be selected.
   - Select **Enable** option for each of the address parameters that you want to configure here.

![Figure 43: Setting IP Address (2)](image2)
Enter the IP address parameters.

**Note:** The IP address which you configure here will be stored “non-volatile” (i.e. permanently) in the netHOST device after download – unlike the temporary address which you before have assigned with the Ethernet Device Configuration Tool. If this new permanent address differs from the old temporary address, and if you later want to re-establish a connection between SYCON.net and the netHOST device after downloading the configuration, you need to enter this new permanent address (which now has become valid) in the netX Driver dialog window (see step 3: “Set IP address of netHOST in netX Driver” in the previous section), thus overwriting the obsolete old temporary IP address assigned by the Ethernet Device Configuration Tool. Otherwise you won’t be able to re-establish a connection between SYCON.net and the new IP address of the netHOST device.

At least during testing, it is recommended to work with a fixed IP address. It is, however, possible to have the netHOST device receive its IP address from a BOOTP or DHCP server utility.

If you choose the BootP or DHCP options in the dialog window by activating the corresponding check boxes, the manually entered address parameters stay (remain) in the dialog fields, but they are not authoritative any longer. Thus, if you later want to re-use the manually entered address parameters, just uncheck BootP or DHCP options and enable the address parameters.

Click **OK** to close the Ethernet Marshalling dialog window.
7.2.2.4 Adding and Configuring Slave Devices in Fieldbus

**Note:** In this manual, the Hilscher CB-AB32-DPS IO test board serves as example of a slave device in the PROFIBUS DP network (secondary network). Should any other device that you might want to add and configure as slave in your Fieldbus not be listed in the Device Catalog of SYCON.net, you have to import the corresponding device description file into SYCON.net. Instructions for this can be found in the Importing Device Description Files into SYCON.net chapter on page 95.

1. Add PROFIBUS DP slave.
   - In the Fieldbus tab of the device catalog (right window), open folder PROFIBUS DPV0 > Slave.
   - Select CB_AB32-DPS device, then drag it into the middle window and drop it onto the line symbolizing the secondary network (next to the netHOST symbol).

   ![Figure 44: Add Slave Device](image)

   The device is displayed as slave in the PROFIBUS (secondary network) line.

2. Configure PROFIBUS DP slave.
   - To open the configuration dialog window, double-click the slave device on the secondary bus line, or select the device, then choose Configuration... from the context menu (to open context menu, right-click on the slave symbol).
The configuration dialog window of the PROFIBUS DP slave opens:

![Figure 45: Configure Slave Device](image)

- Configure the slave device.

Detailed instructions on how to configure a slave device in the fieldbus network can be found in the operating instruction manual of the corresponding slave DTM. The slave DTM manuals are stored on the netHOST Solutions DVD in the directory `Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\[protocol]\Slave Configuration`. For our PROFIBUS DP example, you need the operating instruction manual *Generic Slave DTM for PROFIBUS DP Slave Devices*, DOC031001OIxxEN.

As an alternative, you can open the corresponding online help by clicking the **Help** button in the opened configuration dialog window of the slave DTM, or by pressing the **F1** key on your keyboard.

- Click **OK** to close the dialog window.
- Repeat this process for each slave device in the Fieldbus.
7.2.2.5 Configuring Fieldbus Master

1. Open the configuration dialog window of the PROFIBUS DP master.
   - Select the netHOST symbol, then choose Configuration > PROFIBUS DP Master from the context menu (to open context menu, right-click on the netHOST symbol).
   - The Bus Parameters dialog of the PROFIBUS DP Master configuration window opens:

   ![Figure 46: PROFIBUS DP Master – Bus Parameters](image)

2. Configure PROFIBUS DP bus parameters.
   - Set the bus parameters.

   Detailed instructions on how to configure the master device in the Fieldbus network can be found in the operating instruction manual of the corresponding master DTM. The master DTM manuals are stored on the netHOST Solutions DVD in the directory Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\[protocol].

   For our PROFIBUS DP example, you need the operating instruction manual DTM for Hilscher-PROFIBUS DP Master Devices, DOC070401OIxxEN.

   As an alternative, you can open the corresponding online help by clicking the Help button in the opened configuration dialog window of the slave DTM, or by pressing the F1 key on your keyboard.

   - Click Apply.
3. Define addresses of the stations.
   - In the **Navigation Area**, select **Configuration > Station Table**.
   - The **Station Table** dialog opens:

     ![Figure 47: PROFIBUS DP Slave Station Address](image)

     In the **Station Address** fields, enter an individual station address for each slave device.

     - Click **OK** to close the **PROFIBUS DP Master** configuration dialog.

     You can now save the completed configuration project on your configuration PC, and then download the configuration to the netHOST device.

4. Save project on configuration PC.

   **Note:** Save the project on your configuration PC after you have completed the configuration. Thus, you can later edit the project and reload it into the netHOST device or into a different (e.g., a substitute) device. Configuration projects stored only in a netHOST device cannot be “read back” into SYCON.net.

   - In the menu, choose **File > Save** or **Save as...** to save the configuration project, or click ![save](image) symbol.
7.2.2.6 Loading Configuration into netHOST Device

1. Start SYCON.net.
   - In the Windows Start menu, select **All Programs > SYCON.net System Configurator > SYCON.net**.

2. Open configuration project.
   - In the menu of SYCON.net, choose **File > Open...** to open the project.

3. Download configuration to netHOST.
   - Select netHOST symbol, then choose **Download** from the context menu (to open context menu, right-click on the netHOST symbol).

![SYCON.net - netHOST Project]()

**Figure 48: Download Configuration**

**NOTICE**

**Hazard of device damage by disruption of voltage supply during configuration download!**

Do not interrupt the voltage supply while downloading the configuration to the netHOST. Power failure during a writing process in the file system can cause severe malfunctioning of the device.

- Answer the security question with **Yes**.
- The configuration file is downloaded to the netHOST. After the download has been completed, the netHOST device automatically resets itself.
Note: By default, the start of the bus communication is controlled by the application. In the Master Settings dialog window of the Fieldbus Master DTM you can configure whether the bus communication is to be started automatically by the device itself or whether it is to be started by the application. To open the Fieldbus Master DTM, right-click netHOST symbol, then choose Configuration -> [Fieldbus system] Master) from the context menu.

How to start Fieldbus communication manually in the netHOST Device Test Application is described in section Testing Communication of netHOST for RTE Systems: NHST-T100-EN/PNM Example on page 86.
7.3 Configuring netHOST for RTE Systems with SYCON.net: NHST-T100-EN/PNM Example

In this example for PROFINET IO, a pre-configured PC card CIFX 50-RE/PNS serves as IO Device (slave device) in the RTE network.

7.3.1 Prerequisites

- You have installed SYCON.net on your configuration PC.
- You have the user right Maintenance, Planning Engineer or Administrator in SYCON.net.
- The slave devices have been configured properly and you know the required configuration parameters of the slaves. In this example for PROFINET IO, you must know the “name of station” of each IO Device and the number of bytes of the input/output modules.
- If the slave devices you want to add to the RTE network are missing in the device catalog of SYCON.net, you first have to import the device description files of these devices into SYCON.net. Instructions for this can be found in the Importing Device Description Files into SYCON.net chapter on page 95.
- You have assigned a suitable temporary IP address to the netHOST device (see section Assigning Temporary IP Address to netHOST Device on page 24).
- The netHOST device is connected to a voltage supply.
- The configuration PC and the netHOST device are connected to the same local TCP/IP (Ethernet LAN) network.

Note: Plug-in the Ethernet LAN cable in the single RJ45 socket on the right side of the device (X3 interface).

7.3.2 Step-By-Step Instructions

7.3.2.1 Creating New netHOST Project in SYCON.net

1. Start SYCON.net configuration software.
   - In the Windows Start menu, select All Programs > SYCON.net System Configurator > SYCON.net.
   - A login dialog appears:

   ![SYCON.net User Login](image)

   Figure 49: SYCON.net Login

   - Enter your password, then click OK.
SYCON.net opens with a new empty project:

![Figure 50: Empty Project in SYCON.net](image)

2. Add netHOST device to the configuration project.
   - In the **Vendor** tab of the **Device Catalog** (right window), open folder **Hilscher GmbH > Master**.
Then select **NHST-T100-EN/PNM** device and drag & drop it onto the bus configuration line in the **SYCON.net** configuration window (middle window):

![Figure 51: Add netHOST Device in Configuration Project](image)

The netHOST device appears in the project:

![Figure 52: netHOST Device in Configuration Project](image)
3. Save project.
   ➢ In the menu, choose File > Save As to save the netHOST configuration project.

### 7.3.2.2 Assigning Device to Driver and Configuring Driver

1. Open the netHOST configuration window (i.e. the netHOST DTM).
   ➢ Double-click the netHOST symbol in the bus configuration line or select the netHOST symbol and choose Configuration > Main Settings from the context menu (to open context menu, right-click on the netHOST symbol).
   ➢ The netHOST DTM opens with the Device Assignment dialog window. SYCON.net automatically starts to search for connected devices.

   ![Figure 53: Scanning for Devices in SYCON.net](image)

   Because the netX Driver (which enables the Ethernet LAN connection to the netHOST device) is not yet acquainted with the IP address of the device, the netHOST is not found for the time being.

2. Select driver.
   ➢ In the Navigation Area, select Settings > Driver.
The Driver dialog window opens. It lists all available drivers:

- Make sure the netX Driver is selected (check box must be activated).

**Note:** In the netHOST DTM, the netX Driver usually is already selected by default. If this is not the case, activate the check box in front of the netX driver.

- Click OK or Apply.

3. Set IP address of netHOST in netX Driver.
   - In the Navigation Area, select **Settings > Driver > netX Driver**.
   - The netX Driver dialog window opens.
   - Select TCP Connection tab:

![Figure 55: Set IP Address in netX Driver](image-url)
- Make sure the Enable TCP Connector option is selected (check box must be activated).
- Click on button next to the Select IP Range drop-down list.
- In the IP Address field, enter the IP address which you have assigned to the netHOST device with the Ethernet Device Configuration Tool (see Assigning Temporary IP Address to netHOST Device section on page 24).

**Note:** You will find a detailed description of this dialog in the netX Driver Dialog Window section on page 114.

- Click Save.

4. Assign netHOST device.
- In the Navigation area, select Settings > Device Assignment.
- The Device Assignment dialog window opens.
- In the Device selection drop-down list, choose suitable only entry.
- Click Scan.
- If all prerequisites are fulfilled (see Prerequisites section on page 49) and the IP address has been properly set in the netX Driver, the netHOST device will now be found and displayed in the list.

![Figure 56: Select Device](image-url)
- Activate the check box in front of the netHOST device.
- Click **Apply**.

**Note:** You can create and edit a configuration project for the netHOST device without being actually connected to the device via Ethernet LAN. In this case, no netHOST device will be found in the **Device Assignment** dialog window. For downloading the configuration, however, you eventually need an Ethernet connection to the netHOST device, and then you also need to assign the device in this dialog window.

### 7.3.2.3 Configuring Ethernet Marshalling

1. Open the configuration window for the Ethernet Marshalling.
   - Select the netHOST symbol, then choose **Configuration > Ethernet Marshalling** from the context menu (to open context menu, right-click on the netHOST symbol).

![Figure 57: Open Configuration Dialog for Ethernet Marshalling](image)
The **General** dialog of the **Ethernet Marshalling** configuration opens:

2. Set IP parameters.
   - In the **Extras** section, uncheck the **DHCP** option to deactivate the assignment of the IP address by DHCP server. This enables you to set the address parameters manually.
   - The **Enable** check boxes can now be selected.
   - Select **Enable** option for each of the address parameters that you want to configure here.
Enter the IP address parameters.

**Note:** The IP address which you configure here will be stored “non-volatile” (i.e. permanently) in the netHOST device after download – unlike the temporary address which you before have assigned with the Ethernet Device Configuration Tool. If this new permanent address differs from the old temporary address, and if you later want to re-establish a connection between SYCON.net and the netHOST device after downloading the configuration, you need to enter this new permanent address (which now has become valid) in the netX Driver dialog window (see step 3: “Set IP address of netHOST in netX Driver” in the previous section), thus overwriting the obsolete old temporary IP address assigned by the Ethernet Device Configuration Tool. Otherwise you won’t be able to re-establish a connection between SYCON.net and the new IP address of the netHOST device.

At least during testing, it is recommended to work with a fixed IP address. It is, however, possible to have the netHOST device receive its IP address from a BOOTP or DHCP server utility. If you choose the BootP or DHCP options in the dialog window by activating the corresponding check boxes, the manually entered address parameters stay (remain) in the dialog fields, but they are not authoritative any longer. Thus, if you later want to re-use the manually entered address parameters, just uncheck BootP or DHCP options and enable the address parameters.

Click **OK** to close the dialog window.

### 7.3.2.4 Adding and Configuring IO Devices (Slaves) in RTE Network

**Note:** In this example for PROFINET IO, the Hilscher PC card cifX serves as example of a slave device in the RTE network. The PC card has already been loaded with firmware and a proper IO device configuration; therefore downloading firmware and configuration files to the cifX card are not described here.

Should any other device which you might want to add and configure as slave in your RTE network not be listed in the Device Catalog of SYCON.net, you have to import the corresponding device description file into SYCON.net. Instructions for this can be found in the Importing Device Description Files into SYCON.net chapter on page 95.

1. Add PROFINET IO Device.

   In the Fieldbus tab of the device catalog (right window), open folder PROFINET IO > Slave.
Select **CIFX RE/PNS V3.4.19 – V3.4.x** device, then drag it into the middle window and drop it onto the line symbolizing the RTE network (next to the netHOST symbol).

![Image of SYCON.net configuration software with the CIFX RE/PNS device added to the RTE network]

Figure 60: Add IO Device to RTE Network

The PROFINET IO Device (i.e. the PC Card cifX) is displayed as slave in the RTE network line.
2. Configure PROFINET IO Device.

- To open the configuration dialog window, double-click the slave device on the RTE bus line, or select the device, then choose **Configuration** from the context menu (to open context menu, right-click on the device symbol).

- The **Modules** configuration dialog window of the PROFINET IO Device opens:

![Figure 61: Configure IO Device (1)](image)

- Click **Add Module** button to add a module for input data.
- Click in the **Module** field of the newly added module, then select the number of input bytes of your IO Device from the drop-down list. In this example, the PC card cifX has 16 Bytes Input and 16 Bytes Output data. Therefore select **16 Bytes Input** from the drop-down list.

![Figure 62: Configure IO Device (2)](image)

- Click **Add Module** button again to add a module for the output data.
- Click in the **Module** field of the newly added module, then select **16 Byte Output** from the drop-down list.
Detailed information on how to configure a slave device in the Real-Time Ethernet network can be found in the operating instruction manual of the corresponding slave DTM. The slave DTM manuals are stored on the netHOST Solutions DVD in the directory `Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\[protocol]\[Slave Configuration].

For our PROFINET IO example, you need the operating instruction manual `Generic DTM for PROFINET IO Devices`, DOC060305OIxxEN. As an alternative, you can open the corresponding online help by clicking the Help button in the opened configuration dialog window of the slave DTM, or by pressing the F1 key on your keyboard.

- Click **OK** to close the dialog window.
- You have configured the I/O data of the PROFINET IO Device.

Repeat this process for each slave device in the RTE network.
7.3.2.5 Configuring IO Controller (Master) of RTE Network

Note: In this example you do not need to change the default settings of the IO Controller configuration.

1. Open the configuration dialog window of the PROFINET IO Controller.
   - Select the netHOST symbol, then choose Configuration > PROFINET IO Controller from the context menu (to open context menu, right-click on the netHOST symbol).
   - The Controller Network Settings dialog of the PROFINET IO Controller configuration window opens:

   ![Figure 64: PROFINET IO Controller – Network Settings](image)

2. Check or change (if necessary) the IO Controller settings.
   - Navigate through the configuration dialog windows and check or change individual parameters, if necessary.

Detailed information on how to configure the master device in the RTE network can be found in the operating instruction manual of the corresponding master DTM. The master DTM manuals are stored on the netHOST Solutions DVD in the directory Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\[protocol].

For the PROFINET IO Controller, for instance, you need the operating instruction manual DTM for Hilscher-PROFINET IO-Controller Devices, DOC060302OIxxEN.

As an alternative, you can open the corresponding online help by clicking the Help button in the opened configuration dialog window of the slave DTM, or by pressing the F1 key on your keyboard.
After having finished the configuration, click **Apply**, respectively **OK**.

3. Save project on configuration PC.

**Note:** Save the project on your configuration PC after you have completed the configuration. Thus, you can later edit the project and reload it into the netHOST device or into a different (e.g. a substitute) device. Configuration projects stored only in a netHOST device cannot be “read back” into SYCON.net.

- In the menu, choose **File > Save** or **Save as...** to save the configuration project, or click symbol.

### 7.3.2.6 Loading Configuration into netHOST Device

1. Start SYCON.net.

- In the Windows Start menu, select **All Programs > SYCON.net System Configurator > SYCON.net**.

2. Open configuration project.

- In the menu of SYCON.net, choose **File > Open...** to open the project.

3. Download configuration to netHOST.

- Select netHOST symbol, then choose **Download** from the context menu (to open context menu, right-click on the netHOST symbol).
Hazard of device damage by disruption of voltage supply during configuration download!

Do not interrupt the voltage supply while downloading the configuration to the netHOST. Power failure during a writing process in the file system can cause severe malfunctioning of the device.

- Answer the security question with Yes.
- The configuration file is downloaded to the netHOST. After the download has been completed, the netHOST device automatically resets itself.

**Note:** By default, the start of the communication of the RTE systems PROFINET IO and EtherNet/IP is controlled by the application; EtherCAT communication on the other hand is started automatically by the device. In the **Master Settings** dialog window of the RTE Master DTM you can configure whether the bus communication is to be started automatically by the device itself or whether it is to be started by the application. To open the RTE Master DTM, right-click netHOST symbol, then choose **Configuration -> [RTE system] Master** from the context menu.

For PROFINET IO: open **Controller Settings** dialog window,
for EtherCAT: open **Scanner Settings** dialog window
for EtherCAT: open **General** dialog window,
then set the start of the bus communication according to your needs.

How to start RTE communication manually in the netHOST Device Test Application is described in section **Testing Communication of netHOST for RTE Systems: NHST-T100-EN/PNM Example** on page 86.
8 Testing Communication Step-By-Step

8.1 Testing Communication of netHOST for Fieldbus: NHST-T100-DP/DPM Example

This chapter describes how to use the Hilscher netHOST Device Test Application to test the bus communication of the netHOST acting as master in a PROFIBUS DP network.

8.1.1 Prerequisites

- You have inserted the netHOST Solutions DVD (on which the netHOST Device Test Application is stored) into the DVD drive of your Windows PC/notebook. Alternatively, you can copy the netHOST Test folder (stored on the DVD in the Setups & Drivers directory) from the DVD to a local drive of your Windows PC/notebook.
- The Windows PC/notebook and the netHOST device are connected to the same Ethernet LAN.
- The netHOST device and the fieldbus slave devices are connected to the Fieldbus, are properly configured and supplied with voltage.

8.1.2 Step-By-Step Instructions

1. Start netHOST Device Test Application.
   - Insert the netHOST Solutions DVD into your local DVD ROM drive.
   - The netHOST Solutions start screen opens.
   - In the menu of the start screen, choose Run Windows Test Application.

     Note: As an alternative, you can also start the Test Application by double-clicking the netHOST.exe file stored in the netHOST Test folder.

   - netHOST Device Test Application opens.
2. Check TCP/IP settings of the netX Driver.
   - In the menu, choose **Device > Setup**.
   - The **Connector Configuration** dialog opens.
   - Choose **TCP Connection** tab:

   ![Figure 67: TCP Connection netX Driver](image)

   - Check whether the **IP Address** field displays the actual address of the netHOST. If not, enter the correct address.

   **Note:** The netHOST Device Test Application uses the same netX Driver parameters as SYCON.net. If you have already configured the right IP address in the **netX Driver** dialog window in SYCON.net, this address is also displayed and taken over by the netHOST Device Test Application.

   - Click **OK**.
   - The **Connector Configuration** dialog closes.
3. Open communication channel.
   - In the menu, choose **Device > Open**.
   - The Test Application establishes an Ethernet connection to the netHOST. This may take a few seconds. Afterwards, the **Channel Selection** dialog window opens:

```
Figure 68: Channel Selection in netHOST Device Test Application
```

- In the navigation tree on the left side, select **Channel1** entry. This is the channel of the fieldbus master, in this case the PROFIBUS DP master.

**Important:** Please note that in netHOST devices for **Fieldbus** (NHST-T100-DP/DPM, NHST-T100-CO/COM and NHST-T100-DN/DNM), the communication stack of the Fieldbus master is always located in **Channel 1**.

On the other hand, in netHOST devices for **Real-Time Ethernet** systems (NHST-T100-EN/PM, NHST-T100-EN/ECM and NHST-T100-EN/EIM), the communication stack of the RTE master is always located in **Channel 0**.

- In the right part of the dialog window, the device parameters of the connected netHOST are displayed.

**Note:** You can check whether you are connected to the right device by comparing the number indicated in the **Serial Number** field with the serial number printed on the device label of the netHOST.

- Click **Open**.
- The **Channel Selection** dialog window closes. The opened channel afterwards is displayed in the header of the netHOST Device Test Application.
4. Start bus communication.
   ➢ In the menu, choose **Device > Bus State**.
   ➢ The **Bus State Test** dialog window opens:

   ![Bus State Test](image)

   *Figure 69: Bus State Test in netHOST Device Test Application*

   ➢ In the **New Bus State** drop-down list, select **Bus ON** option.
   ➢ Click **Set Bus State**.
   ➢ The fieldbus communication is being started.

5. Read and write I/O data.
   ➢ In the menu, choose **Data Transfer > I/O Data**.
   ➢ The **Process Data I/O Image** dialog window opens:

   ![I/O Data](image)

   *Figure 70: I/O Data in netHOST Device Test Application*

   ➢ In the **Length** field of the **Process Data Input Image** area, enter the number of bytes to be displayed.
   ➢ Then click into the **Data** field.
Make sure that one or several slave devices belonging to the secondary network (i.e. slaves in the fieldbus) produce output signals, which then in turn will be displayed as incoming data in the **Data** field in the **Process Data Input Image** area of the Test Application. In our configuration example using the **CB-AB32-DPS IO test board** as fieldbus slave device, you can, for instance, press the **S1** button on the test board.

The signal of the slave device is being displayed in the **Data** field.

![Figure 71: Displaying Input Data in the netHOST Device Test Application](image)

In the **Data** field of the **Process Data Output Image** area, enter output data that can be sent to the slave device and trigger an event there. In our configuration example using the **CB-AB32-DPS IO test board** as fieldbus slave device for instance, you can enter the value **02 00**.

Then click **Update**.

![Figure 72: Entering Output Data in the netHOST Device Test Application](image)

At the slave device, the corresponding Bits are being received. (In our configuration example using the **CB-AB32-DPS IO test board** as fieldbus slave device for instance, the **OUT LED at S2** lights up.)
6. End testing.
   - In the menu, choose Device > Bus State.
   - The Bus State Test dialog window opens.
   - In the New Bus State drop-down list, select Bus OFF option, then click Set Bus State.
   - In the menu, choose Device > Close to close the communication channel.
   - In the menu, choose File > Quit to exit the netHOST Device Test Application.
8.2 Testing Communication of netHOST for RTE Systems: NHST-T100-EN/PNM Example

This chapter describes how to use the Hilscher netHOST Device Test Application to test the bus communication of the netHOST acting as IO Controller in a PROFINET network. In this example a PC card CIFX 50-RE/PNS is used as IO device and the cifX Test Application (which is part of the cifX driver installed on the PC hosting the cifX card) serves as slave application.

8.2.1 Prerequisites

- You have inserted the netHOST Solutions DVD (on which the netHOST Device Test Application is stored) into the DVD drive of your Windows PC/notebook. Alternatively, you can copy the netHOST Test folder (stored on the DVD in the Setups & Drivers directory) from the DVD to a local drive of your Windows PC/notebook.
- The Windows PC/notebook and the netHOST device are connected to the same local Ethernet LAN.
- The netHOST device and the slave devices are connected to the Real-Time Ethernet network, are properly configured and supplied with voltage.
- For this example you need a CIFX 50-RE/PNS serving as IO device and the cifX Test Application (which is part of the cifX driver installed on the PC hosting the cifX card).

8.2.2 Step-By-Step Instructions

1. Start netHOST Device Test Application.
   - Insert the netHOST Solutions DVD into your local DVD ROM drive.
   - The netHOST Solutions start screen opens.
   - In the menu of the start screen, choose Run Windows Test Application.

   **Note:** As an alternative, you can also start the Test Application by double-clicking the netHOST.exe file stored in the netHOST Test folder.

   - netHOST Device Test Application opens.
2. Check TCP/IP settings of the netX Driver.
   ➢ In the menu, choose Device > Setup.
   ➢ The Connector Configuration dialog opens.
   ➢ Choose TCP Connection tab:

   ![TCP Connection netX Driver](image)

   Figure 74: TCP Connection netX Driver

   ➢ Check whether the IP Address field displays the actual address of the netHOST. If not, enter the correct address.

   **Note:** The netHOST Device Test Application uses the same netX Driver parameters as SYCON.net. If you have already configured the right IP address in the netX Driver dialog window in SYCON.net, this address is also displayed and taken over by the netHOST Device Test Application.

   ➢ Click OK.
   ➢ The Connector Configuration dialog closes.
3. Open communication channel.
   - In the menu, choose **Device > Open**.
   - The Test Application establishes an Ethernet connection to the netHOST. This may take a few seconds. Afterwards, the **Channel Selection** dialog window opens:

   ![Figure 75: Channel Selection in netHOST Device Test Application](image)

   - In the navigation tree on the left side, select **Channel0** entry. This is the channel of the RTE master, in this case the PROFINET IO Controller.

   **Important:** Please note that the communication stack of the RTE master in netHOST devices for Real-Time Ethernet systems (NHST-T100-EN/PNM, NHST-T100-EN/ECM and NHST-T100-EN/EIM) is always located in **Channel 0**.

   On the other hand, in netHOST devices for Fieldbus (NHST-T100-DP/DPM, NHST-T100-CO/COM and NHST-T100-DN/DNM), the Fieldbus master is always located in **Channel 1**.

   - In the right part of the dialog window, the device parameters of the connected netHOST are displayed.

   **Note:** You can check whether you are connected to the right device by comparing the number indicated in the **Serial Number** field with the serial number printed on the device label of the netHOST.

   - Click **Open**.
   - The **Channel Selection** dialog window closes. The opened channel afterwards is displayed in the header of the netHOST Device Test Application.
4. Start bus communication.
   ➢ In the menu, choose **Device > Bus State**.
   ➢ The **Bus State Test** dialog window opens:

   ![Bus State Test in netHOST Device Test Application](image)

   Figure 76: Bus State Test in netHOST Device Test Application

   ➢ In the **New Bus State** drop-down list, select **Bus ON** option.
   ➢ Click **Set Bus State**.
   ➢ Communication of the RTE network is being started.

5. Read and write I/O data.
   ➢ In the menu, choose **Data Transfer > I/O Data**.
   ➢ The **Process Data I/O Image** dialog window opens:

   ![I/O Data in netHOST Device Test Application](image)

   Figure 77: I/O Data in netHOST Device Test Application
In the **Length** field of the **Process Data Input Image** area, enter the number of bytes to be displayed.

Then click into the **Data** field.

**Note:** Make sure that one or several slave devices belonging to the RTE network) produce output signals, which then in turn will be displayed as incoming data in the **Data** field in the **Process Data Input Image** area of the Test Application. Using the PC card CIFX 50-RE/PNS as IO Device, the following steps describe how to use the **cifX Test Application** (which is part of the cifX driver installed on the PC hosting the cifX card) for this.

6. **Open the cifX Test Application** on your PC.
   - In the Windows **Start** menu of the PC hosting your PC card cifX, choose **Control Panel > cifX Test**.
   - The **cifX Test Application** opens:

   ![cifX Test Application](image)

   *Figure 78: Start cifX Test Application*

7. Open connection to PC Card cifX in cifX Test Application.
   - In the menu, choose **Device > Open**.
The cifX Test Application establishes a connection to the PC card via cifX driver and PCI interface. After a while, the Channel Selection dialog box opens:

- In the left part of the dialog box, select **Channel0**. This is the channel of the PROFINET IO Device.
- Click **Open** button.
- The **Channel Selection** dialog box closes. The header of the **cifX Test Application** now displays the selected channel:

![Figure 79: Channel Selection Dialog in cifX Test Application](image)

![Figure 80: cifX Test Application After Channel Selection](image)
8. Send output data.
   - In the menu of the cifX Test Application, choose **Data Transfer > I/O Data**.
   - The **Process Data I/O Image** dialog window opens:

   ![I/O Data Dialog in cifX Test Application (1)](image)

   - In the **Data** field of the **Process Data Output Image** area, enter output data that can be sent to the PROFINET IO Controller (i.e. the netHOST) in order to be displayed in the netHOST Device Test Application.

   ![I/O Data Dialog in cifX Test Application (2)](image)

   - After having entered the output data, click **Update**.
   - The data is sent from the IO Device (i.e. the PC card cifX) to the IO Controller (i.e. the netHOST) via PROFINET network.
9. Read I/O data from IO Device in netHOST Device Test Application.
   - Change to the netHOST Device Test Application.
   - The incoming data from the IO Device is displayed in the **Data** field in the **Process Data Input Image** area:

   ![Figure 83: Displaying Incoming Data in netHOST Device Test Application](image)

10. Send Output data from IO Controller to IO Device.
   - In the **Data** field of the **Process Data Output Image** of the netHOST Device Test Application, enter output data that can be sent to the IO Device.
   - Click **Update** Button.

   ![Figure 84: Entering Output Data in netHOST Device Test Application](image)
11. Display input data in cifX Test Application.
   ➢ Change to the cifX Test Application.
   ➢ In the **Length** field of the **Process Data Input Image** area, enter the number of bytes to be displayed. Then click into the **Data** field.
   ➢ The incoming signals of the IO Controller are being displayed in the **Data** field:

   ![Figure 85: Displaying Input Data in cifX Test Application](image)

12. End testing.
   ➢ In the menu of the netHOST Device Test Application, choose **Device > Bus State**.
   ➢ The **Bus State Test** dialog window opens.
   ➢ In the **New Bus State** drop-down list, select **Bus OFF** option, then click **Set Bus State**.
   ➢ In the menu, choose **Device > Close** to close the communication channel.
   ➢ In the menu, choose **File > Quit** to exit the netHOST Device Test Application.
9 Importing Device Description Files into SYCON.net

This section is only relevant to you if the slave device, which you want to add to your netHOST configuration project in SYCON.net, is not listed in the device catalog of SYCON.net. In this case, you have to import the device description file of the slave device into SYCON.net. To do so, proceed as follows:

- Open your netHOST configuration project in SYCON.net.
- In the SYCON.net menu, choose Network > Import Device Descriptions…
- The following dialog window opens:

Figure 86: Import Device Description File (PROFIBUS GSD Example)

- In the Files of type drop-down list, select the appropriate file type for the fieldbus/RTE system.
- Then navigate to the directory where the device description file is stored.
- All device description files fitting the chosen type of fieldbus/RTE system are displayed in the dialog window.
- Select the appropriate file, then click Open.
- Answer the security question, whether you want to reload the catalog, with Yes.
- You have imported the device description file into SYCON.net, and you can now add the device to the secondary network in your configuration project.
10 Updating Firmware with SYCON.net

10.1 Overview

With the exception of the NHST-T100-EN device (order no.: 1890.800), all netHOST devices are shipped with their firmware already loaded. In case updating the firmware of the netHOST becomes necessary, this chapter describes how to use the SYCON.net configuration software to do so. The NHST-T100-DP/DPM serves as example device in this chapter.

Note that any configuration file and IP address stored in the netHOST device will be erased by the firmware update. The device falls back to its default 0.0.0.0 IP address, therefore you have to re-assign an IP address to the netHOST device with the Ethernet Device Configuration Tool before you can download a new configuration with SYCON.net (see Assigning Temporary IP Address to netHOST Device section on page 24).

Note: Updating firmware with SYCON.net as described in this chapter is only possible if a firmware is running in the netHOST device. If the firmware inside the device is defective or altogether missing, you have to perform a so-called “firmware recovery” by using an SD memory card or a USB connection. Instructions on this can be found in the user manual netHOST NHST-T100 – LAN controlled master devices for Fieldbus and Real-Time Ethernet networks in the Firmware recovery chapter.

10.2 Prerequisites for Updating Firmware with SYCON.net

- You have installed SYCON.net on your configuration PC.
- You have inserted the netHOST Solutions DVD into your local DVD drive or have access to the firmware file intended for download (e.g. you have stored the file on your configuration PC).
- The configuration PC and the netHOST device are connected to the same local Ethernet network.
- The netHOST device is connected to a voltage supply.
- You know the IP address of the netHOST device.
10.3 Step-By-Step Instructions for Updating Firmware with SYCON.net

1. Start SYCON.net configuration software.
   - In the Windows Start menu, select All Programs > SYCON.net System Configurator > SYCON.net.
   - A login dialog appears:

   ![SYCON.net User Login](image)

   - Enter your password, then click OK.
   - SYCON.net opens with a new empty project:

   ![Empty Project in SYCON.net](image)
2. Open existing netHOST project or create a new project.

Note: To download the firmware to the netHOST, you can use your already existing configuration project. If you don’t have access to the old configuration project file, you can create a provisional new project, consisting only of the netHOST symbol, and use this makeshift project to establish an online connection and download the firmware file to the device.

- In the menu, choose File > Open... to open an existing netHOST project.

OR

- In the Vendor tab of the Device Catalog (right window), open folder Hilscher GmbH > Master. Then select the netHOST device (in this example the NHST-T100-DP/DPM) and drag & drop it onto the bus configuration line in the middle window.

3. Open the netHOST configuration window (i. e. the netHOST DTM).

- Double-click the netHOST symbol in the bus configuration line, or select the netHOST symbol and choose Configuration > Main Settings from the context menu (to open context menu, right-click on the netHOST symbol).

  If you are using an existing netHOST project (for which the configuration of the driver and the device assignment had already taken place) the netHOST DTM now opens with the Settings dialog window, which features the download function. In this case, you can directly proceed with step 4 and start downloading the firmware.

OR

  If you have just now created a new project, the netHOST DTM opens with the Device Assignment dialog window and automatically starts to search for connected devices. In this case, you first have to assign the device and configure the driver before you can proceed to download the firmware in the Settings dialog window. Information on how to assign the device and configure the driver can be found in the Assigning Device to Driver and Configuring Driver section on page 52.
   - In the **Navigation Area**, select **Configuration > Settings**.
   - The **Settings** dialog window opens:
     - Click the **Browse** button next to the **Available Firmware** field, in order to search for the appropriate firmware file.
The **Select Firmware File** dialog opens:

![Select Firmware File Dialog in SYCON.net](image)

Navigate to the directory where the firmware file is stored. Firmware files are stored on the netHOST Solutions DVD in the `Firmware\netHOST` directory.

The subsequent table indicates which file belongs to which device:

<table>
<thead>
<tr>
<th>netHOST device</th>
<th>Protocol (Fieldbus or RTE)</th>
<th>Firmware file</th>
</tr>
</thead>
<tbody>
<tr>
<td>NHST-T100-DP/DPM</td>
<td>PROFIBUS DP Master</td>
<td>FT20V010.NXF</td>
</tr>
<tr>
<td>NHST-T100-CO/COM</td>
<td>CANopen Master</td>
<td>FT20V040.NXF</td>
</tr>
<tr>
<td>NHST-T100-DN/DNM</td>
<td>DeviceNet Master</td>
<td>FT20V060.NXF</td>
</tr>
<tr>
<td>NHST-T100-EN/PNM</td>
<td>PROFINET IO Controller</td>
<td>FT20C0V0.NXF</td>
</tr>
<tr>
<td>NHST-T100-EN/ECM</td>
<td>EtherCAT Master</td>
<td>FT20E0V0.NXF</td>
</tr>
<tr>
<td>NHST-T100-EN/EIM</td>
<td>EtherNet/IP Scanner</td>
<td>FT20G0V0.NXF</td>
</tr>
</tbody>
</table>

Table 16: netHOST Firmware

Select the appropriate firmware file, then click **Open**.
Back in the **Settings** dialog window, the selected firmware file is now displayed in the **Available Firmware** field:

![Figure 91: Firmware Download in SYCON.net](image)

5. Download firmware to netHOST device.
   - In the **Available Firmware** field, select the firmware file.
   - Class and version of the software are displayed.
   - Check whether you have selected the appropriate firmware file.

   **NOTICE**

   **Hazard of device damage by disruption of voltage supply during firmware update!**

   Do not interrupt the voltage supply while updating the firmware of the netHOST. Power failure during a writing process in the file system can cause severe malfunctioning of the device.

   - If you have selected the appropriate firmware file, click **Download**, to start downloading the file to the netHOST device.
   - The firmware is downloaded to the netHOST.
**Note:** Any configuration file and IP address stored in the netHOST device will be erased by the firmware download. The device falls back to its default 0.0.0.0 IP address, therefore you have to re-assign an IP address to the netHOST device afterwards with the **Ethernet Device Configuration** Tool. Instructions for this can be found in the **Assigning Temporary IP Address to netHOST Device** section on page 24.

- To close the netHOST DTM, click **OK** or **Cancel**.
11 Using SD Memory Card to Copy Configuration Data into Spare netHOST Devices

11.1 Overview

With the Memory Card Management function of the netHOST DTM in SYCON.net, you can copy an already downloaded configuration together with the firmware and the IP address from the internal load memory of the netHOST device onto an SD memory card, which has been inserted into the netHOST device. Thus, you can “backup” this data to an external storage medium. Afterwards, you can remove the SD memory card from the netHOST device, insert it into other devices and thus copy the data into their internal load memory.

By this method, you can easily bring several devices to an identical state of configuration (i.e. “clone” a primary device) without having each time to establish an online connection between the configuration PC (respectively SYCON.net) and the individual devices.

This can be useful, e.g., if you want to prepare an identical “spare” device.

This chapter describes this procedure using the NHST-T100-DP/DPM as example device.

11.2 Prerequisites

- SD memory card, FAT16 formatted.

**Note:** The SD memory card is not included in the delivery of the netHOST device, but can be obtained from Hilscher, part number 1719.003.

- A configuration has been downloaded to the netHOST device.
- The Windows PC/Notebook with SYCON.net and the netHOST device are connected to the same local Ethernet network.
- The netHOST device is connected to a voltage supply.

11.3 Step-By-Step Instructions

1. Start **SYCON.net** configuration software.
   - In the Windows Start menu, select **All Programs > SYCON.net System Configurator > SYCON.net**.
   - A login dialog appears:

![SYCON.net User Login](image)

**Figure 92: SYCON.net Login**

- Enter your password, then click **OK**.
SYCON.net opens with a new empty project:

Figure 93: Empty Project in SYCON.net

2. Open existing netHOST project or create a new project.

**Note:** You can use your already existing configuration project to establish an online connection between SYCON.net and the netHOST device, and to open the Memory Card Management dialog. If you don’t have access to the old configuration project file, you can create a provisional new project, consisting only of the netHOST symbol, and use this makeshift project to establish the online connection.

- In the menu, choose **File > Open...** to open an existing netHOST project.

**OR**

- In the **Vendor** tab of the Device Catalog (right window), open folder **Hilscher GmbH > Master**. Then select **NHST-T100-DP/DPM** device and drag & drop it onto the bus configuration line in the middle window.

3. Open the netHOST configuration window (i.e. the netHOST DTM).

- Double-click the netHOST symbol in the bus configuration line, or select the netHOST symbol and choose **Configuration > Main Settings** from the context menu (to open context menu, right-click on the netHOST symbol).

- If you are using an existing netHOST project, for which the configuration of the driver and the device assignment had already taken place, the netHOST DTM now opens with the **Settings** dialog window. In this case, you can directly proceed with **step 4**.
OR

If you have just now created a new project, the netHOST DTM opens with the **Device Assignment** dialog window and automatically starts to search for connected devices. In this case, you first have to assign the device and configure the driver before you can use the **Memory Card Management** dialog window to access the SD memory card inserted in the netHOST device. Information on how to assign the device and configure the driver can be found in the **Assigning Device to Driver and Configuring Driver** section on page 52.

4. Copy configuration data from netHOST device to SD memory card.
   - In the **Navigation Area**, select **Configuration > Memory Card Management**.
   - The **Memory Card Management** dialog window opens. If no SD memory card has been inserted into the netHOST device, the **Folder** field in the **Directory** area of the dialog window displays the file system of the internal load memory of the netHOST device.

   ![Memory Card Management of the netHOST DTM](image)

   *Figure 94: Memory Card Management of the netHOST DTM*

   - Insert the SD memory card into the netHOST device.
   - In order to refresh the display, close the **Memory Card Management** dialog window, then open it again.
After having inserted the SD memory card into the netHOST device, the **Folder** field in the **Directory** area of the dialog window displays the file system of the internal load memory of the netHOST device. Below that, the file system of the SD memory card is displayed. Furthermore, the **Restore** and **Backup** buttons are now active and can be used:

![Figure 95: Memory Card Management After Inserting SD Memory Card](image)

- Click **Backup** to copy the data stored in the internal load memory of the netHOST to the SD memory card.
- The data is copied to the SD memory card and is then displayed below **SDMMC:\Backup** in the **Folder** field:

![Figure 96: Memory Card Management After Backup to SD Memory Card](image)
5. Copy data from SD memory card to spare netHOST device.
   - Remove the SD memory card from the original netHOST device.
   - Insert the SD memory card into the spare device.
   - Connect spare device to voltage supply or briefly disconnect voltage supply (in case the device had already been connected to voltage supply).

   The spare netHOST device then loads the data from the SD memory card into its own internal load memory. While loading, the SYS LED quickly alternates between green and yellow for approximately eight seconds, then shows steady yellow for approximately ten seconds, then is switched off for a short while before it finally shows steady green light. The device automatically starts the loaded firmware and the configuration.

   - Remove the SD memory card from the netHOST device.

   - Click OK to close the netHOST DTM.
   - Exit SYCON.net.
12 Description of the netHOST DTM

12.1 Overview

The SYCON.net configuration software consists of an FDT frame application (FDT = Field Device Tool) and individual DTMs (Device Type Managers). DTMs are software modules with a graphical user interface for configuring a certain device within the FDT frame application. The DTM contains the specific device and protocol parameters needed for configuration.

This chapter describes the control elements and parameters of the netHOST DTM contained in SYCON.net.

SYCON.net provides a context-sensitive online help for the DTM which can be called up in the opened DTM by clicking the Help button or by pressing the F1 key on your keyboard.

12.2 Description of the GUI

This section describes the structure of the graphical user interface (GUI) of the netHOST DTM. The GUI is divided into five areas:

![Figure 97: GUI of the netHOST DTM](image)

**General Device Information**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>IO Device</td>
<td>Name of the device</td>
</tr>
<tr>
<td>Vendor</td>
<td>Vendor name of the device</td>
</tr>
<tr>
<td>Device ID</td>
<td>Identification number of the device</td>
</tr>
<tr>
<td>Vendor ID</td>
<td>Identification number of the vendor</td>
</tr>
</tbody>
</table>

Table 17: General Device Information
Navigation Area

In the navigation area, you can open individual dialog windows of the DTM by clicking on an entry in the navigation tree. The entries are grouped into different categories and folders.

Note that the categories/folders displayed in this area depend on whether there is an active online connection between SYCON.net and the netHOST device. If the netHOST DTM in SYCON.net has an online connection to the netHOST device, only the dialog windows for Diagnosis will be offered in the navigation area. If there is no active online connection, only the dialog windows belonging to the Settings and Configuration categories will be displayed here.

By clicking on the button, you can hide the navigation area. By clicking the control element on the bottom left side of the currently opened dialog window, you can re-open the navigation area.

Dialog Pane (main area on the right side)

The Dialog Pane displays the dialog windows which have been selected in the navigation area. If there is no active online connection, the dialog windows for Settings and Configuration can be chosen here:

<table>
<thead>
<tr>
<th>Dialog window</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Settings</td>
<td></td>
</tr>
<tr>
<td>Driver</td>
<td>In the Driver dialog window, you can select a driver from the drivers list.</td>
</tr>
<tr>
<td></td>
<td>For further information, refer to Driver Dialog Window section on page 113.</td>
</tr>
<tr>
<td>netX Driver</td>
<td>In the netX Driver dialog window, you can configure the driver enabling communication between the DTM in SYCON.net and the netHOST device. For instance, you have to specify the IP address of the netHOST device here. For further information, refer to netX Driver Dialog Window section on page 114.</td>
</tr>
<tr>
<td>Device Assignment</td>
<td>In the Device Assignment dialog window, you have to select the device which you want to configure, and assign it to the driver. For further information, refer to Device Assignment Dialog Window section on page 116.</td>
</tr>
<tr>
<td>Configuration</td>
<td></td>
</tr>
<tr>
<td>Settings</td>
<td>In the Settings dialog window, you can update the firmware of the netHOST, if necessary. You can also define a name for the configuration. For further information, refer to Settings Dialog Window section on page 119.</td>
</tr>
<tr>
<td>Memory Card Management</td>
<td>In the Memory Card Management dialog window, you can save the firmware and the configuration file from the netHOST to an SD memory card. You can also restore the saved files from memory card to netHOST device here. For further information, refer to Memory Card Management Dialog Window section on page 121.</td>
</tr>
</tbody>
</table>
In the **Licensing** dialog window, you can check which license is present in the netHOST device. You can also order a license from Hilscher and download the license to the netHOST device. For further information, refer to **Licensing Dialog Window** section on page 123.

**Table 18: Dialog Windows in the Dialog Pane**

If there is an active online connection, the dialog windows for **Diagnosis** are displayed here instead of the **Settings** and **Configuration** dialog windows described above. For a description of the **Diagnosis** dialog windows, see **Windows of the “Diagnosis” Group** section on page 124.

**4 OK, Cancel, Apply and Help buttons**

<table>
<thead>
<tr>
<th>Meaning</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>OK</strong></td>
<td>To confirm your latest settings, click <strong>OK</strong>. All changed values will be applied on the frame application database. The dialog then closes.</td>
</tr>
</tbody>
</table>
| **Cancel** | To cancel your latest changes, click **Cancel**. Answer to the safety query **Configuration data has been changed. Do you want to save the data?** by **Yes**, **No** or **Cancel**.  
  **Yes**: The changes are saved or the changed values are applied on the frame application database. The dialog then closes.  
  **No**: The changes are not saved or the changed values are not applied on the frame application database. The dialog then closes.  
  **Cancel**: Back to the DTM. |
| **Apply** | To confirm your latest settings, click **Apply**. All changed values will be applied on the frame application database. The dialog remains opened. |
| **Help** | To open the DTM online help, click **Help**. |

**Table 19: Standard Command Buttons in the netHOST DTM**
The **Status Bar** displays information about the current state of the DTM. The current activity, e.g. download, is signaled graphically via icons in the status bar.

**Table 20: Status Bar Icons [1]**

<table>
<thead>
<tr>
<th>Status Field</th>
<th>Icon / Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 DTM Connection States</td>
<td>![Disconnected] Icon closed = Device is online ![Data Set] Icon opened = Device is offline</td>
</tr>
<tr>
<td>2 Data Source States</td>
<td>![Data set] The displayed data are read out from the instance data set (database). ![Device] The displayed data are read out from the device.</td>
</tr>
<tr>
<td>3 States of the instance Date Set</td>
<td>![Valid Modified] Parameter is changed (not equal to data source).</td>
</tr>
<tr>
<td>4 Changes directly made on the Device</td>
<td>![Load/configure diagnosis parameters] Diagnosis is activated.</td>
</tr>
<tr>
<td>6 Device Diagnosis Status</td>
<td>![Save operation succeeded] The save operation has been successful. Further messages due to successful handling of device data. ![Firmware Download] Firmware Download is running ![Save operation failed] The save operation has failed. Further fail operation messages due to incorrect communication due to malfunction in the field device or its peripherals.</td>
</tr>
</tbody>
</table>

**Figure 99: Status Bar – Status Fields 1 to 6**

**Figure 100: Status Bar Display Examples**
Table lines
In the DTM dialog pane table lines can be selected, inserted or deleted.

<table>
<thead>
<tr>
<th>Meaning</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>First Line</td>
<td>To select the first line of a table</td>
</tr>
<tr>
<td>Previous Line</td>
<td>To select the previous line of a table</td>
</tr>
<tr>
<td>Next Line</td>
<td>To select the next line of a table</td>
</tr>
<tr>
<td>Last Line</td>
<td>To select the last line of a table</td>
</tr>
<tr>
<td>Create a new Line</td>
<td>Inserts new lines into the table.</td>
</tr>
<tr>
<td>Delete selected Line</td>
<td>Deletes the selected line from the table.</td>
</tr>
</tbody>
</table>

Table 21: Selecting, inserting, deleting Table Line

12.3 Dialog Windows of the “Settings” Group
12.3.1 Overview
This section describes the dialog windows belonging to the Settings category of the netHOST DTM.

Note: You need the user right Maintenance, Planning Engineer or Administrator in order to be allowed to edit the dialog windows belonging to the Settings category. For information about user rights for the netHOST DTM, see User Rights for the netHOST DTM section on page 155.

Figure 101: Settings in netHOST DTM
12.3.2 Driver Dialog Window

In the **Driver** dialog window, you can select the driver needed for establishing a connection between SYCON.net and the field device which is to be configured. For the netHOST, you need the netX Driver. The netX Driver is included in the SYCON.net installation and already pre-selected in the netHOST DTM.

- To open the **Driver** dialog window, click **Driver** entry in the **Settings** folder in the **Navigation Area** of the opened netHOST DTM.

![Driver List](image)

**Figure 102: Driver List**

**Note:** The **Driver** dialog window lists all Hilscher drivers installed on your system, which means that also drivers not relevant for the netHOST might be displayed here.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Driver</td>
<td>Name of the driver</td>
</tr>
<tr>
<td>Version</td>
<td>Version of the driver</td>
</tr>
<tr>
<td>ID</td>
<td>ID of the driver (driver identification)</td>
</tr>
</tbody>
</table>

**Table 22: Driver Selection List Parameters**
12.3.3 netX Driver Dialog Window

The Driver folder in the Navigation Area lists all drivers that can be configured by a configuration dialog. The netX Driver dialog window allows you to configure the USB/RS232 and the TCP connection of the netX Driver to the netHOST device.

![Figure 103: netX Driver]

**Note:** The USB/RS232 interface of the netX Driver is not needed for configuring the netHOST.

- To configure the netX Driver, select Settings > Driver > netX Driver in the Navigation Area of the opened netHOST DTM.
- The netX Driver dialog window opens.
- Select TCP Connection tab:

![Figure 104: Configure TCP/IP Connection in netX Driver]

The subsequent table provides a description of the parameters:
### Description of the netHOST DTM

#### Configuration of LAN Controlled Master Devices

**Parameter** | **Meaning** | **Range of Value / Default Value**
--- | --- | ---
Enable TCP Connector (Restart of ODM required) | checked: The netX Driver can communicate via the TCP/IP interface. 
unchecked: The netX Driver can not communicate via the TCP/IP interface. 
If the check mark for Enable TCP Connector is set or removed, then the ODM server must be restarted\(^1\), to make the new setting valid. | checked, unchecked; Default: unchecked

\(^1\) Restart the ODM server via the ODMV3 Tray Application:
- In the foot line click on using the right mouse key.
- In the context menu select Service > Start.

Select IP Range | Via Select IP Range already created IP ranges can be selected. 
Via an additional IP range can be added. 
Via an IP range can be deleted. | 

Scan Timeout [ms] | With Scan Timeout can be set, how long to wait for a response while a connection is established. | 10 \(\ldots\) 10000 [ms]; Default: 100 ms

IP Range Configuration

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Meaning</th>
<th>Range of Value / Default Value</th>
</tr>
</thead>
</table>
| Disable IP Range | checked: No connection. 
unchecked: The netX Driver tries to establish a connection using the configured TCP/IP interface. | checked, unchecked (Default) |
| IP Address (left) | Enter the IP address of the device, (if Use IP Range is not checked). 
Enter the start address of the IP scanning range, (if Use IP Range is checked). | valid IP address; Default: 192.168.1.1 |
| Use IP Range | checked: An IP address range is used. 
unchecked: Only one IP address is used. | checked, unchecked; Default: unchecked |
| IP Address (right) | Enter the ending address of the IP scanning range, (only if Use IP Range is checked). | valid IP address; Default: 0.0.0.0 |
| Address Count | Displays the scanning range address count, depending on the selected IP-start or IP-end address. (For this read the note given below.) | recommended: 10 |
| TCP Port | Identifies the endpoint of a logical connection or addresses a specific endpoint on the device or PC. | 0 \(\ldots\) 65535; Default Hilscher device: 50111 |
| Send Timeout [ms] | Maximum time before the transfer of the transmission data is canceled, when the send process fails, for example, because of the transfer buffer is full. | 100 \(\ldots\) 60.000 [ms]; Default (TCP/IP): 1000 ms |
| Reset Timeout [ms] | Maximum time for a device reset, including the re-initialization of the physical interface used for the communication. | 100 \(\ldots\) 60.000 [ms]; Default (TCP/IP): 2000 ms |
| Keep Alive Timeout [ms] | The "Keep Alive" mechanism is used to monitor whether the connection to the device is active. Connection errors are detected using a periodic heartbeat mechanism. The heartbeat mechanism will be initiated after the set time has elapsed if the communication has failed. | 100 \(\ldots\) 60.000 [ms]; Default (TCP/IP): 2000 ms |
| Restore | Resets all settings in the configuration dialog to the default values. | 
| Save | Saving all settings made in the configuration dialog netX Driver > Save TCP/IP Connection, i. e. only for the selected connection type. | 
| Save All | Saving all settings made in the configuration dialog netX Driver, i. e. for all connection types. | 

Table 23: Parameters netX Driver > TCP Connection
Note: Do not use large IP ranges in combination with a low scan timeout. In Windows® XP SP2, Microsoft has introduced a limit for concurrent half-open outbound TCP/IP connections (connection attempts) to slow the spread of virus and malware from system to system. This limit makes it impossible to have more than 10 concurrent half-open outbound connections. Every further connection attempt is put in a queue and forced to wait. Due to this limitation, a large IP range used in combination with a low scan timeout could prevent the connection establishment to a device.

12.3.4 Device Assignment Dialog Window

In order to establish an online connection between SYCON.net/the netHOST DTM and the netHOST device, you first need to assign the netHOST device to the netX Driver in the Device Assignment dialog window.

Note: Before you can assign the netHOST device to the netX driver in the Device Assignment window, the driver has to be selected in the Driver dialog window. In the netHOST DTM, the appropriate driver for the netHOST – i.e., the netX driver – is already pre-selected by default. Note, however, that you still have to set the IP address of the netHOST in the netX Driver dialog window.

➢ To assign the netHOST device to the driver, select Settings > Device Assignment in the Navigation Area of the opened netHOST DTM.

➢ The Device Assignment dialog window opens and SYCON.net automatically starts scanning for connected devices:

![Device Assignment Window](image)

Figure 105: Scanning for Devices in SYCON.net

➢ Afterwards, select the netHOST device which you want to assign to the netX driver.
The subsequent table provides a description of the parameters:

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Meaning</th>
<th>Range of Value / Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Device selection</td>
<td>Selecting suitable only or all devices.</td>
<td>suitable only, all</td>
</tr>
<tr>
<td>Device</td>
<td>Device name.</td>
<td></td>
</tr>
<tr>
<td>Hardware Port 0/1/2/3</td>
<td>Shows, which hardware is assigned to which communication interface.</td>
<td></td>
</tr>
</tbody>
</table>
| Slot number                         | When using netHOST devices, the n/a entry means that no Slot-Nummer (Karten-ID) exists.  
Note: When using cifX PC cards, this parameter indicates the Slot Number (Card ID) preset at the cifX card via the Rotary Switch Slot Number (Card ID). | 1 to 9, n/a                          |
| Serial number                       | Serial number of the device                                             |                                      |
| Driver                             | Name of the driver                                                     |                                      |
| Channel Protocol                   | Shows, which firmware is loaded to which device channel. The data for the used channel consists of the protocol class and the communication class.  
a.) For devices without firmware: Undefined Undefined,  
b.) For devices with firmware: Protocol name according to the used Firmware |                                      |
| Access path (under Device selection, last column on the right) | Depending on the used driver, the column Access path shows various data concerning the access path.  
For the cifX Device Driver the following data is displayed:  
a.) For devices without firmware: ...\cifX[0toN]_SYS,  
b.) For devices with firmware: ...\cifX[0toN]_Ch[0to3].  
cifX[0toN] = Board number 0 to N  
Ch[0to3] = Channel number 0 to 3 | Depending on the device and on the driver: board or channel number, IP address or COM interface |
| Access path (at the lower side of the dialog pane) | If under Device selection the check box for a device is checked, under Access path (at the lower side of the dialog pane) the driver identification or (depending on the used driver) additional data of the device is displayed.  
For the cifX Device Driver the following data are displayed:  
a.) For devices without firmware: ...\cifX[0toN]_SYS,  
b.) For devices with firmware: ...\cifX[0toN]_Ch[0to3].  
cifX[0toN] = Board number 0 to N  
Ch[0to3] = Channel number 0 to 3 | driver identification (ID) depending on the device and on the driver: board or channel number, IP address or COM interface |

Table 24: Parameters of the Device Assignment
12.4 Dialog Windows of the “Configuration” Group

12.4.1 Overview

This section describes the dialog windows belonging to the Configuration category of the netHOST DTM.

**Note:** You need the user right Maintenance, Planning Engineer or Administrator in order to be allowed to edit the dialog windows belonging to the Configuration category. For information about user rights for the netHOST DTM, see User Rights for the netHOST DTM section on page 155.

Figure 107: “Configuration” in netHOST DTM
12.4.2 Settings Dialog Window

In the Settings dialog window, you can download firmware into the netHOST device (firmware update) and define a name for the configuration.

- To open the Settings dialog window, click Settings entry in the Configuration folder in the Navigation Area of the opened netHOST DTM.

Figure 108: „Settings“ Dialog Window in the netHOST DTM

Note: In the Settings dialog window, only the Description field, the Available Firmware field and the Browse and Download buttons are active and can be used. All other fields or parameters are preset and can not be edited by the user.
### General

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Here you can enter a descriptive or symbolic name for the netHOST device. Afterwards, this name will be displayed in SYCON.net in front of the device.</td>
</tr>
</tbody>
</table>

### Protocol Combination

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Primary network (Port X2)</td>
<td>Displays the protocol of the network connected to port X2 of the netHOST device.</td>
</tr>
<tr>
<td>Secondary network (Port X3)</td>
<td>Displays the protocol of the network connected to port X3 of the netHOST device.</td>
</tr>
<tr>
<td>Required gateway</td>
<td>Displays the netHOST device type.</td>
</tr>
<tr>
<td>Required license</td>
<td>Displays the number of master licenses required in the device if a netHOST with master functionality is being used.</td>
</tr>
</tbody>
</table>

### Available Firmware

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Available Firmware</td>
<td>Lists the firmware file selected for the device. Firmware files are stored on the netHOST Solutions DVD in the Firmware\netHOST directory.</td>
</tr>
</tbody>
</table>

### Basic Settings

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mapping Cycle time</td>
<td>Displays the cycle time for the device internal transfer of the input and output data from the buffer of port X2 to the buffer of X3 and visa versa (default = 1 ms).</td>
</tr>
<tr>
<td>Mapping mode</td>
<td>Always set to default.</td>
</tr>
</tbody>
</table>

### Network Address Switch

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>enable</td>
<td>Not applicable for netHOST devices.</td>
</tr>
<tr>
<td>Used by</td>
<td>Not applicable for netHOST devices.</td>
</tr>
</tbody>
</table>

*Table 25: Elements in the “Settings” Dialog Window*
12.4.3 Memory Card Management Dialog Window

In the **Memory Card Management** dialog window, you can:

- copy the firmware file and the configuration data from the netHOST device to an inserted SD memory card (backup),
- copy the firmware file and the configuration data from the inserted SD memory card to the netHOST device (restore). All old files stored in the netHOST device will thereby be overwritten.

**Note:** For these functions, you need a FAT16-formatted SD memory card, which you insert into the netHOST device. You also need an active online connection between SYCON.net and the netHOST device.

The SD memory card is not included in the delivery of the netHOST device and can be ordered from Hilscher, part number 1719.003.

- To open the **Memory Card Management** dialog window, click **Memory Card Management** entry in the **Configuration** folder in the **Navigation Area** of the opened netHOST DTM.
<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Directory</strong></td>
<td></td>
</tr>
<tr>
<td>Folder</td>
<td>If no SD memory card has been inserted, the file system of the netHOST device is displayed here. If an SD memory card has been inserted into the netHOST device, the file system of the card is displayed here in addition to the file system of the netHOST. You can select a folder in order to display its contents in the adjacent File field.</td>
</tr>
<tr>
<td>File</td>
<td>Displays the names of the files stored in the selected folder.</td>
</tr>
<tr>
<td>Size</td>
<td>Displays the size of the files stored in the selected folder.</td>
</tr>
<tr>
<td><strong>Start-Up Options</strong></td>
<td></td>
</tr>
<tr>
<td>Restore automatically</td>
<td>Sets start-up options for booting from SD memory card. Selecting an option is currently not supported. At every start (preset): If an SD memory card is inserted in the netHOST device at the time of power return, the netHOST takes over the data from the SD card. If different: Data from the SD card is only taken over if it differs from the data stored in the internal load memory of the netHOST.</td>
</tr>
<tr>
<td><strong>Commands</strong></td>
<td></td>
</tr>
<tr>
<td>Restore</td>
<td>Copies the firmware and the configuration files stored on the SD memory card to the netHOST device. All old files stored in the netHOST device will thereby be overwritten. This button is only active if an SD memory card has been inserted into the netHOST device. If this is the case, the Folder field displays the directory of the memory card. The root directory of the card is „SDMMC“.</td>
</tr>
<tr>
<td>Backup</td>
<td>Copies the firmware and the configuration files stored in the netHOST device to the SD memory card. This button is only active if an SD memory card has been inserted into the netHOST device. If this is the case, the Folder field displays the directory of the memory card. The root directory of the card is „SDMMC“.</td>
</tr>
</tbody>
</table>

*Table 26: Elements of the Memory Card Management*
12.4.4 Licensing Dialog Window

**Note:** Usually, all netHOST devices are already equipped with the necessary license on delivery. The individual control elements in this dialog window are therefore not described here. In case you want to belatedly order and download a license for the NHST-T100-EN device, see section *Ordering and Downloading License to NHST-T100-EN with SYCON.net* on page 36 for more information.

In the **Licensing** dialog window, you can check which license is present in the netHOST device.

**Note:** For these functions, you need an active online connection between SYCON.net and the netHOST device.

- To open the **Licensing** dialog window, click **Licensing** entry in the **Configuration** folder in the **Navigation Area** of the opened netHOST DTM.

![Figure 110: Licensing Dialog Window of the netHOST DTM](image-url)
12.5 Windows of the “Diagnosis“ Group

12.5.1 Overview

This section describes the dialog windows belonging to the Diagnosis category of the netHOST DTM. With the diagnosis functions, you can check the behavior of the device and detect communication errors. An active online connection between the netHOST DTM in SYCON.net and the netHOST device is needed for this. Double-clicking the netHOST symbol during an active online connection automatically opens the Diagnosis windows. (Without an active online connection, double-clicking the netHOST automatically opens the Settings and Configuration dialog windows.) Alternatively, you can open the diagnosis by selecting the netHOST symbol and then choosing Diagnosis > Main Settings from the context menu.

The Extended Diagnosis helps to find communication and configuration errors if the functions of the general diagnosis do not suffice.

Note: You need the user right maintenance, Planning Engineer or Administrator in order to be allowed to open the diagnosis windows. For information about user rights for the netHOST DTM, see User Rights for the netHOST DTM section on page 155.

Figure 111: Diagnosis in netHOST DTM
12.5.2 General Diagnosis Window

The **General Diagnosis** window displays information about the current states of device, network and configuration.

- To open the **General Diagnosis** window, click **General Diagnosis** entry in the **Diagnosis** folder in the **Navigation Area** of the opened netHOST DTM.

**Note:** You need an active online connection between the netHOST DTM and the netHOST device for this.

![Image of General Diagnosis window in netHOST DTM]

**Figure 112: General Diagnosis in netHOST DTM**

<table>
<thead>
<tr>
<th>Indication</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Device State</strong></td>
<td></td>
</tr>
<tr>
<td><img src="GreenCircle.png" alt="Green Circle" /> Communicating</td>
<td>Shows that the netHOST firmware executes the network communication.</td>
</tr>
<tr>
<td><img src="YellowCircle.png" alt="Yellow Circle" /> Run</td>
<td>Shows that the netHOST firmware has been configured correctly.</td>
</tr>
<tr>
<td><img src="YellowCircle.png" alt="Yellow Circle" /> Ready</td>
<td>Shows that the netHOST firmware has been started correctly. The netHOST firmware waits for a configuration.</td>
</tr>
<tr>
<td><img src="RedCircle.png" alt="Red Circle" /> Error</td>
<td>Shows that the netHOST firmware records a device status error. For further information about the error characteristics and the number of counted errors, please refer to the extended diagnosis.</td>
</tr>
</tbody>
</table>
**Network State**

- **Operate**: Shows that the netHOST firmware is in data exchange.
- **Idle**: Shows that the netHOST firmware is in idle mode.
- **Stop**: Shows that the netHOST firmware is in Stop state: There is no cyclic data exchange at the network. The netHOST firmware was stopped by the application program or it changed to the Stop state because of a bus error.
- **Offline**: The netHOST firmware is offline, it does not have a valid configuration.

**Configuration State**

- **Configuration locked**: Shows that the netHOST firmware configuration is locked in order to avoid that the configuration data is being typed over.
- **New Configuration pending**: Shows that a new netHOST firmware configuration is available.
- **Reset required**: Shows that a firmware reset is required because a new netHOST firmware configuration has been loaded into the device.
- **Bus ON**: Shows whether the bus communication was started or stopped. I.e., whether the device is active on the bus or no bus communication to the device is possible and no response telegrams are sent.

*Table 27: Indications General Diagnosis*

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Communication Error</td>
<td>Shows the message text of the communication error. If the cause of the current error is resolved, “–” is displayed.</td>
</tr>
<tr>
<td>Watchdog time</td>
<td>Shows the watchdog time in ms.</td>
</tr>
<tr>
<td>Error Count</td>
<td>This field holds the total number of errors detected since power-up, respectively after reset. The protocol stack counts all sorts of errors in this field no matter if they were network related or caused internally.</td>
</tr>
</tbody>
</table>

*Table 28: Further Parameter General Diagnosis*
12.5.3 Firmware Diagnosis Window

The Firmware Diagnosis window displays information about the current tasks of the firmware.

- To open the Firmware Diagnosis window, click Firmware Diagnosis entry in the Diagnosis folder in the Navigation Area of the opened netHOST DTM.

**Note:** You need an active online connection between the netHOST DTM and the netHOST device for this.

![Firmware Diagnosis in netHOST DTM](image)

**Figure 113: Firmware Diagnosis in netHOST DTM**

<table>
<thead>
<tr>
<th>Column</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Task</td>
<td>Task number</td>
</tr>
<tr>
<td>Name of Task</td>
<td>Name of the task</td>
</tr>
<tr>
<td>Version</td>
<td>Version of the task</td>
</tr>
<tr>
<td>Prio</td>
<td>Priority of the task</td>
</tr>
<tr>
<td>Description</td>
<td>Description of the task</td>
</tr>
<tr>
<td>State</td>
<td>Status of the task</td>
</tr>
</tbody>
</table>

**Table 29: Parameters Task Information**
12.6 Establishing Online Connection

For some functions of the netHOST DTM – like diagnosis or downloading the configuration or firmware to the device – an active online connection between SYCON.net/netHOST DTM and the netHOST device is required.

Prerequisites
Prerequisites for an online connection are:

• The configuration PC with SYCON.net/netHOST DTM and the netHOST device are connected to the same local Ethernet network.
• The netHOST device is connected to a voltage supply.
• You have assigned a suitable IP address to the netHOST device.
• The netX Driver has been configured in the netX Driver dialog window (i.e. the IP address of the device has been set) and the netHOST Device has been assigned to the driver in the Device Assignment dialog window (see Assigning Device to Driver and Configuring Driver on page 52).

Establish online connection
Once you have opened certain dialog windows of the netHOST DTM, e.g. the Device Assignment dialog window, SYCON.net automatically establishes an online connection between the DTM and the device.

If the netHOST Device is closed, you can manually establish an online connection in SYCON.net. For this:

➢ Select the netHOST symbol in the configuration window, then choose Connect from the context menu (to open context menu, right-click on the netHOST symbol):

Figure 114: Connect netHOST
OR

- In the menu bar of SYCON.net, choose **Device > Connect**.

- An active online connection is indicated in the configuration window by the green highlighted netHOST label:

![Figure 115: netHOST Connected](image)

**Note:** It is not possible to open the **Settings** and **Configuration** dialog windows of the netHOST DTM during an active online connection. If you double-click on the netHOST symbol while the device is online, the **Diagnosis** windows of the netHOST DTM open instead of the **Settings** and **Configuration** dialog windows.

**Close online connection**

You can close the online connection by

- choosing **Disconnect** from the context menu of the netHOST symbol.

OR

- choosing **Device > Disconnect** in the menu bar of SYCON.net.
13 Brief Instructions for Configuring netHOST Master Devices

13.1 netHOST as Master for Fieldbus Systems

13.1.1 CANopen Master: NHST-T100-CO/COM

The NHST-T100-CO/COM as CANopen Master device needs a configuration, i.e., for instance, information about how many CANopen Slave devices with how many input and output data are to be connected to the master.

This section provides cursory instructions on how to configure the NHST-T100-CO/COM netHOST device as CANopen Master in SYCON.net. More detailed instructions on how to configure a netHOST as Fieldbus master (on the basis of an example for PROFIBUS DP) can be found in section Configuring netHOST for Fieldbus Systems with SYCON.net: NHST-T100-DP/DPM Example on page 49.

1. Add CANopen slave devices to configuration project.
   - Open device catalog and drag & drop as many CANopen slave(s) as needed onto the bus line of the CANopen master.

2. Configure CANopen slave devices.
   - Open the configuration dialog for each CANopen slave device and configure the device.
   - Detailed information on this can be found in the operating instruction manual Generic Slave DTM for CANopen Slave Devices, DOC060203O1xxEN. This manual is stored on the netHOST Solutions DVD in the directory Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\CANopen Master\Slave Configuration.
   - As an alternative, you can open the corresponding online help by clicking the Help button in the opened configuration dialog window of the slave DTM, or by pressing the F1 key on your keyboard.

3. Configure CANopen master (NHST-T100-CO/COM).
   - Select the netHOST symbol, then choose Configuration > CANopen Master from the context menu (to open context menu, right-click on the netHOST symbol).
   - Configure the master device.
   - Detailed information on this can be found in the operating instruction manual DTM for Hilscher-CANopen Master Devices, DOC070402O1xxEN. This manual is stored on the netHOST Solutions DVD in the directory Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\CANopen Master.
   - As an alternative, you can open the corresponding online help by clicking the Help button in the opened configuration dialog window of the DTM, or by pressing the F1 key on your keyboard.
13.1.2 DeviceNet Master: NHST-T100-DN/DNM

The NHST-T100-DN/DNM as DeviceNet Master device needs a configuration, i.e., for instance, information about how many DeviceNet Slave devices with how many input and output data are to be connected to the master.

This section provides cursory instructions on how to configure the NHST-T100-DN/DNM netHOST device as DeviceNet Master in SYCON.net. More detailed instructions on how to configure a netHOST as Fieldbus master (on the basis of an example for PROFIBUS DP) can be found in section Configuring netHOST for Fieldbus Systems with SYCON.net: NHST-T100-DP/DPM Example on page 49.

1. Add DeviceNet slave devices to configuration project.
   - Open device catalog and drag & drop as many DeviceNet slave(s) as needed onto the bus line of the DeviceNet master.

2. Configure DeviceNet slave devices.
   - Open the configuration dialog for each DeviceNet slave device and configure the device.

   | Detailed information on this can be found in the operating instruction manual Generic Slave DTM for DeviceNet Slave Devices, DOC041201OlxEN. This manual is stored on the netHOST Solutions DVD in the directory Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\DeviceNet Master\Slave Configuration.
   | As an alternative, you can open the corresponding online help by clicking the Help button in the opened configuration dialog window of the slave DTM, or by pressing the F1 key on your keyboard.

   - Select the netHOST symbol, then choose Configuration > DeviceNet Master from the context menu (to open context menu, right-click on the netHOST symbol).
   - Configure the master device.

   | Detailed information on this can be found in the operating instruction manual DTM for Hilscher-DeviceNet Master Devices, DOC070403OlxEN. This manual is stored on the netHOST Solutions DVD in the directory Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\DeviceNet Master.
   | As an alternative, you can open the corresponding online help by clicking the Help button in the opened configuration dialog window of the DTM, or by pressing the F1 key on your keyboard.
13.1.3 PROFIBUS DP Master: NHST-T100-DP/DPM

The NHST-T100-DP/DPM as PROFIBUS DP Master device needs a configuration, i.e., for instance, information about how many PROFIBUS DP Slave devices with how many input and output data are to be connected to the master.

This section provides only cursory instructions on how to configure the NHST-T100-DP/DPM netHOST device as PROFIBUS DP Master in SYCON.net. Detailed instructions can be found in section Configuring netHOST for Fieldbus Systems with SYCON.net: NHST-T100-DP/DPM Example on page 49.

1. Add PROFIBUS DP slave devices to configuration project.
   - Open device catalog and drag & drop as many PROFIBUS DP slave(s) as needed onto the bus line of the PROFIBUS DP master.

2. Configure PROFIBUS DP slave devices.
   - Open the configuration dialog for each PROFIBUS DP slave device and configure the device.

   Detailed information on this can be found in the operating instruction manual Generic Slave DTM for PROFIBUS DP Slave Devices, DOC031001OIxxEN. This manual is stored on the netHOST Solutions DVD in the directory Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\PROFIBUS DP Master\Slave Configuration.

   As an alternative, you can open the corresponding online help by clicking the Help button in the opened configuration dialog window of the slave DTM, or by pressing the F1 key on your keyboard.

3. Configure PROFIBUS DP master (NHST-T100-DP/DPM).
   - Select the netHOST symbol, then choose Configuration > PROFIBUS DP Master from the context menu (to open context menu, right-click on the netHOST symbol).
   - Configure the master device.

   Detailed information on this can be found in the operating instruction manual DTM for Hilscher-PROFIBUS DP Master Devices, DOC070401OIxxEN. This manual is stored on the netHOST Solutions DVD in the directory Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\PROFIBUS DP Master.

   As an alternative, you can open the corresponding online help by clicking the Help button in the opened configuration dialog window of the DTM, or by pressing the F1 key on your keyboard.
13.2 netHOST as Master for Real-Time Ethernet Systems

13.2.1 EtherCAT Master: NHST-T100-EN/ECM

The NHST-T100-EN/ECM as EtherCAT Master device (respectively the NHST-T100-EN with loaded EtherCAT master firmware) needs a configuration, i.e., for instance, information about how many EtherCAT Slave devices with how many input and output data are to be connected to the master.

This section provides cursory instructions on how to configure the NHST-T100-EN/ECM netHOST device as EtherCAT Master in SYCON.net. More detailed instructions on how to configure a netHOST as master device in a Real-Time Ethernet network (on the basis of an example for PROFINET IO) can be found in section Configuring netHOST for RTE Systems with SYCON.net: NHST-T100-EN/PNM Example on page 64.

1. Add EtherCAT slave devices to configuration project.
   - Open device catalog and drag & drop as many EtherCAT slave(s) as needed onto the bus line of the EtherCAT master.

2. Configure EtherCAT slave devices.
   - Open the configuration dialog for each EtherCAT slave device and configure the device.
   - Detailed information on this can be found in the operating instruction manual Generic Slave DTM for EtherCAT Slave Devices, DOC071202OIxxEN. This manual is stored on the netHOST Solutions DVD in the directory Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\EtherCAT Master\Slave Configuration.
   - As an alternative, you can open the corresponding online help by clicking the Help button in the opened configuration dialog window of the slave DTM, or by pressing the F1 key on your keyboard.

3. Configure EtherCAT master (NHST-T100-EN/ECM).
   - Select the netHOST symbol, then choose Configuration > EtherCAT Master from the context menu (to open context menu, right-click on the netHOST symbol).
   - Configure the master device.
   - Detailed information on this can be found in the operating instruction manual DTM for Hilscher EtherCAT Master Device, DOC080404OIxxEN. This manual is stored on the netHOST Solutions DVD in the directory Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\EtherCAT Master.
   - As an alternative, you can open the corresponding online help by clicking the Help button in the opened configuration dialog window of the DTM, or by pressing the F1 key on your keyboard.
13.2.2 EtherNet/IP Scanner: NHST-T100-EN/EIM

The NHST-T100-EN/EIM as EtherNet/IP Scanner (respectively the NHST-T100-EN with loaded EtherNet/IP Scanner firmware) needs a configuration, i.e., for instance, information about how many EtherNet/IP Adapter (slave devices) with how many input and output data are to be connected to the scanner.

This section provides cursory instructions on how to configure the NHST-T100-EN/EIM netHOST device as EtherNet/IP Scanner in SYCON.net. More detailed instructions on how to configure a netHOST as master device in a Real-Time Ethernet network (on the basis of an example for PROFINET IO) can be found in section Configuring netHOST for RTE Systems with SYCON.net: NHST-T100-EN/PNM Example on page 64.

1. Add EtherNet/IP Adapters to configuration project.
   - Open device catalog and drag & drop as many EtherNet/IP slaves as needed onto the bus line of the EtherNet/IP Scanner.

2. Configure EtherNet/IP Adapters.
   - Open the configuration dialog for each EtherNet/IP Adapter and configure the device.

   Detailed information on this can be found in the following operating instruction manuals:
   - Generic, Modular Generic DTM from EDS File for non-modular and modular EtherNet/IP Adapter Devices, DOC100221O1xxEN
   - Generic DTM for EtherNet/IP Adapter Devices and Modular Generic DTM for modular EtherNet/IP Adapter Devices, DOC060305O1xxEN,
   both stored on the netHOST Solutions DVD in the directory Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\EtherNetIP Scanner\Adapter Configuration.

   As an alternative, you can open the corresponding online help by clicking the Help button in the opened configuration dialog window of the slave DTM, or by pressing the F1 key on your keyboard.

3. Configure EtherNet/IP Scanner (NHST-T100-EN/EIM).
   - Select the netHOST symbol, then choose Configuration > EtherNet/IP Scanner from the context menu (to open context menu, right-click on the netHOST symbol).
   - Configure the Scanner.

   Detailed information on this can be found in the operating instruction manual DTM for EtherNet/IP Scanner Devices, DOC061201O1xxEN. This manual is stored on the netHOST Solutions DVD in the directory Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\EtherNetIP Scanner.

   As an alternative, you can open the corresponding online help by clicking the Help button in the opened configuration dialog window of the DTM, or by pressing the F1 key on your keyboard.
13.2.3 PROFINET IO Controller: NHST-T100-EN/PNM

The NHST-T100-EN/PNM as PROFINET IO Controller (respectively the NHST-T100-EN with loaded PROFINET IO Controller firmware) needs a configuration, i.e., for instance, information about how many PROFINET IO Devices (slaves) with how many input and output data are to be connected to the Controller.

This section provides only cursory instructions on how to configure the NHST-T100-EN/PNM netHOST device as PROFINET IO Controller in SYCON.net. Detailed instructions can be found in section Configuring netHOST for RTE Systems with SYCON.net: NHST-T100-EN/PNM Example on page 64.

1. Add PROFINET IO Devices (slaves) to configuration project.
   - Open device catalog and drag & drop as many PROFINET IO Devices as needed onto the bus line of the PROFINET IO Controller.

2. Configure PROFINET IO Devices.
   - Open the configuration dialog for each PROFINET IO Device and configure the device.

   Detailed information on this can be found in the operating instruction manual DTM for Hilscher-PROFINET IO-Controller Devices, DOC060302OIxxEN. This manual is stored on the netHOST Solutions DVD in the directory Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\PROFINET IO Controller\IO Device Configuration.

   As an alternative, you can open the corresponding online help by clicking the Help button in the opened configuration dialog window of the slave DTM, or by pressing the F1 key on your keyboard.

3. Configure PROFINET IO Controller.
   - Select the netHOST symbol, then choose Configuration > PROFINET IO Controller from the context menu (to open context menu, right-click on the netHOST symbol).
   - Configure the Controller.

   Detailed information on this can be found in the operating instruction manual DTM for Hilscher-PROFINET IO-Controller Devices, DOC060302OIxxEN. This manual is stored on the netHOST Solutions DVD in the directory Documentation\english\1.Software\SYCON.net Configuration Software\Master Configuration\PROFINET IO Controller.

   As an alternative, you can open the corresponding online help by clicking the Help button in the opened configuration dialog window of the DTM, or by pressing the F1 key on your keyboard.
14 Error Codes

14.1 Error Code Definitions

For COM based application, like the ODM Server and ODM drivers, a common error definition is used, similar to the Microsoft Windows® HRESULT definition.

Error Code Structure:
COM Errors are HRESULTs, which are 32 bit values using the following layout:

```
 3 3 2 2 2 2 2 2 2 2 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1
1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0
```

where

- **Sev** - is the severity code:
  - 00 = Success
  - 01 = Informational
  - 10 = Warning
  - 11 = Error
- **C** - is the Customer code flag
- **R** - is a reserved bit
- **Facility** - is the facility code
- **Code** - is the facility’s status code

In this common error definition, several error code regions are already reserved by Windows® itself, the ODM and some other modules.
### 14.2 Overview Error Codes

<table>
<thead>
<tr>
<th>Overview Error Codes</th>
<th>Range</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>General Hardware Errors</strong></td>
<td><strong>RCX General Task Errors</strong>: 0xC02B0001 to 0xC02B4D52</td>
</tr>
<tr>
<td><strong>RCX Operating System</strong></td>
<td><strong>RCX Common Status &amp; Errors Codes</strong>: 0x00000000 to 0xC002000C</td>
</tr>
<tr>
<td></td>
<td><strong>RCX Status &amp; Error Codes</strong>: 0x00000000 to 0xC0000008</td>
</tr>
<tr>
<td><strong>ODM Server</strong></td>
<td><strong>General ODM Error Codes</strong>: 0x8004C700 to 0x8004C781</td>
</tr>
<tr>
<td></td>
<td><strong>General ODM Driver Error Codes</strong>: 0x8004C7A0 to 0x8004C7C2</td>
</tr>
<tr>
<td><strong>ODM Drivers</strong></td>
<td><strong>cifX Driver Specific ODM Error Codes</strong>: 0x8004C001 to 0x8004C0A4</td>
</tr>
<tr>
<td><strong>cifX Device Driver and netX Driver</strong></td>
<td><strong>Generic Error Codes</strong>: 0x800A0001 to 0x800A0017</td>
</tr>
<tr>
<td></td>
<td><strong>Generic Driver Error Codes</strong>: 0x800B0001 to 0x800B0042</td>
</tr>
<tr>
<td></td>
<td><strong>Generic Device Error Codes</strong>: 0x800C0010 to 0x800C0041</td>
</tr>
<tr>
<td><strong>netX Driver</strong></td>
<td><strong>CIFX API Transport Error Codes</strong>: 0x800D0001 to 0x800D0013</td>
</tr>
<tr>
<td></td>
<td><strong>CIFX API Transport Header State Error Codes</strong>: 0x800E0001 to 0x800E000B</td>
</tr>
<tr>
<td><strong>DBM</strong></td>
<td><strong>ODM Error Codes DBM V4</strong>: 0xC004C810 to 0xC004C878</td>
</tr>
</tbody>
</table>

*Table 30: Overview Error Codes and Ranges*

The protocol-specific error codes are described in the Protocol API manuals of the corresponding communication protocols. These manuals are provided on the netHOST Solutions DVD in the `Documentation\english\3.For Programmers\4.Communication Protocol specific APIs. directory`. 
### 14.3 General Hardware Error Codes

#### 14.3.1 RCX General Task Errors

<table>
<thead>
<tr>
<th>Error Code (Definition)</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RCX_E_QUE_UNKNOWN</td>
<td>0xC02B0001</td>
<td>Unknown Queue</td>
</tr>
<tr>
<td>RCX_E_QUE_INDEX_UNKNOWN</td>
<td>0xC02B0002</td>
<td>Unknown Queue Index</td>
</tr>
<tr>
<td>RCX_E_TASK_UNKNOWN</td>
<td>0xC02B0003</td>
<td>Unknown Task</td>
</tr>
<tr>
<td>RCX_E_TASK_INDEX_UNKNOWN</td>
<td>0xC02B0004</td>
<td>Unknown Task Index</td>
</tr>
<tr>
<td>RCX_E_TASK_HANDLE_INVALID</td>
<td>0xC02B0005</td>
<td>Invalid Task Handle</td>
</tr>
<tr>
<td>RCX_E_TASK_INFOIDX_UNKNOWN</td>
<td>0xC02B0006</td>
<td>Unknown Index Index</td>
</tr>
<tr>
<td>RCX_E_FILE_XFR_TYPE_INVALID</td>
<td>0xC02B0007</td>
<td>Invalid Transfer Type</td>
</tr>
<tr>
<td>RCX_E_FILE_REQUEST_INCORRECT</td>
<td>0xC02B0008</td>
<td>Invalid File Request</td>
</tr>
<tr>
<td>RCX_E_TASK_INVALID</td>
<td>0xC02B000E</td>
<td>Invalid Task</td>
</tr>
<tr>
<td>RCX_E_SEC_FAILED</td>
<td>0xC02B001D</td>
<td>Security EEPROM Access Failed</td>
</tr>
<tr>
<td>RCX_E_EEPROM_DISABLED</td>
<td>0xC02B001E</td>
<td>EEPROM Disabled</td>
</tr>
<tr>
<td>RCX_E_INVALID_EXT</td>
<td>0xC02B001F</td>
<td>Invalid Extension</td>
</tr>
<tr>
<td>RCX_E_SIZE_OUT_OF_RANGE</td>
<td>0xC02B0020</td>
<td>Block Size Out Of Range</td>
</tr>
<tr>
<td>RCX_E_INVALID_CHANNEL</td>
<td>0xC02B0021</td>
<td>Invalid Channel</td>
</tr>
<tr>
<td>RCX_E_INVALID_FILE_LEN</td>
<td>0xC02B0022</td>
<td>Invalid File Length</td>
</tr>
<tr>
<td>RCX_E_INVALID_CHAR_FOUND</td>
<td>0xC02B0023</td>
<td>Invalid Character Found</td>
</tr>
<tr>
<td>RCX_E_PACKET_OUT_OF_SEQ</td>
<td>0xC02B0024</td>
<td>Packet Out Of Sequence</td>
</tr>
<tr>
<td>RCX_E_SEC_NOT_ALLOWED</td>
<td>0xC02B0025</td>
<td>Not Allowed In Current State</td>
</tr>
<tr>
<td>RCX_E_SEC_INVALID_ZONE</td>
<td>0xC02B0026</td>
<td>Security EEPROM Invalid Zone</td>
</tr>
<tr>
<td>RCX_E_SEC_EEPROM_NOT_AVAL</td>
<td>0xC02B0028</td>
<td>Security EEPROM Eeprom Not Available</td>
</tr>
<tr>
<td>RCX_E_SEC_INVALID_CHECKSUM</td>
<td>0xC02B0029</td>
<td>Security EEPROM Invalid Checksum</td>
</tr>
<tr>
<td>RCX_E_SEC_ZONE_NOT_WRITEABLE</td>
<td>0xC02B002A</td>
<td>Security EEPROM Zone Not Writeable</td>
</tr>
<tr>
<td>RCX_E_SEC_READ_FAILED</td>
<td>0xC02B002B</td>
<td>Security EEPROM Read Failed</td>
</tr>
<tr>
<td>RCX_E_SEC_WRITE_FAILED</td>
<td>0xC02B002C</td>
<td>Security EEPROM Write Failed</td>
</tr>
<tr>
<td>RCX_E_SEC_ACCESS_DENIED</td>
<td>0xC02B002D</td>
<td>Security EEPROM Access Denied</td>
</tr>
<tr>
<td>RCX_E_SEC_EEPROM_EMULATED</td>
<td>0xC02B002E</td>
<td>Security EEPROM Emulated</td>
</tr>
<tr>
<td>RCX_E_INVALID_BLOCK</td>
<td>0xC02B0038</td>
<td>Invalid Block</td>
</tr>
<tr>
<td>RCX_E_INVALID_STRUCT_NUMBER</td>
<td>0xC02B0039</td>
<td>Invalid Structure Number</td>
</tr>
<tr>
<td>RCX_E_INVALID_CHECKSUM</td>
<td>0xC02B4352</td>
<td>Invalid Checksum</td>
</tr>
<tr>
<td>RCX_E_CONFIG_LOCKED</td>
<td>0xC02B4B54</td>
<td>Configuration Locked</td>
</tr>
<tr>
<td>RCX_E_SEC_ZONE_NOT_READABLE</td>
<td>0xC02B4D52</td>
<td>Security EEPROM Zone Not Readable</td>
</tr>
</tbody>
</table>

*Table 31: RCX General Task Errors*
## 14.3.2 RCX Common Status & Errors Codes

<table>
<thead>
<tr>
<th>Error Code (Definition)</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RCX_S_OK</td>
<td>0x00000000</td>
<td>Success, Status Okay</td>
</tr>
<tr>
<td>RCX_E_FAIL</td>
<td>0xC0000001</td>
<td>Fail</td>
</tr>
<tr>
<td>RCX_E_UNEXPECTED</td>
<td>0xC0000002</td>
<td>Unexpected</td>
</tr>
<tr>
<td>RCX_E_OUTOFMEMORY</td>
<td>0xC0000003</td>
<td>Out Of Memory</td>
</tr>
<tr>
<td>RCX_E_UNKNOWN_COMMAND</td>
<td>0xC0000004</td>
<td>Unknown Command</td>
</tr>
<tr>
<td>RCX_E_UNKNOWN_DESTINATION</td>
<td>0xC0000005</td>
<td>Unknown Destination</td>
</tr>
<tr>
<td>RCX_E_UNKNOWN_DESTINATION_ID</td>
<td>0xC0000006</td>
<td>Unknown Destination ID</td>
</tr>
<tr>
<td>RCX_E_INVALID_PACKET_LEN</td>
<td>0xC0000007</td>
<td>Invalid Packet Length</td>
</tr>
<tr>
<td>RCX_E_INVALID_EXTENSION</td>
<td>0xC0000008</td>
<td>Invalid Extension</td>
</tr>
<tr>
<td>RCX_E_INVALID_PARAMETER</td>
<td>0xC0000009</td>
<td>Invalid Parameter</td>
</tr>
<tr>
<td>RCX_E_WATCHDOG_TIMEOUT</td>
<td>0xC000000C</td>
<td>Watchdog Timeout</td>
</tr>
<tr>
<td>RCX_E_INVALID_LIST_TYPE</td>
<td>0xC000000D</td>
<td>Invalid List Type</td>
</tr>
<tr>
<td>RCX_E_UNKNOWN_HANDLE</td>
<td>0xC000000E</td>
<td>Unknown Handle</td>
</tr>
<tr>
<td>RCX_E_PACKET_OUT_OF_SEQ</td>
<td>0xC000000F</td>
<td>Out Of Sequence</td>
</tr>
<tr>
<td>RCX_E_PACKET_OUT_OF_MEMORY</td>
<td>0xC000010</td>
<td>Out Of Memory</td>
</tr>
<tr>
<td>RCX_E_QUE_PACKETDONE</td>
<td>0xC0000011</td>
<td>Queue Packet Done</td>
</tr>
<tr>
<td>RCX_E_QUE_SENDPACKET</td>
<td>0xC0000012</td>
<td>Queue Send Packet</td>
</tr>
<tr>
<td>RCX_E_POOL_PACKET_GET</td>
<td>0xC0000013</td>
<td>Pool Packet Get</td>
</tr>
<tr>
<td>RCX_E_POOL_GET_LOAD</td>
<td>0xC0000015</td>
<td>Pool Get Load</td>
</tr>
<tr>
<td>RCX_E_REQUEST_RUNNING</td>
<td>0xC000001A</td>
<td>Request Already Running</td>
</tr>
<tr>
<td>RCX_E_INIT_FAULT</td>
<td>0xC0000100</td>
<td>Initialization Fault</td>
</tr>
<tr>
<td>RCX_E_DATABASE_ACCESS_FAILED</td>
<td>0xC0000101</td>
<td>Database Access Failed</td>
</tr>
<tr>
<td>RCX_E_NOT_CONFIGURED</td>
<td>0xC0000119</td>
<td>Not Configured</td>
</tr>
<tr>
<td>RCX_E_CONFIGURATION_FAULT</td>
<td>0xC0000120</td>
<td>Configuration Fault</td>
</tr>
<tr>
<td>RCX_E_INCONSISTENT_DATA_SET</td>
<td>0xC0000121</td>
<td>Inconsistent Data Set</td>
</tr>
<tr>
<td>RCX_E_DATA_SET_MISMATCH</td>
<td>0xC0000122</td>
<td>Data Set Mismatch</td>
</tr>
<tr>
<td>RCX_E_INSUFFICIENT_LICENSE</td>
<td>0xC0000123</td>
<td>Insufficient License</td>
</tr>
<tr>
<td>RCX_E_PARAMETER_ERROR</td>
<td>0xC0000124</td>
<td>Parameter Error</td>
</tr>
<tr>
<td>RCX_E_INVALID_NETWORK_ADDRESS</td>
<td>0xC0000125</td>
<td>Invalid Network Address</td>
</tr>
<tr>
<td>RCX_E_NO_SECURITY_MEMORY</td>
<td>0xC0000126</td>
<td>No Security Memory</td>
</tr>
<tr>
<td>RCX_E_NETWORK_FAULT</td>
<td>0xC0000140</td>
<td>Network Fault</td>
</tr>
<tr>
<td>RCX_E_CONNECTION_CLOSED</td>
<td>0xC0000141</td>
<td>Connection Closed</td>
</tr>
<tr>
<td>RCX_E_CONNECTION_TIMEOUT</td>
<td>0xC0000142</td>
<td>Connection Timeout</td>
</tr>
<tr>
<td>RCX_E_LONELY_NETWORK</td>
<td>0xC0000143</td>
<td>Lonely Network</td>
</tr>
<tr>
<td>RCX_E_DUPLICATE_NODE</td>
<td>0xC0000144</td>
<td>Duplicate Node</td>
</tr>
<tr>
<td>RCX_E_CABLE_DISCONNECT</td>
<td>0xC0000145</td>
<td>Cable Disconnected</td>
</tr>
<tr>
<td>RCX_E_BUS_OFF</td>
<td>0xC0000180</td>
<td>Network Node Bus Off</td>
</tr>
<tr>
<td>RCX_E_CONFIG_LOCKED</td>
<td>0xC0000181</td>
<td>Configuration Locked</td>
</tr>
<tr>
<td>RCX_E_APPLICATION_NOT_READY</td>
<td>0xC0000182</td>
<td>Application Not Ready</td>
</tr>
<tr>
<td>RCX_E_TIMER_APPL_PACKET_SENT</td>
<td>0xC002000C</td>
<td>Timer App Packet Sent</td>
</tr>
</tbody>
</table>

Table 32: RCX Common Status & Errors Codes
14.3.3 RCX Status & Error Codes

<table>
<thead>
<tr>
<th>Error Code (Definition)</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RCX_S_OK</td>
<td>0x00000000</td>
<td>SUCCESS, STATUS OKAY</td>
</tr>
<tr>
<td>RCX_S_QUE_UNKNOWN</td>
<td>0xC02B0001</td>
<td>UNKNOWN QUEUE</td>
</tr>
<tr>
<td>RCX_S_QUE_INDEX_UNKNOWN</td>
<td>0xC02B0002</td>
<td>UNKNOWN QUEUE INDEX</td>
</tr>
<tr>
<td>RCX_S_TASK_UNKNOWN</td>
<td>0xC02B0003</td>
<td>UNKNOWN TASK</td>
</tr>
<tr>
<td>RCX_S_TASK_INDEX_UNKNOWN</td>
<td>0xC02B0004</td>
<td>UNKNOWN TASK INDEX</td>
</tr>
<tr>
<td>RCX_S_TASK_HANDLE_INVALID</td>
<td>0xC02B0005</td>
<td>INVALID TASK HANDLE</td>
</tr>
<tr>
<td>RCX_S_TASK_INFO_IDX_UNKNOWN</td>
<td>0xC02B0006</td>
<td>UNKNOWN INDEX</td>
</tr>
<tr>
<td>RCX_S_FILE_XFR_TYPE_INVALID</td>
<td>0xC02B0007</td>
<td>INVALID TRANSFER TYPE</td>
</tr>
<tr>
<td>RCX_S_FILE_REQUEST_INCORRECT</td>
<td>0xC02B0008</td>
<td>INVALID FILE REQUEST</td>
</tr>
<tr>
<td>RCX_S_UNKNOWN_DESTINATION</td>
<td>0xC0000005</td>
<td>UNKNOWN DESTINATION</td>
</tr>
<tr>
<td>RCX_S_UNKNOWN_DESTINATION_ID</td>
<td>0xC0000006</td>
<td>UNKNOWN DESTINATION ID</td>
</tr>
<tr>
<td>RCX_S_INVALID_LENGTH</td>
<td>0xC0000007</td>
<td>INVALID LENGTH</td>
</tr>
<tr>
<td>RCX_S_UNKNOWN_COMMAND</td>
<td>0xC0000004</td>
<td>UNKNOWN COMMAND</td>
</tr>
<tr>
<td>RCX_S_INVALID_EXTENSION</td>
<td>0xC0000008</td>
<td>INVALID EXTENSION</td>
</tr>
</tbody>
</table>

Table 33: RCX Status & Error Codes

14.3.3.1 RCX Status & Error Codes Slave State

<table>
<thead>
<tr>
<th>Error Code (Definition)</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RCX_SLAVE_STATE_UNDEFINED</td>
<td>0x00000000</td>
<td>UNDEFINED</td>
</tr>
<tr>
<td>RCX_SLAVE_STATE_OK</td>
<td>0x00000001</td>
<td>OK</td>
</tr>
<tr>
<td>RCX_SLAVE_STATE_FAILED</td>
<td>0x00000002</td>
<td>FAILED (at least one slave)</td>
</tr>
</tbody>
</table>

Table 34: RCX Status & Error Codes Slave State
## 14.4 ODM Error Codes

### 14.4.1 General ODM Error Codes

<table>
<thead>
<tr>
<th>Error Code (Definition)</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CODM3_E_INTEGRALERROR</td>
<td>0x8004C700</td>
<td>Internal ODM Error</td>
</tr>
<tr>
<td>ODM3_E_DESCRIPTION_NOTFOUND</td>
<td>0x8004C701</td>
<td>Description not found in ODM database</td>
</tr>
<tr>
<td>CODM3_E_WRIITEREGISTRY</td>
<td>0x8004C710</td>
<td>Error writing to the registry</td>
</tr>
<tr>
<td>CODM3_E_BAD_REGULAR_EXPRESSION</td>
<td>0x8004C711</td>
<td>Invalid regular expression</td>
</tr>
<tr>
<td>CODM3_E_COMCATEGORIE_MANAGER_FAILED</td>
<td>0x8004C712</td>
<td>Component Category Manager could not be instantiated</td>
</tr>
<tr>
<td>CODM3_E_COMCATEGORIE_ENUMERATION_FAILED</td>
<td>0x8004C713</td>
<td>Driver could not be enumerated by the Category Manager</td>
</tr>
<tr>
<td>CODM3_E_CREATE_LOCAL_BUFFER</td>
<td>0x8004C714</td>
<td>Error creating local buffers</td>
</tr>
<tr>
<td>CODM3_E_UNKNOWNHANDLE</td>
<td>0x8004C715</td>
<td>Unknown handle</td>
</tr>
<tr>
<td>CODM3_E_QUEUE_LIMIT_REACHED</td>
<td>0x8004C717</td>
<td>Queue size limit for connection reached</td>
</tr>
<tr>
<td>CODM3_E_DATASEIZE_ZERO</td>
<td>0x8004C718</td>
<td>Zero data length passed</td>
</tr>
<tr>
<td>CODM3_E_INVALID_DATA</td>
<td>0x8004C719</td>
<td>Invalid data content</td>
</tr>
<tr>
<td>CODM3_E_INVALID_MODE</td>
<td>0x8004C71A</td>
<td>Invalid mode</td>
</tr>
<tr>
<td>CODM3_E_DATABASE_READ</td>
<td>0x8004C71B</td>
<td>Error reading database</td>
</tr>
<tr>
<td>CODM3_E_CREATE_DEVICE_THREAD</td>
<td>0x8004C750</td>
<td>Error creating device thread</td>
</tr>
<tr>
<td>CODM3_E_CREATE_DEVICE_THREAD_STOP_EVENT</td>
<td>0x8004C751</td>
<td>Error creating device thread stop event</td>
</tr>
<tr>
<td>CODM3_E_CLIENT_NOT_REGISTERED</td>
<td>0x8004C752</td>
<td>Client is not registered at the ODM</td>
</tr>
<tr>
<td>CODM3_E_NO_MORE_CLIENTS</td>
<td>0x8004C753</td>
<td>Maximum number of clients reached</td>
</tr>
<tr>
<td>CODM3_E_MAX_CLIENT_CONNECTIONS_REACHED</td>
<td>0x8004C754</td>
<td>Maximum number of client connections reached</td>
</tr>
<tr>
<td>CODM3_E_ENTRY_NOT_FOUND</td>
<td>0x8004C755</td>
<td>Driver/device not found</td>
</tr>
<tr>
<td>CODM3_E_DRIVER_NOT_FOUND</td>
<td>0x8004C757</td>
<td>The requested driver is unknown to the ODM</td>
</tr>
<tr>
<td>CODM3_E_DEVICE_ALREADY_LOCKED</td>
<td>0x8004C758</td>
<td>Device is locked by another process</td>
</tr>
<tr>
<td>CODM3_E_DEVICE_UNLOCKED_FAILED</td>
<td>0x8004C759</td>
<td>Device could not be unlocked, lock was set by another process</td>
</tr>
<tr>
<td>CODM3_E_DEVICE_LOCK_NECESSARY</td>
<td>0x8004C75A</td>
<td>Operation requires a device lock to be set</td>
</tr>
<tr>
<td>CODM3_E_DEVICE_SUBSCRIPTIONLIMIT</td>
<td>0x8004C75B</td>
<td>Maximum number of servers registered for this device reached</td>
</tr>
<tr>
<td>CODM3_E_DEVICE_NOTSUBSCRIBED</td>
<td>0x8004C75C</td>
<td>Process is not registered as a server on this device</td>
</tr>
<tr>
<td>CODM3_E_DEVICE_NO_MESSAGE</td>
<td>0x8004C75D</td>
<td>No message available</td>
</tr>
<tr>
<td>CODM3_E_TRANSFER_TIME_OUT</td>
<td>0x8004C760</td>
<td>Message transfer timeout</td>
</tr>
<tr>
<td>CODM3_E_MESSAGE_INSERVICE</td>
<td>0x8004C761</td>
<td>Message in service</td>
</tr>
</tbody>
</table>

Table 35: ODM Error Codes - General ODM Error Codes
### 14.4.2 General ODM Driver Error Codes

<table>
<thead>
<tr>
<th>Error Code (Definition)</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CODM3_E_DRV_OPEN_DEVICE</td>
<td>0x8004C7A0</td>
<td>Packet type unsupported by driver</td>
</tr>
<tr>
<td>CODM3_E_DRV_INVALID_IDENTIFIER</td>
<td>0x8004C7A1</td>
<td>Invalid device identifier</td>
</tr>
<tr>
<td>CODM3_E_DRV_DEVICE_PARAMETERS_MISMATCH</td>
<td>0x8004C7A3</td>
<td>Parameters differ from requested device</td>
</tr>
<tr>
<td>CODM3_E_DRV_BROWSE_NO_DEVICES</td>
<td>0x8004C7A4</td>
<td>No devices found</td>
</tr>
<tr>
<td>CODM3_E_DRV_CREATE_DEVICE_INST</td>
<td>0x8004C7A5</td>
<td>Device instance could not be created</td>
</tr>
<tr>
<td>CODM3_E_DRV_DEVICE_NOMORE_TX</td>
<td>0x8004C7A6</td>
<td>Device connection limit reached</td>
</tr>
<tr>
<td>CODM3_E_DRV_DEVICE_DUPLICATE_TX</td>
<td>0x8004C7A7</td>
<td>Duplicate transmitter ID</td>
</tr>
<tr>
<td>CODM3_E_DRV_DEVICE_NOT_CONFIGURED</td>
<td>0x8004C7A8</td>
<td>Device is not configured</td>
</tr>
<tr>
<td>CODM3_E_DRV_DEVICE_COMMUNICATION</td>
<td>0x8004C7A9</td>
<td>Device communication error</td>
</tr>
<tr>
<td>CODM3_E_DRV_DEVICE_NO_MESSAGE</td>
<td>0x8004C7AA</td>
<td>No message available</td>
</tr>
<tr>
<td>CODM3_E_DRV_DEVICE_NOT_READY</td>
<td>0x8004C7AB</td>
<td>Device not ready</td>
</tr>
<tr>
<td>CODM3_E_DRV_INVALIDCONFIGURATION</td>
<td>0x8004C7AC</td>
<td>Invalid driver configuration</td>
</tr>
<tr>
<td>CODM3_E_DRV_DLINVALIDMODE</td>
<td>0x8004C7C0</td>
<td>Invalid download mode</td>
</tr>
<tr>
<td>CODM3_E_DRV_DLINPROGRESS</td>
<td>0x8004C7C1</td>
<td>Download is active</td>
</tr>
<tr>
<td>CODM3_E_DRV_ULINPROGRESS</td>
<td>0x8004C7C2</td>
<td>Upload is active</td>
</tr>
</tbody>
</table>

Table 36: ODM Error Codes - General ODM Driver Error Codes
### 14.4.3 cifX Driver Specific ODM Error Codes

<table>
<thead>
<tr>
<th>Error Code (Definition)</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DRV_E_BOARD_NOT_INITIALIZED</td>
<td>0x8004C001</td>
<td>DRIVER Board not initialized</td>
</tr>
<tr>
<td>DRV_E_INIT_STATE_ERROR</td>
<td>0x8004C002</td>
<td>DRIVER Error in internal init state</td>
</tr>
<tr>
<td>DRV_E_READ_STATE_ERROR</td>
<td>0x8004C003</td>
<td>DRIVER Error in internal read state</td>
</tr>
<tr>
<td>DRV_E_CMD_ACTIVE</td>
<td>0x8004C004</td>
<td>DRIVER Command on this channel is active</td>
</tr>
<tr>
<td>DRV_E_PARAMETER_UNKNOWN</td>
<td>0x8004C005</td>
<td>DRIVER Unknown parameter in function</td>
</tr>
<tr>
<td>DRV_E_WRONG_DRIVER_VERSION</td>
<td>0x8004C006</td>
<td>DRIVER Version is incompatible with DLL</td>
</tr>
<tr>
<td>DRV_E_PCI_SET_CONFIG_MODE</td>
<td>0x8004C007</td>
<td>DRIVER Error during PCI set configuration mode</td>
</tr>
<tr>
<td>DRV_E_PCI_READ_DPM_LENGTH</td>
<td>0x8004C008</td>
<td>DRIVER Could not read PCI dual port memory length</td>
</tr>
<tr>
<td>DRV_E_PCI_SET_RUN_MODE</td>
<td>0x8004C009</td>
<td>DRIVER Error during PCI set run mode</td>
</tr>
<tr>
<td>DRV_E_DEV_DPM_ACCESS_ERROR</td>
<td>0x8004C00A</td>
<td>DEVICE Dual port ram not accessible(board not found)</td>
</tr>
<tr>
<td>DRV_E_DEV_NOT_READY</td>
<td>0x8004C00B</td>
<td>DEVICE Not ready (ready flag failed)</td>
</tr>
<tr>
<td>DRV_E_DEV_NOT_RUNNING</td>
<td>0x8004C00C</td>
<td>DEVICE Not running (running flag failed)</td>
</tr>
<tr>
<td>DRV_E_DEV_WATCHDOG_FAILED</td>
<td>0x8004C00D</td>
<td>DEVICE Watchdog test failed</td>
</tr>
<tr>
<td>DRV_E_DEV_OS_VERSION_ERROR</td>
<td>0x8004C00E</td>
<td>DEVICE Signals wrong OS version</td>
</tr>
<tr>
<td>DRV_E_DEV_SYSERR</td>
<td>0x8004C00F</td>
<td>DEVICE Error in dual port flags</td>
</tr>
<tr>
<td>DRV_E_DEV_MAILBOX_FULL</td>
<td>0x8004C010</td>
<td>DEVICE Send mailbox is full</td>
</tr>
<tr>
<td>DRV_E_DEV_PUT_TIMEOUT</td>
<td>0x8004C011</td>
<td>DEVICE PutMessage timeout</td>
</tr>
<tr>
<td>DRV_E_DEV_GET_TIMEOUT</td>
<td>0x8004C012</td>
<td>DEVICE GetMessage timeout</td>
</tr>
<tr>
<td>DRV_E_DEV_GET_NO_MESSAGE</td>
<td>0x8004C013</td>
<td>DEVICE No message available</td>
</tr>
<tr>
<td>DRV_E_DEV_RESET_TIMEOUT</td>
<td>0x8004C014</td>
<td>DEVICE RESET command timeout</td>
</tr>
<tr>
<td>DRV_E_DEV_NO_COM_FLAG</td>
<td>0x8004C015</td>
<td>DEVICE COM-flag not set. Check if Bus is running</td>
</tr>
<tr>
<td>DRV_E_DEV.Exchange_FAILED</td>
<td>0x8004C016</td>
<td>DEVICE I/O data exchange failed</td>
</tr>
<tr>
<td>DRV_E_DEV.Exchange_TIMEOUT</td>
<td>0x8004C017</td>
<td>DEVICE I/O data exchange timeout</td>
</tr>
<tr>
<td>DRV_E_DEV.COM_MODE_UNKNOWN</td>
<td>0x8004C018</td>
<td>DEVICE I/O data mode unknown</td>
</tr>
<tr>
<td>DRV_E_DEV_FUNCTION_FAILED</td>
<td>0x8004C019</td>
<td>DEVICE Function call failed</td>
</tr>
<tr>
<td>DRV_E_DEV_DPMSIZE_MISMATCH</td>
<td>0x8004C01A</td>
<td>DEVICE DPM size differs from configuration</td>
</tr>
<tr>
<td>DRV_E_DEV_STATE_MODE_UNKNOWN</td>
<td>0x8004C01B</td>
<td>DEVICE State mode unknown</td>
</tr>
<tr>
<td>DRV_E_DEV_HW_PORT_IS_USED</td>
<td>0x8004C01C</td>
<td>DEVICE Output port already in use</td>
</tr>
<tr>
<td>DRV_E_USR.OPEN_ERROR</td>
<td>0x8004C01E</td>
<td>USER Driver not opened (device driver not loaded)</td>
</tr>
<tr>
<td>DRV_E_USR_INIT_DRV_ERROR</td>
<td>0x8004C01F</td>
<td>USER Can't connect to device</td>
</tr>
<tr>
<td>DRV_E_USR_NOT_INITIALIZED</td>
<td>0x8004C020</td>
<td>USER Board not initialized (DevInitBoard not called)</td>
</tr>
<tr>
<td>DRV_E_USR.COMM_ERR</td>
<td>0x8004C021</td>
<td>USER ICTRL function failed</td>
</tr>
<tr>
<td>DRV_E_USR.DEV_NUMBER_INVALID</td>
<td>0x8004C022</td>
<td>USER Parameter DeviceNumber invalid</td>
</tr>
<tr>
<td>DRV_E_USR.INFO_AREA_INVALID</td>
<td>0x8004C023</td>
<td>USER Parameter InfoArea unknown</td>
</tr>
<tr>
<td>DRV_E_USR.NUMBER_INVALID</td>
<td>0x8004C024</td>
<td>USER Parameter Number invalid</td>
</tr>
<tr>
<td>DRV_E_USR.MODE_INVALID</td>
<td>0x8004C025</td>
<td>USER Parameter Mode invalid</td>
</tr>
<tr>
<td>DRV_E_USR.MSG_BUF_NULL_PTR</td>
<td>0x8004C026</td>
<td>USER NULL pointer assignment</td>
</tr>
<tr>
<td>DRV_E_USR.MSG_BUF_TOO_SHORT</td>
<td>0x8004C027</td>
<td>USER Message buffer too small</td>
</tr>
<tr>
<td>Error Code</td>
<td>Definition</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>DRV_USR_SIZE_INVALID</td>
<td>0x8004C028</td>
<td>USER Parameter Size invalid</td>
</tr>
<tr>
<td>DRV_USR_SIZE_ZERO</td>
<td>0x8004C02A</td>
<td>USER Parameter Size with zero length</td>
</tr>
<tr>
<td>DRV_USR_SIZE_TOO_LONG</td>
<td>0x8004C02B</td>
<td>USER Parameter Size too long</td>
</tr>
<tr>
<td>DRV_USR_DEV_PTR_NULL</td>
<td>0x8004C02C</td>
<td>USER Device address null pointer</td>
</tr>
<tr>
<td>DRV_USR_BUF_PTR_NULL</td>
<td>0x8004C02D</td>
<td>USER Pointer to buffer is a null pointer</td>
</tr>
<tr>
<td>DRV_USR_SENDSIZE_TOO_LONG</td>
<td>0x8004C02E</td>
<td>USER Parameter SendSize too large</td>
</tr>
<tr>
<td>DRV_USR_RECVSIZE_TOO_LONG</td>
<td>0x8004C02F</td>
<td>USER Parameter ReceiveSize too large</td>
</tr>
<tr>
<td>DRV_USR_SENDBUF_PTR_NULL</td>
<td>0x8004C030</td>
<td>USER Pointer to send buffer is a null pointer</td>
</tr>
<tr>
<td>DRV_USR_RECVBUF_PTR_NULL</td>
<td>0x8004C031</td>
<td>USER Pointer to receive buffer is a null pointer</td>
</tr>
<tr>
<td>DRV_DMA_INSUFF_MEM</td>
<td>0x8004C032</td>
<td>DMA Memory allocation error</td>
</tr>
<tr>
<td>DRV_DMA_TIMEOUT_CH4</td>
<td>0x8004C033</td>
<td>DMA Read I/O timeout</td>
</tr>
<tr>
<td>DRV_DMA_TIMEOUT_CH5</td>
<td>0x8004C034</td>
<td>DMA Write I/O timeout</td>
</tr>
<tr>
<td>DRV_DMA_TIMEOUT_CH6</td>
<td>0x8004C035</td>
<td>DMA PCI transfer timeout</td>
</tr>
<tr>
<td>DRV_DMA_TIMEOUT_CH7</td>
<td>0x8004C036</td>
<td>DMA Download timeout</td>
</tr>
<tr>
<td>DRV_DMA_DB_DOWN_FAIL</td>
<td>0x8004C037</td>
<td>DMA Database download failed</td>
</tr>
<tr>
<td>DRV_DMA_FW_DOWN_FAIL</td>
<td>0x8004C038</td>
<td>DMA Firmware download failed</td>
</tr>
<tr>
<td>DRV_CLEAR_DB_FAIL</td>
<td>0x8004C039</td>
<td>DMA Clear database on the device failed</td>
</tr>
<tr>
<td>DRV_DEV_NO_VIRTUAL_MEM</td>
<td>0x8004C03C</td>
<td>DMA USER Virtual memory not available</td>
</tr>
<tr>
<td>DRV_DEV_UNMAP_VIRTUAL_MEM</td>
<td>0x8004C03D</td>
<td>DMA USER Unmap virtual memory failed</td>
</tr>
<tr>
<td>DRV_GENERAL_ERROR</td>
<td>0x8004C046</td>
<td>DRIVER General error</td>
</tr>
<tr>
<td>DRV_DMA_ERROR</td>
<td>0x8004C047</td>
<td>DRIVER General DMA error</td>
</tr>
<tr>
<td>DRV_WDG_IO_ERROR</td>
<td>0x8004C048</td>
<td>DRIVER I/O WatchDog failed</td>
</tr>
<tr>
<td>DRV_WDG_DEV_ERROR</td>
<td>0x8004C049</td>
<td>DRIVER Device Watchdog failed</td>
</tr>
<tr>
<td>DRV_USR_DRIVER_UNKNOWN</td>
<td>0x8004C050</td>
<td>USER Driver unknown</td>
</tr>
<tr>
<td>DRV_USR_DEVICE_NAME_INVALID</td>
<td>0x8004C051</td>
<td>USER Device name invalid</td>
</tr>
<tr>
<td>DRV_USR_DEVICE_NAME_UNKNOWN</td>
<td>0x8004C052</td>
<td>USER Device name unknown</td>
</tr>
<tr>
<td>DRV_USR_DEVICE_FUNC_NOTIMPL</td>
<td>0x8004C053</td>
<td>USER Device function not implemented</td>
</tr>
<tr>
<td>DRV_USR_FILE_OPEN_FAILED</td>
<td>0x8004C064</td>
<td>USER File could not be opened</td>
</tr>
<tr>
<td>DRV_USR_FILE_SIZE_ZERO</td>
<td>0x8004C065</td>
<td>USER File size zero</td>
</tr>
<tr>
<td>DRV_USR_FILE_NO_MEMORY</td>
<td>0x8004C066</td>
<td>USER Not enough memory to load file</td>
</tr>
<tr>
<td>DRV_USR_FILE_READ_FAILED</td>
<td>0x8004C067</td>
<td>USER File read failed</td>
</tr>
<tr>
<td>DRV_USR_FILETYPE</td>
<td>0x8004C068</td>
<td>USER File type invalid</td>
</tr>
<tr>
<td>DRV_USR_FILENAME_INVALID</td>
<td>0x8004C069</td>
<td>USER Invalid filename</td>
</tr>
<tr>
<td>DRV_FW_FILE_OPEN_FAILED</td>
<td>0x8004C06E</td>
<td>USER Firmware file could not be opened</td>
</tr>
<tr>
<td>DRV_FW_FILE_SIZE_ZERO</td>
<td>0x8004C06F</td>
<td>USER Not enough memory to load firmware file</td>
</tr>
<tr>
<td>DRV_FW_FILE_NO_MEMORY</td>
<td>0x8004C070</td>
<td>USER Not enough memory to load firmware file</td>
</tr>
<tr>
<td>DRV_FW_FILE_READ_FAILED</td>
<td>0x8004C071</td>
<td>USER Firmware file read failed</td>
</tr>
<tr>
<td>DRV_FW_FILE_INVALID_FILETYPE</td>
<td>0x8004C072</td>
<td>USER Firmware file type invalid</td>
</tr>
<tr>
<td>DRV_FW_FILENAME_INVALID</td>
<td>0x8004C073</td>
<td>USER Firmware file name not valid</td>
</tr>
<tr>
<td>DRV_FW_DOWNLOAD_ERROR</td>
<td>0x8004C074</td>
<td>USER Firmware file download error</td>
</tr>
<tr>
<td>DRV_FW_FILENAME_NOT_FOUND</td>
<td>0x8004C075</td>
<td>USER Firmware file not found in the internal table</td>
</tr>
<tr>
<td>DRV_FW_BOOTLOADER_ACTIVE</td>
<td>0x8004C076</td>
<td>USER Firmware file BOOTLOADER active</td>
</tr>
</tbody>
</table>
### cifX Driver Specific ODM Error Codes

<table>
<thead>
<tr>
<th>Error Code (Definition)</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DRV_E_FW_NO_FILE_PATH</td>
<td>0x8004C077</td>
<td>USER Firmware file no file path</td>
</tr>
<tr>
<td>DRV_E_CF_FILE_OPEN_FAILED</td>
<td>0x8004C078</td>
<td>USER Configuration file could not be opened</td>
</tr>
<tr>
<td>DRV_E_CF_FILE_SIZE_ZERO</td>
<td>0x8004C079</td>
<td>USER Configuration file size zero</td>
</tr>
<tr>
<td>DRV_E_CF_FILE_NO_MEMORY</td>
<td>0x8004C07A</td>
<td>USER Not enough memory to load configuration file</td>
</tr>
<tr>
<td>DRV_E_CF_READ_FAILED</td>
<td>0x8004C07B</td>
<td>USER Configuration file read failed</td>
</tr>
<tr>
<td>DRV_E_CF_INVALID_FILETYPE</td>
<td>0x8004C07C</td>
<td>USER Configuration file type invalid</td>
</tr>
<tr>
<td>DRV_E_CF_FILENAME_INVALID</td>
<td>0x8004C07D</td>
<td>USER Configuration file name not valid</td>
</tr>
<tr>
<td>DRV_E_CF_DOWNLOAD_ERROR</td>
<td>0x8004C07E</td>
<td>USER Configuration file download error</td>
</tr>
<tr>
<td>DRV_E_CF_FILE_NO_SEGMENT</td>
<td>0x8004C07F</td>
<td>USER No flash segment in the configuration file</td>
</tr>
<tr>
<td>DRV_E_CF_DIFFERS_FROM_DBM</td>
<td>0x8004C080</td>
<td>USER Configuration file differs from database</td>
</tr>
<tr>
<td>DRV_E_DBM_SIZE_ZERO</td>
<td>0x8004C083</td>
<td>USER Database size zero</td>
</tr>
<tr>
<td>DRV_E_DBM_NO_MEMORY</td>
<td>0x8004C084</td>
<td>USER Not enough memory to upload database</td>
</tr>
<tr>
<td>DRV_E_DBM_READ_FAILED</td>
<td>0x8004C085</td>
<td>USER Database read failed</td>
</tr>
<tr>
<td>DRV_E_DBM_NO_FLASH_SEGMENT</td>
<td>0x8004C086</td>
<td>USER Database segment unknown</td>
</tr>
<tr>
<td>DEV_E_CF_INVALID_DESCRIP_VERSION</td>
<td>0x8004C096</td>
<td>CONFIG Version of the description table invalid</td>
</tr>
<tr>
<td>DEV_E_CF_INVALID_INPUT_OFFSET</td>
<td>0x8004C097</td>
<td>CONFIG Input offset is invalid</td>
</tr>
<tr>
<td>DEV_E_CF_INVALID_INPUT_SIZE</td>
<td>0x8004C098</td>
<td>CONFIG Input size is 0</td>
</tr>
<tr>
<td>DEV_E_CF_MISMATCH_INPUT_SIZE</td>
<td>0x8004C099</td>
<td>CONFIG Input size does not match configuration</td>
</tr>
<tr>
<td>DEV_E_CF_INVALID_OUTPUT_OFFSET</td>
<td>0x8004C09A</td>
<td>CONFIG Invalid output offset</td>
</tr>
<tr>
<td>DEV_E_CF_NO_OUTPUT_SIZE</td>
<td>0x8004C09B</td>
<td>CONFIG Output size is 0</td>
</tr>
<tr>
<td>DEV_E_CF_MISMATCH_OUTPUT_SIZE</td>
<td>0x8004C09C</td>
<td>CONFIG Output size does not match configuration</td>
</tr>
<tr>
<td>DEV_E_CF_STN_NOT_CONFIGURED</td>
<td>0x8004C09D</td>
<td>CONFIG Station not configured</td>
</tr>
<tr>
<td>DEV_E_CF_CANNOT_GET_STN_CONFIG</td>
<td>0x8004C09E</td>
<td>CONFIG Cannot get the Station configuration</td>
</tr>
<tr>
<td>DEV_E_CF_MODULE_DEF_MISSING</td>
<td>0x8004C09F</td>
<td>CONFIG Module definition is missing</td>
</tr>
<tr>
<td>DEV_E_CF_MISMATCH_EMPTY_SLOT</td>
<td>0x8004C0A0</td>
<td>CONFIG Empty slot mismatch</td>
</tr>
<tr>
<td>DEV_E_CF_MISMATCH_INPUT_OFFSET</td>
<td>0x8004C0A1</td>
<td>CONFIG Input offset mismatch</td>
</tr>
<tr>
<td>DEV_E_CF_MISMATCH_OUTPUT_OFFSET</td>
<td>0x8004C0A2</td>
<td>CONFIG Output offset mismatch</td>
</tr>
<tr>
<td>DEV_E_CF_MISMATCH_DATA_TYPE</td>
<td>0x8004C0A3</td>
<td>CONFIG Data type mismatch</td>
</tr>
<tr>
<td>DEV_E_CF_MODULE_DEF_MISSING_NO_SI</td>
<td>0x8004C0A4</td>
<td>CONFIG Module definition is missing,(no Slot/Ldx)</td>
</tr>
</tbody>
</table>

Table 37: cifX Driver Specific ODM Error Codes
## 14.5 Error Codes cifX Device Driver and netX Driver

### 14.5.1 Generic Error Codes

<table>
<thead>
<tr>
<th>Error Code (Definition)</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CIFX_INVALID_POINTER</td>
<td>0x800A0001</td>
<td>Invalid pointer (NULL) passed to driver</td>
</tr>
<tr>
<td>CIFX_INVALID_BOARD</td>
<td>0x800A0002</td>
<td>No board with the given nameindex available</td>
</tr>
<tr>
<td>CIFX_INVALID_CHANNEL</td>
<td>0x800A0003</td>
<td>No channel with the given index available</td>
</tr>
<tr>
<td>CIFX_INVALID_HANDLE</td>
<td>0x800A0004</td>
<td>Invalid handle passed to driver</td>
</tr>
<tr>
<td>CIFX_INVALID_PARAMETER</td>
<td>0x800A0005</td>
<td>Invalid parameter</td>
</tr>
<tr>
<td>CIFX_INVALID_COMMAND</td>
<td>0x800A0006</td>
<td>Invalid command</td>
</tr>
<tr>
<td>CIFX_INVALID_BUFFERSIZE</td>
<td>0x800A0007</td>
<td>Invalid buffer size</td>
</tr>
<tr>
<td>CIFX_INVALID_ACCESS_SIZE</td>
<td>0x800A0008</td>
<td>Invalid access size</td>
</tr>
<tr>
<td>CIFX_FUNCTION_FAILED</td>
<td>0x800A0009</td>
<td>Function failed</td>
</tr>
<tr>
<td>CIFX_FILE_OPEN_FAILED</td>
<td>0x800A000A</td>
<td>File could not be opened</td>
</tr>
<tr>
<td>CIFX_FILE_SIZE_ZERO</td>
<td>0x800A000B</td>
<td>File size is zero</td>
</tr>
<tr>
<td>CIFX_FILE_LOAD_INSUFF_MEM</td>
<td>0x800A000C</td>
<td>Insufficient memory to load file</td>
</tr>
<tr>
<td>CIFX_FILE_CHECKSUM_ERROR</td>
<td>0x800A000D</td>
<td>File checksum compare failed</td>
</tr>
<tr>
<td>CIFX_FILE_READ_ERROR</td>
<td>0x800A000E</td>
<td>Error reading from file</td>
</tr>
<tr>
<td>CIFX_FILE_TYPE_INVALID</td>
<td>0x800A000F</td>
<td>Invalid file type</td>
</tr>
<tr>
<td>CIFX_FILE_NAME_INVALID</td>
<td>0x800A0010</td>
<td>Invalid file name</td>
</tr>
<tr>
<td>CIFX_FUNCTION_NOT_AVAILABLE</td>
<td>0x800A0011</td>
<td>Driver function not available</td>
</tr>
<tr>
<td>CIFX_BUFFER_TOO_SHORT</td>
<td>0x800A0012</td>
<td>Given buffer is too short</td>
</tr>
<tr>
<td>CIFX_MEMORY_MAPPING_FAILED</td>
<td>0x800A0013</td>
<td>Failed to map the memory</td>
</tr>
<tr>
<td>CIFX_NO_MORE_ENTRIES</td>
<td>0x800A0014</td>
<td>No more entries available</td>
</tr>
<tr>
<td>CIFX_CALLBACK_MODE_UNKNOWN</td>
<td>0x800A0015</td>
<td>Unknown callback handling mode</td>
</tr>
<tr>
<td>CIFX_CALLBACK_CREATE_EVENT_FAILED</td>
<td>0x800A0016</td>
<td>Failed to create callback events</td>
</tr>
<tr>
<td>CIFX_CALLBACK_CREATE_RECV_BUFFER</td>
<td>0x800A0017</td>
<td>Failed to create callback receive buffer</td>
</tr>
</tbody>
</table>

*Table 38: Generic Error Codes*
### 14.5.2 Generic Driver Error Codes

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CIFX_DRV_NOT_INITIALIZED</td>
<td>0x800B0001</td>
<td>Driver not initialized</td>
</tr>
<tr>
<td>CIFX_DRV_INIT_STATE_ERROR</td>
<td>0x800B0002</td>
<td>Driver init state error</td>
</tr>
<tr>
<td>CIFX_DRV_READ_STATE_ERROR</td>
<td>0x800B0003</td>
<td>Driver read state error</td>
</tr>
<tr>
<td>CIFX_DRV_CMD_ACTIVE</td>
<td>0x800B0004</td>
<td>Command is active on device</td>
</tr>
<tr>
<td>CIFX_DRV_DOWNLOAD_FAILED</td>
<td>0x800B0005</td>
<td>General error during download</td>
</tr>
<tr>
<td>CIFX_DRV_WRONG_DRIVER_VERSION</td>
<td>0x800B0006</td>
<td>Wrong driver version</td>
</tr>
<tr>
<td>CIFX_DRV_DRIVER_NOT_LOADED</td>
<td>0x800B0030</td>
<td>CIFx driver is not running</td>
</tr>
<tr>
<td>CIFX_DRV_INIT_ERROR</td>
<td>0x800B0031</td>
<td>Failed to initialize the device</td>
</tr>
<tr>
<td>CIFX_DRV_CHANNEL_NOT_INITIALIZED</td>
<td>0x800B0032</td>
<td>Channel not initialized (xOpenChannel not called)</td>
</tr>
<tr>
<td>CIFX_DRV_IO_CONTROL_FAILED</td>
<td>0x800B0033</td>
<td>IOCTL call failed</td>
</tr>
<tr>
<td>CIFX_DRV_NOT_OPENED(</td>
<td>0x800B0034</td>
<td>Driver was not opened</td>
</tr>
<tr>
<td>CIFX_DRV_DOWNLOAD_STORAGE_UNKNOWN</td>
<td>0x800B0040</td>
<td>Unknown download storage type (RAMFLASH based) found</td>
</tr>
<tr>
<td>CIFX_DRV_DOWNLOAD_FW_WRONG_CHANNEL</td>
<td>0x800B0041</td>
<td>Channel number for a firmware download not supported</td>
</tr>
<tr>
<td>CIFX_DRV_DOWNLOAD_MODULE_NO_BASEOS</td>
<td>0x800B0042</td>
<td>Modules are not allowed without a Base OS firmware</td>
</tr>
</tbody>
</table>

*Table 39: Generic Driver Error Codes*
### 14.5.3 Generic Device Error Codes

<table>
<thead>
<tr>
<th>Error Code (Definition)</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CIFX_DEV_DPM_ACCESS_ERROR</td>
<td>0x800C0010</td>
<td>Dual port memory not accessible (board not found)</td>
</tr>
<tr>
<td>CIFX_DEV_NOT_READY</td>
<td>0x800C0011</td>
<td>Device not ready (ready flag failed)</td>
</tr>
<tr>
<td>CIFX_DEV_NOT_RUNNING</td>
<td>0x800C0012</td>
<td>Device not running (running flag failed)</td>
</tr>
<tr>
<td>CIFX_DEV_WATCHDOG_FAILED</td>
<td>0x800C0013</td>
<td>Watchdog test failed</td>
</tr>
<tr>
<td>CIFX_DEV_SYSERR</td>
<td>0x800C0015</td>
<td>Error in handshake flags</td>
</tr>
<tr>
<td>CIFX_DEV_MAILBOX_FULL</td>
<td>0x800C0016</td>
<td>Send mailbox is full</td>
</tr>
<tr>
<td>CIFX_DEV_PUT_TIMEOUT</td>
<td>0x800C0017</td>
<td>Send packet timeout</td>
</tr>
<tr>
<td>CIFX_DEV_GET_TIMEOUT</td>
<td>0x800C0018</td>
<td>Receive packet timeout</td>
</tr>
<tr>
<td>CIFX_DEV_GET_NO_PACKET</td>
<td>0x800C0019</td>
<td>No packet available</td>
</tr>
<tr>
<td>CIFX_DEV_MAILBOX_TOO_SHORT</td>
<td>0x800C001A</td>
<td>Mailbox too short</td>
</tr>
<tr>
<td>CIFX_DEV_RESET_TIMEOUT</td>
<td>0x800C0020</td>
<td>Reset command timeout</td>
</tr>
<tr>
<td>CIFX_DEV_NO_COM_FLAG</td>
<td>0x800C0021</td>
<td>COM-flag not set</td>
</tr>
<tr>
<td>CIFX_DEV_EXCHANGE_FAILED</td>
<td>0x800C0022</td>
<td>IO data exchange failed</td>
</tr>
<tr>
<td>CIFX_DEV_EXCHANGE_TIMEOUT</td>
<td>0x800C0023</td>
<td>IO data exchange timeout</td>
</tr>
<tr>
<td>CIFX_DEV_COM_MODE_UNKNOWN</td>
<td>0x800C0024</td>
<td>Unknown IO exchange mode</td>
</tr>
<tr>
<td>CIFX_DEV_FUNCTION_FAILED</td>
<td>0x800C0025</td>
<td>Device function failed</td>
</tr>
<tr>
<td>CIFX_DEV_DPMSIZE_MISMATCH</td>
<td>0x800C0026</td>
<td>DPM size differs from configuration</td>
</tr>
<tr>
<td>CIFX_DEV_STATE_MODE_UNKNOWN</td>
<td>0x800C0027</td>
<td>Unknown state mode</td>
</tr>
<tr>
<td>CIFX_DEV_HW_PORT_IS_USED</td>
<td>0x800C0028</td>
<td>Device is still accessed</td>
</tr>
<tr>
<td>CIFX_DEV_CONFIG_LOCK_TIMEOUT</td>
<td>0x800C0029</td>
<td>Configuration locking timeout</td>
</tr>
<tr>
<td>CIFX_DEV_CONFIG_UNLOCK_TIMEOUT</td>
<td>0x800C002A</td>
<td>Configuration unlocking timeout</td>
</tr>
<tr>
<td>CIFX_DEV_HOST_STATE_SET_TIMEOUT</td>
<td>0x800C002B</td>
<td>Set HOST state timeout</td>
</tr>
<tr>
<td>CIFX_DEV_HOST_STATE_CLEAR_TIMEOUT</td>
<td>0x800C002C</td>
<td>Clear HOST state timeout</td>
</tr>
<tr>
<td>CIFX_DEV_INITIALIZATION_TIMEOUT</td>
<td>0x800C002D</td>
<td>Timeout during channel initialization</td>
</tr>
<tr>
<td>CIFX_DEV_BUS_STATE_ON_TIMEOUT</td>
<td>0x800C002E</td>
<td>Set Bus ON Timeout</td>
</tr>
<tr>
<td>CIFX_DEV_BUS_STATE_OFF_TIMEOUT</td>
<td>0x800C002F</td>
<td>Set Bus OFF Timeout</td>
</tr>
<tr>
<td>CIFX_DEV_MODULE_ALREADY_RUNNING</td>
<td>0x800C0040</td>
<td>Module already running</td>
</tr>
<tr>
<td>CIFX_DEV_MODULE_ALREADY_EXISTS</td>
<td>0x800C0041</td>
<td>Module already exists</td>
</tr>
</tbody>
</table>

*Table 40: Generic Device Error Codes*
14.6 Error Codes netX Driver

14.6.1 CIFX API Transport Error Codes

<table>
<thead>
<tr>
<th>Error Code (Definition)</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CIFX_TRANSPORT_SEND_TIMEOUT</td>
<td>0x800D0001</td>
<td>Time out while sending data</td>
</tr>
<tr>
<td>CIFX_TRANSPORT_RECV_TIMEOUT</td>
<td>0x800D0002</td>
<td>Time out waiting for incoming data</td>
</tr>
<tr>
<td>CIFX_TRANSPORT_CONNECT</td>
<td>0x800D0003</td>
<td>Unable to communicate to the device no answer</td>
</tr>
<tr>
<td>CIFX_TRANSPORT_ABORTED</td>
<td>0x800D0004</td>
<td>Transfer has been aborted due to keep alive timeout or interface detachment</td>
</tr>
<tr>
<td>CIFX_CONNECTOR_FUNCTIONS_READ_ERROR</td>
<td>0x800D0010</td>
<td>Error reading the connector functions from the DLL</td>
</tr>
<tr>
<td>CIFX_CONNECTOR_IDENTIFIER_TOO_LONG</td>
<td>0x800D0011</td>
<td>Connector delivers an identifier longer than 6 characters</td>
</tr>
<tr>
<td>CIFX_CONNECTOR_IDENTIFIER_EMPTY</td>
<td>0x800D0012</td>
<td>Connector delivers an empty identifier</td>
</tr>
<tr>
<td>CIFX_CONNECTOR_DUPLICATE_IDENTIFIER</td>
<td>0x800D0013</td>
<td>Connector identifier already used</td>
</tr>
</tbody>
</table>

Table 41: CIFX API Transport Error Codes

14.6.2 CIFX API Transport Header State Error Codes

<table>
<thead>
<tr>
<th>Error Code (Definition)</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CIFX_TRANSPORT_ERROR_UNKNOWN</td>
<td>0x800E0001</td>
<td>Unknown error code in transport header</td>
</tr>
<tr>
<td>CIFX_TRANSPORT_CHECKSUM_ERROR</td>
<td>0x800E0002</td>
<td>CRC16 checksum failed</td>
</tr>
<tr>
<td>CIFX_TRANSPORT_LENGTH_INCOMPLETE</td>
<td>0x800E0003</td>
<td>Transaction with incomplete length detected</td>
</tr>
<tr>
<td>CIFX_TRANSPORT_DATA_TYPE_UNKNOWN</td>
<td>0x800E0004</td>
<td>Device does not support requested data type</td>
</tr>
<tr>
<td>CIFX_TRANSPORT_DEVICE_UNKNOWN</td>
<td>0x800E0005</td>
<td>Device not available unknown</td>
</tr>
<tr>
<td>CIFX_TRANSPORT_CHANNEL_UNKNOWN</td>
<td>0x800E0006</td>
<td>Channel not available unknown</td>
</tr>
<tr>
<td>CIFX_TRANSPORT_SEQUENCE</td>
<td>0x800E0007</td>
<td>Sequence error detected</td>
</tr>
<tr>
<td>CIFX_TRANSPORT_BUFFEROVERFLOW</td>
<td>0x800E0008</td>
<td>Buffer overflow detected</td>
</tr>
<tr>
<td>CIFX_TRANSPORT_RESOURCE</td>
<td>0x800E0009</td>
<td>Device signals out of resources</td>
</tr>
<tr>
<td>CIFX_TRANSPORT_KEEPALIVE</td>
<td>0x800E000A</td>
<td>Device connection monitoring error (Keep alive)</td>
</tr>
<tr>
<td>CIFX_TRANSPORT_DATA_TOO_SHORT</td>
<td>0x800E000B</td>
<td>Received transaction data too short</td>
</tr>
</tbody>
</table>

Table 42: CIFX API Transport Header State Error Codes
## 14.7 ODM Error Codes DBM V4

<table>
<thead>
<tr>
<th>Error Code (Definition)</th>
<th>Value (Hex)</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CDBM_E_MD5_INVALID</td>
<td>0XC004C810</td>
<td>Checksum invalid</td>
</tr>
<tr>
<td>CDBM_E_INTERNALERROR</td>
<td>0XC004C811</td>
<td>Internal Error</td>
</tr>
<tr>
<td>CDBM_W_WRITEREGISTRY</td>
<td>0X8004C812</td>
<td>Error writing to the registry</td>
</tr>
<tr>
<td>CDBM_E_UNEXPECTED_VALUE_IN_OLD_HEADER_FORMAT</td>
<td>0XC004C813</td>
<td>Error in a file containing the old DBM Header format.</td>
</tr>
<tr>
<td>CDBM_E_CHECKSUM_INVALID</td>
<td>0XC004C814</td>
<td>The Checksum of the old Header is invalid</td>
</tr>
<tr>
<td>CDBM_E_DB_ALREADY_LOADED_FORMAT</td>
<td>0XC004C815</td>
<td>A database is already loaded</td>
</tr>
<tr>
<td>CDBM_E_NO_VALID_TRANSACTION</td>
<td>0XC004C816</td>
<td>No valid transaction handle given</td>
</tr>
<tr>
<td>CDBM_E_STD_STRUCT_ERROR</td>
<td>0XC004C817</td>
<td>An error occurred during validation of data</td>
</tr>
<tr>
<td>CDBM_E_UNSUPPORTED_DATA_TYPE_FORMAT</td>
<td>0XC004C818</td>
<td>Unsupported Data Type</td>
</tr>
<tr>
<td>CDBM_W_CLASS_DELETED_FORMAT</td>
<td>0X8004C819 (Warning)</td>
<td>Using an Object which is marked as deleted</td>
</tr>
<tr>
<td>CDBM_W_CLIENT_DISCONNECTED</td>
<td>0X8004C81A (Warning)</td>
<td>A Client has already an outstanding connection to a Table. The connection is now destroyed.</td>
</tr>
<tr>
<td>CDBM_E_STRUCTURE_DEFINITION_INVALID</td>
<td>0XC004C81B</td>
<td>A structure definition of an Element in a Table is invalid</td>
</tr>
<tr>
<td>CDBM_E_NO_DATA_AVAILABLE</td>
<td>0XC004C81C</td>
<td>No data available for this operation</td>
</tr>
<tr>
<td>CDBM_E_NO_VALID_STRUCTURE</td>
<td>0XC004C81D</td>
<td>No valid structure available for this operation</td>
</tr>
<tr>
<td>CDBM_E_NO_TOGGLE_STRING_FOUND</td>
<td>0XC004C81E</td>
<td>No Toggle string found for this number</td>
</tr>
<tr>
<td>CDBM_E_ELEMENT_OUT_OF_RANGE</td>
<td>0XC004C81F</td>
<td>An element wasn’t found in the Record of a Table</td>
</tr>
<tr>
<td>CDBM_E_ELEMENT_NOT_IN_TABLE</td>
<td>0XC004C820</td>
<td>The element is not part of the Table</td>
</tr>
<tr>
<td>CDBM_E_CANNOT_CONVERT_INTO_CLIENT_TYPE</td>
<td>0XC004C821</td>
<td>The data can’t be converted into the Client type</td>
</tr>
<tr>
<td>CDBM_E_TRANSACTION_ALREADY_OPEN</td>
<td>0XC004C822</td>
<td>A transaction is already open. Please close this one first before opening a new one.</td>
</tr>
<tr>
<td>CDBM_I_OLD_WITHOUT_HEADER</td>
<td>0X4004C823 (Informational)</td>
<td>Use of an old DBM file Format without Header</td>
</tr>
<tr>
<td>CDBM_E_HR_FROM</td>
<td>0XC004C824</td>
<td>An HRESULT was received from a Subroutine</td>
</tr>
<tr>
<td>CDBM_E_PARAMETER</td>
<td>0XC004C825</td>
<td>A Parameter is invalid</td>
</tr>
<tr>
<td>CDBM_E_NOTIMPL</td>
<td>0XC004C826</td>
<td>Method is currently not implemented</td>
</tr>
<tr>
<td>CDBM_E_OUTOFMEMORY</td>
<td>0XC004C827</td>
<td>Out of memory</td>
</tr>
<tr>
<td>CDBM_E_NO_OPEN_TRANSACTION</td>
<td>0XC004C828</td>
<td>No transaction open</td>
</tr>
<tr>
<td>CDBM_E_NO_CONTENTS</td>
<td>0XC004C829</td>
<td>No contents available</td>
</tr>
<tr>
<td>CDBM_REC_NO_NOT_FOUND</td>
<td>0XC004C82A</td>
<td>Record not found</td>
</tr>
<tr>
<td>CDBM_STRUCTURE_ELEMENT_NOT_FOUND</td>
<td>0XC004C82B</td>
<td>Element of the Structure not found</td>
</tr>
<tr>
<td>CDBM_E_NO_MORE_RECORDS_IN_TABTYPE</td>
<td>0XC004C82C</td>
<td>Table type 3 can contain only one record</td>
</tr>
<tr>
<td>CDBM_E_WRITE</td>
<td>0XC004C82D</td>
<td>The data in the VARIANT must be given in a SafeArray</td>
</tr>
<tr>
<td>CDBM_E_WRITE_NO_PARRAY</td>
<td>0XC004C82E</td>
<td>The VARIANT contains no valid [parray] element</td>
</tr>
</tbody>
</table>
## ODM Error Codes DBM V4

<table>
<thead>
<tr>
<th>Error Code (Definition)</th>
<th>Value</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CDBM_E_WRITE_CANT_ACCESS_DATA</td>
<td>0XC004C82F</td>
<td>Unable to access SafeArray Data in the VARIANT</td>
</tr>
<tr>
<td>CDBM_E_WRITE_DATA</td>
<td>0XC004C830</td>
<td>To write the data of this Element it must be given as a BSTR, or as an Array of VT_UI1/VT_I1</td>
</tr>
<tr>
<td>CDBM_E_WRITE_BSTR_E1</td>
<td>0XC004C831</td>
<td>The BSTR string must have an even length.</td>
</tr>
<tr>
<td>CDBM_E_WRITE_BSTR_E2</td>
<td>0XC004C832</td>
<td>The BSTR string must contain only hex digits (0..9 and a/A..f/F).</td>
</tr>
<tr>
<td>CDBM_E_WRITE_CANT_INTERPRET_ARRAY</td>
<td>0XC004C833</td>
<td>Unable to interpret data in the SafeArray.</td>
</tr>
<tr>
<td>CDBM_E_WRITE_VT_ERROR</td>
<td>0XC004C834</td>
<td>Data type in the SafeArray is not VT_UI1 or VT_I1.</td>
</tr>
<tr>
<td>CDBM_E_WRITE_LENGTH</td>
<td>0XC004C835</td>
<td>Data length is invalid for write operation of this type.</td>
</tr>
<tr>
<td>CDBM_WRITE_ELEMENT</td>
<td>0XC004C836</td>
<td>Element not found in the Record of the Table</td>
</tr>
<tr>
<td>CDBM_MIN_MAX_ERROR</td>
<td>0XC004C837</td>
<td>Can't write data because of min underflow or max overflow</td>
</tr>
<tr>
<td>CDBM_TABLE_EXIST</td>
<td>0XC004C838</td>
<td>Table already exist in the database</td>
</tr>
<tr>
<td>CDBM_MIN_MAX_INVALID</td>
<td>0XC004C839</td>
<td>The Min value is greater than the Max Value</td>
</tr>
<tr>
<td>CDBM_DEF_MIN_MAX_INVALID</td>
<td>0XC004C83A</td>
<td>The Default Value is not in the range between the Min value and the Max Value</td>
</tr>
<tr>
<td>CDBM_CANT_CHANGE_STRUCTURE_WHILE_RECORDS_EXIST</td>
<td>0XC004C83B</td>
<td>It's not allowed to change the structure while Records exist in the Table</td>
</tr>
<tr>
<td>CDBM_NEW_STRUCT_NEEDS_TYPE</td>
<td>0XC004C83C</td>
<td>In a newly added structure the data type must be set also</td>
</tr>
<tr>
<td>CDBM_VALUE_ERROR</td>
<td>0XC004C83D</td>
<td>Range error while validating a value</td>
</tr>
<tr>
<td>CDBM_DATATYPE_UNSUPPORTED_IN_RCS</td>
<td>0XC004C83E</td>
<td>The data type is unsupported in the RCS file format</td>
</tr>
<tr>
<td>CDBM_I_COUNT_OF_TABLES_EXCEEDS_RCS_RANGE</td>
<td>0X4004C83F</td>
<td>The count of Tables exceeds the RCS range of Tables. This can cause problems if the file is downloaded to RCS Systems</td>
</tr>
<tr>
<td>CDBM_I_COUNT_OF_TABLES_EXCEEDS_OLDDBM_RANGE</td>
<td>0X4004C840</td>
<td>The count of Tables exceeds the DBM32.DLL range of Tables. This can cause problems if the file is used with older Tools using the DBM32.DLL</td>
</tr>
<tr>
<td>CDBM_UNSUPPORTED_DATATYPE_IN_RCS_MODE</td>
<td>0XC004C841</td>
<td>The Data type is not compatible with the old database format</td>
</tr>
<tr>
<td>CDBM_WRITE_UNSTRUCTURED_1</td>
<td>0XC004C842</td>
<td>The data of an unstructured record can only be written with the 'Write' Method not with 'WriteElement'.</td>
</tr>
<tr>
<td>CDBM_READ_UNSTRUCTURED_1</td>
<td>0XC004C843</td>
<td>The data of an unstructured record can only be read with the 'Read' Method not with 'ReadElement'</td>
</tr>
<tr>
<td>CDBM_WRITE_DATA_LENGTH_INVALID</td>
<td>0XC004C844</td>
<td>The given data length doesn't correspond with the expected data length.</td>
</tr>
<tr>
<td>CDBM_UNKNOWN_VIEW_MODE</td>
<td>0XC004C845</td>
<td>The View Mode is unknown.</td>
</tr>
<tr>
<td>CDBM_E_DIAG_TABLE</td>
<td>0XC004C846</td>
<td>It doesn't make much sense to add or delete records from a diagnostic table because those changes are never saved.</td>
</tr>
<tr>
<td>Error Code (Definition)</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------------------</td>
<td>----------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>CDBM_E_ADR_STRING_ERROR</td>
<td>0XC004C847</td>
<td>The given Address string doesn’t fit the required format of this type where all address bytes must be in the range between 0 and FF</td>
</tr>
<tr>
<td>CDBM_ERROR_FROM_VAR_CHANGE_TYPE</td>
<td>0XC004C848</td>
<td>Function VariantChangeType return an error when trying to convert the Parameter</td>
</tr>
<tr>
<td>CDBM_E_MINERROR</td>
<td>0XC004C849</td>
<td>Error while comparing the Value with the lower range</td>
</tr>
<tr>
<td>CDBM_E_MAXERROR</td>
<td>0XC004C84A</td>
<td>Error while comparing the Value with the upper range</td>
</tr>
<tr>
<td>CDBM_E_RANGE_ERROR</td>
<td>0XC004C84B</td>
<td>Value out of Range</td>
</tr>
<tr>
<td>CDBM_E_TABLE_TYPE1</td>
<td>0XC004C84C</td>
<td>Table type 1 doesn’t have a unique record length over all records</td>
</tr>
<tr>
<td>CDBM_E_TABLE_TYPE3_ADDR</td>
<td>0XC004C84D</td>
<td>Table type 3 doesn’t allow to insert more than one Record</td>
</tr>
<tr>
<td>CDBM_E_TABTYPE1</td>
<td>0XC004C84E</td>
<td>It's not allowed to insert more Records than structure definitions in Table Type 1</td>
</tr>
<tr>
<td>CDBM_E_TOGGLE_NOT_FOUND</td>
<td>0XC004C84F</td>
<td>Could not find the string for this value in the list of valid toggle strings</td>
</tr>
<tr>
<td>CDBM_E_TOGGLE_VALUE_IS_EMPTY_STRING</td>
<td>0XC004C850</td>
<td>The toggle string for this value is empty.</td>
</tr>
<tr>
<td>CDBM_VARIANT2BYTEARRAY_ERROR</td>
<td>0XC004C851</td>
<td>Error during conversion of Variant to byte array</td>
</tr>
<tr>
<td>CDBM_E_SET_ELEM_PROP_DEPENDENCY</td>
<td>0XC004C852</td>
<td>The Toggle Type needs also the additional string and the additional number entries in the Method</td>
</tr>
<tr>
<td>CDBM_E_TABTYPE1_REC_DOESNT_CORRESPOND_WITH_ELEMENT</td>
<td>0XC004C853</td>
<td>When reading the records of Table type 1 elementwise the record number must correspond with the element number</td>
</tr>
<tr>
<td>CDBM_TABTYPE1_NO_DATA_FOUND_FOR_RECORD</td>
<td>0XC004C854</td>
<td>When reading the records of Table type 1 and structure definitions are present it's assumed that for each structure element a corresponding record must exist</td>
</tr>
<tr>
<td>CDBM_E_TABTYPE1_WRITE_ELEMENT_NE_RECORD</td>
<td>0XC004C855</td>
<td>When writing the records of Table type 1 elementwise and structure definitions are present it's only allowed to write the corresponding element number in each record</td>
</tr>
<tr>
<td>CDBM_E_TABTYPE1_WRITE_ELEMENT_NOT_FOUND</td>
<td>0XC004C856</td>
<td>When writing the records of Table type 1 with an array and structure definitions are present it's assumed that a corresponding element number of this record exist</td>
</tr>
<tr>
<td>CDBM_I_TABLE_NAME_EXCEEDS_RCS_RANGE</td>
<td>0X4004C857</td>
<td>The Table name exceeds the maximum length of RCS compatible Table names</td>
</tr>
<tr>
<td>CDBM_W_CUT_STRING</td>
<td>0X8004C858</td>
<td>The string exceeds the maximum length and will be limited to the maximum length (Warning)</td>
</tr>
<tr>
<td>CDBM_I_STRING_TOO_SHORT</td>
<td>0X4004C859</td>
<td>The string is below the minimum length. The minimum length will be reduced. (Informational)</td>
</tr>
<tr>
<td>CDBM_I_STRING_TOO_LONG</td>
<td>0X4004C85A</td>
<td>The string is exceeding the maximum. The maximum length will be extended. (Informational)</td>
</tr>
<tr>
<td>CDBM_E_STRING_TOO_SHORT</td>
<td>0XC004C85B</td>
<td>The string is below the minimum length. (Error)</td>
</tr>
<tr>
<td>CDBM_E_STRING_TOO_LONG</td>
<td>0XC004C85C</td>
<td>The string is exceeding the maximum length. (Error)</td>
</tr>
<tr>
<td>Error Code (Definition)</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------------------------------------</td>
<td>---------</td>
<td>-------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>CDBM_E_WRONG_TYPE_FOR_WRITE</td>
<td>0XC004C85D</td>
<td>Writing on the Element type with the given Data type is not implemented</td>
</tr>
<tr>
<td>CDBM_E_NO_APPEND_IN_STRUCTURED_RECORDS</td>
<td>0XC004C85E</td>
<td>Method IDbmRecord::AppendData is not allowed for structured records</td>
</tr>
<tr>
<td>CDBM_E_DATA_UNAVAILABLE</td>
<td>0XC004C85F</td>
<td>No data available</td>
</tr>
<tr>
<td>CDBM_E_CANT_CONVERT_INTO</td>
<td>0XC004C860</td>
<td>Unable to convert the value into the Element type</td>
</tr>
<tr>
<td>CDBM_E_DBM_FILE_OVERFLOW</td>
<td>0XC004C861</td>
<td>You try to write a RCS like database which needs too much bytes</td>
</tr>
<tr>
<td>CDBM_E_PW_ERROR</td>
<td>0XC004C862</td>
<td>Password not correct</td>
</tr>
<tr>
<td>CDBM_E_FILELENGTH_CORRUPT</td>
<td>0XC004C863</td>
<td>The file length doesn't correspond to the length given in the Header.</td>
</tr>
<tr>
<td>CDBM_E_STRUCT_TYPE</td>
<td>0XC004C864</td>
<td>Error in the file.</td>
</tr>
<tr>
<td>CDBM_E_MD5SUM_INVALID</td>
<td>0XC004C865</td>
<td>MD5 sum invalid</td>
</tr>
<tr>
<td>CDBM_E_STRUCT_LENGTH</td>
<td>0XC004C866</td>
<td>Error in the expected and given structure length at a specific offset in the file.</td>
</tr>
<tr>
<td>CDBM_E_APPEND</td>
<td>0XC004C867</td>
<td>Append of data is only allowed if the Record contains only one data field and the field type will support this</td>
</tr>
<tr>
<td>CDBM_APPEND_NOT_SUPPORTED</td>
<td>0XC004C868</td>
<td>Append of Data not supported by this filed type</td>
</tr>
<tr>
<td>CDBM_DATA_TYPE_APPEND_ERROR</td>
<td>0XC004C869</td>
<td>Can't append Data of this type.</td>
</tr>
<tr>
<td>CDBM_E_UNSTRUCTURED_TABLE_DOESNT_SUPPORT_LENGTH</td>
<td>0XC004C86A</td>
<td>A Table without structure information doesn't support a record length</td>
</tr>
<tr>
<td>CDBM_E_DISABLED WHILE TRANSACTION_IS_OPEN</td>
<td>0XC004C86B</td>
<td>The Method is disabled while a transaction is open. Please close this one first and call the Method again.</td>
</tr>
<tr>
<td>CDBM_E_UNABLE_TO_CALL_READ_ON_LINKED_LIST</td>
<td>0XC004C86C</td>
<td>The Method is disabled on a LinkedList type. Please use the IRecordCollection on this type.</td>
</tr>
<tr>
<td>CDBM_E_ELEMENT_HAS_NO_SUBSTRUCTURE</td>
<td>0XC004C86D</td>
<td>An Element from a Table has no substructure</td>
</tr>
<tr>
<td>CDBM_STRUCT_ERROR_FROM_VAR_CHANGE_TYPE</td>
<td>0XC004C86E</td>
<td>Error from calling VariantChangeType</td>
</tr>
<tr>
<td>CDBM_E_FOREIGNKEY_DEF</td>
<td>0XC004C86F</td>
<td>The definition of a FOREIGNKEY must contain the name of the related Table in the description and this Table must exist at this time</td>
</tr>
<tr>
<td>CDBM_E_FOREIGNKEY_REF_TAB</td>
<td>0XC004C870</td>
<td>The description of a FOREIGNKEY must refer to a Table of type 'eDbmTableTypeLinkedList'</td>
</tr>
<tr>
<td>CDBM_E_KEY</td>
<td>0XC004C871</td>
<td>To create a Record Collection with a KEY it's necessary to have the data type KEY at the first position in all Records of the searched Table</td>
</tr>
<tr>
<td>CDBM_E_KEY_TABLE_TYPE</td>
<td>0XC004C872</td>
<td>This Method needs a Table of type 'eDbmTableTypeLinkedList'</td>
</tr>
<tr>
<td>CDBM_DATATYPE_NOT_IMPLEMENTED</td>
<td>0XC004C873</td>
<td>This data type is currently not implemented</td>
</tr>
<tr>
<td>CDBM_INSERT_POS_NOT_FOUND</td>
<td>0XC004C874</td>
<td>The position of the Record where the new one should be inserted wasn't found</td>
</tr>
<tr>
<td>CDBM_E_INSERT_REC_QI</td>
<td>0XC004C875</td>
<td>Error during insertion of a Record</td>
</tr>
<tr>
<td>CDBM_E_TAB_PROP</td>
<td>0XC004C876</td>
<td>Invalid Property in Table</td>
</tr>
<tr>
<td>CDBM_E_KEY_NOT_FOUND</td>
<td>0XC004C877</td>
<td>The KEY wasn’t found in the Table</td>
</tr>
<tr>
<td>Error Code (Definition)</td>
<td>Value</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>CDBM_E_KEY_INVALID</td>
<td>0XC004C878</td>
<td>The KEY is invalid for this operation</td>
</tr>
</tbody>
</table>

*Table 43: ODM Error Codes DBM V4*
15 Appendix

15.1 User Rights for the netHOST DTM

The user rights for the netHOST DTM are set within the FDT-container, i.e. SYCON.net. Opening the dialog windows and reading the parameters do not require special user rights. Also, all users can choose between the decimal or hexadecimal display mode or sort table entries.

Editing/configuring the parameters of the dialog windows belonging to the Settings and Configuration category, however, requires the user right of Maintenance, Planning Engineer or Administrator.

The following tables give an overview of the existing user groups and their access rights regarding the netHOST DTM.

User rights for the “Settings” dialog windows

<table>
<thead>
<tr>
<th>Dialog window / activity</th>
<th>Observer</th>
<th>Operator</th>
<th>Maintenance</th>
<th>Planning Engineer</th>
<th>Administrator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Driver Dialog Window</td>
<td>D</td>
<td>D</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Select driver</td>
<td>-</td>
<td>-</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>netX Driver Dialog Window</td>
<td>D</td>
<td>D</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Configure driver</td>
<td>-</td>
<td>-</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Device Assignment Dialog Window</td>
<td>D</td>
<td>D</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Search device</td>
<td>-</td>
<td>-</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Select device</td>
<td>-</td>
<td>-</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

Table 44: Settings (D = Displaying, X = Editing, Configuring)

User rights for the “Configuration” dialog windows

<table>
<thead>
<tr>
<th>Dialog window</th>
<th>Observer</th>
<th>Operator</th>
<th>Maintenance</th>
<th>Planning Engineer</th>
<th>Administrator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Settings Dialog Window</td>
<td>D</td>
<td>D</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Memory Card Management Dialog Window</td>
<td>D</td>
<td>D</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Licensing Dialog Window</td>
<td>D</td>
<td>D</td>
<td>X</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

Table 45: Configuration (D = Displaying, X = Editing, Configuring)
15.2 List of Figures

Figure 1: Data Flow of LAN Controlled netHOST Device 17
Figure 2: Data Flow and Software Components for Configuration and Testing 20
Figure 3: Ethernet Device Configuration Tool (1) 25
Figure 4: Ethernet Device Configuration Tool (2) 25
Figure 5: Ethernet Device Configuration Tool (3) 26
Figure 6: SYCON.net Login 28
Figure 7: Empty Project in SYCON.net 28
Figure 8: Select NHST-T100-EN DTM 29
Figure 9: Scanning for Devices in SYCON.net 30
Figure 10: Select Driver 30
Figure 11: Set IP Address in netX Driver 31
Figure 12: Select Device 32
Figure 13: Settings Dialog 33
Figure 14: Select Firmware File Dialog in SYCON.net 33
Figure 15: Firmware Download in SYCON.net 34
Figure 16: Security Question Firmware Download 35
Figure 17: License Pane 37
Figure 18: License Pane - License Type 38
Figure 19: License Pane – License Type / Master protocols 38
Figure 20: License Pane – License Type / Utilities 38
Figure 21: License Pane - Request Form, please fill out / Device Information 41
Figure 22: License Pane - Request Form, please fill out / License Type 42
Figure 23: License Pane - Request Form, please fill out / Mandatory data 42
Figure 24: License Pane – Selecting the Subsidiary / Ordering / Contacts 43
Figure 25: License Pane – placing the order by E-mail 44
Figure 26: Example: Order E-Mail License request 44
Figure 27: License Pane - placing the order by Fax or by Telephone 45
Figure 28: Example: Order Data Form PrintOrderRequest 45
Figure 29: License Pane – Fax Number of the selected Subsidiary 46
Figure 30: License Pane – Telephone Number of the selected Subsidiary 46
Figure 31: License Pane - Ordering by exported File and E-Mail 47
Figure 32: License Pane - Download License 48
Figure 33: SYCON.net Login 50
Figure 34: Empty Project in SYCON.net 50
Figure 35: Add netHOST Device in Configuration Project 51
Figure 36: netHOST Device in Configuration Project 51
Figure 37: Scanning for Devices in SYCON.net 52
Figure 38: Select Driver 53
Figure 39: Set IP Address in netX Driver 53
Figure 40: Select Device 54
Figure 41: Open Configuration Dialog for Primary Network 55
Figure 42: Setting IP Address (1) 56
Figure 43: Setting IP Address (2) 56
Figure 44: Add Slave Device 58
Figure 45: Configure Slave Device 59
Figure 46: PROFIBUS DP Master – Bus Parameters 60
Figure 47: PROFIBUS DP Slave Station Address 61
Figure 48: Download Configuration 62
Figure 49: SYCON.net Login 64
Figure 50: Empty Project in SYCON.net 65
Figure 51: Add netHOST Device in Configuration Project 66
Figure 52: netHOST Device in Configuration Project 66
Figure 53: Scanning for Devices in SYCON.net 67
Figure 54: Select Driver 68
Figure 55: Set IP Address in netX Driver 68
Figure 56: Select Device 69
Figure 57: Open Configuration Dialog for Ethernet Marshalling 70
Figure 58: Setting IP Address (1) 71
Figure 59: Setting IP Address (2) 71
Figure 60: Add IO Device to RTE Network 73
Figure 61: Configure IO Device (1) 74
Figure 62: Configure IO Device (2) 75
Figure 63: Configure IO Device (3) 76
Figure 64: PROFINET IO Controller – Network Settings 77
Figure 65: Download Configuration 78
Figure 66: Start netHOST Device Test Application 80
Figure 67: TCP Connection netX Driver 81
Figure 68: Channel Selection in netHOST Device Test Application 82
Figure 69: Bus State Test in netHOST Device Test Application 83
Figure 70: I/O Data in netHOST Device Test Application 83
Figure 71: Displaying Input Data in the netHOST Device Test Application 84
Figure 72: Entering Output Data in the netHOST Device Test Application 84
Figure 73: Start netHOST Device Test Application 86
Figure 74: TCP Connection netX Driver 87
Figure 75: Channel Selection in netHOST Device Test Application 88
Figure 76: Bus State Test in netHOST Device Test Application 89
Figure 77: I/O Data in netHOST Device Test Application 89
Figure 78: Start cifX Test Application 90
Figure 79: Channel Selection Dialog in cifX Test Application 91
Figure 80: cifX Test Application After Channel Selection 91
Figure 81: I/O Data Dialog in cifX Test Application (1) 92
Figure 82: I/O Data Dialog in cifX Test Application (2) 92
Figure 83: Displaying Incoming Data in netHOST Device Test Application 93
Figure 84: Entering Output Data in netHOST Device Test Application 93
Figure 85: Displaying Input Data in cifX Test Application 94
Figure 86: Import Device Description File (PROFIBUS GSD Example) 95
Figure 87: SYCON.net Login 97
Figure 88: Empty Project in SYCON.net 97
Figure 89: Settings Dialog 99
Figure 90: Select Firmware File Dialog in SYCON.net 100
Figure 91: Firmware Download in SYCON.net 101
Figure 92: SYCON.net Login 103
Figure 93: Empty Project in SYCON.net 104
Figure 94: Memory Card Management of the netHOST DTM 105
Figure 95: Memory Card Management After Inserting SD Memory Card 106
Figure 96: Memory Card Management After Backup to SD Memory Card 106
Figure 97: GUI of the netHOST DTM 108
Figure 98: Navigation Area of the netHOST DTM 109
Figure 99: Status Bar – Status Fields 1 to 6 111
Figure 100: Status Bar Display Examples 111
Figure 101: Settings in netHOST DTM 112
Figure 102: Driver List 113
Figure 103: netX Driver 114
Figure 104: Configure TCP/IP Connection in netX Driver 114
Figure 105: Scanning for Devices in SYCON.net 116
Figure 106: Device Assignment in netHOST DTM 117
Figure 107: „Configuration“ in netHOST DTM 118
Figure 108: „Settings“ Dialog Window in the netHOST DTM 119
Figure 109: Memory Card Management of the netHOST DTM 121
Figure 110: Licensing Dialog Window of the netHOST DTM 123
Figure 111: Diagnosis in netHOST DTM 124
Figure 112: General Diagnosis in netHOST DTM 125
| Figure 113: Firmware Diagnosis in netHOST DTM       | 127 |
| Figure 114: Connect netHOST                        | 128 |
| Figure 115: netHOST Connected                      | 129 |
15.3 List of Tables

Table 1: List of Revisions 6
Table 2: Reference to devices with preloaded firmware 8
Table 3: Reference to devices for loadable firmware 8
Table 4: Software 8
Table 5: Basic Documentation for netHOST 9
Table 6: Additional Documentation for netHOST as PROFIBUS DP Master 10
Table 7: Additional Documentation for netHOST as CANopen Master 10
Table 8: Additional Documentation for netHOST as DeviceNet Master 10
Table 9: Additional Documentation for netHOST as PROFINET IO Controller 11
Table 10: Additional Documentation for netHOST as EtherCAT Master 11
Table 11: Additional Documentation for netHOST as EtherNet/IP Scanner 12
Table 12: Overview Configuration and Testing of netHOST with Preloaded Firmware 22
Table 13: Overview Configuration and Testing of NHST-T100-EN 23
Table 14: Loadable firmware for NHST-T100-EN 27
Table 15: Protocol/Firmware for NHST-T100-EN 34
Table 16: netHOST Firmware 100
Table 17: General Device Information 108
Table 18: Dialog Windows in the Dialog Pane 110
Table 19: Standard Command Buttons in the netHOST DTM 110
Table 20: Status Bar Icons [1] 111
Table 21: Selecting, inserting, deleting Table Line 112
Table 22: Driver Selection List Parameters 113
Table 23: Parameters netX Driver > TCP Connection 115
Table 24: Parameters of the Device Assignment 117
Table 25: Elements in the “Settings” Dialog Window 120
Table 26: Elements of the Memory Card Management 122
Table 27: Indications General Diagnosis 126
Table 28: Further Parameter General Diagnosis 126
Table 29: Parameters Task Information 127
Table 30: Overview Error Codes and Ranges 137
Table 31: RCX General Task Errors 138
Table 32: RCX Common Status & Errors Codes 139
Table 33: RCX Status & Error Codes 140
Table 34: RCX Status & Error Codes Slave State 140
Table 35: ODM Error Codes - General ODM Error Codes 141
Table 36: ODM Error Codes - General ODM Driver Error Codes 142
Table 37: cifX Driver Specific ODM Error Codes 145
Table 38: Generic Error Codes 146
Table 39: Generic Driver Error Codes 147
Table 40: Generic Device Error Codes 148
Table 41: cifX API Transport Error Codes 149
Table 42: cifX API Transport Header State Error Codes 149
Table 43: ODM Error Codes DBM V4 154
Table 44: Settings (D = Displaying, X = Editing, Configuring) 155
Table 45: Configuration (D = Displaying, X = Editing, Configuring) 155
15.4 Contacts

Headquarters

Germany
Hilscher Gesellschaft für Systemautomation mbH
Rheinstrasse 15
65795 Hattersheim
Phone: +49 (0) 6190 9907-0
Fax: +49 (0) 6190 9907-50
E-Mail: info@hilscher.com

Support
Phone: +49 (0) 6190 9907-99
E-Mail: de.support@hilscher.com

Subsidiaries

China
Hilscher Systemautomation (Shanghai) Co. Ltd.
200010 Shanghai
Phone: +86 (0) 21-6355-5161
E-Mail: info@hilscher.cn

Support
Phone: +86 (0) 21-6355-5161
E-Mail: cn.support@hilscher.com

France
Hilscher France S.a.r.l.
69500 Bron
Phone: +33 (0) 4 72 37 98 40
E-Mail: info@hilscher.fr

Support
Phone: +33 (0) 4 72 37 98 40
E-Mail: fr.support@hilscher.com

India
Hilscher India Pvt. Ltd.
Pune, Delhi, Mumbai
Phone: +91 8888 750 777
E-Mail: info@hilscher.in

Italy
Hilscher Italia S.r.l.
20090 Vimodrone (MI)
Phone: +39 02 25007068
E-Mail: info@hilscher.it

Support
Phone: +39 02 25007068
E-Mail: it.support@hilscher.com

Japan
Hilscher Japan KK
Tokyo, 160-0022
Phone: +81 (0) 3-5362-0521
E-Mail: info@hilscher.jp

Support
Phone: +81 (0) 3-5362-0521
E-Mail: jp.support@hilscher.com

Korea
Hilscher Korea Inc.
Seongnam, Gyeonggi, 463-400
Phone: +82 (0) 31-789-3715
E-Mail: info@hilscher.kr

Switzerland
Hilscher Swiss GmbH
4500 Solothurn
Phone: +41 (0) 32 623 6633
E-Mail: info@hilscher.ch

Support
Phone: +49 (0) 6190 9907-99
E-Mail: ch.support@hilscher.com

USA
Hilscher North America, Inc.
Lisle, IL 60532
Phone: +1 630-505-5301
E-Mail: info@hilscher.us

Support
Phone: +1 630-505-5301
E-Mail: us.support@hilscher.com