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1 Introduction

1.1 About this Manual

This manual provides information on how to set and configure the device

parameters of

e a netTAP device of the NT 50 device family
e anetTAP device of the NT 100 device family

e anetTAP device of the NT 151-RE-RE device family

e anetTAP device of the NT 151-CCIES-RE device family

¢ a netBRICK device of the NB 100 device family

e a netLINK proxy device
using the netGateway DTM, and what can be read from the diagnosis

panes.

Dialog Panes

The table below gives an overview for the individual dialog panes

descriptions:

Section Subsection Page
Settings Overview Settings 137
Driver 138
Device Assignment 147
Configuration Overview Configuration 150
Settings 151
Licenses 153
Signal Mapping 166
Memory Card Management 173
Diagnosis Overview Diagnosis 284
General Diagnosis 285
Firmware Diagnosis 287

Table 1: Descriptions Dialog Panes
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Introduction
1.1.1 Online Help
The netGateway DTM contains an integrated online help facility.
» To open the online help, click on the Help button or press the F1 key.
1.1.2 List of Revisions
Index |Date Version Chapter Revision
11 2018-08-07 |1.1000 2 Chapter Safety added.
2.6 Section Safety Messages on Firmware or Configuration
Download added.
3.6 Section Configuration of the NT 151-CCIES-RE added.
5.19 Section Configuration CC-Link IE Field Slave added.
10 Chapter Acyclic Communication of NT 151-CCIES-RE
11 added.
Chapter Diagnosis and Status Messages of NT 151-
12 CCIES-RE added.
Chapter Error Codes revised.
12 2020-05-11 (1.1100 1, 2, 13, Structure of the chapters Introduction, Safety and
4.2.3.2, Appendix revised.
5.7.1,5.9.1, Section netX Driver - TCP/IP Connection updated.
5.10.1,5.11.1, Sections EtherCAT Slave Parameter, EtherNet/IP
5.13.1,5.15.1, Adapter Parameter, Open Modbus/TCP Parameter,
POWERLINK Controlled Node Parameter, PROFINET
IO Device Parameter, Sercos Slave Parameter:
Bus startup for NT151-RE-RE “Application controlled”.
5.17.1, Section CANopen Slave Parameter updated.
5.23.1 Section PROFIBUS DP Slave Parameter completed: use

of the Manual input field explained and list with identifier
bytes added.

Table 2: List of Revisions
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1.2 About netGateway DTM

You can use the netGateway DTM to configure

¢ a netTAP device of the NT 50 device family as a gateway,

e a netTAP device of the NT 100 device family as a gateway,

e anetTAP device of the NT 151 device family as a gateway,

¢ a netBRICK device of the NB 100 device family as a gateway,

e anetTAP device of the NT 100 device family as a proxy respectively
e a netLINK proxy device of the type NL 51N-DPL as a proxy

within a FDT Framework.

1.2.1 Requirements

System Regquirements
o PC with 1 GHz processor or higher

e Windows® XP SP3,
Windows® Vista (32-Bit) SP2,
Windows® 7 (32-Bit and 64-Bit) SP1,
Windows® 8 (32-Bit and 64-Bit),
Windows® 8.1 (32-Bit and 64-Bit),
Windows® 10 (32-Bit and 64-Bit)
¢ Administrator privilege required for installation
¢ Internet Explorer 5.5 or higher
¢ RAM: min. 512 MByte, recommended 1024 MByte
e Graphic resolution: min. 1024 x 768 pixel
e Keyboard and Mouse

¢ Restriction: Touch screen is not supported.

9 Note: If the project file is used on a further PC,
= this PC must also comply with the above system requirements,

= the device description files of the devices used in the project must be
imported into the configuration software SYCON.net on the new PC,

= and the DTMs of the devices used in the project must also be installed
on that further PC.

Requirements netGateway DTM

To configure a netTAP NT 50 device, a netTAP NT 100 device, a netTAP
NT 151 device, a netBRICK NB 100 device or a netLINK proxy NL 51N-
DPL device with a DTM the following requirements have to be
accomplished:

e Completed hardware installation of a netTAP NT 50 device, a netTAP
NT 100 device, a netTAP NT 151 device, a netBRICK NB 100 device
respectively a netLINK proxy device, where at least a base firmware has
to be loaded in the device

¢ Installed FDT/DTM V 1.2 compliant frame application
e Loaded DTM in the Device Catalog of the FTD Framework

Configuration of Gateway and Proxy Devices | netTAP, netBRICK and netLINK
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: "_'\_ For more information on the hardware installation, please refer to the
l. ) corresponding User Manual of your device.

1.3 Dialog Structure of the netGateway DTM

The graphical user interface of the DTM is composed of different areas and
elements listed hereatfter:

1. A header area containing the General Device Information,
The Navigation Area (area on the left side),

The Dialog Pane (main area on the right side),

OK, Cancel, Apply, Help,

o bk~ WD

The Status Line containing information e. g. the online-state of the
DTM.

General Device Information

Navi
gation

Area Dialog Pane

OK Cancel Apply Help

Status Line

Figure 1: Dialog Structure of netGateway DTM
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1.3.1 General Device Information

Parameter Meaning

10 Device Name of the device

Vendor Vendor name of the device

Device ID Identification number of the device
Vendor ID Identification number of the vendor

Table 3: General Device Information

1.3.2 Navigation Area

The Navigation Area contains folders and subfolders to open the dialog
panes of the DTM.

Navigation Area =l

Settings
= Driver
Device Assignment
Configuration

Figure 2: Navigation Area

» Select the required folder and subfolder.
2 The corresponding Dialog pane is displayed.

Hide / display Navigation

(= | Hiding the navigation area (above right side).

M  show navigation area Opening the navigation area (below left side).
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1.3.3 Dialog Panes

At the dialog pane the Settings, Configuration, Diagnosis/Extended
Diagnosis or the Additional Tools panes are opened via the
corresponding folder in the navigation area.

Settings

Driver

On the pane Driver you can select a driver from the driver list. For further information, refer to
section Driver on page 138.

Device Assignment

On the pane Device Assignment you must select the device and assign the device to the
driver. For further information, refer to section Device Assignment on page 147.

Configuration

Setting The Settings pane serves for selection of the protocols for the Gateway respectively the
Proxyfunctionality. For further information, refer to section Settings on page 151.
Licensing On the pane Licensing you can verify which licenses are available in the netTAP NT 100

device, order licenses and transfer license files into the netTAP NT 100 device. For further
information, refer to section Licenses on page 153.

Signal Mapping

On the pane Signal Mapping you can map the signals (I/O Data) of port X2 to the signals (/O
data) of port X3. For further information, refer to section Signal Mapping on page 166.

Memory Card On the pane Memory Card Management you can backup and restore the firmware and the
Management configuration to respectively from an MMC card. For further information, refer to section
Memory Card Management on page 173.
Diagnosis
Diagnosis At the Diagnosis panes diagnosis information can be read. For further information, refer to

section Overview Diagnosis on page 284.

Table 4: Overview Dialog Panes

Note: Accessing the Diagnosis panes of the netGateway DTM requires
an online connection from the netGateway DTM to the device.
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1.3.4 OK, Cancel, Apply and Help

OK, Cancel, Apply and Help you can use as described hereafter.

Meaning

OK To confirm your latest settings, click OK. All changed values will be applied on the frame application
database.
The dialog then closes.

Cancel To cancel your latest changes, click Cancel.

Answer to the safety query Configuration data has been changed. Do you want to save the data?
by Yes, No or Cancel.

Yes: The changes are saved or the changed values are applied on the frame application database.
The dialog then closes.

No: The changes are not saved or the changed values are not applied on the frame application
database.

The dialog then closes.

Cancel: Back to the DTM.

Apply To confirm your latest settings, click Apply. All changed values will be applied on the frame application

database.
The dialog remains opened.

Help To open the DTM online help, click Help.
Table 5: OK, Cancel, Apply and Help

1.3.5 Table Lines

In the DTM dialog pane table lines can be selected, inserted or deleted.

Meaning

4 To select the first line of a table use First Line.

To select the previous line of a table use Previous Line.

To select the next line of a table use Next Line.

b To select the last line of a table use Last Line.

Create a new Line inserts new lines into the table.

Delete selected Line deletes the selected line from the table.

FEFFE

Table 6: Selecting, inserting, deleting Table Line
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1.3.6 Status Bar

The Status Bar displays information about the current state of the DTM.

The current activity, e.g. download, is signaled graphically via icons in the
status bar.

=)[= Disconnecked

(J Data Set j

1 2 3456686
Figure 3: Status Bar — Status Fields 1 to 6
Status | Icon/Meaning
Field
1 DTM Connection States
ﬂf Connected: Icon closed = Device is online
K]0~ | Disconnected: Icon opened = Device is offline
2 Data Source States
G Data set: The displayed data are read out from the instance data set
(database).
_[j_ Device: The displayed data are read out from the device.
3 States of the instance Date Set
/ Valid Modified: Parameter is changed (not equal to data source).
4 Changes directly made on the Device
'@ Load/configure diagnosis parameters: Diagnosis is activated.
6 Device Diagnosis Status
] Save operation succeeded: The save operation has been successful.
Further messages due to successful handling of device data.
{D Firmware Download: Firmware Download is running
@ Save operation failed: The save operation has failed.
Further fail operation messages due to incorrect communication due to
malfunction in the field device or its peripherals.

Table 7: Status Bar Icons [1]

Offline State

Save operation
succeeded

Firmware Download

Firmware Download
successful

Online State and
Diagnosis

2)l= Disconnected () Data Set

<)l Disconnected | [ Daka Set f |sall |5ave operation succeeded
s Disconnected ([ Data Set @ Firrnware Download

<)l= Disconnected [ Data Set |seall

ﬂ: Connecked i Cevice o

Figure 4: Status Bar Display Examples
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2 Safety
2.1 General Note

The documentation in the form of a user manual, an operating instruction
manual or other manual types, as well as the accompanying texts have
been created for the use of the products by educated personnel. When
using the products, all Safety Messages, Integrated Safety Messages,
Property Damage Messages and all valid legal regulations must be obeyed.
Technical knowledge is presumed. The user has to assure that all legal
regulations are obeyed.

2.2 Intended Use

Refer to section section About netGateway DTM on page 10 .

2.3 Personnel Qualification

Personnel responsible for the application of the network system shall be
aware of the system behavior and shall be trained in using the system.

2.4 Safety Instructions

To ensure your own personal safety and to avoid personal injury, you
necessarily must read, understand, and comply with the safety instructions
and safety messages in this manual before you install and operate your
system.

For cases if both, personal injury as well as property damage (damage of
equipment or device) may occur together, you find the safety instructions in
this section.
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2.4.1 Communication Stop during Firmware or Configuration
Download

If you want to perform either a firmware update (as a download) or a
configuration download, both via the netGateway DTM, be aware of the
following:

e Together with the firmware download, an automated reset to the device
is performed that will interrupt all network communication and all
established connections will drop.

e If you download the configuration during bus operation, the
communication between master and slaves is stopped.

Possible faulty System Operation

¢ An unpredictable and unexpected behavior of machines and plant
components may cause personal injury and property damage.

» Stop the application program, before starting the firmware update or
before downloading the configuration.

» Make sure that your equipment operates under conditions that prevent
personal injury or property damage. All network devices should be
placed in a fail-safe mode, before starting the firmware update or before
downloading a configuration.

Loss of Device Parameters, Overwriting of Firmware

¢ Both the firmware download and the configuration download erase the
configuration data base. The firmware download overwrites the existing
firmware in the network device.

» To complete the firmware update and to make the device operable
again, re-load the configuration after the firmware update has been
finished.

For devices with Ethernet technology

» Device parameters that have been saved volatile, e. g. as the
temporarily set IP address parameters, are getting lost during the reset.

» In order to prevent loss of configuration data, make sure that your
project configuration data are saved non-volatile, before you initiate a
firmware update or download the configuration.

2.4.2 Mismatching System Configuration

Mismatching system configuration loaded into the device could result in
faulty data mapping in the application program and thus unexpected
equipment operation may cause personal injury or damage of equipment.

» In the device use only a configuration suitable for the system.

Configuration of Gateway and Proxy Devices | netTAP, netBRICK and netLINK
DOCO0812010I12EN | Revision 12 | English | 2020-05 | Released | Public © Hilscher, 2009-2020



Safety

18/355

2.5 Property Damage

251

2.5.2

To avoid property damage and damage to your system or to your
equipment, you necessarily must read, understand, and comply with the
safety instructions and safety messages in this manual before you
configure your system.

Power Disconnect while dowloading Firmware or Configuration

If during the process of downloading a firmware or configuration

¢ the power supply to a PC with the software application is interrupted,
¢ or the power supply to the device is interrupted,

e oOr areset to the device is done,

this may lead to the following consequences:

Loss of Device Parameters, Firmware Corruption

e The firmware download or the configuration download will be interrupted
and remains incomplete.

¢ The firmware or the configuration database will be corrupted and device
parameters will be lost.

e Device damage may occur as the device cannot be rebooted.

Whether these consequences occur depends on when the power
disconnect occurs during the download.

Power Drop during Write and Delete Accesses in the File System

The FAT file system in the netX firmware is subject to certain limitations in
its operation. Write and delete accesses in the file system (firmware
update, configuration download etc.) can destroy the FAT (File Allocation
Table) if the accesses cannot be completed if the power drops. Without a
proper FAT, a firmware may not be found and cannot be started.

Make sure that the power supply to the device is not interrupted during
write and delete accesses in the file system (firmware update, configuration
download, etc.).

Invalid Firmware

Loading invalid firmware files could render your device unusable.
» Only download firmware files to the device that are valid for this device.
Otherwise you might be forced to return your device for repair.
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2.6 Safety Messages on Firmware or Configuration Download

If you perform a firmware download or a configuration download via the
netGateway DTM be aware of the following:

| A WARNING |

Communication Stop caused by Firmware or Configuration Download
Initiating a firmware or configuration dowload process during bus operation
will stop the communication and a subsequent plant stop may cause
unpredictable and unexpected behavior of machines and plant
components, possibly resulting in personal injury and damage to your
equipment.

The firmware download overwrites the existing firmware. The
communication stop may cause loss of device parameters and possible
device damage may occur.

» Stop the application program, before you start the firmware or
configuration dowload.

» Make sure that all network devices are placed in a fail-safe condition.

| A WARNING |

Mismatching System Configuration

Mismatching system configuration loaded into the device could result in
faulty data mapping in the application program and thus unexpected
equipment operation may cause personal injury or damage of equipment.

» In the device use only a configuration suitable for the system.

Power Disconnect while dowloading Firmware or Configuration

If the power supply to the PC or device is interrupted while the firmware or
configuration is being downloaded, the download will be aborted, the
firmware may be corrupted, the device parameters may be lost, and the
device may be damaged.

» During firmware or configuration download process do not interrupt the
power supply to the PC, or to the device and do not perform a reset to
the device!

Invalid Firmware
Loading invalid firmware files could render your device unusable.

» Only proceed with a firmware version valid for your device.
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3 Configuration Sequence for Gateway and Proxy
3.1 Gateway and Proxy Device

Two networks are connected via a gateway or a proxy device together. For
the data transfer from one network into the other it is necessary that these
data are mapped. This mapping is done within SYCON.net.

Gateway Devices
The mapping of the data can be done by the user and be configured within

SYCON.net.

The following gateway devices are in the device catalog.
e netTAP NT 50 B NT 50-X%-0%

e netTAP NT 100 M nT 100-x-n

e netTAP NT 151-RE-RE il NT151-RE-RE

e netTAP NT 151-CCIES-RE [} NT151-CCIES-RE/PNS
e netBRICK NB 100 %3 NB 100-i-%

Proxy Devices

The mapping of data is already specified and done automatically by
SYCON.net.

The following proxy devices are in the device catalog.
e netTAP NT 100 H MT 100-RE-$#/PROKY
e netLINK Proxy (2 NLSIN-DRL

Note: The gateway or proxy device can only be used at the (gray) main
line.
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3.2 Configuration of a NT 50 as a Gateway
This section is valid for netTAP NT 50 devices as a gateway. These
devices are called gateway devices in the following description.

The configuration of the NT 50 devices is explained exemplarily with the
protocol conversion PROFIBUS DP Slave to Modbus RTU Slave.

The device NT 50-DP-RS is necessary for the protocol conversion from
PROFIBUS DP Slave to Modbus RTU Slave.

The following steps have to be done to configure the device:

3.2.1 Requirement for the Configuration

The device is configured via the Ethernet port. Therefore it is necessary
that the device gets an IP address assigned before.

Therefore do the followings steps:

1.

Establish an Ethernet connection between the Ethernet network port of
your PC and the Ethernet port of the netTAP NT 50 device

Start the “Ethernet-Device Setup” software. Therefore select Start >
Programs > SYCON.net System Configurator > Ethernet Device
Setup.

Search for connected devices. Therefore click on Search Devices.
Devices are searched in the local network using broadcast telegrams.

Assign an IP address to the NT 50 device, which should be used for the
device configuration.

This address can be stored in a non volatile memory of the device.

3.2.2 Start SYCON.net and User Login

Start SYCON.net

Select Start > Programs > SYCON.net System Configurator >
SYCON.net

SYCON.net is started

User Login

In the window SYCON.net User Login click OK to login or enter your
password and then click OK to login

SYCON.net frame application appears
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3.2.3 Insert the Gateway Device into the Configuration Window

» Go to the device catalog under vendor Hilscher GmbH to the category
Gateway / Stand-Alone Slave. Use drag and drop with the NT 50-XX-
XX gateway device to insert it at the (gray) main line.

| | =1+ Hilscher GmbH

—-£3 Gateway | Stand-alone Slave

T B T 50-RN-R

\ Fieldbus \)\ Yendor /{DTM Class J,-"
Figure 5: Insert Gateway Device into the Project

2 The gateway device appears in the project

nEtTAR[MNT S0-XX-KX]< = (#1)

q

Figure 6: Gateway Device in the Project
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3.2.4  Select the Protocol Conversion of the Gateway

1. Open the Gateway configuration window

» Double click the gateway device symbol
or

select from the context menu of the gateway device symbol the entry
Configuration > Gateway

> The Gateway configuration window opens

3 netDevice - Gateway netTAP[NT 50-XX-XX]<>(#1) M=E3
I Device: MT S0-2k-Xx Device 1Dt =
Vendar: Hilscher GribH Yendor 1D 0x011E DT
Mavigation area =
= Settlngs Scan progress: 313 Devices (Current device: -)
a Drriver
nety Driver
I L= vice Assianment Device selection: suitable only -
‘=34 Canfiguration
Settings | Device | Hardware Parts 0f1f... | Slok nu... | Setial nu... | Driver Channel Protocol | Access path |

Signal Mapping

Access path:

(814 | Cancel Help

=i (0

Figure 7: Device Assignment without Device
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2. Open dialog for protocol selection
» Select in the navigation area Configuration > Settings
2 The configuration window Settings opens

2 netDevice - Gateway net TAP[NT 50-XX-XX]<=(#1)

10 Device: T S0-85-%k Device ID: = =
Yendor: Hilscher GrabH Wendor ID: Ox011E DT
Mavigation area =
{23 Settings General
=3 Driver
nety Driver Descripkion: | netTAR

Device Assignment

¥4 Configuration
= 4 Settings
Signal Mapping

Pratocol Combinations

Prirnary netwaork (Port %270 | j Secondary network (Port %30 | ﬂ

Required gateway: | j

Required license:

Available Firmware: MEASCEIM, MXF ~
MNSASCEIS. MEF

MNSASCOME. MNAF
MNSASCPMM, MF

Erowse

MSASCPNS NEF
MSBASEFW, WX v

Software dass:
Software version:
Baszic Settings

Mapping Cycle time: 10 ms Mapping mode: J

Metwork Address Switch
Enable: ™

Used by | J

(o] 4 | Cancel Help

<=0

Figure 8: Gateway Protocol Selection (1)
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3. Select the protocol for the primary network and for the secondary
network and apply.

» Select in the window Configuration > Settings at Protocol
Combinations for the Primary Network (Port X2) the protocol
PROFIBUS DP Slave

» Select then at Protocol Combinations for the Secondary Network
(Port X3) the protocol Modbus RTU

» Click Apply

> The Gateway configuration window shows the following

2 netDevice - Gateway netTAP[NT 50-XX-XX]<>(#1) =13
10 Device: T S0-XX-XX Device ID: = =
Wendor: Hilscher GmbH Vendor ID: 0x011E OT
Navigation area =
= Settings General
a Drriver
nieks Driver Descripkion: | netTap

Device Assignment
‘=4 Configuration
kmp Sethings

Pratocal Combinations

signal Mapping Primary nebwark (Port $23: |PROFIBUS—DP Slave ﬂ Secondary network (Park 230 |M0db'-|5 RTU ﬂ
Required gateway: ||\,|T S0-DP-RS ﬂ
Required license: Mone

Available Firmyare: WSDPSMER., NxF Browse:

Software class: Multi protocol {combinable) Gateway

Software version: 1.1.3.0

Basic Settings

Mapping Cycle time: ’710 ms IMapping mode: J
Metwork Address Switch
Enable: ™
Used by; | J

Ok | Cancel Apply Help

<=0 7

Figure 9: Gateway Protocol Selection (2)

The Required gateway as shown above depends on the selected
protocols.
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4. Enable address switch.

» Check Enable to enable that the PROFIBUS station address is set by
the rotary switch at the device.

If Enable is uncheked, the the PROFIBUS station address is set by the
configuration software.

2 netDevice - Gateway netTAP[NT 50-XX-XX]<>{#1) (=13
10 Device: T 50-2%-XKx Device I0: - &
Wendor: Hilscher GrmbH Vendor 10 0x011E DT
M avigation area 3
‘=3 Settings General
a Driver
Rty Driver Descripkion: | netTAP

Device Assignment

29 Confiquration Protocal Combinations

by Sebbings .
Primary network (Port X2} |PROFIBUS-DF Slave * | Secondaty network (Port %33 [Modbus RTU A
Signal Mapping v { 2 | J ¥ : 2 | J
Required gateway: |NT 50-DP-RS ﬂ
Required license: Mone
Available Firmuare: MEDPSMER., hxF Browise

Software class: Multi protocal {combinable) Gateway

Software version: 1.1.3.0

Basic Settings:

Mapping Cycle time: 10 ms Mapping mode: J

Metwaork, Address Switch
Enable: v
Uised by: [PROFIBUS-DP Slave |

ok | Cancel Apply Help

<=0 7

Figure 10: Gateway Protocol Selection (3)

5. Close the Gateway configuration window
» Click OK
> The Gateway configuration window closes
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3.2.5

Configuration of the secondary Network

1. Configure the protocol at the secondary network (Port X3)

» Select from the context menu of the NT 50-XX-XX symbol the entry

Configuration > Modbus RTU

> The Modbus RTU configuration window opens

: netDevice - Modbus RTU net TAP[NT 50-DP-RS]<2>(#1)

3

Mavigation area
¥4 Configuration

10 Device:
‘endor:

L 4 Configuration
Signal Configuration

NT 50-DP-RS Device ID: E
Hilscher GrmbH Vendor ID: DT
]
Interface e
Bus Startup: | J
‘wiatchdog Time: | 1000 me
Address Mapping: | J
Data Swapping: |Yes j
Map FC1 and FC3 I
Ident
Device: | MT50 [ Enable
Bus
Protocol Mode: ||D Slave j Fiesponze Timegut: | TS
Modbus Address: | 2 Send Retries: |
Interface type: e |F|S 232 j Frame Farmat: | J
ATS Controt (4 )[RTS Contol Of =]
BadRate: (5[50 =l
Stop Bits: e |1 j
Parity: o |Even j
Data
Mumber of Begister: | 256 Mumber of Coils:
Drefault
v
’Tl Cancel | | Help

b=

Figure 11: Protocol Configuration

2. Set protocol parameter

> Set the parameters. To configure the device as a Modbus RTU Slave
set for @ Protocol Mode the value 10 Slave. Set the following
important parameter: @ Modbus Address, @ Interface type, @ RTS

Control, @ Baud Rate, Stop Bits and @ Parity. These parameter
are important that the used Modbus RTU Master can communicate with

the gateway device.

More information about Modbus RTU parameter is in section Modbus

RTU Parameter on page 247.
3. Close the configuration window
» Click OK

> The configuration window closes

Configuration of Gateway and Proxy Devices | netTAP, netBRICK and netLINK
DOCO0812010I12EN | Revision 12 | English | 2020-05 | Released | Public

© Hilscher, 2009-2020



Configuration Sequence for Gateway and Proxy 28/355

3.2.6 Configuration of the primary Network

1. Configure the protocol at the primary network (Port X2)

> Select from the context menu of the NT 50-XX-XX symbol the entry
Configuration > PROFIBUS DP Slave

» The PROFIBUS DP Slave configuration window opens

"2 netDevice - PROFIBUS-DP Slave netTAP[NT 50-DP-RS]<2>(#1) M=1E3
10 Device: WT S0-DP-RS Dervice ID: D 049F —
Yendor: Hilscher GmbH Wendor ID: Ox011e DT
Navigation area B
“=3 Configuration Interface -

= Configuration

Signal Configquration Bus startup:
W atchdog time: ms
1/0 data status:

Ident

Ident number: [~ Enable

Bus
Station Qddress:@ v
B aud rate: Auto-detect -

Eutras; Sync supported |w DPFY1 enable v
Freeze supported [w Addrezs change not allowed [w

Fail Safe supported [w

Data
Output |nput
Module Tupe Size Module Type Size
1 | Byte 2):2 ﬂ 5 | Byte @ 2 j
2 |B_l,lte j |D ﬂ g |B_l,lte j |D j
3 |B_l,lte j |D j 7 |B_l,lte j |D j
4 |Byte ~| o =l 8 |Byte ~| o ~|
Configuration data: | Manual input: [
Output data bytes: 2 Input data bytes: 2
Default 3
(a4 | Cancel | | Help |

Figure 12: Protocol Configuration

2. Set parameter for protocol at the primary network (port X2).

> If the PROFIBUS station address is set by the rotary switch at the
device, then the field Station Address @ is grayed out.
If the PROFIBUS station address is set by configuration software, then

enter in Station Address @ the PROFIBUS station address for the
gateway device.

> Set size and type of the modules for Output @ and Input @
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> Default values can be used normally for the other parameters.
Depending on additionally requirements and the design of the
PROFIBUS network as well as the used devices parameters needs to
be adjusted if necessary.

More information about PROFIBUS DP Slave parameter is in section
PROFIBUS DP Slave Parameter on page 241.

3. Close the configuration window.
> Click OK.
2> The configuration window closes.

3.2.7 Configure the Gateway — Signal Mapping

1. Open the Gateway configuration window

> Select from the context menu of the gateway device symbol the entry
Configuration > Gateway

> The Gateway configuration window opens
2. Open the Signal Mapping window
» Select Configuration > Signal Mapping
 The window Signal Mapping opens
2 netDevice - Gateway netTAP[NT 50-DP-RS]<2 >{#1)
IO Device: MNT S0-DP-RS Device ID: = =
Vendar: Hilscher GribH Yendor 1D 0x011E DT
Mavigation area =
a Settings o] .
vailable Signals
a Drriver < !
riet Driver =112 Port X2 (PROFIBUS-DP) <Addr 2! || =2 iPort 23 (Modbus RTUY <Addr 0
Device Assignment " 32 Bvtes Out <Slat 1= I " 256 Registers In <Slot 0= w
‘=4 Canfiguration — —
Settings Patt %2 | Signals  # Data byvpe || Port %3 | Signals 4 Data type -~
lay Signal Mapping
Receive CutByte 0000 BYTE
Receive CutByte _0001 BYTE Send ~256 InWORDs WORD_0...  WORD
Receive CutByte 0002 BYTE Send ~256 InWORDs WORD_0...  WORD
Receive OutByhe 0003 BYTE | | Send 256 InWORDs WORD_D,..  WORD -
< > < >
Mapped Signalz
= § Port %2 (PROFIBUS-DP) <Addr 23 || =57 iPort %3 (Modbus RTU) <Addr 0= ~
{77 32 Bytes Out <Slot 13> v " 256 Registers In <Slok 0 w
| Port 42 [PROFIBUS-DP) | | Pt 243 [Modbus ATL)
Manual Mapping: | Aubo Mapping: |off -
(814 | Cancel | | Help |
<1 |0

Figure 13: Gateway Signal Mapping
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3. Signal Mapping: Data transfer from Port X2 to Port X3

Map the signals, which are received on Port X2 (Port X2 receive), with
signals, which should be sent on Port X3 (Port X3 send).

» For this, mark the signal received (Port X2) and the signal to be sent
(Port X3) and the click the button Map Signals
Or
Map the signal using drag and drop. For this, drag the signal received
(Port X2 receive) and drop it on the signal to be sent (Port X3 send)

4. Signal Mapping: Data transfer from Port X3 to Port X2

Map the signals, which are received on Port X3 (Port X3 receive), with
signals, which should be sent on Port X2 (Port X2 send).

> For this, mark the signal received (Port X3) and the signal to be sent
(Port X2) and the click the button Map Signals
Or
Map the signal using drag and drop. For this, drag the signal received
(Port X3 receive) and drop it on the signal to be sent (Port X2 send)

5. Signal Mapping: Transfer status info of Port X2 to Port X3

If necessary, map the status information of Port X2 (Port X2 generated,
which are generated device internal) to signals which should be sent on
Port X3 (Port X3 send)

» For this mark the status signal (Port X2) and the signal which should be
sent (Port X3) and click the button Map Signals
Or
Map the signal using drag and drop. For this, drag the status signal
(Port X2 generated) and drop it on the signal to be sent (Port X3 send)
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6. Signal Mapping: Transfer status info of Port X3 to Port X2

» If necessary, map the status information of Port X3 (Port X3 generated,
which are generated device internal) to signals which should be sent on
Port X2 (Port X2 send)

» For this mark the status signal (Port X3) and the signal which should be
sent (Port X2) and click the button Map Signals
Or
Map the signal using drag and drop. For this, drag the status signal
(Port X3 generated) and drop it on the signal to be sent (Port X2 send)

2 An example of the Signal Mapping window shows the following figure

2 netDevice - Gateway netTAP[NT 50-DP-RS]<2>(#1) M=E3
I Device: MNT 50-DP-R3 Device ID: = =
Vendar: Hilscher GribH Yendor 1D 0x011E DT
Mavigation area =
3 Settings Available Signalz
a Drriver !
ety Ciriver =112 Port X2 (PROFIBUS-DP) <Addr 2! =R rt %3 (Modbus RTUY <Addr 0>:
Device Assignment i 32 Bytes Out <Slot 1= 3z 256 Reqisters In <Slot 0= 3
‘=3 Canfiguration — —
Settings Part x2 | signals 2 | Data type A Port ¥3 | signals Data bype -~
[="4 Signal Mapping
Send InEvyke_0000 EYTE
Send ~256 InWORDs WORD_0...  WORD
Generated Communication Change of...  UNSIGMEDSZ2 Send ~256 InWORDs WORD_0...  WORD
Generated Cornmunication Stake LMSIGMEDSZ Send ~256 InWORDs WORD_D,..  WORD
Generated CComrmunication Errar LIMSIGHELS2 ¥ || Send ~256 InWORDs WORD 0., WORD b’
4 * £ >
Mapped Signals
=) {7 Port %2 (PROFIEUS-DF) <Addr 25 A | =8 Port %3 (Modbus RTUY <Addr 0> ~
{77 32 Bytes Out <Slot 13> w " 256 Registers In <Slok 0 v
Part %2 [PROFIEUS-DF) -~

32 Bytes Out <Slot 13 A0utByte_0002 - OutByte_ 0003 ey 206 Registers In<Slat 03 /~256 W ORD s wORD_0001
32 Bytes Out <Slot 1> /0utBypte_0004 - DutByte_0005 w256 Regizters In <Slot 02 /7256 Inw/ORD W ORD _0002 v

Manual Mapping: Remove link | Auta Mapping: | off -
(814 | Cancel | | Help |

=i |0 |l Save aperation succeeded

Figure 14: Gateway Signals mapped
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3.2.8 Establish a Connection to the netTAP NT 50

1. Connect an Ethernet cable to the NT 50

> Build up an Ethernet connection between the Ethernet port of the NT 50
device and to the Ethernet port of the configuration PC.

2. Set the IP address of the NT 50 device

Set with the Ethernet Device setup software, which is part of the
SYCON.net installation, the IP address for the NT 50. With this software
it is also possible to read an already assigned IP address from the
NT 50 device.

The IP address is required for the communication with the SYCON.net
software.

To communication from the SYCON.net software with the NT 50 device,
an IP address has to be assigned before to the NT 50 device. How to
assign an IP address is described in the document ,Ethernet Device
Configuration Ol xx DE.pdf*.

{
-

3. Open the gateway configuration window

Select from the context menu of the gateway device symbol
Configuration > Gateway

> The gateway configuration window opens

4. Select driver

» Select in the navigation area Settings > Driver and then check netX
Driver.

> The following figure shows the selected driver.

3 netDevice - Gateway netTAP[NT 50-XX-XX]<={#1) EEX
10 Device: T S0-RkK-%x Device 1D: = =
‘endor: Hilscher GmbH ‘endor ID: 0x011E BT
Mavigation area B
a Settings
[ e | Driver Wersion | pie]
nieki Driver O CIF% Device Driver 1.0.3.2 {368BECSE-0EQ2-4C0E-B4AY-64F62AETAAFA)L
Device Assignment F3Gateway Driver For netx (v3,x) 0.9.2.0 {7ETCDSAI-4CFE-4259-5E40- L D9BEASBEADL
¥4 Configuration ( netis Driver 1.101.1.1878 {BS4CECCT-F333-4135-6405-6E1 2FCEREERZ}
Settings
Signal Mapping
K, | Cancel Help
<= 0

Figure 15: Select Driver
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5. Set the IP search range

» Select in the navigation area Settings > Driver > netX Driver.

> The window for driver settings opens.

IO Device:
Wendar:

Navigation area
@ Setbings
a Driver
ey Nt Driver
Device Assignment
=3 Configuration

NT 50-DP-RS
Hilscher GmbH

=)

USE/RSZ32 Connection  TCP Connection @

Iv Enable TCP Connector (Restart of QDM required)

2 netDevice - Gateway netTAP[NT 50-DP-RS]<2>(#1) =3

Device 1D
Wendor 10:

0x011E

Settings . =
. Select IP Range: Scan Timeout: | 100 ms
Signal Mapping -
IP Range Configuration
I
IP Address r TCP Port Address Count

| -1 : 1

Send Timeout: :I ms Keep Alive Timeout: i‘ ms
Reset Timeout: :I ms

alr

alr

| Save Al |

Restare | Save

o]

Cancel | ‘ Help ‘

i |0

Figure 16: Set IP Address Search Range (1)

An IP address (one) or IP addresses (several, address range) are set in
this window which SYCON.net uses to build up a connection to the proxy
device.

> Select (as shown in the figure above):
@ Select the tap TCP Connection.

@ Is the Select IP Range grayed out (as shown above), then no IP
range is defined.

Click on @ + to add a new range, which enables the field below.
Otherwise an address range configured earlier can be selected or by a

mouse click on @ + a new address range can be configured. Set the IP
(start) address (and end address) the proxy devices are searched for.
Make sure that the proxy device can be reached via Ethernet and is
reachable via the address range.

> The fields to configure an IP address range are enabled.
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Select IP Range: |1P_Rp.N(5E|:| jl " = | Scan Timeout: | 100 il ms

IP Range Configuration
| Disable IP Range

IP Address Use IP Range TCP Port Address Count

o
@192.153 60,199 - | @) ¢ |s0111 |1

Send Timeout: | 1000 :‘ ms Keep Alive Timeout: | 2000 :I ms
Reset Timeout: | 20000 :‘ ms

Figure 17: Set IP Address Search Range (2)

> You can enter one IP address of the proxy device at @ as shown
above or you can set an IP address range by a check at @ Use IP

Range and set the IP end address at @ Make sure that the proxy

device can be reached via Ethernet and is reachable via the address
range.

_} Note: Set the IP address range not to large, which results in a long scan
time.

» After the address range was set click on Save.
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3.2.9 Device Assignment

» Select Settings > Device Assighment

> Click on @ Scan.
> The search process is started. Devices found are display in a list then.

: netDevice - Gateway netTAP[NT 50-DP-RS5]=<2={#1)

IO Device: MT 50-DP-RS Device ID: o =
Vendor: Hilscher GmbH Wendor ID: 0x011E DT
Navigation area |
= Sa'att;?jer Scan progress: 33 Devices (Current device: -)
O =]
Dievice selection: suitahle only -
Settings | Device | Hardware Ports Of1/... | Slok nu... | Serial nu... | Driver Channel Frotocol | Access path |
Signal Mapping ! NT 50-DP-RS Ethernet/PROFIEBUS... nfa 20004 ngk¥ Driver Gateway L4192,166 .60,
Access path: ‘ {BS4CECCT-F333-4135-8405-6E12FCEBEER2H 192, 168,60, 1965011 16fx0_Ch2
O | Cancel Help
AlT] ludl Save operation succesded

Figure 18: Select Device

> Select the device from the list @ by a check in the field of the device as
shown above.

» Click on the button OK

> The configuration window closes.
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3.2.10 Load Firmware

The firmware has to be loaded into the netTAP only for first commissioning
only. Therefore do the following steps:

1. Open the Gateway configuration window

» Select from the context menu of the gateway device symbol the entry
Configuration > Gateway

> The Gateway configuration window opens

2. Open the Settings window
» Select Configuration > Settings

> The window Settings opens

"3 netDevice - Gateway netTAP[NT 50-XX-XX]<>(#1) =3
10 Device: NT 50-DP-R5 Device I: o =
Vendor: Hilscher GrabH Wendor 10 0:x011E DT
Mavigation area =]
{3 Settings General
a Crriver
niek Driver Description: | netTAP

Dewvice Assignment
¥=3 Configuration

=y Sefkings . .
Signal Mapping Primary netwaork (Port X2 | J

Pratocol Combinations

Secondary netwark (Port X3 | J

Required gateway: | J

Required license:

Available Firmgsare: NSDPSMER. NXF Browse
@ Download
Software class: Gateway
Software wersion: 1.0.2.0
Basic Settings
Mapping Cyele time: 10 ms Mapping mode: | J
(04 | Cancel | | Help |

i |0 |odl |Save operation succeeded

Figure 19: Firmware Download

3. Select Firmware

Mark at Available Firmware the firmware file @: N5DPSMBR.NXF
(Firmware for PROFIBUS DP Slave to Modbus RTU).

4. Load firmware into the device
» Click on Download

R The firmware is loaded into the netTAP device

‘_" ' | Important: Do not remove the cable during the firmware download.
Do not disconnect the power supply of the device during the firmware
download.
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Download of firmware

Wait until the firmware was transferred completely into the device.
Close the Gateway configuration window after the download

Click OK

2 The Gateway configuration window closes

vV © v 9

3.2.11 Load Configuration

1. Download configuration

» Select from the context menu of the gateway device symbol the entry
Download

» Answer the security question with Yes, if the download should start

» SYCON.net builds up an online connection to the device. This the
indicated by a green highlighted device name.

> The configuration is transferred info the gateway device

> The device performs a reset and then starts with the new configuration.

Note: The device performs a reset after the download. Because of that,
the Ethernet connection gets lost and (has to be stopped from SYCON.net
and then) has to be established again.

Stop the online connection to the device, which was established
automatically to the device before.

2. Disconnect

> Select from the context menu of the proxy device symbol the entry
Disconnect.

_} Note: To establish a connection again, do the steps described in section
Device Assignment on page 35.
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3.2.12 Save Project

Note: The configuration downloaded from SYCON.net into the device
can't be uploaded from the device. Only the SYCON.net project can be
downloaded into additional devices.

Save the SYCON.net project. In case of a device replacement the saved
project can be opened with SYCON.net and loaded into the device.

» To save a project select menu File > Save respectively File > Save As

: ) ]
or click on icon .

When you exit the program and the current configuration differs from the
last saved configuration, then the following question appears:

L] "_-. Save changes to the project?
L

Tes o Cancel

Figure 20: Security Question — Save Project

When you answer with Yes, then the project is saved. When you answer
with No, then the project is not saved and the changes are lost. When you
answer with Cancel, then the project is not saved.
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3.3 Configuration of a NT 100 or NB 100 as a Gateway

This section is valid for netTAP NT 100 and netBRICK NB 100 devices as a
gateway. These devices are called gateway devices in the following
description.

The configuration of a netTAP NT 100 device is described as example.
Differences and extras to other devices are pointed out respectively are
described in own sections.

The configuration of the NT 100 devices is explained exemplarily with the
protocol conversion PROFINET 10 Device to PROFIBUS DP Master.

The device NT 100-RE-DP with one master license is necessary for the
protocol conversion from PROFINET IO Device to PROFIBUS DP Master.

The following steps have to be done to configure the device:

3.3.1 Start SYCON.net and User Login

1. Start SYCON.net

» Select Start > Programs > SYCON.net System Configurator >
SYCON.net

2 SYCON.net is started

2. User Login

In the window SYCON.net User Login click OK to login or enter your
password and then click OK to login

2 SYCON.net frame application appears
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3.3.2 Insert the Gateway Device into the Configuration Window

» Go to the device catalog under vendor Hilscher GmbH to the category
Gateway / Stand-Alone Slave. Use drag and drop with the NT 100-XX-
XX respectively NB 100-XX-XX gateway device to insert it at the (gray)
main line.

| | =1+ Hilscher GmbH
—-£23 Gateway | Stand-alone Slave

\E*;} MEB 100-25-%5

\\ WY T 100--n

\ Fieldbus }\ Yendor ,{DTM Class },-"
Figure 21: Insert Gateway Device into the Project

2 The gateway device appears in the project

REtTAP[MT 100-Xx-Xx]< = (#1)

Figure 22: Gateway Device in the Project

NT 100 is shown as example.
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3.3.3 Select the Protocol Conversion of the Gateway

1. Open the Gateway configuration window

» Select from the context menu of the gateway device symbol the entry
Configuration > Gateway

2 The Gateway configuration window opens

3 Gateway - netTAP[NT 100-XX-XX]<>(#1) {=(E3]
10 Device: MNT 100-%8-mK Device 1Dy =
Yendor: Hilscher GmbH Wendor ID: 0x011E DT
Mavigation area =
a Setkings . .
£3 Driver Scan progress: 0f0 Devices {(Current device: -}
TCP/IP Driver for net
netk Driver Device selection: suitable only v
ke Device Assigniment
{3 Configuration | Device | Hardware Porks 0f11... | Slot nu, .. | Serial nu... | Driver | Channel Protocal | Access path |
Settings
Licensing

Signal Mapping
Memory Card Management

Access path:

Ok | Cancel Help

<=0

Figure 23: Device Assignment without Device

The entry Memory Card Management in the navigation area is only
available for netTAP NT 100 devices.
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2. Open dialog for protocol selection

» Select in the Navigation area Configuration > Settings

2 The configuration window Settings opens

2 netDevice - Gateway net TAP[NT 100-XX-XX]==(#1)

10 Device:
Yendor:

T 100-%%-2%
Hilscher GmbH

Device ID:

Yendor ID: 0x011E DT

CEX

Mavigation area =
{23 Settings General
=5 Driver
ety Driver Description: | netTAP

Device Assignment

29 Configuration Pratocol Combinations

= 4 Settings

Signal Mapping Primary netwark (Park X23: |

j Secondary nebwork (Port %30 |

Memary Card Management

Required gateway: |
Licensing

Required license:

=

Avvailable Firmsare: NTCOMASE, NXF

MNTCOMCCS MNeF
NTCOMCOS,. NEF
MNTCOMDMS, MNxF
MNTCOMDPS, MeF
NTCOMMER. NXF

Software class:
Sofbware wersion:
Basic Settings
Mapping Cycle kime:

Metwork Address Switch
Enable: ™

Used by: |

[~

Etowse

ez
[l

Mapping mode:

Ok | Cancel

Help

== |0

Figure 24: Gateway Protocol Selection (1)

The entry Memory Card Management in the navigation area is only
available for netTAP NT 100 devices.
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3. Select the protocol for the primary network and for the secondary
network and apply

» Select in the window Configuration > Settings at Protocol
Combinations for the Primary Network (Port X2) the protocol
PROFINET 10 Device

» Select then at Protocol Combinations for the Secondary Network
(Port X3) the protocol PROFIBUS DP Master

» Click the button Apply

> The Gateway configuration window shows the following

2 neiDevice - Gateway netTAP[NT 100-XX-XX]<>(#1) M[=1/E3]
IO Device: MT 100-k5-5% Device ID: =
Yendaor: Hilscher GmbH Yendor 1D 0x011E DT
Navigation area =
{24 Settings General
=5 Driver
neky Driver Description: | netTAP
Device Assi k L
=3 Confi::::io;ﬂgnmen Protocol Combinations
Sethi
- S?gnggl\iapping Primary network (Pork X23: |PROFINET 10 Device ﬂ Secondary network (Pork 530 |PROFIBUS-DP IMaster j
I‘\‘?emory Zard Management Required gateway: |NT 1 00-RE-DP ﬂ
Licensing
Required license: Yes (1)
Aveailable Firmnware: NTPMSDPM, MxF Eremes
Software class: Multi protacal {combinable) Gateway
Software version: 1.5.5.0
Basic Settings
Mapping Cycle time: 1 ms Mapping mode: J
Metwork Address Switch
Enable: ™
Used by: | J
(o4 || Cancel Apply Help
<= 07

Figure 25: Gateway Protocol Selection (2)

The entry Memory Card Management in the navigation area is only
available for netTAP NT 100 devices.

The Required gateway as shown above depends on the selected
protocols.

4. Close the Gateway configuration window
» Click on the button OK

> The Gateway configuration window closes
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3.3.4  Configuration of the primary Network

1. Configure the protocol at the primary network (Port X2)

» Select from the context menu of the gateway device symbol the entry
Configuration > PROFINET IO Device

2 The PROFINET IO Device configuration window opens

2 PROFINET IO Device - netTAP[NT 100-RE-DP]<=>{#1) |

Marme of Station:

IO Device: MT 100-RE-DP Device ID: 0x010b =
Yendar: Hilscher GmbH Yendor ID: 0x011e DT
Havigation area =
‘=3 Configuration Interface
L 3 Configuration
Signal Configuration Bus Startup: | J
Watchdog Time; | 1000 ps
1/0 Drata Status: | Mot j
Ident

Wendor |D: | [~ Enable
Device ID: |
Device Type: |
Order 1D: |

Tvpe of Station:

Data
Input Data Bytes: | 128
Output Data Bytes: | 128

Default

Ok | Cancel Help

s

Figure 26: Protocol Configuration

» Set the parameters. Set especially the number of Input Data Bytes and
Output Data Bytes.

More information about PROFINET IO Device parameter is in section
Configuration PROFINET IO Device (Gateway) on page 205.

2. Close the configuration window
Click on OK

2 The configuration window closes

A\
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3.35 Configuration of the secondary Network

If the slave device is not listed in the device catalog, then it has to be
imported into the device catalog first.

3.35.1 Expand PROFIBUS DP Slave Device Catalog

If you want to use a PROFIBUS DP slave device that is not listed in the
device catalog, then you have to import the GSD file into the SYCON.net
device catalog.

> Proceed as follows:

1. Missing PROFIBUS DP Slave devices can be added to the device
catalog using the menu Network > Import Device Descriptions.

Select the new GSD file.

3. Answer the question “Do you want to reload the device catalog?* with
Yes to reload the catalog.

- More information about the device catalog is in the document
) . SYCONnet_netDevice_en.pdf* in the directory ,Documentation“ on the
product DVD.

3.35.2 Insert PROFIBUS DP Slave Device to the PROFIBUS Network

» Go to the device catalog. Use drag and drop with one or more
PROFIBUS DP Slave devices to insert it/them at the PROFIBUS bus
line.

2 The PROFIBUS DP Slave device icons appear at the PROFIBUS
network line (Secondary network)

netTAP[NT 100-RE-DP]<=({#1)

CE_ARZ2-DPS[CE_AB32-DPS]<2=

L7

Figure 27: Gateway Device with Slave
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3.35.3 Configure the PROFIBUS DP Slave device

> Open the configuration window with a double click on the device icon of
the PROFIBUS DP Slave

> The configuration window of the PROFIBUS DP Slave device opens
» Select in the navigation area Configuration > Modules.

» Select from Available Modules the module(s) and add it'them to the
Configured Modules to configure the Slave. The Configured Modules
has to match the configuration of the used PROFIBUS DP slave device.

~ More information about the configuration of PROFIBUS DP Slave devices
are in the document PROFIBUS_Generic_Slave_DTM_en.pdf on the
product DVD in section Configuration.

3.354 Configure PROFIBUS DP Master

1. Open the PROFIBUS DP Master (Port X3) configuration window

> Select from the context menu of the gateway device symbol the entry
Configuration > PROFIBUS DP Master

» The PROFIBUS DP Master configuration window opens

E netDevice - PROFIBUS-DP Master netTAP[NT 100-RE-DP/PROXY <=>(#1) |
10 Device: NT 100-%8-ikk Device ID: O=0B44 =
Yendor: Hilscher GmbH “endor [0 0x011E DT
Havigation area =5
¥=4 Configuration
[S 4 Eus Parameters Profile: PROFIEUS DP -
:jodcess [_)I_a:' Bus Parameters
ress Table ) _ =
Station Table EBaud Rate: 1500 - kBitfs  Station Address: 1 ZI
Slok Time: 300 EEik Target Rotation Time: 11594  EBit
Min. Station Delay Time: 11 LBk = 7.9293 ms
Mazx, Station Delay Time: 150 LBk GAP Actualization Factor: 10
Quiek Time: u] EEik Mazx, Retry Limit: 1
Setup Time: 1 LBt Highest Skation Address (H54A): 126
Buz Monitaring
Data Control Time: 1200 ms [ oOverride slave specific Watchdog Control Time
Min. Slave Interval: 2000 ys ‘Watchdog Control Time: ms
Calculated Timir
? r

Tid1: 37 Bt

Tidz: 150 thit Yalues marked with this symbal should be Adiust
adjusted to changes in the topology.

K | Cancel | | Help |

Kil= Disconnected | (] Data Sat

Figure 28: PROFIBUS DP Bus Parameter
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2. Configure the PROFIBUS DP Master

» Set the parameter. Set especially under
Configuration > Bus Parameter the bus parameter and under
Configuration > Stationtable the station addresses (stations
addresses of the PROFIBUS DP Slave devices)

"3 netDevice - PROFIBUS-DP Master netTAP[NT 100-RE-DP]<>(#1) =13
10 Device: NT 100-%5-2% Device ID: Dx0B4A —
Wendor: Hilscher GrbH Wendor 10t 0x011E T
Mavigation &rea =B
=3 Configuration
BUS Paramaters Aotivate | Station . | Device | [RENI | *endar
Process Data Ld CB_AB32-DFS CB_AB32-DPS Hilscher GmbH

Address Table
kmp Station Table

Figure 29: PROFIBUS DP Slave Station Address

More information about the configuration of PROFIBUS DP Master
devices are in the document PROFIBUS_Master_netX_DTM_en.pdf in
section Configuration.

3. Close the configuration window
» Click on the button OK

> The configuration window closes
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3.3.6 Configure the Gateway — Signal Mapping

1. Open the Gateway configuration window

» Select from the context menu of the gateway device symbol the entry
Configuration > Gateway

The Gateway configuration window opens

)%
2. Open the Signal Mapping window

» Select Configuration > Signal Mapping
2 The window Signal Mapping opens

“a Gateway - net TAP[NT 100-RE-DP]<=(#1) |
10 Device: NT 100-RE-DP Dievice ICn = =
Wendor: Hilscher GmbH Yendor 10 0x011E DT
Navigation area =
‘3 Settings Available Signals
=3 Driver .
TCPJIF Driver For nets i Port X2 (PROFINET 10) <Addr ntl00repns:: A -5 Port %3 (PROFIBUS-DPY <Addr 1= T
niets Driver T 128 Bytes In <Slat 1= +-400 CB_AB32-DP5 <Addr 2
Device Assigrment I 128 Bytes OUt <Slot 23 7 + I CB_AE32-DPS <Addr 33 3
¥ Configuration o— o—
Settings Park 52 | Signals Data bype || Port 83 | Signals 4 Data bype ~
Licensing
Sigrial Mapping Send Cutput_0001 BYTE
Memary Card Management Send ~128 InBytes. BYTE_0000  BYTE Send Output_0002 BYTE
Send ~128 InBytes BYTE_OOOL EYTE Receive Inpuk_0001 EY¥TE
Cand w122 TrRubas PVYTE OON2 RYTE v Daraive Trek OO RPYTF v
L > £ >
M apped Signals
| | = Port %3 (PROFIBUS-DP) <addr 1> ~
B_AB32-DPS <Addr 2=
v +- i CB_AB32-DPS <Addr 3= 3
| Part 42 [PROFINET 10] | | Part 33 [PROFIBUS-DF)

Manual Mapping: | Auto Mapping: |off -
[0]4 | Cancel | | Help |

== | (0

Figure 30: Gateway Signal Mapping

The entry Memory Card Management in the navigation area is only
available for netTAP NT 100 devices.
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3. Signal Mapping: Data transfer from Port X2 to Port X3

Map the signals, which are received on Port X2 (Port X2 receive), with
signals, which should be sent on Port X3 (Port X3 send).

» For this, mark the signal received (Port X2) and the signal to be sent
(Port X3) and the click the button Map Signals
Or
Map the signal using drag and drop. For this, drag the signal received
(Port X2 receive) and drop it on the signal to be sent (Port X3 send)

4. Signal Mapping: Data transfer from Port X3 to Port X2

Map the signals, which are received on Port X3 (Port X3 receive), with
signals, which should be sent on Port X2 (Port X2 send).

> For this, mark the signal received (Port X3) and the signal to be sent
(Port X2) and the click the button Map Signals
Or
Map the signal using drag and drop. For this, drag the signal received
(Port X3 receive) and drop it on the signal to be sent (Port X2 send)

5. Signal Mapping: Transfer status info of Port X2 to Port X3

If necessary, map the status information of Port X2 (Port X2 generated,
which are generated device internal) to signals which should be sent on
Port X3 (Port X3 send)

» For this mark the status signal (Port X2) and the signal which should be
sent (Port X3) and click the button Map Signals
Or
Map the signal using drag and drop. For this, drag the status signal
(Port X2 generated) and drop it on the signal to be sent (Port X3 send)
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6. Signal Mapping: Transfer status info of Port X3 to Port X2

> If necessary, map the status information of Port X3 (Port X3 generated,
which are generated device internal) to signals which should be sent on
Port X2 (Port X2 send)

» For this mark the status signal (Port X3) and the signal which should be
sent (Port X2) and click the button Map Signals
Or
Map the signal using drag and drop. For this, drag the status signal
(Port X3 generated) and drop it on the signal to be sent (Port X2 send)

2 An example of the Signal Mapping window shows the following figure

"2 Gateway - netTAP[NT 100-RE-DP]<=>(#1) ([=(E3]
10 Device: MNT 100-RE-DP Device ID: = =
Vendor: Hilscher GmbH Yendaor ID: 0x011E DT
Navigation area B
3 Settings Available Signals
a Drriver :
TCP/IP Driver For nety =42 Part %2 (PROFINET I0) <Addr nt100repns:>i A | | =42 iPort %3 (PROFIBUS-DP) <Addr 1=:
Device Assignment 128 Bytes In <Slot 1= CB_AB3Z-DPS <Addr 2
#23 Configuration i 128 Bytes Out <Slot 23 2 i Status
Settings —
Licensing Part X2 Signals 4 Data bype | Port ®3 Signals 4 [raka bype ~
=y Signal Mapping Generated SlaveDiag 016,,.023 UNSIGNEDS
Memory Card Management Generated SlaveDiag 024...031 UMSIGMEDS
Send ~128 InBytes BYTE_0006 BYTE Generated SlaveDiag 032,,.039 LMSIGNEDS
Send ~128 InBytes BYTE_00O7 BYTE Generated SlaveDiag 040,,.047 LMSIGNEDS
Cand A1 28 ThRukar RYTE ONONS RYTF v Canaratad Clawahiza N4 nce LIRISTERFE v
£ > hS b
Mapped Signals
i s
-
Fart 2 [FROFINET 10] Fart %3 [FROFIBLS-DP)
¢ 128 Bytes In <Slat 1347128 InBytes.BYTE_0000 - ? byte input/output <Slot 13 Anput, 0001
128 Bytes In <Slot 1> /~128 InBytes BYTE_000 = CB_AB32-DPS <Addr 2»/2 byte input/output <Slot 13 Anput_0002
128 Bytes Dut <Slot 2> #~128 OutBytes. BY'TE_0000 wmy  CB_AB32-DPS <Addr 2 /2 byte input/output <Slot 13 A0utput_00C
128 Bytes Dut <Slot 2> /~128 OutBytes. BY'TE_0007 wmy  CB_AB32-DPS <Addr 2 /2 byte input/output <Slot 13 A0utput_00C

128 Bytes In <Slot 1>/7128 InBytes BYTE_DO0Z - ~128 InBytes. BYT <« Statuzibctive Slaves

Manual Mapping: Remaove link | Auto Mapping: |oFf -
(a4 | Cancel | Apply | Help |

<07

Figure 31: Gateway Signals mapped

The entry Memory Card Management in the navigation area is only
available for netTAP NT 100 devices.
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3.3.7 Establish a Connection to the Gateway Device

1. Connect the USB cable

» Connect with an USB cable the USB connector of the netTAP
(respectively the netBRICK NB 100) device with the USB connector of

the PC.

2. Select the driver

» Select Settings > Driver and then check netXDriver

> The following figure shows the selected Driver

2 netDevice - Gateway netTAP[NT 100-XX-XX]<>{#1) EEX
I Device: MT 100-Kx-5% Device ID: =
Vendar: Hilscher GrbH Vendar ID: DT
[ avigation area =
{23 Settings
=4 Driver | Driver ‘ersion
neks Driver D CIF Device Driver 1.0.3.1 {368BECSE-0E92-4C0E-B4AT-E4F6ZAETAAFA}
Device Assignment 35Gateway Driver For nety (W3.x) 0.9.2.0 {7a7CD3AT-4FA-4259-8E4D- 109BEAGBEADL
a Configuration ‘ nieky Driver 1.101.1.1875 {BS4C8CC7-F333-4135-6405-6E1 2FCE3EERZ}
Settings
Signal Mapping
Memory Card Management
Licensing
Ok | Help

<= 0

Figure 32: Select USB Driver (1)

The entry Memory Card Management in the navigation area is only

available for netTAP NT 100 devices.
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4. Select the netXDriver
» Select Settings > Driver > netXDriver

> The following figure shows the selected Driver

2 netDevice - Gateway netTAP[NT 100-XX-XX]==(#1)

10 Device: NT 100-X%-Xx% Device 1D _ L
Wendar: Hilscher GrmbH Wendor ID: Ox011E DT
Mavigation area =)
a Settings
a Driver
N Driver USBJRS232 Connection | TCP Connection |
Device Assignrnent
‘=3 Canfiguration @ v Enable USB/RS232 Connector (Restart of QDM required)
Settings T ’—4|
Signal Mapping glect Fort: ComM1 hd
Memoary Card Management Part Configuration
Licensing

[ Disable Port

Baud Rate: ’m‘ Byte Size: m
Stop Bits: ’m Parity: ’m
Send Timeout: llﬂﬂﬂi i‘ ms Keep Alive Timeout: ’2!]["]7 i‘ ms

()
S
Restore | Save | Save Al |

[s]4 | Cancel ‘ | Help |

== 10

Figure 33: Select USB Driver (2)

5. Select the netXDriver

> (D select the tab USB/RS232 Connection.
> @ Check Enable USB/RS232 Connector.
> (@ click on Save.

_} Note: The standard setting of the netX Driver USB/RS232 can be used for
netTAP respectively netBRICK devices without changes.
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3.3.8

Device Assignment
» Select Settings > Device Assighment

> Click on @ Scan.
> The search process is started. Devices found are display in a list then.

2 netDevice - Gateway netTAP[NT 100-XX-XX]<>(#1) [=(E3]
10 Device: MT 100-K8-52 Device ID: = =
Vendor: Hilscher GmbH Vendor ID: 0x011E DT
Mavigation area =
Setti
3 ae Ilil;r?:er Scan progress: 44 Devices (Current device: -)
niety, Driver o
s et Device selection: suitable only -
¥=3 Configuration
Settings Device | Hardware Ports 0f11,., | Slot ... | Serial nu... | Driver | Channel Prokocal | Access path |
Signal Mapping MT 100-RE-DP  EthernetfEthernet/P... nfa 20060 nety, Driver Gateway L ACOM3_cifx0..,
Memory Card Management 2
Licensing
#fccess path: | {B54CBCC7-Fa33-4135-6405-6E 1 2FCBREEGZHCOMA _cifxd_Ch2
OF | Cancel Help
<= |0 sl |5ave operation succeeded

Figure 34: Select Device

> Select the device from the list @ by a check in the field of the device as
shown above.

» Click on OK

2 The configuration window closes.

The entry Memory Card Management in the navigation area is only
available for netTAP NT 100 devices.
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3.3.9 Load Firmware

The firmware has to be loaded into the netTAP only for first commissioning
only. Therefore do the following steps:

1. Open the Gateway configuration window

» Select from the context menu of the gateway device symbol the entry
Configuration > Gateway

> The Gateway configuration window opens

2. Open the Settings window
» Select Configuration > Settings

> The window Settings opens

2 netDevice - Gateway net TAP[NT 100-XX-XX]<={#1)

E 10 Device: NT 100-RE-DP Device ID: - L

vendor: Hilscher GmbH Wendor ID: Ox011E OT
Navigation area (=
{3 Settings General
A Driver
neky Driver Description: | netTAP

Device Assignment

23 Canfiguration Frotocol Combinations

Setki
- S\Egn::Igl\:apnlng Primary network {Port X2 Secondary network, (Port 3):
Memary Card Management Required gateway:
Licensing
Required license: Yes (1)
Available Firmeare: ® Browse
@ Download
Software class: Gateway
Software version: 1.3.3.0
Baszic Settings
Mapping Cycle time: 1 ms Mapping mode:
Ok | Cancel Help

i |0 lud] Save operation succeeded

Figure 35: Firmware Download

3. Select Firmware

Mark at Available Firmware the firmware file @: NTPNSDPM.NXF
(Firmware for PROFINET 10 Device to PROFIBUS DP Master).

4. Load firmware into the device
» Click on Download

X The firmware is loaded into the netTAP device

| | Important: Do not remove the cable during the firmware download.
Do not disconnect the power supply of the device during the firmware
download.
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Download of firmware

Wait until the firmware was transferred completely into the device.
Close the Gateway configuration window after the download

Click OK

> The Gateway configuration window closes

v 9 v &

3.3.10 Load Configuration

1. Download configuration

» Select from the context menu of the gateway device symbol the entry
Download

» Answer the security question with Yes, if the download should start

2 SYCON.net builds up an online connection to the device. This the
indicated by a green highlighted device name.

2 The configuration is transferred info the gateway device
2 The device performs a reset and then starts with the new configuration.

3.3.11 Save Project

_}

Note: The configuration downloaded from SYCON.net into the device
can’'t be uploaded from the device. Only the SYCON.net project can be
downloaded into additional devices.

Save the SYCON.net project. In case of a device replacement the saved
project can be opened with SYCON.net and loaded into the device.

» To save a project select menu File > Save respectively File > Save As

. . ]
or click on icon .

When you exit the program and the current configuration differs from the
last saved configuration, then the following question appears:

L] "_-. Save changes to the project?
L

Yes Mo Cancel

Figure 36: Security Question — Save Project

When you answer with Yes, then the project is saved. When you answer
with No, then the project is not saved and the changes are lost. When you
answer with Cancel, then the project is not saved.
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3.3.12 Device Description File to configure the Master
A GSDML file is required to configure the PROFINET 10 Controller.
> To configure the PROFINET IO Controller use the following GSDML file
from the product DVD directory EDS/PROFINET.
for NT 100: GSDML-V2.1-HILSCHER-NT 100-RE PNS-20090123.xml,
for NB 100: GSDML-V2.1-HILSCHER-NB 100-RE PNS-20100226.xml,
for NT 50: GSDML-V2.1-HILSCHER-NT 50-EN PNS-20100226.xml

devices used as proxy. Make sure to use/import the right GSDML file at

Note: The product IDs are different for devices used as gateway and
the PROFINET 10 Controller.

» Load the GSDML file into the configuration software of the PROFINET
IO Controller.
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3.4 Configuration of a NT 100 as Proxy

For the conversion from PROFINET 10 Device to PROFIBUS DP Master
with proxy functionality the device NT 100-RE-DP can be used. Therefore
use the device NT 100-RE-XX/PROXY from the device catalog.

These devices are called proxy device in the following description.

The device NT 100-RE-DP with one master license is necessary for the
protocol conversion from PROFINET IO Device to PROFIBUS DP Master.

The following steps have to be done to configure the device:

3.4.1 Start SYCON.net and User Login

1. Start SYCON.net

» Select Start > Programs > SYCON.net System Configurator >
SYCON.net

X SYCON.net is started

2. User Login

» In the window SYCON.net User Login click OK to login or enter your
password and then click OK to login

2 SYCON.net frame application appears
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3.4.2 Insert the Proxy Device into the Configuration Window

» Go to the device catalog under vendor Hilscher GmbH to the category
Gateway / Stand-Alone Slave. Use drag and drop with the NT 100-XX-
XX proxy device to insert it at the (gray) main line.

| | =1+ Hilscher GmbH

—-£3 Gateway | Stand-alone Slave

T a MT 100-RE-x PROKY

\ Fieldbus \)\ Yendor /{DTM Class J,-"
Figure 37: Insert Proxy Device into the Project

2 The proxy device appears in the project

netTAP[MT 100-RE-Xx/PROXY ]< = (#1)

Figure 38: Proxy Device in the Project
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3.4.3 Select the Protocol Conversion of the Proxy

1. Open the Proxy configuration window.

» Select from the context menu of the proxy device symbol the entry
Configuration > Proxy.

> The Proxy configuration window opens.

2 Proxy - netTAP[NT] 100-RE-DP/PROXY]<>(#1)

10 Device: NT 100-RE-DP/PROXY Device ID: - =
Yendaor: Hilscher GmbH Yendor ID: 0x011E DT
Navigation area =
a nsa.attll:l;r?\fer Scan progress: 00 Devices (Current device: -)

TCPJIP Driver for nets

nieki Driver Device selection: sutable only  «
ey Device Assignment
{3 Configuration | Device | Hardware Ports 0f1f... | Slot nu. .. | Setial nu... | Driver | Channel Protocol | Access path |
Settings
Licensing

Memory Card Management

Access path: | 42564406 0-7EDE-4504-B634-21 B22C 386499 COME_ChZ

(o4 | Cancel Help

<= |0

Figure 39: Device Assignment without Device
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2. Open dialog for protocol selection
» Select in the Navigation area Configuration > Settings
2 The configuration window Settings opens

T netDevice - Proxy netTAP[NT 100-RE-XX/PROXY]=<>(#1)

I Device: NT 100-RE-¥x/PRORY Device ID: - =
Yendaor: Hilscher GmbH Yendor ID: 0x011E DT
Navigation area =
{23 Settings General
a Driver
neky Driver Description: | netTAP
Device Assignment L
9 Configuration Protocol Combinations
[~ 3 “ettings . , .
Mermory Card Managsment Primary network (Port 23 | J Secondary network (Port 53 | ﬂ

Licensing Required gateway: | J

Required license:

Available Firniware: MNTPMNSASC MXF A
MNTPMICCS MNEF

MNTPHSCOM, NEF

Browse

MNTPHSCOS . NXF
MTPMSDMM, MEF
MTPHSDMS NEF b

Software class:

Software version:

Basic Settings

Mapping Cycle time: 1 ms Mapping mode: J

[o]4 | Cancel Help

<=0

Figure 40: Proxy Protocol Selection (1)
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3. Select the protocol for the primary network and for the secondary
network and apply

» In the window Configuration > Settings at Protocol Combinations for
the Primary Network (Port X2) the protocol PROFINET 10 Device is
already preselected.

» Select then at Protocol Combinations for the Secondary Network
(Port X3) the protocol PROFIBUS DP Master

> The proxy configuration window shows the following.

"2 Proxy - netTAP[NT 100-RE-DP/PROXY]<>(#1) M{=1[E3]
10 Device: MNT 100-RE-DP/PRO®Y Device ID: - =
Yendar: Hilscher GmbH Yendor ID: 0x011E DT
Havigation area =
{24 Settings General
a Diriveer
TCRYIP Driver for net Dgseription: | netTAR
b Dri -
he T"'er Praotocol Combinatiohs
Device Assignment
3 Configuration Prirnary network (Pork %23 J Secondary network (Port X370
ap Settings v ' Q\ v '
Licensing Required gateway: | J
Memary Card Management
Required license: Yes (1)
Available Firrmware: NTPMSDPM.MNYF EramEs
Software dass:
Software version:
B asic: Settings
Mapping Cycle time: 1 ms Mapping mode: J
oK | Cancel Help
< 0

Figure 41: Proxy Protocol Selection (2)

The Mapping Mode is preselected with Default (only selection) and works
as follows:

PROFIUS-DP Slave devices which are inserted at the bus line are
represented by a slot number on PROFINET. The PROFINET slot number
is equal to the PROFIBUS station address. The PROFIBUS modules are
represented by a PROFINET sub slot number.

4. Close the proxy configuration window
» Click on OK

> The proxy configuration window closes

Configuration of Gateway and Proxy Devices | netTAP, netBRICK and netLINK
DOCO0812010I12EN | Revision 12 | English | 2020-05 | Released | Public © Hilscher, 2009-2020



Configuration Sequence for Gateway and Proxy 62/355

3.4.4  Configuration of the secondary Network

If the slave device is not listed in the device catalog, then it has to be
imported into the device catalog first.

3441 Expand PROFIBUS DP Slave Device Catalog

If you want to use a PROFIBUS DP slave device that is not listed in the
device catalog, then you have to import the GSD file into the SYCON.net
device catalog.

> Proceed as follows:

1. Missing PROFIBUS DP Slave devices can be added to the device
catalog using the menu Network > Import Device Descriptions.

Select the new GSD file.

3. Answer the question “Do you want to reload the device catalog?* with
Yes to reload the catalog.

~ More information about the device catalog is in the document
) . SYCONnet_netDevice_en.pdf* in the directory ,Documentation“ on the
product DVD.

3.4.4.2 Insert PROFIBUS DP Slave Device to the PROFIBUS Network

» Go to the device catalog. Use drag and drop with one or more
PROFIBUS DP Slave devices to insert it/them at the PROFIBUS bus
line.

2 The PROFIBUS DP Slave device icons appear at the PROFIBUS
network line (Secondary network)

netTAP[NT 100-RE-DP]<=({#1)

CE_ARZ2-DPS[CE_AB32-DPS]<2=

L7

Figure 42: Proxy Device with Slave
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3.44.3 Configure the PROFIBUS DP Slave device

> Open the configuration window with a double click on the device icon of
the PROFIBUS DP Slave

> The configuration window of the PROFIBUS DP Slave device opens
» Select in the navigation area Configuration > Modules.

» Select from Available Modules the module(s) and add it'them to the
Configured Modules to configure the Slave. The Configured Modules
has to match the configuration of the used PROFIBUS DP slave device.

~ More information about the configuration of PROFIBUS DP Slave devices
are in the document PROFIBUS_Generic_Slave_DTM_en.pdf on the
product DVD in section Configuration.

3.44.4 Configure PROFIBUS DP Master

1. Open the PROFIBUS DP Master (Port X3) configuration window

> Select from the context menu of the gateway device symbol the entry
Configuration > PROFIBUS DP Master

» The PROFIBUS DP Master configuration window opens

= netDevice - PROFIBUS-DP Master netTAP[NT 100-RE-DP/PROXY]<>{#1) |

10 Device: NT 100-X3-2% Device 1Dt 0x0B4A =
Vendor: Hilscher GmbH Vendor ID: 0x011E DT
Navigation iea =
¥=3 Configuration
=4 Eus Parameters Profile: PROFIEUS DP -
:jodcess [')I'a:‘ Bus Parameters
ress Table =
8 i i 8 1
Station Table Baud Rate 1500 - kBit!s  Station Address :I
Slat: Time: 300 [{=114 Tarqget Rotation Time: 11594  EBit
Min. Station Delay Time: 11 [{=114 = 7.9293 ms
Maz. Station Delay Time: 150 EBit GAP Actualization Factor: 10
Quiek Time: 1] kBt Maz, Rekry Limnik: 1
Setup Time: 1 LEiE Highest Station Address (HSA): 126
Buz Monitoring
Diata Control Time: 1200 ms [T Override slave specific Watchdog Contral Time
Min. Slave Interval: 2000 ys ‘Watchdog Control Time: ms
Calculated Timing -
Tid1: 37 kBit
Tidz: 150 kBit Yalues marked with this symbal should be Adiust
adjusted to changes in the topolagy.
< ¥
a4 | Cancel | | Help
Kl Disconnected  |[J Data Set

Figure 43: PROFIBUS DP Bus Parameter
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2. Configure the PROFIBUS DP Master

» Set the parameter. Set especially under
Configuration > Bus Parameter the bus parameter and under
Configuration > Station Table the station addresses (stations
addresses of the PROFIBUS DP Slave devices)

"3 netDevice - PROFIBUS-DP Master netTAP[NT 100-RE-DP/PROXY]<>(#1) M=1E3
10 Device: MWT 100-kk-X Device ID: 0x0B44 N
Wendor: Hilscher GrbH Wendor 10 0x011E 0T
Mavigation &rea =
=3 Corfiguration . - .

Bus Paramaters Activate | Statian ___ | Device | [REL | Wendar

Process Data L CB_&B32-DPS CB_&B32-DPS Hilzcher GmbH

Address Table n 3CB_aB32-DPS CB_&B32-DPS Hilzcher GmbH

kmy Station Table

Figure 44: PROFIBUS DP Slave Station Address

More information about the configuration of PROFIBUS DP Master devices
are in the document PROFIBUS Master netX DTM en.pdf in section
Configuration.

3. Close the configuration window
» Click on the button OK

> The configuration window closes
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3.4.5 Configuration of the primary Network
The PROFINET IO network is on port X2 of the proxy device.
1. Open PROFINET IO Device configuration window

» Select from the context menu of the proxy device symbol the entry
Configuration > PROFINET IO Device.

2 The PROFINET IO Device configuration window opens with the view of
the modules

 netDevice - PROFINET I0 Device netTAP[NT 100-RE-DP/PROXY]<>(#1) |

0 FoD 10 Device: MWT 100-RE-DP Dewice I0: 0x0106 =
— Wendar: Hilscher GmbH Yendaor ID: 0x011E DT
Mavigation Area [
“=3 Corfiguration
General Slot | Subslot | | Modul ~
HE 0 % |NT 100-RE-DP/PROXY
Address Table N 1 & 000000007
/23 pescription 1=l |®INT100 (PROFIBUS-DP) |
Device Info | 1 & 0x00000001
Module Info & | 2| |#|cB_AB32-DPS |
GEOML Wiswer i 1 R 2 byte input/output
3] 3| | |ce_aAB32-DPS |
| 1 8 2 byte input/output .,,
Use of slats: 22
State of data length: Input 01024 Ockets, Qutput 0/1024 Octets, In-Output 0f2048 Ockets
Submodule details
Dataset: Display mode:
| Diection | Consistence | D ata bype Text D [ Length |
£ b
OF | Cancel Help
<= Disconnected ([ Data Set

Figure 45: PROFINET IO Device Table

Here the modules with its slot number and sub slot number are displayed,
as they will become visible at the PROFINET IO Controller. These slot
numbers and sub slot numbers will be exported into the GSDML file, which
is described later.

Slot 0 (NT 100-RE-DP/PROXY) and slot 1 (NT100 (PROFIBUS DP)) are
always present. Two additional slots (slot 2 in this case, which represent
the PROFIBUS DP Slave with station address 2; slot 3 in this case, which
represent the PROFIBUS DP Slave with station address 3) are
automatically displayed when the PROFIBUS DP Slaves were inserted to
the PROFIBUS DP network.

These Slot and sub slot numbers are used in the GSDML file. The GSDML
file can be created (exported) which is described later.
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2. Set the name of station
» Select in the navigation area General.

> The following configuration window opens

7 netDevice - PROFINET I0 Device netTAP[NT 100-RE-DP/PROXY]=>(#1)

MNT 100-RE-DP
Hilscher GmbH

© o 10 Device:
—_ Vendar:

Navigation drea [
¥ Configuration

Device ID: 00106
Wendor ID: 0:x011E

DT

Mame of station: nt100reproxy

Modules

Gateway address: |

oK | Cancel

address Table Description: | MT_100-RE-DP
a Descripkion
Device Info IP zettings
Module Info
GSDML Yiewer IP address: |
el regk | Mote: These values are set by

the controller of the netwaork!

Help

Kil= Disconnected | (] Data Sat

Figure 46: PROFINET 10 Name of Station

» Enter the Name of Station

PROFINET IO Controller to identify the proxy device.

Note: The name of station is very important and is used by the

3. Close the configuration window
» Click on the button OK
> The configuration window closes
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3.4.6 Establish a Connection to the Proxy Device

1. Connect the USB cable

» Connect with an USB cable the USB connector of the netTAP device
with the USB connector of the PC.

2. Select the driver
» Select Settings > Driver and then check netXDriver
> The following figure shows the selected Driver

T netDevice - Proxy netTAP[NT 100-RE-DP/PROXY]<>(#1)

IO Device: MT 100-RE-DP{PRORY Device ID: - =
m Vendar: Hilscher GrbH Vendar ID: 0x011E DT
Mavigation area =]
a Settings
| Driver ‘ersion | (o]
etk Criver O CIFx Device Driver 1.0.3.1 {368BECSE-0E92-4C0E-B4A-E4FEZAETAAFA}
Device Assignment 35Gateway Driver For nety (W3.x) 0.9.2.0 {7a7CD3AT-4FA-4259-8E4D- 109BEAGBEADL
{23 Configuration nieky Driver 1.101.1.1761 {BS4C8CC7-F333-4135-6405-6E1 2FCE3EERZ}
Settings
Memary Card Management
Licensing

OF | Cancel Help

<= 0

Figure 47: Select USB Driver (1)
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4. Select the netXDriver
» Select Settings > Driver > netXDriver

> The following figure shows the selected Driver

T netDevice - Proxy netTAP[NT 100-RE-DP/PROXY]<>(#1)

10 Device: NT L00-RE-DPJPROKY Device 1D: - =
Wendar: Hilscher GrmbH Wendor ID: Ox011E DT
Mavigation area =)
a Settings
a Drriver
N Driver @ISBIRSZSZ Cannection | Tcp Connactien |
Device Assignrnent
{23 Configuration @ lv Enable USBfR5232 Connectar (Restart of QDM required)
Settings el Ports ET—
Memoary Card Management elect Part: comt >
Licensing Port Configuration
[ Disable Port
Baud Rate: 115.2 kBitfs - Byte Size: 3 Byte -
Stop Bits: 1 Stophit - Parity: Mo Pariy hd
Send Timeout: | 1000 i‘ ms Keep Alive Timeout: | 2000 i‘ ms
Reset Timgout: | 5000 il ms
(3)
A
Restore | Save | Save Al |
[s]4 | Cancel ‘ | Help |
<010

Figure 48: Select USB Driver (2)

5. Select the netXDriver

> (D select the tab USB/RS232 Connection.
> @ Check Enable USB/RS232 Connector.
> (@ click on Save.

Note: The standard setting of the netX Driver USB/RS232 can be used for

netTAP respectively netBRICK devices without changes.
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3.4.7 Device Assignment
» Select Settings > Device Assighment

> Click on @ Scan.
> The search process is started. Devices found are display in a list then.

2 netDevice - Proxy netTAP[NT, 100-RE-XX/PROXY]<>(#1) =3
10 Device: MT 100-RE-¥¥/PRO®Y Device ID: =
Vendor: Hilscher GmbH Vendor ID: 0x011E DT
Mavigation area =
Setti
3 ae Ilil;r?:er Scan progress: 44 Devices (Current device: -)
niety Driver o
nd" =5 Device selection: suitable onl
B y
¥=3 Configuration
Settings | Device | Hardware Ports 0f11,., | Slot ... | Serial nu... | Driver | Channel Prokocal | Access path |
Memory Card Management MT 100-RE-DP  EthernetfEthernet/P... nfa 20060 nety, Driver Gateway L ACOM3_cifx0..,
Licensing
#fccess path: | {B54CBCC7-Fa33-4135-6405-6E 1 2FCBREEGZHCOMA _cifxd_Ch2
OF | Cancel Help
<= |0 sl |5ave operation succeeded

Figure 49: Select Device

> Select the device from the list @ by a check in the field of the device as
shown above.

» Click on OK
> The configuration window closes.
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3.4.8 Load Firmware

The firmware has to be loaded into the netTAP only for first commissioning
only. Therefore do the following steps:

1. Open the proxy configuration window

» Select from the context menu of the gateway device symbol the entry
Configuration > Proxy

> The proxy configuration window opens

2. Open the Settings window
» Select Configuration > Settings

> The window Settings opens

"2 netDevice - Proxy net TAP[NT 100-RE-XX/PROXY]<>(#1)

10 Device: MT 100-RE-DPPRORY Device ID; L
Yendor: Hilscher GmbH Wendor 10t 0x011E DT
Mavigation area (=
“23) Settings General
=3 Driver
Rk Driver Description: | retTAP

Device Assignment
“23 Configuration

Setki
nd MZnErg: Card Management Primary network {Port X2 Secondary network, (Port 3):

Frotocol Combinations

Licsnsing Required gateway:
Required license: Wes (13
Available Firmware: Browse
@ Download
Software class: Gateway
Software version: 1.3.3.0
Baszic Settings
Mapping Cycle time: 1 ms Mapping mode:
Ok | Cancel Help

i |0 lud] Save operation succeeded

Figure 50: Firmware Download

3. Select Firmware

Mark at Available Firmware the firmware file @: NTPNSDPM.NXF
(Firmware for PROFINET 10 Device to PROFIBUS DP Master).

4. Load firmware into the device
» Click on Download

X The firmware is loaded into the netTAP device

| | Important: Do not remove the cable during the firmware download.
Do not disconnect the power supply of the device during the firmware
download.
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Download of firmware

Wait until the firmware was transferred completely into the device.
Close the Gateway configuration window after the download

Click OK

2 The Gateway configuration window closes

vV © v 9

3.4.9 Load Configuration

1. Download configuration

» Select from the context menu of the proxy device symbol the entry
Download

» Answer the security question with Yes, if the download should start

» SYCON.net builds up an online connection to the device. This the
indicated by a green highlighted device name.

2 The configuration is transferred info the proxy device
> The device performs a reset and then starts with the new configuration.

3.4.10 Save Project

Note: The configuration downloaded from SYCON.net into the device
can't be uploaded from the device. Only the SYCON.net project can be
downloaded into additional devices.

Save the SYCON.net project. In case of a device replacement the saved
project can be opened with SYCON.net and loaded into the device.

» To save a project select menu File > Save respectively File > Save As

) ) ]
or click on icon .

When you exit the program and the current configuration differs from the
last saved configuration, then the following question appears:

L] "_-. Save changes to the project?
L

Tes o Cancel

Figure 51: Security Question — Save Project

When you answer with Yes, then the project is saved. When you answer
with No, then the project is not saved and the changes are lost. When you
answer with Cancel, then the project is not saved.
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3.4.11 Device Description File to configure the PROFINET 10
Controller

A GSDML file is required to configure the PROFINET IO Controller. This file

is creates as follows:

> Select from the context menu of the proxy device symbol the entry
Additional Functions > PROFINET 10 Device > Export GSDML.

> The dialog to save the XML file appears.
» Select the directory the GSDML file should be saved into.

» A name for the GSDML file is proposed. Accept it or change it useful.

» Click on Save.
X The GSDML file is saved.

The structure of the file name is:
GSDML—V2.2—HiIsche_r—netTAP—zm 00?2}_1 1 3409.me|

DO O ® 00

(1) Fixed prefix

@ Version number of the GSDML specification
(3 Manufacturer name

(4) Device type

(5) Date: Format yyyymmdd

(6) Time: Format hhmmss

@ File extension (always): xml

» Use the GSDML file to configure the PROFINET 10 Controller
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3.5 Configuration of the NT 151-RE-RE (netTAP Real-Time
Ethernet Gateway)

This section provides step-by-step instructions for configuring the netTAP
NT 151-RE-RE device. In the following description, this device is also
called “gateway device”.

The configuration is exemplified by using the protocol conversion
PROFINET 10 Device to PROFINET IO Device.

. =™  Information on how to use an SD memory card to copy configuration data

) ' from one netTAP into another netTAP device (e.g. in order to “clone” a
spare device) can be found in the user manual netTAP NT 151-RE-RE,
DOC150802UMXXEN.

3.5.1 Start SYCON.net and User Login

1. Start SYCON.net.

» Choose Start > Programs > SYCON.net System Configurator >
SYCON.net

X SYCON.net is started.

2. User Login

» In the window SYCON.net User Login click OK to login or enter your
password and then click OK to login.

» SYCON.net frame application appears.
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3.5.2 Insert the Gateway Device into the Configuration Window

There are two options of inserting the gateway device:

e Option 1: You can insert the NT 151-RE-RE dummy gateway element,
which is not equipped with a preset protocol conversion. In this case,
you afterwards have to configure the protocol conversion as described in
section Select the Protocol Conversion of the Gateway on page 77.

e Option 2: You can insert a gateway element featuring a preset protocol
conversion. In this case, you can proceed as described in section
Configuration of the primary Network on page 80.

Option 1

» In the device catalog, open Vendor tab, then open Hilscher GmbH >
Gateway / Stand-Alone Slave folder. Select the NT 151-RE-RE
gateway, then “drag and drop” the device onto the (gray) main line.

B8 NRP 52-RE/EIS
.38 NRP 52-RE/OMB
.88 NRP 52-RE/PLS

BB NRP 52-RE/VRS
..... B NT 100-RE-XX/PROXY
..... B T 100-206-50

Bl

----- i} NT151-RE-RE/ECS/ECM
----- E_f MNT 151-RE-RE/ECS/ECS
..... i} NT151-RE-RE/ECS/EIM

----- E_f MT 151-RE-RE/ECS/EIS

----- £} NT151-RE-RE/ECS/OMB
----- E_] MT 151-RE-RE/ECS/PLS
----- £} NT151-RE-RE/ECS/PNM
----- E_] MNT 151-RE-RE/ECS/PNS

i Fiel-ld.bl..llss: Fe;éo;zDﬁfﬁEléss}\ Found /

m

Figure 52: Insert Gateway Device into the Project

> The gateway device appears in the project:

netTAP[NT 151-RE-RE]<>(#1)

|

Figure 53: Gateway Device in the Project

» Proceed as described in section Select the Protocol Conversion of the
Gateway on page 77.
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Option 2

» In the device catalog, open Vendor tab, then open Hilscher GmbH >
Gateway / Stand-Alone Slave folder. Select the gateway element that
represents your desired protocol conversion (e.g. NT 151-RE-
RE/PNS/PNS), then “drag and drop” the device onto the (gray) main
line.

..... f} NT151-RE-RE/PLS/535
..... f} NT151-RE-RE/PNS/ECM
..... B} NT151-RE-RE/PNS/ECS
..... £} NT151-RE-RE/PNS/EIM
..... i} NT151-RE-RE/PNS/EIS
..... f NT151-RE-RE/PNS/OMB
..... f] NT151-RE-RE/PNS/PLS
M £} NT151-RE-RE/PNS/PNM
.
..... B} NT151-RE-RE/PNS/S3M
..... B} NT151-RE-RE/PNS/535
..... f} NT151-RE-RE/S3S/ECM
..... B} NT151-RE-RE/S3S/ECS
..... £} NT151-RE-RE/S3S/EIM
..... i} NT151-RE-RE/S3S/EIS

\ Fiel.-.d.bL.llsT}\‘ ‘P-"erhhéo;;{r[}ltﬁti;ss}\ Found f-’

m

Figure 54: Insert pre-configured Gateway Device into the Project

2 The gateway device appears in the project:

netTAP[NT 151-RE-RE/PNS/PNS]<>

|

Figure 55: Pre-configured Gateway Device in Project

> Proceed as described in section Configuration of the primary Network
on page 80.
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Abbreviations of the protocol conversions

The protocol conversions of the elements in the device catalog can be
inferred from the abbreviations:

MRP 52-RE/VRS -
MT 100-RE-XK/PROXY

MT 100-XK-XX Abbreviation of primary network protocol at X2
NT151-RE-RE J}

NT 151-RE-RE/ECS/ECM 4mm Abbreviation of secondary

MT 151-RE-RE/ECS/ECS network protocal at X3

MT 151-RE-RE/ECS/EIM

MT 151-RE-RE/ECS/EIS

MT 151-RE-RE/ECS/OME

MT 151-RE-RE/ECS/PLS

MT 151-RE-RE/ECS/PMNM

MT 151-RE-RE/ECS/PNS

MT 151-RE-RE/ECS/53M

MT 151-RE-RE/ECS/535

KITAC1 DC DCYOIC IO TRA

£
"\ Fieldbus ' Vendor / DTM Class}‘ Found f

Figure 56: Protocol conversions

The combination NT 151-RE-RE/ECS/ECM for example means that the
gateway is pre-configured for acting as EtherCAT Slave at the X2 primary
network and as EtherCAT Master at the X3 secondary network.

Abbreviation

Meaning

PNM

PROFINET IO Controller

PNS

PROFINET IO Device

ECM

EtherCAT Master

ECS

EtherCAT Slave

S3M

Sercos Master

S3S

Sercos Slave

EIM

EtherNet/IP Scanner

EIS

EtherNet/IP Adapter

PLS

POWERLINK Controlled Node

OMB

OpenModbus/TCP

Table 8: Abbreviations of the protocols
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3.5.3 Select the Protocol Conversion of the Gateway

1. Open the Gateway configuration window.

» In the context menu of the gateway device symbol, choose
Configuration > Gateway.

2 The Gateway configuration window opens:

B netDevice - Gateway netTAP[NT 151-RE-RE]<> (1) =8 BER(F<T
- 10 Device: NT 151-RE-RE Device ID: = =
'-_J Vendor: Hilscher GmbH Vendor ID: Ox011E oT
Navigation area B Device Assignment

3 ;ﬁénss Scan progress: 3f3 Devices (Current device: -)
rver
netX Driver
=S Device selection: suitable only hd

3 ConfigL.lration | Device | Hardware Ports 0/... | Slotn... | Serial nu... | Driver Channel Protocol | Access path |

Settings

Signal Mapping

Memory Card Management

Licensing

Access path:
oK | Cancel Help
<= |0
Figure 57: Device Assignment without Device
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2. Open dialog for protocol selection.
» Inthe Navigation area, select Configuration > Settings.

2 The configuration window Settings opens:

B netDevice - Gateway netTAP[NT 151-RE-RE] <> (#1) |- S
= | 10 Device: NT 151-RERE Device ID: - =
_J Vendar: Hilscher GmbH Vendor ID: 0x011E DT
Navigation area B Settings

{4 Settings General
=3 Driver »
netX Driver Description: | netTAP
Device Assignment Protocol Combinations
{=3 Configuration
=9 m Primary network (Port X2): | j Secondary network (Port ¥3): | j
Signal Mappi
‘gnativapping Required gateway: | j
Memaory Card Management
Licensing Required license:
Available Firmyare: T12000C0.MNXF - Browse
T12000D0.NXF —

T120D0G0.NXF
T1200010.NXF

T120F0C0.NXF

T120F0D0.MXF o
] Software dass: = 1
Software version:
Basic Settings
Mapping Cyde time: 1 ms Mapping mode: Default J
Network Address Switch
-

oK | Cancel Help

<= |0

Figure 58: Gateway Protocol Selection (1)
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3. Select the protocol for the primary network and for the secondary
network.

» In the Protocol Combinations area, select PROFINET 10 Device
from the the Primary Network (Port X2) drop-down list.

» From the Secondary Network (Port X3) drop-down list, also select
PROFINET 10 Device.

» Click Apply button.

 The Gateway configuration window now looks as depicted below:

B netDevice - Gateway netTAP[NT 151-RE-RE] <> (£1) =N Eoh
= | 10 Device: NT 151-RE-RE/PNS/PNS Device ID: - =
_J Vendor: Hilscher GmbH Vendor 1D: 0x011E DT
Navigation area B Settings

{3 Settings General
{3 Driver o
et Driver Description: | netTAP
Device Assignment Frotocol Combinations
{3 Configuration
=N m Primary network (Port X2): |PROFII-IEI' 10 Device J Secondary network (Port X3): |PROFII-IEI' 10 Device J
Signal Mapping "
Required gateway: T 151RE-RE/PNS/PNS
Memory Card Management quired gateway [NT 151-RE-RE/PNSPNS |
Licensing Required license: Mone
Available Firmware: T1200000.MXF Browse
Software dass: PROFIMET-IO IO Device | PROFINET-IO IO Device |
Software version: 1.0.0.0
Basic Settings
Mapping Cyde time: 1 ms Mapping mode: Default J

Network Address Switch

| =

Ok Cancel Help

=i |0 |ud |Save operation succeeded

Figure 59: Gateway Protocol Selection (2)

4. Close the Gateway configuration window.
» Click OK button.

> The Gateway configuration window closes.
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3.5.4  Configuration of the primary Network

1. Open the configuration window.

» In the context menu of the gateway device symbol, choose
Configuration > PROFINET 10 Device (choose the upper of the two
PROFINET IO Device entries).

Metwork Scan...

Configuration 2 Gateway

Measured Value... PROFINET IO Device

o
Simulation... PROFINET IO Device

Diagnosis »

Figure 60: Open Port X2 via context menu

» The PROFINET IO Device configuration window opens for the primary
network at Port X2:

B netDevice - PROFINET 10 Device netTAP[NT 151-RE-RE/PNS/PNS] <> (£1) o ==
10 Device: NT 151-RE-RE/PMS/PNS Device ID: 0x0121 =
Vendor: Hilscher Gesellschaft fiir Systemautomation mbH Vendor ID: 0x011E DT
Navigation Area [ Modules
= CD"SE:';::“ [ 1 5ot [ Swsi 1] Module
h' ﬂ 0 £ NT 151-RE-RE/PNS V1.0 - Vix [1722.122]

Address Table
#=3 Description

Device Info
Module Info
GSDML Viewer
Add Module
) |
Use of slots: 1/2586
State of data length: Input 0/1024 Octets, Output 01024 Octets, In-Output 02048 Octets
Submodule details
Dataset: 10 data Display mode: Dedmal
| Diection | Consistence | Data type Teat ID | Length |
< i b

oK | Cancel Help

_<||> Disconnected |(J Data Set

Figure 61: Configuring PROFINET 10 Device at X2 (1)
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2. Configure input data for primary network at Port X2.
» Click Add Module button to add a module for input data.

» In the Modules table, click on the newly added module entry, then
select the number of input bytes for your gateway device at Port X2
from the drop-down list. For receiving e.g. 16 bytes of input data, select
16 Bytes Input entry from the drop-down list.

B netDevice - PROFINET 10 Device netTAP[NT 151-RE-RE/PHS/PNS] <> (#1) o=
10 Device: MNT 151-RE-RE/PNS/PNS Device ID: 0x0121 =
Vendar: Hilscher Gesellschaft fir Systemautomation mbH Vendar ID: 0x011E DT
Navigation Area [ Modules
Configuration
= s J | | st | SubsSiot [ 1] Module |
enera = 0 T NT 151-RE-RE/PNS V1.0 - V1x [1722.122]
= Modules a 1 1 Byte Input g I~
Address Table 4 Bytes Input "
#=3 Description & Bytes Input
. 12 Bytes Input (4
Device Info = -
Module Info 20 Bytes Input
GSDML Viewer 32 Bytes Input =

Add Module | | Remove |

Use of slots: 2/256
State of data length: Input 1/1024 Octets, Cutput 0/1024 Octets, In-Output 12048 Octets

Submodule details
Dataset: 10 data Display mode: Dedmal

| Direction | Congistence | Data type Texd ID | Length |

4 T 3

oK | Cancel Apply Help

<> Disconnected |(J Data Set 4

Figure 62: Configuring PROFINET IO Device at X2 (2)
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3. Configure output data for primary network at Port X2.

» Click Add Module button again to add a module for output data.

» In the Modules table, click on the newly added second module entry,
then select the number of output bytes for your gateway device at Port
X2 from the drop-down list. For sending e.g. 32 bytes of output data,
select 32 Bytes Output entry from the drop-down list.

4 n

B netDevice - PROFINET IO Device netTAP[NT 151-RE-RE/PNS/PNS] <> (#1) o] @ ==
10 Device: MT 151-RE-RE/PNS/PNS Device ID: 0x0121 =
Vendor: Hilscher Gesellschaft fiir Systemautomation mbH Vender ID: 0x011E DT
Navigation Area [ Modules
Configuration
= aneml [ St [ Subsiet [1] Module |
n 0 E NT 151-RE-RE/PNS V1.0 - Vix [1722.122]
iy Modules 1 16 Bytes Input
AddressTable )| 2 [32 Bytes Output__ e |
{3 Description
Device Info
Module Info
GSDML Viewer
Add Module | Remove

Use of slots: 3/256
State of data length: Input 17/1024 Octets, Output 0/1024 Cctets, In-Output 17/2048 Octets

Submodule details

Dataset: 10 data Display mode: Decimal

| Diection | Consistence | Data type Text ID [ Length |

oK | Cancel Apply Help

=il= Disconnected

(0 Data Set f

Figure 63: Configuring PROFINET IO Device at X2 (3)

Detailed information on how to configure a PROFINET 1O Device at Port
X2 can be found in the operating instruction manual Generic DTM for
PROFINET IO Devices, DOC0603050IxxEN stored on the Gateway
Solutions DVD in the directory
Documentation\english\1._Software\SYCON.net
Configuration Software\Master Configuration\PROFINET

10 Controller\10 Device Configuration.

If you are using the EtherCAT Slave protocol at X2, see section
Configuration EtherCAT Slave on page 175 for further information.

If you are using the EtherNet/IP Adapter protocol at X2, see section
Configuration EtherNet/IP Adapter on page 179 for further information.

If you are using the Sercos Slave protocol at X2, see section
Configuration Sercos Slave on page 212 for further information.

If you are using the POWERLINK Controlled Node protocol at X2, see
section Configuration POWERLINK Controlled Node on page 199 for
further information.

As an alternative, you can open the corresponding online help by clicking
the Help button in the opened configuration dialog window of the slave
DTM, or by pressing the F1 key on your keyboard.
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4. Close the configuration window.
» Click OK.

2> The configuration window closes.
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3.5.5 Configuration of the secondary Network

1. Open the configuration window.

» In the context menu of the gateway device symbol, choose
Configuration > PROFINET IO Device (choose the lower of the two
PROFINET IO Device entries).

Metwork Scan...

Configuration » Gateway

Measured Value... PROFINET IO Device
= .

simulation.. PROFINET IO Device
Diagnosis 2

Figure 64: Open Port X3 via context menu

> The PROFINET IO Device configuration window opens for the
secondary network at Port X3:

B netDevice - PROFINET IO Device netTAP[NT 151-RE-RE/PNS/PNS]< > (£1) [=] ===
10 Device: MT 151-RE-RE/PNS/PNS Device ID: 0x0121 =
Vendor: Hilscher Gesellschaft fir Systemautomation mbH Vendor ID: 0x011E OT
Navigation Area [ Modules
= Cméi:n”e':lim [ [ St [ Subsiot [1] Module
o [57S EE 0 I NT 151-RE-RE/PNS V1.0 - Vix [1722.122]

Address Table
‘=3 Description

Device Info
Medule Info
GSDML Viewer
Add Module
Use of slots: 1/256
State of data length: Input 01024 Octets, Output 01024 Octets, In-Output 0/2048 Octets
Submodule details
Dataget: IO data Digplay mode: Decimal
| Diection | Consistence | Data type Text ID [ Length |
4 T 3

0K | Cancel Help

_<JD= Disconnected G Data Set

Figure 65: PROFINET IO Device Configuration Window
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2. Configure input data for secondary network at Port X3.
» Click Add Module button to add a module for input data.

» In the Modules table, click on the newly added module entry, then
select the number of input bytes for your gateway device at Port X3
from the drop-down list. For receiving e.g. 16 bytes of input data, select
16 Bytes Input entry from the drop-down list.

B netDevice - PROFINET 10 Device netTAP[NT 151-RE-RE/PNS/PNS] < > (#1) o ===
10 Device: MT 151-RE-RE/PNS/PMS Device ID: 0x0121 =
Vendor: Hilscher Gesellschaft fiir Systemautomation mbH Vendor ID: 0x011E OT
Navigation Area [ Modules
Confi ti
= D"G'g”'a I'D" [ St [ Subsiot [1] Module |
Eners = 0 % NT 151-RE-RE/PNS V1.0 - Vix [1722.122]
= Modules M 1 1 Byte Input g |-
Address Table 4 Bytes Input i
=3 Description 8 Bytes Input
. 12 Bytes Input [
Device Info = .
Module Info 20 Bytes Input
GSDML Viewer 32 Bytes Input 4

Add Module | | Remove |

Use of slots: 2/256
State of data length: Input 1/1024 Octets, Output 071024 Octets, In-Output 1/2048 Octets

Submodule details
Dataget: 10 data Display maode: Decimal

| Direction | Congistence | Data type Text ID | Length |

4 LI} 3

Ok | Cancel Apply Help

<= Disconnected |[J Data Set 4

Figure 66: Configuring PROFINET IO Device at X3 (1)
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3. Configure output data for secondary network at Port X3.
» Click Add Module button again to add a module for output data.

» In the Modules table, click on the newly added second module entry,
then select the number of output bytes for your gateway device at Port
X3 from the drop-down list. For sending e.g. 32 bytes of output data,
select 32 Bytes Output entry from the drop-down list.

B netDevice - PROFINET IO Device netTAP[NT 151-RE-RE/PNS/PNS] <> (£1) o -2 ==
10 Device: MT 151-RE-RE/PNS/PNS Device ID: 0x0121 =
Vendor: Hilscher Gesellschaft fir Systemautomation mbH Vendor ID: 0x011E DT
Navigation Area [ Modules
Cenfigurati
= °"G'§n”;al'°" [ St | SubSiot [1] Module |
| B 0 E NT 151-RE-RE/PNS V1.0 - Vix [1722.122]
iy Modules 1 16 Bytes Input
AddressTable |y 2 [32 Bytes Output e |
{3 Description
Device Info
Module Info
GSDML Viewer
Add Module | Remove

Use of slots: 3/256
State of data length: Input 171024 Octets, Output 0/1024 Octets, In-Output 17/2048 Octets

Submodule details
Dataget: 1/0 data Display mode: Dedmal

| Direction | Consistence | Data type Text ID [ Length |

oK | Cancel Apply Help

<l Disconnected |(J Data Set 4

Figure 67: Configuring PROFINET 1O Device at X3 (3)

Detailed information on how to configure a PROFINET 1O Device at Port
X3 can be found in the operating instruction manual Generic DTM for
PROFINET IO Devices, DOC0603050IxXEN stored on the Gateway

Solutions DVD in the directory
Documentation\english\1._Software\SYCON.net
Configuration Software\Master Configuration\PROFINET

10 Controller\10 Device Configuration.

If you are using the EtherCAT Slave protocol at X3, see section
Configuration EtherCAT Slave on page 175 for further information.

If you are using the EtherNet/IP Adapter protocol at X3, see section
Configuration EtherNet/IP Adapter on page 179 for further information.

If you are using the Sercos Slave protocol at X3, see section
Configuration Sercos Slave on page 212 for further information.

If you are using the OpenModbus/TCP protocol at X3, see section
Configuration Open Modbus/TCP on page 185 for further information.

As an alternative, you can open the corresponding online help by clicking
the Help button in the opened configuration dialog window of the slave
DTM, or by pressing the F1 key on your keyboard.
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Detailed information on how to configure a master protocol at Port 3 can
be found in the operating instruction manual of the corresponding Master
DTM. The Master DTM manuals are stored on the Gateway Solutions

DVD in the directory
Documentation\english\1._Software\SYCON.net

Configuration Software\Master

Configuration\[protocol].

For EtherCAT Master, for example, you would need the operating
instruction manual DTM for Hilscher EtherCAT Master Device,
DOC0804040IxxEN.

As an alternative, you can open the corresponding online help by clicking
the Help button in the opened configuration dialog window of the Master
DTM, or by pressing the F1 key on your keyboard.

4. Close the configuration window.
» Click on OK.

> The configuration window closes.
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3.5.6 Signal Mapping

choose

1. Open the Gateway configuration window.

> In the context menu of the gateway device symbol,
Configuration > Gateway.

> The Gateway configuration window opens.

2. Open the Signal Mapping window.

» Inthe Navigation area, select Configuration > Signal Mapping.

2 The Signal Mapping window opens:

’ netDevice - Gateway netTAP[NT 151-RE-RE/PNS/PNS]< > (#1)

Device ID:

Vendor 1D: 0x011E

rt X3 (PROFIMET I0) < Addr nt151repnss|

m| »

=| 10 Device; NT 151-RE-RE/PNS/PNS
{J Vendor: Hilscher GmbH
Navigation area = Signal Mapping
3 Settings Available Signals
=3 Driver - : -
etk Driver -4 X2 (PROFINET 10} <Addr ntl51repns>: : =l

6 Bytes Input <5lot 1=

Device Assignment
2 Bytes Output <Slot 2=

{3 Configuration

1

16 Bytes Input <5Slot 1>
32 Bytes Output <5Slot 2>

1

Mapped Signals

ort X2 (PROFINET 10) <Addr ntl51repns>|
6 Bytes Input <Slot1>
2 Bytes Output <Slot 2>

| Prt X2 (PROFINET I0) |

Settings Port X2 | Signals  + | Data type - | Signals  + | Data type -
Lo Signal Mapping
Memaory Card Management
Licensing Send ~Inputs.BYTE_0001 BYTE Send ~Inputs.BYTE_0001 BYTE
Send ~Inputs.BYTE_0002 BYTE ~ | Send ~Inputs.BYTE_0002 BYTE =2
4 1 3 4 1 3

1t 53 (PROFINET 10) < Addr ntl51repnss

| Port X3 (PROFINET I0)

16 Bytes Input <Slot 1>
32 Bytes Qutput <5Slot 2>

Manual Mapping: |

Auto Mapping: |Off -
oK

Cancel | | Help ‘

<=0

Figure 68: Gateway Signal Mapping
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3. Configure data transfer from Port X2 to Port X3.

Map the signals that are received on Port X2 (Port X2 Receive) with the
signals that should be sent on Port X3 (Port X3 Send).

> For this, first select the received signal at Port X2 @ then select the
signal to be sent at Port X3 @ then click Map Signals button @

Signal Mapping

Available Signals

rt X3 (PROFINET 10) <Addr ntl51repns>;
! 16 Bytes Input <Slot 1>

| 32 Bytes Qutput <5lot 2>

| Status

Port X2 (PROFIMET 10) <Addr nﬂSlrepns>§
16 Bytes Input <Slot 1>

32 Bytes Qutput <5Slot 2>

Status

|
m.| »

1
1

Port X2 | Signals  # | Data type + | Port X3 | Signals £ | Data type &

Receive ~Qutputs.BYTE_0001 BYTE

Receive ~Qutputs.BYTE_0002 BYTE Send ~Inputs.BYTE_0001 BYTE
~Qutputs.BYTE_0003 @ Send ~Inputs.BYTE_0002 BYTE

Receive ~Outputs.BYTE_0004 BYTE Er Eﬂ*

Receive ~Qutputs.BYTE_0005 BYTE ~ | Send ~Inputs.BYTE_0004 BYTE i

4 mn L3 4 n 2

Mapped Signals

E1-47% (Port X2 (PROFINET 10) <Addr ntl51repns>: =47 iPort X3 (PROFINET 10} <Addr ntl51repns>;
16 Bytes Input <Slot 1> 5§ 16 Bytes Input <Slot 1=

32 Bytes Qutput <5lot 2 " 32 Bytes Output <5lot 2>

Status " Status

| Port X2 (PROFINET 10) | | Port X3 (PROFINET 10}

Manual Mapping: Map signals | Auto Mapping: |Off -

Figure 69: Map signals (1)

_) Note: You can also map the signals by using drag and drop. For this, drag
the received signal (Port X2 Receive) and drop it on the signal that is to
be sent (Port X3 Send).

> Repeat the procedure with the other required signals.

0 Important: If you use the Auto Mapping function (see position @ in the

‘ figure above), you cannot use the standard GSDML file GSDML-V2.31-
HILSCHER-NT 151-RE-RE PNS-20151021.xml delivered on the
Gateway Solutions DVD for configuring the PROFINET IO Controller.
In this case, you must generate and export a new GSDML after having
finished the configuration in SYCON.net.
To do so, select the gateway device symbol, then choose Additional
Functions > PROFINET 10 Device > Export GSDML from the context
menu and save the file to your PC. Afterwards you can import this file in
your PROFINET engineering tool to configure your 10 Controller.
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4. Configure data transfer from Port X3 to Port X2

» Map the signals that are received on Port X3 (Port X3 Receive) with
the signals that should be sent on Port X2 (Port X2 Send).

For this, first select the received signal at Port X3 @ then select the
signal to be sent at Port X2 @ then click Map Signals button @

Signal Mapping
Ayailable Signals

ort X2 (PROFINET I0) <Addr nﬂ.Slrepns)E
6 Bytes Input <Slot 1>
2 Bytes Qutput <Slot 2=

ort X3 (PROFIMET 10) <Addr nﬂ.Slrepan
6 Bytes Input <5Slot 1>
2 Bytes Cutput <Slot 2=

lam, | »

Status - tatus -
Port X2 | Signals  # | Data type + | Port X3 | Signals  # | Data type o
1
~Qutputs.BYTE_0001 @ |
~Inputs.BYTE_ 0001 Eﬂ# Receive ~Qutputs.BYTE_0002 BYTE b
Send ~Inputs.BYTE_0002 BYTE Receive ~Qutputs.BYTE_0003 BYTE
Send ~Inputs.BYTE_0003 BYTE Receive ~Qutputs.BYTE_0004 BYTE
Send ~Inputs.BYTE_0004 BYTE -~ | Receive ~Qutputs.BYTE_0005 BYTE 5
al- - T — v = N T — ’
Mapped Signals

X2 (PROFINET 10) <Addr ntl51repns>:
16 Bytes Input <Slot 1>

32 Bytes Qutput <5lot 2>

Status

%3 (PROFINET 10) <Addr nt151repns>:
6 Bytes Input <Slot 1=
2 Bytes Output <Slot 2>

<Subslot 1>/~Inputs BYTH

Manual Mapping: Map ;ignals@ Remove link Auto Mapping: |Off -
Figure 70: Map signals (2)

_} Note: You can also map the signals by using drag and drop. For this, drag
the received signal (Port X3 Receive) and drop it onto the signal that is to
be sent (Port X2 Send).

» Repeat the procedure with the other required signals.
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5. Transfer status info of Port X2 to Port X3

> If necessary, map the internally generated status information of Port X2
(Port X2 Generated) to signals which should be sent on Port X3 (Port
X3 Send)

> For this, select the status signal Port X2 Generated @ then the signal

that should be sent (Port X3 Send) @ then click the Map Signals
button.
(You can also map the signals by using “drag and drop”.)

Signal Mapping

Awvailable Signals

ort X2 (PROFINET I0) <Addr m‘l51repn5>§
" 16 Bytes Input <5lot 1>

" 32 Bytes Output <5Slot 2>

* Status

Port X3 (PROFIMET 10) <Addr nﬂSlrepns>§
16 Bytes Input <Slot 1>

32 Bytes Qutput <Slot 2>

Status

Port X2 | Signals 4 | Data type + | Port X3 | Signals £ | Data type a
Send ~Inputs.BYTE_0011 BYTE

Generated Communication Chang... UMNSIGNED32 Send ~Inputs.BYTE 0012 BYTE

Generated Communication State UMNSIGMED32 @
@Im Send ~Inputs.BYTE_0014 BYTE

Generated Version UMNSIGMEDLG Send ~Inputs.BYTE_0015 BYTE

Generated Watchdog Timeout UMNSIGMEDLG -~ | Send ~Inputs.BYTE_0016 BYTE -

“ 1 G 4 T *

Figure 71: Map signals (3)

6. Transfer status info of Port X3 to Port X2

» If necessary, map the internally generated status information of Port X3
(Port X3 Generated) to signals which should be sent on Port X2 (Port
X2 Send)

> For this, select the status signal Port X3 Generated @ then the signal

which should be sent (Port X2 Send) @ then click the button Map
Signals
(You can also map the signals by using “drag and drop”.)

Signal Mapping

Awvailable Signals

-4 iPort X2 (PROFINET 10) <Addr ntl51repns> B
" 16 Bytes Input <5lot 1>
" 32 Bytes Output <5Slot 2>

rt X3 (PROFINET 10) <Addr ntl51repns>:
16 Bytes Input <Slot 1>
32 Bytes Output <5lot 2

" Status Status
Port X2 | Signals 4 | Data type + | Port X3 | Signals 4 | Data type &
Send ~Inputs.BYTE_0007 BYTE Generated Communication Chang... UMNSIGMNED32
Send ~Inputs.BYTE_0009 BYTE Communication State @
Send ~Inputs.BYTE_0011 BYTE Generated Communication Error UMNSIGMED32
Send ~Inputs.BYTE_0012 BYTE Generated Version UMNSIGMEDLG
[Send | ~Inputs.BYTE 0013 Eﬂ? Generated Watchdog Timeout UNSIGMED16
Send ~Inputs.BYTE_0014 BYTE ~ | Generated Host Watchdeg UMNSIGMED32 -

4 LU 2 4 LU 2

Figure 72: Map signals (4)
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2 An example of mapped signals shows

the figure below:

’- netDevice - Gateway netTAP[NT 151-RE-RE/PNS/PNS]< > (#1)
= 10 Device: NT 151-RE-RE/PNS/PNS Device ID: - =
:fJ Vendor: Hilscher GmbH Vendor ID: 0x011E BT
MNavigation area B Signal Mapping
‘23 Settings Available Signals
9 Driver . -
et Driver = ort X2 (PROFIMET 10) <Addr ntl51repns=; = ort X3 (PROFINET 10) <Addr ntl51repns>;
Device Assignment 16 Bytes Input <5lot 1> 16 Bytes Input <Slot1>
23 Configuration 32 Bytes Output <5Slot 2 32 Bytes Output <5lot 2>
Settings Status Status
iy Signal Mapping Port X2 | Signals  # | Data type + | Port X3 | Signals 4 | Data type o
Memeory Card Management Receive ~Outputs.BYTE_0005 BYTE
Licensing Receive ~Outputs.BYTE_0006 BYTE
Send ~Inputs.BYTE_0001 BYTE Receive ~Outputs.BYTE_0007 BYTE
Send ~Inputs.BYTE_0003 BYTE Receive ~Outputs.BYTE_0008 BYTE
Send ~Inputs.BYTE_0004 BYTE Receive ~Outputs.BYTE_0010 BYTE
Send ~Innut= RYTFE 0005 BYTF 7 | Receive ~Chtnut=. RYTE 0011 RYTF S
“ 1 r “ 1 3
Mapped Signals
=1 ort X2 (PROFINET 10) <Addr nﬂ.Slrepnvé = ort X3 (PROFIMET I0) <Addr nﬂSlrepns>§
16 Bytes Input <5lot 1= 16 Bytes Input <Slot 1>
32 Bytes Output <5lot 2 32 Bytes Output <5lot 2=
Status Status
Port ®2 {PROFINET IO} Port XE{PFKOFINET 10)
ytes O : ) - Fh i
32 Bytes Output <Slot 2»/32 By‘tes Output ubs\oi 1=/~Cutputs BY s 16 Bytes Input <Slot 1>/16 Bytes Input <Subslot 1=/~ \nputs BYTE
32 Bytes Output <Slot 2>/32 Bytes Output <Subslot 1=/~Outputs BY s 16 Bytes Input <Slot 1=/16 Bytes Input <Subslat 1>/~Inputs BYTE
16 Bytes Input <Slat 1>/16 Bytes Input <Subslot 13/ ~Inputs BYTE_{ <= 32 Bytes Output <Slot 2»/32 Bytes Output <Subslot 1>/~ Outputs.|
Manual Mapping: Remove link ‘ Auto Mapping: |Off -
0K | Cancel | Apply | Help |
<07

Figure 73: Gateway Signals mapped
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3.5.7 Establish Connection to Gateway Device and Select Driver

1. Connect the netTAP device to the configuration PC via USB.

> Use a USB cable to connect the netTAP device to the configuration PC.

2. Open the Gateway configuration window.

> In the context menu of the gateway device symbol, choose
Configuration > Gateway.

 The Gateway configuration window opens.

3. Select the driver.
In the Navigation area, open Settings > Driver window, then select
netX Driver entry in the main window:

WP netDevice - Gateway netTAP[NT 151-RE-RE/PNS/PNS] <> (21) [E=R|ESR =
= 10 Device: NT 151-RE-RE/PNS/PNS Device ID: - =
_J Vendor: Hilscher GmbH Vendor ID: 0x011E BT
Navigation area =] Driver

{3 Settings
= | Driver Version | D
et Driver nety Driver 1.103.2.7743 {B54C8CCTF333-4135-8405-6E 12FCBBEEG 2}

Device Assignment
¥=3 Cenfiguration

Settings

Signal Mapping

Memory Card Management

Licensing

OK | Cancel Help
<=0

Figure 74: Select USB Driver (1)
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4. Configure the netX Driver.

» Inthe Navigation area, open Settings > Driver > netX Driver window.
> The following figure shows the USB settings of the netX Driver:

r netDevice - Gateway netTAP[NT 151-RE-RE/PNS/PNS] <> (#1)

[E=5) EoR (=)
‘r: | 10 Device: NT 151-RE-RE/PNS/PNS Device ID: - =
:—_J Vendar: Hilscher GmbH Vendor ID: 0x011E DT
Navigation area | netx Driver
(| Settings
{33 Driver @ USB/RS232 Connection | TCP Connection |
=
Device Assignment @ ¥ Enable USB/R5232 Connector (Restart of ODM required)
{23 Configuration
Settings Select Port: COM1 -
Signal Mapping Port Configuration
Memn.ry Card Management [ Disable Port
Licensing
Baud Rate: 115.2 kBitfs - Byte Size: 8 Byte -
Stop Bits: 1 Stopbit - Parity: No Parity -
Send Timeout: | 1000 i‘ ms Keep Alive Timeout: | 2000 i‘ ms
Reset Timeout: | 10000 i‘ ms
Restore Save Save Al
oK | Cancel ‘ | Help |
<=0

Figure 75: Select USB Driver (2)

5. Configure USB connection.

> @Open the USB/RS232 Connection tab.

> @ Check Enable USB/RS232 Connector.

> @ Click Save button.

Note: The standard settings of the netX Driver USB/RS232 can be used
for netTAP devices without changes.
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3.5.8

Device Assignment

>

In the Navigation area, select Settings > Device Assignment.

> The netTAP DTM automatically starts searching for connected devices.

>

Wait for a short while until the device is found and displayed in the list.
If the device is not found, select suitable only entry from the device
selection drop-down list, then click Scan button.

B netDevice - Gateway netTAP[NT 151-RE-RE/PNS/PNS] <> (21) [fol-= ==
g 10 Device: NT 151-RE-RE/PNS/PNS - =
'-_J Vendor: Hilscher GmbH 0x011E DT
Navigation area | Device Assignment

3 Settings Scan progress: 44 Devices (Current device: -)
) Driver
netX Driver
L= 4 Device Assignment Device selection: suitable only -
=3 CD”:‘QL_”Etmn | Device | Hardware Ports 0/1/... | Slotnu... | Serial nu... | Driver | Channel Protocol | Access path |
ettings [] NT1SLRERE EthernetfEthemetfE... nja 20009 netX Driver Undefined Gateway ... \COM15 ...
Signal Mapping
Memery Card Management
Licensing
Access path:
Help
<= |0

Figure 76: Found Device
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» Select the NT 151-RE-RE device by checking the field

in front of the

device.
B netDevice - Gateway netTAP[NT 151-RE-RE/PNS/PNS] <> (1) =n EoN ==
= 10 Device: NT 151-RE-RE/PNS/PNS Device ID: - i
Vendor: Hilscher GmbH Vendor ID: 0x011E DT
Navigation area §| - Device Assignment
= Settlngs Scan progress: 44 Devices (Current device: -)
3 Driver
net¥ Driver | Sean
iy Device Assignment Device selection: Isuiiable only  w
= CDI‘ISfIgL.IrEtIDH Device Hardware Ports 0/1/... | Slotnu... | Serial nu... | Driver Channel Protocol Access path
e Eal | N7 151-RERE | Ethernet/EthernetE... Undefined Gateway
ignal Mapping
Memeory Card Management
Licensing
Access path: | {B54CBCC7+333-4135-8405-6E 12FCBBEEG 2 [COM 15_afX0_Ch2
Ok I Cancel Apply Help |
@Al [ | 4

Figure 77: Found Device

» Click OK.
2> The configuration window closes.
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3.5.9 Loading or Updating Firmware (Firmware Download)

Note: The firmware download procedure described in this section is only
necessary on first commissioning of a device delivered without pre-loaded
firmware, or if updating of an old firmware file already existing in the
device has become necessary.

In a firmware download, the firmware file is remanently stored in the flash
memory of the netTAP device.

For downloading firmware, proceed as follows:
1. Open the Gateway configuration window.

» In the context menu of the gateway device symbol, choose
Configuration > Gateway.

2 The Gateway configuration window opens.

2. Open Settings window.
» Inthe Navigation area, select Configuration > Settings.

 The Settings window opens:

B netDevice - Gateway netTAP[NT 151-RE-RE/PNS/PNS] <> (#1) =8 EoN =)
=| 10 Device: NT 151-RE-RE/PNS/PNS Device ID: - =
_J Vendor: Hilscher GmbH Vendor ID: 0x011E DT
Navigation area B Settings
{3 Settings General
3 Driver L
netX Driver Description: |netTAP
Device Assignment Protocol Combinations
¥=3 Configuration
= Settings Primary network (Port X2): |PROFII-IEI' 10 Device J Secondary network (Port X3): |PROFIHE[ 10 Device J
Signal Mapping .
Required gateway: 51-RE-RE/PNS/PNS
Memory Card Management quired gateway [NT 151-RE-REPNS PNS |
Licensing Required license: MNone
Available Firmuare: Browse
@ Download
i Software dass: PROFINET-IO 10 Device | PROFINET-I0 10 Device |
Software version: 1.0.0.0
Basic Settings
Mapping Cyde time: 1 ms Mapping mode: Default J

Network Address Switch

| =]

0K | Cancel Apply Help

2|0 |7

Figure 78: Firmware Download
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3. Select Firmware.

In the Available Firmware field, select the firmware file that you want to

download @ In this example, it is the T120DODO.NXF file (firmware for
protocol conversion PROFINET 10 Device to PROFINET 10 Device).

Note: The firmware files displayed in the Available Firmware field
depend on the the chosen protocol combination. If you haven't selected
any protocols in the Primary network (Port X2) and Secondary network
(Port X3) drop-down lists yet, all loadable firmware files for the NT 151-
RE-RE that are available on your PC will be displayed here.

NOTICE

Device Damage Due to Power Disconnect While Downloading
Firmware

If the power supply to the PC or to the device is interrupted while the
firmware is being downloaded, the download will be aborted and the
firmware database may be corrupted, leading to loss of device parameters
and possibly to device damage.

» Do not interrupt the power supply to the PC or to the device during
firmware download!

» Do not perform a device reset during firmware download!

4. Load firmware into the device.

Click on Download @
The firmware is loaded into the netTAP device

4

Download of firmware.

Wait until the firmware has been completely transferred to the device.
Close the Gateway configuration window after the download.

Click OK.

 The Gateway configuration window closes.

v 9 v &
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3.5.10 Load Configuration

After having configured the gateway in SYCON.net and having established
a connection to the device (as described in the previous sections), you can
download the configuration to the device via USB.

Device Damage Due to Power Disconnect While Downloading
Configuration

If the power supply to the PC or to the device is interrupted while the
configuration is being downloaded, the download will be aborted and the
configuration database may be corrupted, leading to loss of device
parameters and possibly to device damage.

» Do not interrupt the power supply to the PC or to the device during
configuration download!

» Do not perform a device reset during configuration download!

A\

In the context menu of the gateway device symbol, select Download
entry.

Answer the security question with Yes.
SYCON.net builds up an online connection to the device.
The configuration is transferred info the gateway device.

g &d Iy

The device performs a reset and then starts with the new configuration.
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3.5.11 Save Project

Save the SYCON.net project. In case of a device replacement, the saved
project can be opened and re-edited (if necessary) with SYCON.net and
then loaded into the spare device.

» To save a project, select menu File > Save respectively File > Save As

. . ]
or click on icon .

When you exit the program and the current configuration differs from the
last saved configuration, then the following question appears:

1 "_-. Save changes to the project?
[ ]

Yes Mo Cancel

Figure 79: Security Question — Save Project

When you answer with Yes, the project is saved. When you answer with
No, the project is not saved and the changes are lost. When you answer
with Cancel, then the project is not saved.

3.5.12 Device Description File to configure the Master

The network master device, to which the NT 151-RE-RE device is to be
connected, requires for its configuration a device description file containing
the slave parameters of the NT 151-RE-RE for the corresponding protocol.
These files are stored on the Gateway Solutions DVD in the folder:
Electronic Data Sheets (e.g. EDS,GSD,GSDML)\[protocol].

Thus the network master (in this example the PROFINET 10 Controller),
requires a GSDML file containing the parameters of the NT 151-RE-RE
acting as PROFINET 10 Device.

» To configure the PROFINET IO Controller use the following GSDML file:
GSDML-V2_.31-HILSCHER-NT 151-RE-RE PNS-20151021-1.xml
This file is stored on the Gateway Solutions DVD in the folder:
Electronic Data Sheets (e.g. EDS,GSD,GSDML)\PROFINET.

» Load (import) the GSDML file into the configuration software of your
PROFINET IO Controller.

B Important: If you are using the netTAP as PROFINET 10 Device and if
| ~you did map its signals by using the Auto Mapping function, you cannot
use the standard GSDML file GSDML-V2.31-HILSCHER-NT 151-RE-RE
PNS-20151021.xml delivered on the Gateway Solutions DVD for
configuring the PROFINET IO Controller.
In this case, you must generate and export a new GSDML after having
finished the configuration in SYCON.net.
To do so, select the gateway device symbol, then choose Additional
Functions > PROFINET 10 Device > Export GSDML from the context
menu and save the file to your PC. Afterwards you can import this file in
your PROFINET engineering tool to configure your 10 Controller.
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3.6 Configuration of the NT 151-CCIES-RE

This section provides step-by-step instructions for configuring the netTAP
NT 151-CCIES-RE device. This device is currently only available with the
protocol conversion CC-Link IE Field Slave to PROFINET IO Device.

Information about how to use an SD memory card to copy configuration
data from one netTAP into another netTAP device (e.g. in order to “clone”
a spare device) can be found in the user manual netTAP NT 151-CCIES-
RE — CC-Link IE Field Slave to PROFINET 10-Device gateway,
DOC180403UMXXEN

-?'jj:

3.6.1 Start SYCON.net and User Login

1. Start SYCON.net.

» Choose Start > Programs > SYCON.net System Configurator >
SYCON.net

R SYCON.net is started.

2. User Login

» In the SYCON.net User Login window, click OK to login or enter your
password and then click OK to login.

2 SYCON.net frame application appears.
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3.6.2 Insert the Gateway Device into the Configuration Window
» In the device catalog, open Vendor tab, then open Hilscher GmbH >
Gateway / Stand-Alone Slave folder. Select the NT 151-CCIES-

RE/PNS gateway, then “drag and drop” the device onto the (gray) main
line.

88 MRP 51-RE/PLS B
[38 NRP 51-RE/VRS
88 NRP 52-RE/EIS
88 NRP 52-RE/OMB
88 NRP 52-RE/PLS
88 NRP 52-RE/VRS
[ NT 100-RE-XX/PROXY
e [ NT 100-30-Xx

~ 7
- [} NT151-RE-RE
- [} NT 151-RE-RE/ECS/ECM
[} NT151-RE-RE/ECS/ECS
- [} NT 151-RE-RE/ECS/EIM
- [} NT151-RE-RE/ECS/EIS
- F] MT 151-RE-RE/ECS/OMB
- [} NT 151-RE-RE/ECS/PLS
- ] NT151-RE-RE/ECS/PNM
0 L. Fl MT151-RF-RE/FCS/PNS _ i
o L [3
' Fieldbus ), Vendor ¢ DTM Class % Found /

Figure 80: Insert Gateway Device into the Project

m

m

» The gateway device symbol “hangs” from the gray main line in the
project:

netTAP[NT 151-CCIES-RE/PNS]<=

|

Figure 81: Gateway Device in the Project
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3.6.3 Define Variables for Cyclic Data

1. Open the Gateway configuration window.

» Double-click the gateway device symbol on the main line
or choose Configuration > Gateway from the context menu.

Cenfiguration » Gateway

Meazured Value... PROFINET IO Device

Simulation... CC-Link/IE Slave

Diagnosis *

Figure 82: Open configuration via context menu.

 The Gateway configuration window opens:

B netDevice - Gateway netTAP[NT 151-CCIES-RE/PNS] <> E=nEcE=<=
F' 10 Device; NT 151-CCIES-RE/PNS Device ID; - L
E Vendor: Hilscher GmbH Vendor ID: = BT
MNavigation area B Device Assignment
3 Settings Scan progress: 1/1 Devices (Current device: -}
9 Driver

neti Driver L J £
-, Device selection:
3 Cenfiguration
Settings
Coupler Variables
User Defined Buffers
Acyclic Buffers
Memeory Card Management
Licensing

Device Hardware Ports 0/1/2/3 Slot number  Serial number Driver Channel Protocol Access path

Access path:

2= 0

Figure 83: Device Assignment without Device
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2. Open Coupler Variables window.
» Inthe Navigation area, select Configuration > Coupler Variables.

2 The configuration window Coupler Variables opens:

B netDevice - Gateway netTAP[NT 151-CCIES-RE/PNS] <> ===
=| IO Device: NT 151-CCIES-RE/PNS Device ID: - =
{J Vendor: Hilscher GmbH Wendor ID: = DT
Navigation area B Coupler Yariables
{23 Settings | Name Data Type ‘ Direction | Description
=3 Driver
netX Driver

Device Assignment
£3 Configuration
Settings
- B
User Defined Buffers
Acyclic Buffers
Memory Card Management
Licensing

Consistency key: 0x1100 Add Remove
Cancel App Help

= 0

Figure 84: Gateway Coupler Variables Configuration Window

3. Add variables for input and output data.

» Use the Add button to add as many variables as needed for exchanging
cyclic data between the CC-Link IE and the PROFINET network.
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4. Configure variables.

Click in the Direction field of a variable and use the drop-down list to
set the direction of the data flow, e.g. from PROFINET (output data) to
CC-LINK IE (input data).

» Click in the Data Type field of a variable and use the drop-down list to
select the required data format.

» If necessary, you can use the Name field to enter an appropriate name
for the variable (max. 255 characters).

You can also enter a descriptive note in the Description field (the
description will be visible only in the Coupler Variables dialog window).

> If you want to exchange four data words (each UINT16) from
PROFINET to CC-Link IE, and eight data words (also each UINT16)
from CC-Link IE to PROFINET, the variable list would look as follows:

WP netDevice - Gateway netTAP[NT 151-CCIES-RE/PNS] <> [E=x iR ==
= | 10 Device: NT 151-CCIES-RE/PNS Device ID: - =
r_J Vendor: Hilscher GmbH Wendor ID: = DT
Navigation area B Coupler Variables

{3 Settings Name | Data Type | Direction | Description
3 Driver _|variable 1 UINT16 PROFINET to CC-Link/IE
netX Driver [variable 2 UINT16 PROFINET to CC-Link/IE
Device Assignment |vanable 3 UINT16 PROFINET to CC-Link/IE
£ Configuration _|variable 4 UINT1§ PROFINET to CC-Link/IE
Settings |variable 5 UINT16 CC-Link/IEto PROFINET
= Coupler Varicbles |Variable 6 UINT18 C-Link/IE to PROFINET
u pD cfined Buf _|Variable 7 UINT1§ CC-Link/IE to PROFINET
ser Jetined Butrers |variable 8 UINT16 CC-Link/IE to PROFINET
Acyclic Buffers T|vanable 3 UINT1E CC-Link/IE to PROFINET
Memory Card Management — |yariable 10 UINT16 CC-Link/IEto PROFINET
Licensing _|variable 11 UINT1§ CC-Link/IE to PROFINET
HVariable 12 DINT1E [=]CCLink/IE to PROFINET
INTE
INT16
INT32
UINTE
UINT32
FLOAT32
BOOL
Bit
Consistency key: 0x55C1 Remove

OK ]| Cancel H Apply ‘

<=0 7/

Figure 85: Define Coupler Variables

» After having finished the configuration of the variables, click Apply
button.

Note: The Consistency Key (in the footer of the configuration window) is
'+ newly generated each time the configuration is created or updated.

The key is transferred by configuration download to the gateway, and via
device description file export to the PROFINET 1O Controller and the CC-
Link IE Field Master devices.

When the gateway establishes the network connections, it checks the
keys for concordance (thus checking for the same configuration status).
Differences in the consistency key will be reported by the gateway in its
cyclical Error Codes (see chapter Diagnosis and Status Messages of NT
151-CCIES-RE on page 323), or in the Overview.
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3.6.4  Configuring Acyclic Communication

The NT 151-CCIES-RE supports acyclical data exchange between the two
networks. In the Acyclic Buffers configuration window, you can configure
how to treat the acyclical data buffers in case of an error.

In the User Defined Buffers window, you can define additional acyclic
message buffers that allow independent read and write access from both
networks sides.

For further information about acyclical communication, see chapter Acyclic
Communication of NT 151-CCIES-RE on page 315, in the Overview.

1. Define clearance of acyclic buffers in Acyclic Buffers window.
» Inthe Navigation area, select Configuration > Acyclic Buffers.

 The Acyclic Buffers configuration window opens:

B netDevice - Gateway netTAP[MT 151-CCIES-RE/PNS] <> =N = ==
F- | 10 Device: MT 151-CCIES-RE/PNS Device ID: - L
‘_J Vendor: Hilscher GmbH Vendor ID: = DT
Navigation area B Acyclic Buffers
{23 Settings Action in case of an emor

Dri
{2 Driver Clear buffers written by PROFINET side in case of a connection timeout in PROFIMET side
netX Driver

Device Assignment
23 Configuration

Settings

Coupler Variables

User Defined Buffers

= 4 Acyclic Buffers

Memory Card Management

Clear buffers written by CC-Link/IE side in case of a connection timeout in CC-Link/IE side

Licensing

[ QK l | Cancel | | Apply Help

<= 0.7

Figure 86: Configure Clearance of Acyclic Buffers in Case of Error

> If you want the gateway to clear Buffer 2 (acyclic messages from
PROFINET to CC-Link IE, see section Message Interface Buffer on
page 316) in case of PROFINET connection loss, select Clear buffers
written by PROFINET side in case of connection timeout in
PROFINET side

» If you want the gateway to clear Buffer 1 (acyclic messages from CC-
Link IE to PROFINET) in case of CC-Link IE Field connection loss,
select Clear buffers written by CC-Link/IE side in case of
connection timeout in CC-Link/IE side

» If you do not want to create User Defined Buffers for acyclic messages
(as described in the following step), click OK button to close the
gateway configuration window.
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2. Create User Defined Buffers (optional).

» Inthe Navigation area, select Configuration > User Defined Buffers.

> The User Defined Buffers configuration window opens:

B netDevice - Gateway netTAP[NT 151-CCIES-RE/PNS] <> == ECH ==
=| 10 Device: NT 151-CCIES-REPNS Device ID: - =
_J Vendor: Hilscher GmbH Vendor ID: = DT
Navigation area B User Defined Buffers

= Settmss Uger defined buffers
23 Driver el —
netX Driver Display mode: |Hexadecimal -
Device Assignment Name \ Length in bytes [ PROFINET Index__ | CCLink IE Address
{3 Configuration _|User Defined Buffer 1 el 00 B001 (00001000
Settings _|User Defined Buffer 2 Ded 00 xBODZ (00001400
Coupler Variables [} User Defined Buffer 3| 400 xB003 00001800
wp User Defined Buffers
Acyclic Buffers
Memeory Card Management
Licensing
oK l | Cancel | | Apply | Help

@07
Figure 87: Create User Defined Buffers

» Use the Add button to add as many “user buffers” as needed for
exchanging acyclic data between the CC-Link IE and the PROFINET

network (max. 256).

» If necessary, you can use the Name field to define an appropriate name

for a buffer.

For more information on user defined buffers, see section User Defined

Buffer on page 322 .

» After having finished the configuration, click Apply button, then OK.

> The gateway configuration window closes.
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3.6.5 Configuration of the CC-Link IE Field Slave

1. Open the configuration window.

» In the context menu of the gateway device symbol, choose
Configuration > CC-Link/IE Slave.

Configuration » Gateway

Measured Yalue.., PROFIMET 10 Device
Simulatien.. CC-LinkIE Slave
Diagnosis »

Figure 88: Open configuration via context menu

> The CC-Link IE Slave configuration window opens:

B netDevice - CC-Link/IE Slave netTAP[NT 151-CCIES-RE/PNS] <> = @ ==
= | 10 Device: NT 151-CCIES-RE/PNS Device ID: Ox0001 =
J Vendor: Hilscher GmbH Vendor ID: 0x0352 DT
Navigation Area = Network
3 Configuration
nd Network ) . General
Signal Cenfiguration
{23 Device Description Station number: 1 Network number: 1
CSPP Viewer

FrontBackMixture

Process Data

Intelligent Device Station

%= Disconnected (J] Data Set

Figure 89: Configuration dialog CC-Link IE Slave

2. Define station number.
» Inthe Navigation Area, select Configuration > Network.

» In the Station number field, enter the number that shall be used by the

gateway to communicate with the master of the CC-Link IE Field
network.

» Enter the corresponding number in the Network number field.

Configuration of Gateway and Proxy Devices | netTAP, netBRICK and netLINK
DOCO0812010I12EN | Revision 12 | English | 2020-05 | Released | Public © Hilscher, 2009-2020



Configuration Sequence for Gateway and Proxy 109/355

3. Check signal configuration (optional).

> You can check on the variables/signals, which you have defined in the
Define Variables section, by choosing Configuration > Signal
Configuration from the Navigation Area:

B netDevice - CC-Link/IE Slave netTAP[NT 151-CCIES-RE/PNS] <> =
= 10 Device: NT 151-CCIES-RE/PNS Device ID: 0x0001 =
_J Vendor: Hilscher GmbH Vendor ID: 0x0352 DT
Navigation Area 3 Signal Configuration

3 Configuration
Network Slot  Mame Medule Type
M c. nal Configuration Rilr | Rwir Input Medule | Rir Input Module
£ Device Description MName Type (Offzet
CSPP Viewer PN_ACYC_LEN unsigned 16 ]
Error_Code unsigned 16 2
Wariable 1 unsigned16 4
Variable 2 unsigned 16 ]
Variable 3 unsigned16 g
“ariable 4 unsigned16 10
RX | RX Input Module RX Input Madule
Rwfw | Rindw Qutput Maodule Riwhw Qutput Madule
[ oK l ’ Cancel Apply
<= Disconnected [J Data Set

Figure 90: Signal Configuration dialog CC-Link IE Slave

» After having finished the configuration of the CC-Link IE Slave, click OK
button.

> The gateway configuration window closes.
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Configuration of the PROFINET Device

1. Open the configuration window.

» In the context menu of the gateway device symbol, choose
Configuration > PROFINET IO Device.
Configuration » Gateway
Measured Value... PROFIMET 10 Device
Simulation.. CC-Link/IE Slave
Diagnosis »
Figure 91: Open configuration via context menu
» The PROFINET Device configuration window opens:
B netDevice - PROFINET 10 Device netTAP[NT 151-CCIES-RE/PMS] <> == =]
10 Device: NT 151-CCIES-RE/PMS Device ID: Ox0121 =
Vendor: Hilscher Gesellschaft fiir Systemautomation mbH Vendor ID: 0x011E DT
Mavigation Area = Modules
Confi i
a9 °"G'g”rat|'°" [ Sict ] SubSiot [ 1] Noddle
L EE 0 T NT 151-RE-RE/PNS V1.0- Vix [1722.122]
h' 1 E NT151-CCIES-RE/PNS
Signal Configuration
Address Table
=3 Description
Device Info
Madule Info
GSDML Viewer
Use of slots: 2/2
State of data length: Input 20/1024 Octets, Output 8/1024 Octets, In-Output 25/2048 Octets
Submodule details
Datazet: 10 data Display mode: Decimal
[ Direction | Consistence Data type Text ID | Length |
[ OK ] [ Cancel Apply
Al Disconnected G Diata Set

Figure 92: Configuration dialog PROFINET Device
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2. Define station name.

» Inthe Navigation Area, select Configuration > General.

» The General configuration window opens:

' netDevice - PROFINET IO Device netTAP[NT 151-CCIES-RE/PM5]< =

10 Device: NT 151-CCIES-RE/PNS

Gateway address:

Vendor: Hilscher Gesellschaft fir Systemautomation mbH
Navigation Area =
Configuration
a J Mame of station:
(==
Modules Description: NT_151RE-RE_PNS_V1.0 - Vix
Signal Configuration
Address Table IP settings
{3 Description
Device Info IP address:
Module Info
GSDML Viewer MNetwork mask:

[E=3 Eol
Device ID: 0x0121 =
Vendor ID: 0x011E bT

General

Mote: These values are zet by
the controller of the network!

%= Disconnected [J Data Set

Figure 93: “General” Configuration dialog PROFINET Device

» In the Name of station field, enter the name that shall be used by the
gateway to communicate with the IO Controller of the PROFINET

network.
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3. Check signal configuration (optional).

> You can check on the variables/signals, which you have defined in the
by choosing Configuration > Signal
Configuration from the Navigation Area:

Define Variables section,

B netDevice - PROFINET IO Device netTAP[MT 151-CCIES-RE/PNS] <> = =R
10 Device: NT 151-CCIES-RE/PNS Device ID: 0x0121 =
Vendor: Hilscher Gesellschaft fiir Systemautomation mbH Vendor ID: 0x011E DT
Navigation Area | Signal Configuration
{3 Configuration
Gegneral Slot MWame Module Type
Modules Slot 1/ Subslot 1|NT151-CCIES-RE/PNS ! Coupler Output Submodule Coupler Qutput Submedule
. . . Slot 1/ Subslot 2 NT151-CCIES-RE/PNS / Coupler Input Submodule Coupler Input Submodule
=y Signal Configuration
Address Table MName Type Offset
£ Description Variable 5 unsigned16 0
Device Info :aria::e 9 unsignej 12 i
ariable 7 unsigne
Module Ir.1f0 Variable § unsigned16 6
GSDML Viewer Variable 9 unsigned16 g
Variable 10 unsigned 16 10
Variable 11 unsigned16 12
ariable 12 ungigned 16 14

Slot 1/ Subslot 5 | NT151-CCIES-RE/PNS / Coupler Management Submodule

| Coupler Management Submodule

2l Disconnected [] Data Set

Figure 94: Signal Configuration dialog PROFINET IO Device

» After having finished the configuration of the PROFINET Device, click

OK button.

> The gateway configuration window closes.
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3.6.7 Establish Connection to Gateway Device and Select Driver

1. Connect USB cable.

» Use a USB cable to connect the NT 151-CCIES-RE to the configuration
PC.

2. Open the Gateway configuration window.

» In the context menu of the gateway device symbol, choose
Configuration > Gateway.

2 The Gateway configuration window opens.

3. Select driver.

In the Navigation area, open Settings > Driver window, then select
netX Driver entry from the list in the main window:

WP netDevice - Gateway netTAP[NT 151-CCIES-RE/PNS]<> (= ETR(5|

F_ | 10 Device: NT 151-CCIES-RE/PNS Device ID: - =
_J Vendar: Hilscher GmbH Vendor ID: = BT

Navigation area B Driver
{3 Settings
= m Driver Version jul
netX Driver netX SPM USB Driver 1.0.4.7733 {9634996A-AEAG-42FA-BFBD-5758AED 20303}
Device Assignment i netX Driver 1.200.4.8037 {B54CBCC7-F333-4135-8405-6E12FCB8EEG 2}
=) Configuration
Settings
Coupler Variables
User Defined Buffers
Acyclic Buffers
Memeory Card Management
Licensing

Cancel Appl Help

= 0

Figure 95: Select netX Driver
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4. Configure netX Driver.
» Inthe Navigation area, open Settings > Driver > netX Driver window.
> The following figure shows the USB settings dialog:

B netDevice - Gateway netTAP[NT 151-CCIES-RE/PNS] <> =nE=R~==
}? 10 Device: NT 151-CCIES-RE/PNS Device ID: - i
J Vendor: Hilscher GmbH Vendor ID: = DT
Navigation area B8 netx Driver

{3 Settings @
{3 Driver - ’USBIRSZSZConnechon |'rcp annec_ﬁgnl
[ netX Driver|
Device Assignment 2 ) Enable USB/RS232 Connector (Restart of ODM required)
{23 Configuration
Settings Select Port: CoM1 hd
Coupler Variables Port Configuration
User Defined Buffers [ Disable Port

Acyclic Buffers

Memory Card Management BaudRate: | 115.2 kBit/s - Byte Size:
Licensin

Send Timeout: 1000 ms Keep Alive Timeout: 2000 ~ ms

Reset Timeout: 30000 = ms

o)

Restore ] [ Save ] [ Save Al

<= 0

Figure 96: Select USB Driver (2)

5. Configure USB connection.

> @Open the USB/RS232 Connection tab.
> @ Check Enable USB/RS232 Connector.
> @ Click Save button.

+ Note: The standard settings of the netX Driver USB/RS232 can be used
for netTAP devices without changes.
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3.6.8 Device A

>

ssignment

In the Navigation area, select Settings > Device Assignment.

> The netTAP DTM automatically starts searching for connected devices.

> Wait for a short while until the device is found and displayed in the list.
If the device is not found, select suitable only entry from the device
selection drop-down list, then click Scan button.

Coupler Variables

User Defined Buffers
Acyclic Buffers

Memeory Card Management
Licensing

WP netDevice - Gateway netTAP[NT 151-CCIES-RE/PNS] <> = |
F‘ 10 Device: NT 151-CCIES-RE/PNS Device ID: - =
Vendor: Hilscher GmbH Vendor ID: = DT
Navigation area B Device Assignment
3 Settmss Scan progress: 22 Devices (Current device: -)
23 Driver
netX Driver e
[ Device Assignment Device selection: suitable only -
23 Cenfiguration
Setti Device Hardware Ports 0/1/2/3 Slot number  Serial number Driver Channel Protocol Access path
ings
(=] NT 151-CCIES-RE Ethernet/Ethernet/Ethern... nfa 20007 netX Driver Undefined Gateway ... \COM15_cifXd_Ch2

Access path:

<

Figure 97: Found Device
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» Select the NT 151-CCIES-RE device by checking the check box in front

of the device.

B netDevice - Gateway netTAP[NT 151-CCIES-RE/PNS] <> =2 E=E ===
F' 10 Device: MT 151-CCIES-RE/PNS Device ID: =
Vendor: Hilscher GmbH Vendor ID: DT
Navigation area E‘ - Device Assignment
= SEttmgs Scan progress: 2/2 Devices (Current device: -)
=3 Driver
netX Driver ! Sean
iy Device Assignment Device selection: suitable only -
23 Cenfiguration
Device Hardware Ports 0/1f2/3 Slot number  Serial number Driver Channel Protocol Access path
Settings
Coupler Variables [Bd] | oisi-coEsRE [ Ethernet/EthernetiEthern. . 20007 Undefined Gateway ... \COM15_cifk0_Ch2
User Defined Buffers
Acyclic Buffers
Memory Card Management
Licensing
Access path: {B54C8CC7F333-4135-8405-6E 12FCIBEE62H\COM15_cifk0_Ch2
[ OK J [ Cancel ] [ Apply ] [ Help
<= 0,7

Figure 98: Found Device

» Click OK to close the gateway configuration dialog.
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3.6.9 Updating Firmware (Firmware Download)

Note: The NT 151-CCIES-RE is shipped with pre-installed firmware.
The firmware download described in this section is therefore only
necessary if you want to update an old firmware file already existing in the
device.

In a firmware download, the firmware file is remanently stored in the flash
memory of the netTAP device.

For downloading firmware, proceed as follows:
1. Open the Gateway configuration window.

> In the context menu of the gateway device symbol, choose
Configuration > Gateway.

> The Gateway configuration window opens.

2. Open Settings window.
» Inthe Navigation area, select Configuration > Settings.

 The Settings window opens:

B netDevice - Gateway netTAP[NT 151-CCIES-RE/PNS]<1> =n E=R===
=| 10 Device: NT 151-CCIES-REPNS Device ID: - L
J Vendor: Hilscher GmbH Vendor ID: = BT
Navigation area = Settings
=) Settings General
24 Driver L
et Driver Description: netTAP
Device Assignment Protocal Combinations
=) Configuration
=8 Primary network (Port X2): | CC-Link IE Field Slave Secondary network (Port X3): |PROFINET 10 Device

Coupler Variables
User Defined Buffers
Acyclic Buffers Required license: None

Memery Card Management -
Available Firmpare: T220%000, MXF )
Licensing ”
o =)

Required gateway: NT 151-CCIES-RE(PNS

Software dass: Slave | PROFINET-IO I0 Device |\ Multi protocal (combinable) Gateway
Software version: 13.00
Basic Settings
Mapping Cyde time: 1 ms Mapping mode: Default

Metwork Address Switch

0K ][ Cancel Apply Help

o= 0

Figure 99: Firmware Download
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3. Select Firmware.

» Inthe Available Firmware field, select the firmware file that you want to

download @ For the NT 151-CCIES-RE, this is the T220X0DO0.NXF file
(firmware for protocol conversion CC-Link IE Field Slave to PROFINET
IO Device).

Device Damage Due to Power Disconnect While Downloading
Firmware

If the power supply to the PC or to the device is interrupted while the
firmware is being downloaded, the download will be aborted and the
firmware database may be corrupted, leading to loss of device parameters
and possibly to device damage.

» Do not interrupt the power supply to the PC or to the device during
firmware download!

» Do not perform a device reset during firmware download!

4. Load firmware into the device.

Click Download @ button.

The firmware is loaded into the netTAP device

d

Download of firmware.

Wait until the firmware has been completely transferred into the device.
Close the Gateway configuration window after the download.

Click OK.

> The Gateway configuration window closes.

v 9 v &
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3.6.10 Load Configuration

After having configured the gateway in SYCON.net and having established
a connection to the device (as described in the previous sections), you can
download the configuration to the device via USB.

Device Damage Due to Power Disconnect While Downloading
Configuration

If the power supply to the PC or to the device is interrupted while the
configuration is being downloaded, the download will be aborted and the
configuration database may be corrupted, leading to loss of device
parameters and possibly to device damage.

» Do not interrupt the power supply to the PC or to the device during
configuration download!

» Do not perform a device reset during configuration download!

» In the context menu of the gateway device symbol, select Download
entry.

netTAP[NT 151-CCIES-RE/PNS]<>

il

Connect

Disconnect

Download

Upload

Figure 100: Start download via context menu

» Answer the security question with Yes.
2 SYCON.net builds up an online connection to the device.
> The configuration is transferred info the gateway device.

> The device performs a reset and then starts with the new configuration.
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3.6.11 Save Project

Save the SYCON.net project. In case of a device replacement, the saved
project can be opened and re-edited (if necessary) with SYCON.net and
then loaded into the spare device.

» To save a project, select menu File > Save respectively File > Save As

. . ]
or click on icon .

When you exit the program and the current configuration differs from the
last saved configuration, then the following question appears:

1 "_-. Save changes to the project?
[ ]

Yes Mo Cancel

Figure 101: Security Question — Save Project

When you answer with Yes, the project is saved. When you answer with
No, the project is not saved and the changes are lost. When you answer
with Cancel, then the project is not saved.
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3.6.12 Export Device Description Files

The netTAP NT 151-CCIES-RE acts as slave in the CC-Link IE Field
network and as 10 Device in the PROFINET network, therefore you require
device description files (containing adequate slave parameters) for
configuring your CC-Link IE Field Master and your PROFINET 10O
Controller.

These device description files will be generated automatically after having
configured the netTAP in SYCON.net, and can then be exported as XML
files in order to use them for configuring the CC-Link master respectively
the 10 Controller.

1.

>

Export device description file (GSDML) to configure the PROFINET 10
Controller.

In the context menu of the gateway device symbol, choose Additional
Functions > PROFINET IO Device > Export GSDML.

Additional Functions » Offline Compare...
Delete Online Compare...

Setpoint Value...
Symbolic Name...

Gateway »

PROFIMNET IO Device 3 Export GSDML
CC-Link/IE Slave 3 License
Export »

Print 2

Figure 102: Export GSDML file via context menu

A Save as dialog window opens.
Save the GSDML file on your PC.

Use the GSDML file in your PROFINET engineering tool. Use the import
function of your tool for this.

Export device description file (CSP+) to configure the CC-Link IE Field
Master.

In the context menu of the gateway device symbol, choose Additional
Functions > CC-Link/IE Slave > Export CSP+.

Additicnal Functions » Offline Compare...
Delete Online Compare...
Setpoint Value...
Symbolic Name...
Gateway 4

PROFIMET IO Device

-

CC-Link/IE Slave L Export C5P+

1 3
e Service
Print 3

Figure 103: Export CSP+ file via context menu

A Save as dialog window opens.
Save the CSP+ file on your PC.

Use the CSP+ file in the configuration software of your CC-Link IE Field
Master. Use the import function of your configuration software for this.
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3.7 Configuration of a NL 51N-DPL as Proxy

The netLINK Proxy NL 51N-DPL device can be used for the protocol
conversion from PROFINET 10 Device to PROFIBUS DP Master with proxy
functionality. The device can communicate to one PROFIBUS DP Slave
device.

The following sections describe how to configure the device.

3.7.1 Requirement for the Configuration

The device is configured via the Ethernet port. Therefore it is necessary
that the device gets an IP address assigned before.

Therefore do the followings steps:

1.

Establish an Ethernet connection between the Ethernet network port of
your PC and the Ethernet port of the NL 51N-DPL.

Start the ,Ethernet-Device Setup“ software. Therefore select Start >
Programs > SYCON.net System Configurator > Ethernet Device
Setup.

Search for connected devices. Therefore click on Search Devices.
Devices are searched in the local network using broadcast telegrams.

Assign an IP address to the NL 51N-DPL device, which should be used
for the device configuration.

This address can be stored in a non volatile memory of the device.

_} Note: Use the IP address, which is later assigned by the PROFINET 10
Controller, that you can use SYCON.net for diagnostic later.

3.7.2 Start SYCON.net and User Login

1.

>

Start SYCON.net

Select Start > Programs > SYCON.net System Configurator >
SYCON.net

SYCON.net is started

User Login

In the window SYCON.net User Login click OK to login or enter your
password and then click OK to login

SYCON.net frame application appears
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3.7.3 Insert the Proxy Device into the Configuration Window

» Go to the device catalog under vendor Hilscher GmbH to the category
Gateway / Stand-Alone Slave. Use drag and drop with the NL 51N-
DPL proxy device to insert it at the (gray) main line.

A

=12 Hilscher GmbH
-1-[_1 zateway | Stand-lone Slave
S CIFY CCJCCS

\ Jm CIFX COJCOS (CIFY CO COS eds)

R““'\ [ MLSIN-DRL

M Fieic.lgus___}:\. vendor ADTM Class /-
Or go to the device catalog under fieldbus PROFINET 10 to the

category Gateway / Stand-Alone Slave. Use drag and drop with the
NL 51N-DPL proxy device to insert it at the (gray) main line.

-1-[L1) PROFINET 10
-9 zateway | Stand-Alone Slave
Hm CIFY RE[PNS

\ B2 COMY REPNS

KQ ML S1H-DPL

+-[_1 Master

+-[_1 Slave
n\ Fieldbus /{Vendor %, DM Class /

Figure 104: Insert Proxy Device into the Project

2 The proxy device appears in the project
[ |

nEtLIMK[ML S1M-DPL )<= (#1)

7

T

Figure 105: Proxy Device in the Project
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3.7.4  Configuration of the secondary Network

If the slave device is not listed in the device catalog, then it has to be
imported into the device catalog first.

3.74.1 Expand PROFIBUS DP Slave Device Catalog

If you want to use a PROFIBUS DP slave device that is not listed in the
device catalog, then you have to import the GSD file into the SYCON.net
device catalog.

> Proceed as follows:

1. Missing PROFIBUS DP Slave devices can be added to the device
catalog using the menu Network > Import Device Descriptions.

Select the new GSD file.

3. Answer the question “Do you want to reload the device catalog?* with
Yes to reload the catalog.

~ More information about the device catalog are in the document
) . SYCONnet_netDevice_en.pdf* in the directory ,Documentation“ on the
product DVD.

3.7.4.2 Insert PROFIBUS DP Slave Device to the PROFIBUS Network

» Go to the device catalog. Use drag and drop with one PROFIBUS DP
Slave device to insert it at the PROFIBUS bus line.

> The PROFIBUS DP Slave device icon appears at the PROFIBUS
network line (Secondary network)
[ |

NEfLIMNK ML S1M-DPL <= (#1)

i

ﬂI

CEII_.-'J-.EEE-DF‘S[CEI_.&.EEE-DF‘S]::2::—

Figure 106: Proxy Device with Slave

_) Note: The NL 51N-DPL proxy device support communication only to one
PROFIBUS DP Slave device.
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3.74.3 Configure the PROFIBUS DP Slave device

» Open the configuration window with a double click on the device icon of
the PROFIBUS DP Slave

> The configuration window of the PROFIBUS DP Slave device opens
» Select in the navigation area Configuration > Modules.

» Select from Available Modules the module(s) and add it/them to the
Configured Modules to configure the Slave. The Configured Modules
has to match the configuration of the used PROFIBUS DP slave device.

~ More information about the configuration of PROFIBUS DP Slave devices
y are in the document PROFIBUS_Generic_Slave_DTM_en.pdf on the
product DVD in section Configuration.

3.74.4 Configure PROFIBUS DP Master
1. Open the PROFIBUS DP Master configuration window

» Select from the context menu of the proxy device symbol the entry
Configuration > PROFIBUS DP Master

2 The PROFIBUS DP Master configuration window opens

T netDevice - PROFIBUS-DP Master netl INK[NL 51N-DPL]<>(#1)

: IO Device: ML S1M-DPL Dievice ID: Ox0B44 =
= Yendor: Hilscher GmbH Yendor ID: 0x011E DT

Navigationaiea 5

¥=4 Configuration
S Eus Parameters Profile: PROFIEUS DP -
E:jodc;ssss?:je Bus Parameters
Station Table Baud Rate: 1500 - kBitfs  Station Address: 1 il
Slot Time: 300 Bt Target Rotation Time: A ,W LBt
Min. Station Delay Time: |—11 LBt = 7.929% ms
Mazx, Station Delay Time: ’ﬁ LBt GAP Actualization Factor: lilﬂ
Quiet Time: l—o Rt Max. Retry Limit: ,71
Setup Time: |—1 tEit  Highest Station Address (HSA): 126
Buz Monitoring
Data Control Time: ’W ms [~ Owerride slave specific Watchdog Control Time
Min. Slave Interval: IW ys ‘Watchdog Control Time: li ms
Calculated Timing I—

Tid1: 37 kBt

Tidz: 150 kit Yalues marked with this symbol should be Adjust
adjusted ko changes in the topology.

[s]4 | Cancel | | Help

Kl Disconnected  |[J Data Set

Figure 107: PROFIBUS DP Bus Parameter

2. Configure PROFIBUS DP Master

» Set the parameter. Set especially under
Configuration > Bus Parameter the bus parameter and under
Configuration > Station Table the station addresses (stations
addresses of the PROFIBUS DP Slave device).
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o netDevice - PROFIBUS-DP Master netl INK[NL 51N-DPL]<>(#1)

Address Table
Skation Table

. IO Device: ML S1M-DPL Device ID: 0:x0B4A =
5B Vendar: Hilscher GmbH “Wendor ID: 0x011E DT
Navigation trea =
¥=3 Canfiguration
Bus Parameters | Activate | Station &... | Device Mame | Wendor
Process Data L 2 S 3CB_AB3ZDPS CB_ABZ2DPS Hilscher GmbH

section Configuration.

More information about the configuration of PROFIBUS DP Master
devices are in the document PROFIBUS_Master_netX_ DTM_en.pdf in

3. Close the configuration window

» Click on the button OK

> The configuration window closes
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3.7.5 Configuration of the primary Network
The PROFINET IO network is at port X2 of the proxy device.
1. Open the PROFINET IO Device configuration window

» Select from the context menu of the proxy device symbol the entry
Configuration > PROFINET IO Device

2 The PROFINET IO Device configuration window opens and displays the
modules

= netDevice - PROFINET 0. Device netl INKINL 51N-DPL]<>(#1) ]

3 [} 10 Device; ML S1N-DPL Device ID: 0x0110 =
] Yendor: Hilscher GrbH Wendor ID: 0x011E DT
Navigation Area 5
{23 Configuration
General Slat Sub Slat | ! Module
la 1] ZE|NL 51N-DPL
Address Table n 1 ZE[NLS1N (PROFIBUS-DF)
=3 Description N 3 Z[CB_AB32-DPS
Device Info
Module Info
GSOML Viewer
Use of sloks: 3/3
State of data length: Input 2/0 Octets, Qutput 2/0 Ockets, In-Output 470 Octets
Submodule details
Dataset: Display mode:
| Diection | Consistence | D ata bype Text ID [ Length |
£ >
(814 | Cancel Help
<[ Disconnected | (J Data Set

Figure 108: PROFINET IO Device Table

Here the modules with its slot number and sub slot number are displayed,
as they will become visible at the PROFINET IO Controller. These slot
numbers and sub slot numbers will be exported into the GSDML file, which
is described later.

Slot 0 (NL 51N-DPL) and slot 1 (NL51IN (PROFIBUS DP)) are always
present. An additional slot (slot 2 in this case, which represent the
PROFIBUS DP Slave with station address 2) is automatically displayed
when a PROFIBUS DP Slave was inserted to the PROFIBUS DP network.
These Slot and sub slot numbers are used in the GSDML file. The GSDML
file can be created (exported) which is described later.
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2. Set the name of station
» Select in the navigation area General.

> The following configuration window opens

= netDevice - PROFINET 10 Device netlINK[NL 51N-DPL]<=(#1)

f_r'ﬂ 10 Device: ML S1M-DPL Device ID: 00110 =
5 Vendar: Hilscher GmbH Wendor ID: 0:x011E DT

Navigation drea [
¥ Configuration

—
Mame of station: < | niS1ndpl }

Modules
Address Table Description: | ML_S1M-DPL
a Descripkion
Device Info IF settings
Module Info
GSDML Wiewer IP address: [
Metwork rmask: | Mote: These values are set by

the controller of the netwaork!

Gateway address: |

OF | Cancel Help

Kl Disconnected  |(J) Data Set

Figure 109: PROFINET IO Name of Station

» Enter the Name of Station

_) Note: The name of station is very important and is used by the
PROFINET 10 Controller to identify the proxy device.

3. Close the configuration window
» Click on the button OK

2 The configuration window closes
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3.7.6 Establish a Connection to the netLINK NL 51N-DPL

1. Connect an Ethernet cable to the NL 51N-DPL

» Connect an Ethernet cable to the Ethernet port of the NL 51N-DPL
device and to the Ethernet port of the configuration PC. It is also
possible to connect the NL 51N-DPL and the configuration PC to an
Ethernet switch.

2. Set the IP address of the NL 51N-DPL device

> Set with the Ethernet Device setup software, which is part of the
SYCON.net installation, the IP address for the NL 51N-DPL. With this
software it is also possible to read an already assigned IP address from
the NL 51N-DPL device.

The IP address is required for the communication with the SYCON.net
software.

To communication from the SYCON.net software with the NL 51N-DPL
device, an IP address has to be assigned before to the NL 51N-DPL
device. How to assign an IP address is described in the document
.Ethernet Device Configuration Ol xx DE.pdf*.

-
g :: .

{
-

3. Open the Proxy configuration window

Select from the context menu of the NL 51IN-DPL symbol
Configuration > Proxy

> The Proxy configuration window opens

4. Select driver

Select in the navigation area Settings > Driver and then check netX
Driver.

> The following figure shows the selected driver.

= netDevice - Proxy netLINK[NL 51N DPL]<>(#1) =3
10 Device: ML S1M-DPL Device IDv = =
] Yendor: Hilscher GmbH ‘endor ID: 0x011E DT
Navigation area B
G Settings
o | Drriver Wersion | I
neki Driver a CIFX Device Driver 1031 {368BECEE-0E92-4C0E-B4AD-64FE2AETAAFA}
Device Assignment [ ] 35Gateway Driver For nets (v3.x) 0.9.2.0 {TFE7CDIAS-4CF6-4250-0E40- 109B6ACBEADL )
a Configuration nets Driver 1.101.1.1761 {BS4CECCT-F333-4135-5405-6E 1 2FCEEEER2}
Settings
[a]4 Cancel Help
< (0

Figure 110: Select Driver
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5. Set the IP search range

» Select in the navigation area Settings > Driver > netX Driver.

> The window for driver settings opens.

ﬁ netDevice - Proxy netl INKINL 51N-DPL]=>(#1)

" rH 10 Device:
] ‘Yendor:

Mavigation area
@ Settings

Device Assignment
=3 Configuration

ML S1M-DPL
Hilscher GmbH

=)

USE/RS232 Connection  TCP Connection @

Iv Enable TCP Connector {Restart of ©DM required)

Device I
Wendor I0;

0x011E

Settings
o Select IP Range: d: i Scan Timeouk: | 100 il ms

IF Range Configuration
[

IF Address r TCP Port Address Count

Send Timeout: :‘ ms Keep Alive Timeout: :I ms
Reset Timeout: :‘ ms
Restore | Save ‘ Save Al |
oK Cancel | | Help

i 0

Figure 111: Set IP Address Search Range (1)

An IP address (one) or IP addresses (several, address range) are set in
this window which SYCON.net uses to build up a connection to the proxy
device.

> Select (as shown in the figure above):
@ Select the tap TCP Connection.

@ Is the Select IP Range grayed out (as shown above), then no IP
range is defined.

Click on @ + to add a new range, which enables the field below.
Otherwise an address range configured earlier can be selected or by a

mouse click on @ + a new address range can be configured. Set the IP
(start) address (and end address) the proxy devices is searched for.
Make sure that the proxy device can be reached via Ethernet and is
reachable via the address range.

> The fields to configure an IP address range are enabled.
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Select IP Range: |1P_Rp.N(5E|:| jl " = | Scan Timeout: | 100 il ms

IP Range Configuration
| Disable IP Range

IP Address Use IP Range TCP Port Address Count

o
@192.153 60,199 - | @) ¢ |s0111 |1

Send Timeout: | 1000 :‘ ms Keep Alive Timeout: | 2000 :I ms
Reset Timeout: | 20000 :‘ ms

Figure 112: Set IP Address Search Range (2)

> You can enter one IP address of the proxy device at @ as shown
above or you can set an IP address range by a check at @ Use IP

Range and set the IP end address at @ Make sure that the proxy

device can be reached via Ethernet and is reachable via the address
range.

_} Note: Set the IP address range not to large, which results in a long scan
time.

» After the address range was set click on Save.
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3.7.7 Device Assignment
» Select Settings > Device Assighment

> Click on @ Scan.
> The search process is started. Devices found are display in a list then.

f netDevice - Proxy netLINK[NL 51N-DPL]<=>(#1)

'-r? 10 Device: NL SIN-DPL Device ID: - =
] Vendor: Hilscher GmbH Wendor ID: 0x011E DT
Mavigation area 8
j—j ,g Scan progress: 3f3 Devices (Current device: -)
i O =]
Deviceselection:  [sableonly <)
=4 Configuration
Settings | Device | b Ports 0f1/... | Slot . ... | Serial nu... | Driver Channel Protocol | Access path |
@ = ) NL 51N-DPL Ethemnet/PROFIBUS... nja 20016 netX Driver Gateway .92, 16860,
Access path: | {esacacc7-F333-4135-8405-6E12F CasEER2}|192.168.60.199:501 11|cifX0_Ch2
O | Cancel : Help
== 0

Figure 113: Select Device

> Select the device from the list @ by a check in the field of the device as
shown 