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1 Introduction 
1.1 About this Document 
1.1.1 Description of the Contents 

This Operating Instruction Manual describes how to use the SYCON.net 
configuration software installed on a Windows PC to configure the following 
LAN controlled netHOST devices as master devices in the corresponding 
Fieldbus or Real-Time Ethernet system: 
NHST-T100-DP/DPM for PROFIBUS DP (order no.: 1890.410/DPM) 
NHST-T100-CO/COM for CANopen (order no.: 1890.500/COM) 
NHST-T100-DN/DNM for DeviceNet (order no.: 1890.510/DNM) 
 

NHST-T100-EN/PNM for PROFINET IO (order no.: 1890.840/PNM) 
NHST-T100-EN/ECM for EtherCAT (order no.: 1890.110/ECM) 
NHST-T100-EN/EIM for EtherNet/IP (order no.: 1890.820/EIM) 
 

NHST-T100-EN for PROFINET IO, EtherCAT or EtherNet/IP  
(order no.: 1890.800; hardware and performance are identical to the  
NHST-T100-EN/PNM/ECM/EIM devices, but firmware has to be loaded into 
the device by the customer) 
This document provides step-by-step instructions for configuring a 
netHOST, using the NHST-T100-DP/DPM (PROFIBUS DP Master) and the 
NHST-T100-EN/PNM (PROFINET IO Controller) devices as examples. 
Here, you will also find descriptions of the graphical user interface and the 
dialog windows of the netHOST Device Type Manager (netHOST-DTM), 
which is used in SYCON.net to configure and diagnose a netHOST device. 
If you are using the NHST-T100-EN (which is shipped without pre-installed 
firmware), you will here find instructions on how to install the firmware with 
SYCON.net. 
The testing of reading and writing of Fieldbus or Real-Time Ethernet data 
via the netHOST is also described in this document. For this, the netHOST 
Device Test Application running on a Windows PC is being used. 
How to update firmware and how to use an SD Memory Card to copy 
configuration data of the netHOST is also described here. 
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1.1.2 List of Revisions 
 

Index Date Chapter Revisions 
1 2013-08-05 All Created 

2 2014-12-05 Title Title of document changed from “Configuration of 
Fieldbus Devices with Remote Access“ to „Configuration 
of LAN controlled master devices“. 

All Document completely revised, netHOST devices for 
Real-Time Ethernet added. 

3 2015-07-13 All 
6    

Document revised, netHOST device NHST-T100-EN 
added. 
Chapter NHST-T100-EN: Downloading Firmware to the 
Device with SYCON.net added. 

4 2015-07-22 1.1.4.1  Firmware version in section Hardware and firmware 
updated to version ≥ v1.7 

5 2017-02-27 3.2   Section System Requirements PC/Notebook, Internet 
access added, Windows 8.1 and Windwos 10 added. 

Table 1: List of Revisions 
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1.1.3 Conventions in this Manual 

Notes, operation instructions and results of operation steps are marked as 
follows: 

Notes 
 
 

 

Important: <important note you must follow to avoid malfunction> 

 

 

Note:  <general note> 

 

 

<note, where to find further information> 

 

Operation Instructions 
 

1. <instruction> 

2. <instruction> 
 

or 
 

 <instruction> 

 

Results 
 

 <result> 
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1.1.4 Reference to Devices, Firmware and Software Versions 
1.1.4.1 Hardware and firmware 

This document relates to the following versions of hardware and firmware: 

Devices with preloaded firmware 
 

netHOST device 
preloaded with 
firmware 

Order no. Hardware 
revision 

Protocol Firmware file Firmware 
version 

NHST-T100-DP/DPM 1890.410/DPM 4 PROFIBUS DP Master FT20V010.NXF 1.7.x.x 

NHST-T100-CO/COM 1890.500/COM 4 CANopen Master FT20V040.NXF 1.7.x.x 

NHST-T100-DN/DNM 1890.510/DNM 4 DeviceNet Master FT20V060.NXF 1.7.x.x 

NHST-T100-EN/PNM 1890.840/PNM 2 PROFINET IO 
Controller 

FT20C0V0.NXF 1.7.x.x 

NHST-T100-EN/ECM 1890.110/ECM 2 EtherCAT Master FT20E0V0.NXF 1.7.x.x 

NHST-T100-EN/EIM 1890.820/EIM 2 EtherNet/IP Scanner FT20G0V0.NXF 1.7.x.x 

Table 2: Reference to devices with preloaded firmware 

Device for loadable firmware 
(Firmware not loaded in state of delivery of device) 
 

netHOST device for 
loadable firmware 

Order no. Hardware 
revision 

Supported protocols Loadable 
firmware file 

Firmware 
version 

NHST-T100-EN 1890.800 2 PROFINET IO 
Controller 

FT20C0V0.NXF 1.7.x.x 

EtherCAT Master FT20E0V0.NXF 1.7.x.x 

EtherNet/IP Scanner FT20G0V0.NXF 1.7.x.x 

Table 3: Reference to devices for loadable firmware 

 

 
Note: The device For acting as master device, the NHST-T100-EN 
requires the NXLIC-Master license (order no.: 8211.000). Make sure to 
order the NHST-T100-EN device together with the master license, so that 
it will be delivered with the license already loaded. 
If necessary, a master license can also be ordered and installed belatedly; 
instructions for this are provided in section Ordering and Downloading 
License to NHST-T100-EN with SYCON.net on page 36). 

 

1.1.4.2 Software 
This document refers to the following software versions: 
 

Software Version File name Path on netHOST Solutions DVD 
SYCON.net 1.380.x.x SYCONnet netX setup.exe Setups & Drivers\SYCON.net 

Ethernet Device 
Configuration Tool 

1.501.x.x EnDevConfigTool.msi Setups & Drivers\Ethernet Device 
Setup Utility 

netHOST Device 
Test Application 

1.0.x.x netHOST.exe Setups & Drivers\netHOST Test 

Table 4: Software 
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1.2 Documentation Overview 
This section lists documents that are relevant to the user of the netHOST 
device.  
 

 

Note, that the netHOST Solutions DVD also provides special 
documentation for developers in the Documentation\english\3.For 
Programmers directory. These special documents are not listed in this 
section. 

 

1.2.1 Basic documents 
 

Title Contents  Document ID Path on the netHOST Solutions DVD 
Operating 
Instruction Manual 
Configuration of 
LAN controlled 
master devices – 
netHOST 
(this document) 

Configuring, testing, 
diagnosing and 
updating firmware of 
the netHOST 
devices 

DOC130402OIxxEN Documentation\english\1.Software\SYCON
.net Configuration 
Software\Configuration of netHOST-
Devices OI xx EN.pdf 

User Manual 
netHOST NHST-
T100 – LAN 
controlled master 
devices for 
Fieldbus and Real-
Time Ethernet 
Systems 

Installation, 
commissioning and 
hardware 
description of the 
netHOST devices 

DOC130401UMxxEN Documentation\english\2.Hardware\netHO
ST, Model NHST-T100-xx\netHOST NHST-
T100 – Remote Fieldbus Device UM xx 
EN.pdf 

User Manual 
Software 
Installation 
netHOST Devices 

Instructions for 
installing the 
netHOST software  

DOC130501UMxxEN Documentation\english\4.Installation 
Instructions\netHOST - Software 
Installation UM XX EN.pdf 

User Manual  
Wiring Instructions 

Wiring instructions 
(cable 
characteristics) for 
fieldbus protocols 

DOC120208UMxxEN Documentation\english\4.Installation 
Instructions\Wiring Instructions UM XX 
EN.pdf 

Operating 
Instruction Manual 
Ethernet Device 
Configuration 

Instruction on how 
to assign an IP 
address to Hilscher 
devices 

DOC050402OIxxEN Documentation\english\1.Software\Ether
net Device Setup Utility\Ethernet 
Device Configuration OI XX EN.pdf 

Table 5: Basic Documentation for netHOST 
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1.2.2 Protocol-specific Documents 

netHOST as PROFIBUS DP Master 
You also need the following documents if you are using an  
NHST-T100-DP/DPM netHOST device: 
 

Title Contents  Document ID Path on the netHOST Solutions DVD 
Operating 
Instruction Manual 
DTM for Hilscher-
PROFIBUS DP 
Master Devices 

Description of the 
device type 
manager for 
PROFIBUS DP 
master devices 

DOC070401OIxxEN Documentation\english\1.Software\SYCON
.net Configuration Software\Master 
Configuration\PROFIBUS DP 
Master\PROFIBUS DP Master DTM OI xx 
EN.pdf 

Operating 
Instruction Manual 
Generic Slave DTM 
for PROFIBUS DP 
Slave Devices 

Description of the 
device type 
manager for generic 
PROFIBUS DP 
slave devices 

DOC031001OIxxEN Documentation\english\1.Software\SYCON
.net Configuration Software\Master 
Configuration\PROFIBUS DP Master\Slave 
Configuration\PROFIBUS DP Generic 
Slave DTM OI xx EN.pdf 

Table 6: Additional Documentation for netHOST as PROFIBUS DP Master 

 

netHOST as CANopen Master 
You also need the following documents if you are using an  
NHST-T100-CO/COM netHOST device: 
 

Title Contents  Document ID Path on the netHOST Solutions DVD 
Operating 
Instruction Manual 
DTM for Hilscher-
CANopen Master 
Devices 

Description of the 
device type 
manager for 
CANopen master 
devices 

DOC070402OIxxEN Documentation\english\1.Software\SYCON
.net Configuration Software\Master 
Configuration\CANopen Master\CANopen 
Master DTM OI xx EN.pdf 

Operating 
Instruction Manual 
Generic Slave DTM 
for CANopen Slave 
Devices 

Description of the 
device type 
manager for generic 
CANopen slave 
devices 

DOC060203OIxxEN Documentation\english\1.Software\SYCON
.net Configuration Software\Master 
Configuration\CANopen Master\Slave 
Configuration\CANopen Generic Slave 
DTM OI xx EN.pdf 

Table 7: Additional Documentation for netHOST as CANopen Master 

 

netHOST as DeviceNet Master 
You also need the following documents if you are using an  
NHST-T100-DN/DNM netHOST device: 
 

Title Contents  Document ID Path on the netHOST Solutions DVD 
Operating 
Instruction Manual 
DTM for Hilscher-
DeviceNet Master 
Devices 

Description of the 
device type 
manager for 
DeviceNet master 
devices 

DOC070403OIxxEN Documentation\english\1.Software\SYCON
.net Configuration Software\Master 
Configuration\DeviceNet 
Master\DeviceNet Master DTM OI xx 
EN.pdf 

Operating 
Instruction Manual 
Generic Slave DTM 
for DeviceNet Slave 
Devices 

Description of the 
device type 
manager for generic 
DeviceNet slave 
devices 

DOC041201OIxxEN Documentation\english\1.Software\SYCON
.net Configuration Software\Master 
Configuration\DeviceNet Master\Slave 
Configuration\DeviceNet Generic Slave 
DTM OI xx EN.pdf 

Table 8: Additional Documentation for netHOST as DeviceNet Master 
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netHOST as PROFINET IO Controller 
You also need the following documents if you are using an  
NHST-T100-EN/PNM, respectively NHST-T100-EN device with loaded 
PROFINET IO Controller firmware: 
 

Title Contents  Document ID Path on the netHOST Solutions DVD 
Operating 
Instruction Manual 
DTM for Hilscher-
PROFINET IO-
Controller Devices 

Description of the 
device type 
manager for 
PROFINET IO 
Controller devices 

DOC060302OIxxEN Documentation\english\1.Software\SYCON
.net Configuration Software\Master 
Configuration\PROFINET IO 
Controller\PROFINET IO Controller DTM 
OI xx EN.pdf 

Operating 
Instruction Manual 
Generic DTM for 
PROFINET IO 
Devices 

Description of the 
device type 
manager for generic 
PROFINET IO 
devices 

DOC060305OIxxEN Documentation\english\1.Software\SYCON
.net Configuration Software\Master 
Configuration\PROFINET IO Controller 
\IO Device Configuration\PROFINET IO 
Generic Device DTM OI xx EN.pdf 

Table 9: Additional Documentation for netHOST as PROFINET IO Controller 

 

netHOST as EtherCAT Master 
You also need the following documents if you are using an  
NHST-T100-EN/ECM, respectively NHST-T100-EN device with loaded 
EtherCAT Master firmware: 
 

Title Contents  Document ID Path on the netHOST Solutions DVD 
Operating 
Instruction Manual 
DTM for Hilscher 
EtherCAT Master 
Device 

Description of the 
device type 
manager for 
EtherCAT Master 
devices 

DOC080404OIxxEN Documentation\english\1.Software\SYCON
.net Configuration Software\Master 
Configuration\EtherCAT Master\EtherCAT 
Master DTM OI xx EN.pdf 

Operating 
Instruction Manual 
Generic Slave DTM 
for EtherCAT Slave 
Devices 

Description of the 
device type 
manager for generic 
EtherCAT slave 
devices 

DOC071202OIxxEN Documentation\english\1.Software\SYCON
.net Configuration Software\Master 
Configuration\EtherCAT Master\Slave 
Configuration\EtherCAT Generic Slave 
DTM OI xx EN.pdf 

User Manual  
Wiring Instructions 
EtherCAT 

Wiring instructions 
for EtherCAT 
networks 

DOC121104UMxxEN Documentation\english\4.Installation 
Instructions\ Wiring Instructions UM 
xx EN.pdf 

Table 10: Additional Documentation for netHOST as EtherCAT Master 
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netHOST as EtherNet/IP Scanner 
You also need the following documents if you are using an  
NHST-T100-EN/EIM, respectively NHST-T100-EN device with loaded 
EtherNet/IP Scanner firmware: 
 

Title Contents  Document ID Path on the netHOST Solutions DVD 
Operating 
Instruction Manual 
DTM for 
EtherNet/IP 
Scanner Devices 

Description of the 
device type 
manager for 
EtherNet/IP 
Scanner devices 

DOC061201OIxxEN Documentation\english\1.Software\SYCON
.net Configuration Software\Master 
Configuration\EtherNetIP 
Scanner\EtherNetIP Scanner DTM OI xx 
EN.pdf 

Operating 
Instruction Manual 
Generic, Modular 
Generic DTM from 
EDS File for non-
modular and 
modular 
EtherNet/IP 
Adapter Devices 

Description of the 
generic, modular 
generic device type 
manager from EDS 
file for non-modular 
EtherNet/IP Adapter 
devices and 
modular EtherNet/IP 
Adapter devices 

DOC100221OIxxEN Documentation\english\1.Software\SYCON
.net Configuration Software\Master 
Configuration\EtherNetIP 
Scanner\Adapter 
Configuration\EtherNetIP Generic 
Adapter DTM EDS OI xx EN.pdf 

Operating 
Instruction Manual 
Generic DTM for 
EtherNet/IP 
Adapter Devices 
and Modular 
Generic DTM for 
modular 
EtherNet/IP 
Adapter Devices 

Description of the 
generic device type 
manager for 
EtherNet/IP Adapter 
devices and 
modular EtherNet/IP 
Adapter devices 

DOC070203OIxxEN Documentation\english\1.Software\SYCON
.net Configuration Software\Master 
Configuration\EtherNetIP 
Scanner\Adapter 
Configuration\EtherNetIP Generic 
Adapter DTM OI xx EN.pdf 

Table 11: Additional Documentation for netHOST as EtherNet/IP Scanner 

 

1.2.3 Online Help 
The SYCON.net configuration software provides an online help. 
 To open the online help of the SYCON.net netFrame application, 

choose Help > Content and Index in the menu bar of SYCON.net or 
press F1 key on your keyboard. 

 If you have opened a netHOST configuration dialog in SYCON.net (i. e. 
if you have opened the netHOST DTM), you can call-up a context-
sensitive online help (featuring parts of this operating manual) by 
clicking the Help button in the dialog window or by pressing the F1 key 
on your keyboard. 
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1.3 Legal Notes  
Copyright 
© Hilscher Gesellschaft für Systemautomation mbH 
All rights reserved. 
The images, photographs and texts in the accompanying materials (in the 
form of a user's manual, operator's manual, Statement of Work document 
and all other document types, support texts, documentation, etc.) are 
protected by German and international copyright and by international trade 
and protective provisions. Without the prior written consent, you do not 
have permission to duplicate them either in full or in part using technical or 
mechanical methods (print, photocopy or any other method), to edit them 
using electronic systems or to transfer them. You are not permitted to make 
changes to copyright notices, markings, trademarks or ownership 
declarations. Illustrations are provided without taking the patent situation 
into account. Any company names and product designations provided in 
this document may be brands or trademarks by the corresponding owner 
and may be protected under trademark, brand or patent law. Any form of 
further use shall require the express consent from the relevant owner of the 
rights. 

Important notes 
Utmost care was/is given in the preparation of the documentation at hand 
consisting of a user's manual, operating manual and any other document 
type and accompanying texts. However, errors cannot be ruled out. 
Therefore, we cannot assume any guarantee or legal responsibility for 
erroneous information or liability of any kind. You are hereby made aware 
that descriptions found in the user's manual, the accompanying texts and 
the documentation neither represent a guarantee nor any indication on 
proper use as stipulated in the agreement or a promised attribute. It cannot 
be ruled out that the user's manual, the accompanying texts and the 
documentation do not completely match the described attributes, standards 
or any other data for the delivered product. A warranty or guarantee with 
respect to the correctness or accuracy of the information is not assumed. 
We reserve the right to modify our products and the specifications for such 
as well as the corresponding documentation in the form of a user's manual, 
operating manual and/or any other document types and accompanying 
texts at any time and without notice without being required to notify of said 
modification. Changes shall be taken into account in future manuals and do 
not represent an obligation of any kind, in particular there shall be no right 
to have delivered documents revised. The manual delivered with the 
product shall apply. 
Under no circumstances shall Hilscher Gesellschaft für Systemautomation 
mbH be liable for direct, indirect, ancillary or subsequent damage, or for 
any loss of income, which may arise after use of the information contained 
herein. 

Liability disclaimer 
The hardware and/or software was created and tested by Hilscher 
Gesellschaft für Systemautomation mbH with utmost care and is made 
available as is. No warranty can be assumed for the performance or 
flawlessness of the hardware and/or software under all application 
conditions and scenarios and the work results achieved by the user when 
using the hardware and/or software. Liability for any damage that may have 
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occurred as a result of using the hardware and/or software or the 
corresponding documents shall be limited to an event involving willful intent 
or a grossly negligent violation of a fundamental contractual obligation. 
However, the right to assert damages due to a violation of a fundamental 
contractual obligation shall be limited to contract-typical foreseeable 
damage. 
It is hereby expressly agreed upon in particular that any use or utilization of 
the hardware and/or software in connection with 
• Flight control systems in aviation and aerospace; 
• Nuclear fusion processes in nuclear power plants; 
• Medical devices used for life support and 
• Vehicle control systems used in passenger transport 
shall be excluded. Use of the hardware and/or software in any of the 
following areas is strictly prohibited: 
• For military purposes or in weaponry; 
• For designing, engineering, maintaining or operating nuclear systems; 
• In flight safety systems, aviation and flight telecommunications systems; 
• In life-support systems; 
• In systems in which any malfunction in the hardware and/or software 

may result in physical injuries or fatalities. 
You are hereby made aware that the hardware and/or software was not 
created for use in hazardous environments, which require fail-safe control 
mechanisms. Use of the hardware and/or software in this kind of 
environment shall be at your own risk; any liability for damage or loss due 
to impermissible use shall be excluded. 

Warranty 
Hilscher Gesellschaft für Systemautomation mbH hereby guarantees that 
the software shall run without errors in accordance with the requirements 
listed in the specifications and that there were no defects on the date of 
acceptance. The warranty period shall be 12 months commencing as of the 
date of acceptance or purchase (with express declaration or implied, by 
customer's conclusive behavior, e.g. putting into operation permanently). 
The warranty obligation for equipment (hardware) we produce is 36 
months, calculated as of the date of delivery ex works. The aforementioned 
provisions shall not apply if longer warranty periods are mandatory by law 
pursuant to Section 438 (1.2) BGB, Section 479 (1) BGB and Section 634a 
(1) BGB [Bürgerliches Gesetzbuch; German Civil Code] If, despite of all 
due care taken, the delivered product should have a defect, which already 
existed at the time of the transfer of risk, it shall be at our discretion to 
either repair the product or to deliver a replacement product, subject to 
timely notification of defect. 
The warranty obligation shall not apply if the notification of defect is not 
asserted promptly, if the purchaser or third party has tampered with the 
products, if the defect is the result of natural wear, was caused by 
unfavorable operating conditions or is due to violations against our 
operating regulations or against rules of good electrical engineering 
practice, or if our request to return the defective object is not promptly 
complied with. 
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Costs of support, maintenance, customization and product care 
Please be advised that any subsequent improvement shall only be free of 
charge if a defect is found. Any form of technical support, maintenance and 
customization is not a warranty service, but instead shall be charged extra. 

Additional guarantees 
Although the hardware and software was developed and tested in-depth 
with greatest care, Hilscher Gesellschaft für Systemautomation mbH shall 
not assume any guarantee for the suitability thereof for any purpose that 
was not confirmed in writing. No guarantee can be granted whereby the 
hardware and software satisfies your requirements, or the use of the 
hardware and/or software is uninterruptable or the hardware and/or 
software is fault-free. 
It cannot be guaranteed that patents and/or ownership privileges have not 
been infringed upon or violated or that the products are free from third-party 
influence. No additional guarantees or promises shall be made as to 
whether the product is market current, free from deficiency in title, or can be 
integrated or is usable for specific purposes, unless such guarantees or 
promises are required under existing law and cannot be restricted. 

Confidentiality 
The customer hereby expressly acknowledges that this document contains 
trade secrets, information protected by copyright and other patent and 
ownership privileges as well as any related rights of Hilscher Gesellschaft 
für Systemautomation mbH. The customer agrees to treat as confidential all 
of the information made available to customer by Hilscher Gesellschaft für 
Systemautomation mbH and rights, which were disclosed by Hilscher 
Gesellschaft für Systemautomation mbH and that were made accessible as 
well as the terms and conditions of this agreement itself. 
The parties hereby agree to one another that the information that each 
party receives from the other party respectively is and shall remain the 
intellectual property of said other party, unless provided for otherwise in a 
contractual agreement. 
The customer must not allow any third party to become knowledgeable of 
this expertise and shall only provide knowledge thereof to authorized users 
as appropriate and necessary. Companies associated with the customer 
shall not be deemed third parties. The customer must obligate authorized 
users to confidentiality. The customer should only use the confidential 
information in connection with the performances specified in this 
agreement. 
The customer must not use this confidential information to his own 
advantage or for his own purposes or rather to the advantage or for the 
purpose of a third party, nor must it be used for commercial purposes and 
this confidential information must only be used to the extent provided for in 
this agreement or otherwise to the extent as expressly authorized by the 
disclosing party in written form. The customer has the right, subject to the 
obligation to confidentiality, to disclose the terms and conditions of this 
agreement directly to his legal and financial consultants as would be 
required for the customer's normal business operation. 

Export provisions 
The delivered product (including technical data) is subject to the legal 
export and/or import laws as well as any associated regulations of various 
countries, especially such laws applicable in Germany and in the United 
States. The products / hardware / software must not be exported into such 
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countries for which export is prohibited under US American export control 
laws and its supplementary provisions. You hereby agree to strictly follow 
the regulations and to yourself be responsible for observing them. You are 
hereby made aware that you may be required to obtain governmental 
approval to export, reexport or import the product. 
 

1.4 Registered Trademarks 
Adobe Reader® is a registered trademark of the Adobe Systems 
Incorporated.  
CANopen® is a registered trademark of CAN in AUTOMATION - 
International Users and Manufacturers Group e.V. (CiA), Nürnberg. 
DeviceNet™ and EtherNet/IP™ are trademarks of ODVA (Open DeviceNet 
Vendor Association, Inc). 
EtherCAT® is a registered trademark and a patented technology of 
Beckhoff Automation GmbH, Verl, Germany, formerly Elektro Beckhoff 
GmbH. 
PROFIBUS® and PROFINET® are registered trademarks of PROFIBUS 
International, Karlsruhe. 
Windows® XP, Windows® Vista, Windows® 7, Windows® 8, Windows® 8.1 
and Windows® 10 are registered trademarks of Microsoft Corporation. 
 

All other mentioned trademarks are property of their respective legal 
owners. 
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2 Description 
The netHOST device allows you to access data of a fieldbus or Real-Time 
Ethernet network from your PC, terminal or other host system via TCP/IP 
(Ethernet LAN). The netHOST device thus serves as a gateway 
(respectively programming interface) between your PC/terminal/host 
system and the Fieldbus or Real-Time Ethernet network.   
Once configured, the netHOST device operates the Fieldbus or RTE 
network on its own. An appropriate application program establishes the 
TCP/IP connection to the device and accesses the data of the secondary 
network.   
Access to the netHOST device takes place according to the “Ethernet 
Marshalling” procedures, by which locally generated service requests of an 
initiator (i. e. the host application) are being transmitted to a receiver (i. e. 
the netHOST device) by an appropriate method (i. e. coded/decoded in 
Ethernet telegrams). The service requests are then called and executed “by 
remote” on the netHOST device. 
The host system can be based on a Windows operating system, but is, 
however, not restricted to Windows only. For Windows developers, the 
netHOST Solutions DVD provides the code with the Ethernet Marshalling 
function both as C++ source code and as Windows DLL 
(netXTransport.dll). For developers of embedded systems, the DVD 
provides a C source code which is independent from any specific type of 
operating system. 
 

 

Important: The Ethernet connection to the netHOST device is not 
protected by password or encryption. Protection against unauthorized 
access by external networks has to be ensured by using adequate 
measures ! 

 

The following figure illustrates the data flow of “Ethernet Marshalling” with 
the netHOST: 
 

 
Figure 1: Data Flow of LAN Controlled netHOST Device 
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3 Requirements for Configuring the netHOST 
3.1 Required Software 

Software components needed on a PC or host system under Windows to 
configure or test the netHOST device, or to download/update its firmware, 
are provided on the netHOST Solutions DVD. 
These are: 
• Ethernet Device Configuration Tool   

This tool is needed to assign a temporary IP address to the netHOST 
device (by default/factory setting, the IP address of the netHOST is 
0.0.0.0), so that SYCON.net can access the netHOST and download 
the configuration (and in case of an NHST-T100-EN the initial firmware) 
via LAN. 
The tool is included in the SYCON.net installation, but can also be 
installed separately on a Windows PC or notebook. The installation 
program for separate installation is called EnDevConfigTool.msi and can 
be found in the Setups & Drivers\Ethernet Device Setup 
Utility directory of the netHOST Solutions DVD. 

• SYCON.net  
To configure the netHOST device, you need to install the configuration 
and diagnosis software SYCON.net, version 1.360.x.x or higher, on your 
Windows PC or notebook. From version 1.360.x.x upwards, SYCON.net 
contains the appropriate Device Type Manager (netHOST-DTM) for 
configuring and diagnosing the netHOST device.  
You also need SYCON.net in order to download/update firmware files. 
You can start the installation program for SYCON.net in the menu of the 
start screen of the netHOST Solutions DVD. You can also start the 
installation by double-clicking the SYCONnet netX setup.exe file in the 
Setups & Drivers\SYCON.net directory of the DVD. 

 

 

Detailed instructions on how to install SYCON.net are provided in the user 
manual Software Installation netHOST Devices, DOC130501UMxxEN. 

 
• netHOST Device Test Application   

This application is needed to test the remote access and to read and 
write data of the secondary network, in case you don’t have an own 
application program for this purpose. 
This application does not need to be installed on your Windows PC or 
notebook. It can be started by clicking Run Windows Test Application 
in the menu of the start screen of the netHOST Solutions DVD. You can 
also execute the application by double-clicking the netHOST.exe file in 
the Setups & Drivers\netHOST Test directory of the DVD. 
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• netXTransport.dll  
The netXTransport.dll contains the Ethernet Marshalling functionality. It 
is needed on the Windows PC or accessing host system for 
communicating with the netHOST device via TCP/IP (Ethernet LAN).  
The DLL is included in the SYCON.net installation, but can also be 
installed separately on a Windows PC or notebook. The separate 
netXTransport.dll for Windows can be found on the netHOST Solutions 
DVD in the directory  
Supplements & Examples\netXTransport Protocol DLL – 
Win32 Test Application with Source Code 

 

 
Note: Windows developers will find C++ source code containing the 
Ethernet marshalling functionality in the Programming & 
Development\Developing own remote accessing 
Applications\netXTransport Protocol DLL\Source Codes 
directory of the netHOST Solutions DVD. 
For host systems not based on Windows, C source code containing the 
Ethernet marshalling functionality is available in the Programming & 
Development\Developing own remote accessing 
Applications\netXTransport Protocol C-Toolkit directory. 

 
• USB driver 

The USB driver is needed on the Windows PC or notebook only in the 
exceptional case of having to reset the netHOST device to its “factory 
settings” (firmware recovery via USB). This can be necessary if, e. g., 
the firmware file of the device is corrupted. When performing a recovery 
via USB, a fresh firmware file is reloaded into the device with the 
ComProX tool. 

 

 

Instructions on how to reset the netHOST device to its factory settings can 
be found in the user manual netHOST NHST-T100 – LAN controlled 
master devices for Fieldbus and Real-Time Ethernet systems, 
DOC130401UMxxEN, in the Firmware recovery chapter.  
Instructions on how to install the USB driver under Windows are provided 
in the user manual Software Installation netHOST Devices, 
DOC130501UMxxEN. 
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The figure below depicts the interaction of the required software 
components and the data flow. 
 

 
Figure 2: Data Flow and Software Components for Configuration and Testing 

 

 SYCON.net with netHOST-DTM: Configuration, diagnosis and 
downloading/updating firmware of the netHOST device via TCP/IP. 

 netHOST Device Test Application: Allows testing the communication. 

 Online Data Manager (ODM): Connects the application layer (SYCON.net) 
to the communication layer (netX Driver). The ODM is included in the 
SYCON.net installation. 

 netX Driver: Windows driver for communication between SYCON.net and 
the netHOST device. The netX Driver is included in the SYCON.net 
installation. 

 
cifX Application Interface (API): Enables an application program to access 
the fieldbus/RTE network via netHOST. 

 netXTransport.DLL for Windows: Integrates the commands of the 
application program into an Ethernet protocol and sends the data to the 
netHOST device. Contains the Marshalling function of the host. The DLL is 
included in the SYCON.net installation, but can also be installed separately. 

 Ethernet Device Configuration Tool: Assigns a temporary IP address to 
the netHOST device. The tool is included in the SYCON.net installation. 

 
netHOST firmware: Contains the protocol stack and the Marshalling 
function of the device. 
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3.2 System Requirements PC/Notebook 
For installing and using the SYCON.net configuration software, you need a 
PC or notebook with: 
 

• PC with 1 GHz processor or higher 
• Windows® XP SP3,  

Windows® Vista (32 bit) SP2,   
Windows® 7 (32 bit und 64-Bit) SP1,   
Windows® 8 (32-Bit und 64-Bit),  
Windows® 8.1 (32-Bit und 64-Bit),   
Windows® 10 (32-Bit und 64-Bit) 

• Administrator privilege required for installation 
• Internet Explorer 5.5 or higher 
• RAM: min. 512 MByte, recommended 1024 MByte 
• Graphic resolution: min. 1024 x 768 pixel 
• Keyboard and Mouse 
• Restriction: Touch screen is not supported. 
 

 

Note: If the project file is used on another PC,  
 the other PC must also comply to these system requirements, 
 the device description files of the devices used in the project must be 

imported to the configuration software SYCON.net on the other PC, 
 respectively the DTMs of the devices used in the project must be 

installed on the other PC. 
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4 Getting Started 
netHOST Devices with preloaded firmware 
The subsequent table provides an overview of the steps which need to be 
performed in order to configure and test the netHOST devices 
NHST-T100-DP/DPM  
NHST-T100-CO/COM  
NHST-T100-DN/DNM  
NHST-T100-EN/PNM  
NHST-T100-EN/ECM  
NHST-T100-EN/EIM  
 

# Step For details, refer to  
1 Install netHOST 

- Mount netHOST device. 
- Connect the netHOST device to the LAN network 
(primary network) and the configuration PC. 
- Connect the netHOST device to the fieldbus or Real-
Time Ethernet (secondary network). 
- Connect the netHOST device to a voltage supply. 

User Manual  
netHOST NHST-T100 
 – LAN controlled master devices 
for Fieldbus and Real-Time 
Ethernet networks 

2 Install SYCON.net configuration software on 
configuration PC. 

User Manual  
Software Installation netHOST 
Devices 

3 Use Ethernet Device Configuration tool to assign a 
temporary IP address to the netHOST device. 

Section Assigning Temporary IP 
Address to netHOST Device on 
page 24 

4 Configure netHOST with SYCON.net. Section Configuring netHOST for 
Fieldbus Systems with 
SYCON.net: NHST-T100-
DP/DPM Example on page 49 
or 
section Configuring netHOST for 
RTE Systems with SYCON.net: 
NHST-T100-EN/PNM Example on 
page 64 

5 Test Communication Section Testing Communication 
of netHOST for Fieldbus: NHST-
T100-DP/DPM Example on page 
80  
or 
section Testing Communication of 
netHOST for RTE Systems: 
NHST-T100-EN/PNM Example on 
page 86 

Table 12: Overview Configuration and Testing of netHOST with Preloaded Firmware  
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NHST-T100-EN (device without preloaded firmware) 
The subsequent table provides an overview of the steps which need to be 
performed in order to commission, configure and test the NHST-T100-EN  
 

# Step For details, refer to  
1 Install NHST-T100-EN 

- Mount netHOST device. 
- Connect the netHOST device to the LAN network 
(primary network) and the configuration PC. 
- Connect the netHOST device to the fieldbus or Real-
Time Ethernet (secondary network). 
- Connect the netHOST device to a voltage supply. 

User Manual  
netHOST NHST-T100 
 – LAN controlled master devices 
for Fieldbus and Real-Time 
Ethernet networks 

2 Install SYCON.net configuration software on 
configuration PC 

User Manual  
Software Installation netHOST 
Devices 

3 Use Ethernet Device Configuration tool to assign a 
temporary IP address to the NHST-T100-EN device 

Section Assigning Temporary IP 
Address to netHOST Device on 
page 24 

4 Download firmware to NHST-T100-EN device Section NHST-T100-EN: 
Downloading Firmware to the 
Device with SYCON.net on page 
27 

5 Configure netHOST with SYCON.net. Section Configuring netHOST for 
RTE Systems with SYCON.net: 
NHST-T100-EN/PNM Example on 
page 64 

6 Test Communication Section Testing Communication 
of netHOST for RTE Systems: 
NHST-T100-EN/PNM Example on 
page 86 

Table 13: Overview Configuration and Testing of NHST-T100-EN  
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5 Assigning Temporary IP Address to netHOST Device 
In its state of delivery, the netHOST device has the IP address 0.0.0.0. 
Also, the DHCP option (i. e. the option of the netHOST receiving its IP 
address dynamically from a DHCP server) at first is deactivated by default 
in the firmware (if required, you can activate the DHCP server option in 
SYCON.net later). Because the netHOST is configured via Ethernet LAN 
and SYCON.net, you first need to assign a valid temporary IP address to 
the netHOST, in order to enable SYCON.net to establish an Ethernet 
connection to the device in the first place (the initial firmware download for 
the NHST-T100-EN is also done via Ethernet LAN and SYCON.net and 
thus also requires the assignment of a tempory IP address). You can use 
the Hilscher Ethernet Device Configuration Tool to assign this temporary 
IP address from your configuration PC. 
 

 

The Ethernet Device Configuration Tool is described in the operating 
instructions manual Ethernet Device Configuration, DOC050402OIxxEN, 
which is stored on the netHOST Solutions DVD in the 
Documentation\english\1.Software\Ethernet Device Setup 
Utility directory. 

 

5.1 Prerequisites 
• You have installed the Hilscher Ethernet Device Configuration Tool on 

your configuration PC (is included in the SYCON.net installation). 
• The netHOST device is connected to a voltage supply.  
• The configuration PC and the netHOST device are connected to the 

same local Ethernet network. 
 

 
Note: When using netHOST devices for Fieldbus systems (i. e. NHST-
T100-DP/DPM, NHST-T100-CO/COM or NHST-T100-DN/DNM), plug-in 
the Ethernet LAN cable into one of the two RJ45 sockets on the left side 
of the device (X2 interface).  
When using netHOST devices for RTE systems (i. e. NHST-T100-EN, 
NHST-T100-EN/PNM, NHST-T100-EN/ECM or NHST-T100-EN/EIM), 
plug-in the Ethernet LAN cable into the single RJ45 socket on the right 
side of the device (X3 interface). 
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5.2 Step-By-Step Instructions  
1. Start Ethernet Device Configuration tool on your PC. 
 In the Windows Start menu, choose Start > All Programs > 

SYCON.net System Configurator > Ethernet Device Setup.  
(If you haven’t installed SYCON.net on your PC and have installed the 
Ethernet Device Configuration tool separately, then choose   
Start > All Programs > Hilscher GmbH > Ethernet Device 
Configuration > Ethernet Device Configuration.) 

 The tool starts: 
 

 
Figure 3: Ethernet Device Configuration Tool (1) 

 

2. Search for Hilscher devices in the IP network. 
 Click Search Devices to identify connected Hilscher devices. 
 All found devices are listed: 
 

 
Figure 4: Ethernet Device Configuration Tool (2) 
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3. Assign IP address. 
 Select the line featuring the netHOST device. 
 Click Configure, then choose Set IP Address… from the menu. 
 The IP Configuration dialog opens: 
 

 
Figure 5: Ethernet Device Configuration Tool (3) 

 Enter the IP address by which the netHOST device shall be reached in 
your local IP network. The IP address must be in the same sub net as 
the later to be used configuration PC. 

 Click OK. 
 The netHOST device receives the entered IP address.  
 

 
Note: The IP address assigned by the Ethernet Device Configuration 
Tool is kept by the netHOST device only until next power-on cycle or 
device reset, or until a permanent IP address has been configured and 
downloaded with SYCON.net. 
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6 NHST-T100-EN: Downloading Firmware to the Device 
with SYCON.net 

This chapter is relevant only to users of the NHST-T100-EN device (order 
no.: 1890.800), which – unlike all other netHOST devices – is shipped with 
its firmware not yet loaded. The user thus has to perform the download of 
the firmware file himself.  
One of the following master protocols can be loaded to the NHST-T100-EN: 
 

Supported protocol Loadable firmware file 
PROFINET IO Controller FT20C0V0.NXF 

EtherCAT Master FT20E0V0.NXF 

EtherNet/IP Scanner FT20G0V0.NXF 

Table 14: Loadable firmware for NHST-T100-EN 

The firmware files are stored on the product DVD in the 
Firmware\netHOST folder. 
A netHOST acting as master device requires the NXLIC-Master license.  
If you have ordered the NHST-T100-EN device together with the NXLIC-
Master license (order no. 8211.000), the device was delivered with an 
already installed and activated master license, and you therefore only have 
to download the desired firmware file.   
If your NHST-T100-EN device is not yet equipped with the master license 
for any reason, you can use SYCON.net to order the license from Hilscher 
and then download the license to the device. Instructions for this are 
provided in section Ordering and Downloading License to NHST-T100-EN 
with SYCON.net on page 36). Note that you have to download the firmware 
first. 
The following section describes how  to download the PROFINET IO 
Controller firmware to the NHST-T100-EN device. The procedure for the 
EtherCAT master and EtherNet/IP Scanner firmware is the same. 
 

6.1 Prerequisites 
• You have installed SYCON.net on your configuration PC. 
• You have inserted the netHOST Solutions DVD into your local DVD 

drive or have access to the firmware file intended for download (e. g. you 
have stored the file on your configuration PC). 

• The configuration PC and the NHST-T100-EN device are connected to 
the same local Ethernet network. 

• The NHST-T100-EN device is connected to a voltage supply. 
• You have assigned a suitable temporary IP address to the netHOST 

device (see section Assigning Temporary IP Address to netHOST 
Device on page 24). 
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6.2 Step-By-Step Instructions 
1. Start SYCON.net configuration software. 
 In the Windows Start menu, select All Programs > SYCON.net 

System Configurator > SYCON.net. 
 A login dialog appears: 
 

 
Figure 6: SYCON.net Login 

 

 Enter your password, then click OK. 
 SYCON.net opens with a new empty project: 
 

 
Figure 7: Empty Project in SYCON.net 
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2. Create a new project. 
 In the Vendor tab of the Device Catalog (right window), open folder 

Hilscher GmbH > Master. Then select the netHOST DTM symbol 
corresponding to the protocol of your firmware and drag & drop it onto 
the bus configuration line in the middle window.  

Use the following netHOST-DTMs: 
for PROFINET IO Controller: NHST-T100-EN/PNM  
for EtherCAT Master: NHST-T100-EN/ECM  
for EtherNet/IP Scanner: NHST-T100-EN/EIM 
 

 
Figure 8: Select NHST-T100-EN DTM 

 

3. Open the netHOST configuration window (i. e. the netHOST DTM). 
 Double-click the netHOST symbol in the bus configuration line, or select 

the netHOST symbol and choose Configuration > Main Settings from 
the context menu (to open context menu, right-click on the netHOST 
symbol). 
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 The netHOST DTM opens with the Device Assignment dialog window. 
SYCON.net automatically starts to search for connected devices. 

 

 
Figure 9: Scanning for Devices in SYCON.net 

 Because the netX Driver (which enables the Ethernet LAN connection 
to the netHOST device) is not yet acquainted with the IP address of the 
device, the netHOST is not found for the time being. You therefore first 
have to enter the IP address in the driver configuration dialog. 

 

4. Select driver. 
 In the Navigation Area, select Settings > Driver. 
 The Driver dialog window opens. It lists all available drivers: 
 

 
Figure 10: Select Driver  

 

 Make sure the netX Driver is selected (check box must be activated). 



NHST-T100-EN: Downloading Firmware to the Device with SYCON.net 31/160 

Configuration of LAN Controlled Master Devices | netHOST  
DOC130402OI05EN | Revision 5 | English | 2017-03 | Released | Public  © Hilscher 2013 - 2017 

 

 
Note: In the netHOST DTM, the netX Driver usually is already selected 
by default. If this is not the case, activate the check box in front of the 
netX driver. 

 

 Click OK or Apply. 
 

5. Set IP address of netHOST in netX Driver. 
 In the Navigation Area, select Settings > Driver > netX Driver. 
 The netX Driver dialog window opens.  
 Select TCP Connection tab: 
 

 
Figure 11: Set IP Address in netX Driver  

 

 Make sure the Enable TCP Connector option is selected (check box 
must be activated). 

 Click on  button next to the Select IP Range drop-down list. 
 In the IP Address field, enter the IP address which you have assigned 

to the netHOST device with the Ethernet Device Configuration Tool 
(see Assigning Temporary IP Address to netHOST Device section on 
page 24).  

 

 
Note: You will find a detailed description of this dialog in the netX Driver 
Dialog Window section on page 114. 

 

 Click Save. 
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6. Assign netHOST device. 
 In the Navigation Area, select Settings > Device Assignment. 
 The Device Assignment dialog window opens.  
 In the Device selection drop-down list, choose suitable only entry. 
 Click Scan. 
 If all prerequisites are fulfilled (see Prerequisites section on page 49) 

and the IP address has been properly set in the netX Driver, the NHST-
T100-EN device will now be found and displayed in the list.  

 

 
Figure 12: Select Device  

 

 Activate the check box in front of the netHOST device. 
 Click Apply. 
 

7. Browse for firmware. 
 In the Navigation Area, select Configuration > Settings. 
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 The Settings dialog window opens: 
 

 
Figure 13: Settings Dialog  

 Click Browse button next to the Available Firmware field in order to 
search for the appropriate firmware file. 

 

 The Select Firmware File dialog opens: 
 

 
Figure 14: Select Firmware File Dialog in SYCON.net 
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 Navigate to the directory where the firmware file is stored. Firmware 
files are stored on the netHOST Solutions DVD in the 
Firmware\netHOST directory.  
The subsequent table indicates which file belongs to which protocol: 

 

Protocol  Firmware file 
PROFINET IO Controller FT20C0V0.NXF 

EtherCAT Master FT20E0V0.NXF 

EtherNet/IP Scanner FT20G0V0.NXF 

Table 15: Protocol/Firmware for NHST-T100-EN 

 Select the appropriate firmware file, then click Open. 
 Back in the Settings dialog window, the selected firmware file is now 

displayed in the Available Firmware field: 
 

 
Figure 15: Firmware Download in SYCON.net  

 

8. Download firmware to netHOST device. 
 In the Available Firmware field, select the firmware file. 
 Class and version of the software are displayed. 
 Check whether you have selected the appropriate firmware file. 
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Hazard of device damage by disruption of voltage supply during 
firmware update! 
Do not interrupt the voltage supply while downloading the firmware to the 
netHOST. Power failure during a writing process in the file system can 
cause severe malfunctioning of the device. 

 
 If you have selected the appropriate firmware file, click Download, to 

start downloading the file to the netHOST device. 
 The following security question pops up: 
 

 
Figure 16: Security Question Firmware Download 

 

 
Note: The existing firmware netHOST BFW, which is to be overwritten, is 
a so-called “base firmware” which is present in each NHST-T100-EN 
device in its state of delivery. The purpose of the base firmware is to 
enable access to the device via LAN and SYCON.net, so that the initial 
firmware download can be done by the customer. When downloading the 
“full” firmware, the base firmware is not needed any longer in the device 
and can thus be overwritten. 

 

 
 The firmware is downloaded to the netHOST. 
 

 
Note: The temporary IP address assigned to the netHOST device by the 
Ethernet Device Configuration Tool will be erased by the firmware 
download. The device falls back to its default 0.0.0.0 address, therefore 
you have to re-assign an IP address to the netHOST afterwards with the 
Ethernet Device Configuration Tool. Instructions for this can be found in 
the Assigning Temporary IP Address to netHOST Device section on page 
24. 
A permanent IP address can be assigned to the netHOST during 
configuration of the “Ethernet Marshalling”, see section Configuring 
Ethernet Marshalling on page 70. 
 
 To close the netHOST DTM, click OK or Cancel. 
 You have downloaded the firmware to the NHST-T100-EN device. If 

you did order the device together with the NXLIC-Master license (this is 
usually the case), the device was delivered with an activated license, 
and you can now proceed to configure your device. If your NHST-T100-
EN device has not yet been endowed with a master license, you must 
now proceed to order and download the license as described in the 
following section. 
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6.3 Ordering and Downloading License to NHST-T100-EN 
with SYCON.net 

This section describes how to order and download a master license to the 
NHST-T100-EN with SYCON.net. This is only necessary in the unusual 
case that the device had not been ordered together with an NXLIC-Master 
license, and has thus been delivered without the license already installed.  

6.3.1 Prerequisites 
• The configuration PC and the NHST-T100-EN device are connected to 

the same local TCP/IP (Ethernet LAN) network. 
• The device is connected to a voltage supply. 
• You have successfully downloaded the firmware to the NHST-T100-EN. 
• You have re-assigned a suitable temporary IP address to the netHOST 

device after firmware download (the device loses its temporary IP 
address after firmware download and subsequent device reset).  
For instructions, see section Assigning Temporary IP Address to 
netHOST Device on page 24. 

• You have opened the SYCON.net project of your NHST-T100-EN 
device. 

• You have access to the internet (for downloading the license file from 
the Hilscher web site) 

6.3.2 Instructions 
6.3.2.1 Open License Dialog 

 

1.  Open the configuration dialog. 
 Double-click the netHOST symbol in the bus configuration line, or select 

the netHOST symbol and choose Configuration > Main Settings from 
the context menu (to open context menu, right-click on the netHOST 
symbol). 

 The configuration dialog opens. 

  

2. Open license dialog 
 Select in the navigation area under the folder Configuration the entry 

Licensing. 
 The license dialog opens.  
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6.3.2.2 License Dialog 
In the License

1
 pane you can: 

• check, which licenses for Master protocols or Utilities are present in the 
device (Position  in the figure below), 

• order licenses (Positions  to ), 

• transfer licenses to the device . 

 
Figure 17: License Pane 

 
 

 
Note: To display further entries under License Type, move the scroll box 

 downwards or upwards. To display further entries under Request 
Form, please fill out, move the scroll box  downwards or upwards. 

 

 
__________________________________________ 

1 The title bar contains the notation of the device description: 
Symbolic Name [Device Description]  <Station Address > (#Network ID). 
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6.3.2.3 Which Licenses are present in the Device? 
Check, which licenses are present in the device. 
How to proceed: 
 Open the License pane as described under section Open License 

Dialog on page 36. 

 
Figure 18: License Pane - License Type 

 Under License Type click  at Master protocols. 
 The Master protocols overview opens: 

 
Figure 19: License Pane – License Type / Master protocols 

 Or click  at Utilities. 
 The Utilities overview opens: 

 
Figure 20: License Pane  – License Type / Utilities 

 The column Existing indicates which licenses are present in the device. 
Yes = License is present in the device. 
No = License is not present in the device. 

 
Note: In newer versions of the present configuration software under 
License Type may be displayed additional licenses or other protocols that 
can be ordered later. 
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License for Master Protocols 
One General Master License:  
On the device maximally 1 communication protocol with master function 
can be implemented.  
Two General Master Licenses: 
On the device maximally 2 communication protocols with master function 
can be implemented. 
The license includes the following Master protocols: 
• AS-Interface Master
• CANopen Master
• DeviceNet Master
• EtherCat Master
• EtherNet/IP Scanner
• PROFIBUS Master
• PROFINET IO RT Controller
• Sercos Master

License for Utilities 
• SYCON.net
• OPC Server
• QVis Minimum Size
• QVis Standard Size
• QVis Maximum Size
• CoDeSys Minimum Size
• CoDeSys Standard Size
• CoDeSys Maximum Size

For the utilities QVis and CoDeSys, only one license each may be chosen 
alternatively as: 
• Minimum Size,
• Standard Size or
• Maximum Size.
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6.3.2.4  How to order a License 
To order a license, proceed as follows: 

  Refer to Section: Page 

1. Open the license dialog. Open License Dialog 36 

2. Select the required licenses. Selecting License 40 

3. Enter the ordering data. Ordering Data 41 

4. Place your order. Ordering the License 43 
 

 

6.3.2.5 Selecting License(s) 
You can select licenses for Master protocols and / or utilities. 

1. Selecting license(s) for Master protocol(s): 

 Under License Type click  at Master protocols in the License pane. 
 Under Order check as many licenses must run simultaneously on your 

device: 
One General Master License or   
Two General Master Licenses. 

 

2. And/or select license(s) for utility(utilities): 

 In the License pane under License Type click  at Utilities. 
 Under Order check the required utility(utilities)   

(single or several)
2
: 

• SYCON.net 

• OPC Server 

• QVis Minimum Size* 

• QVis Standard Size* 

• QVis Maximum Size* 

• CoDeSys Minimum Size** 

• CoDeSys Standard Size** 

• CoDeSys Maximum Size** 

 
2 For *) and **) minimum size, standard size or maximum size can be selected only as 

an alternative. 
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6.3.2.6 Ordering Data 

1. Device Information 

 The Device Information required for the order are read from the device 
and automatically filled in the order. 

2. Ordering Data 

Enter the Ordering Data into the License pane.  
 Enter the Data to manage the Order (therefore refer to section Data to 

manage the Order (License Information)on page 42). 
 

 

Device Information (Ordering data read from the Device) 
The following ordering data are read from the device and displayed in the 
License pane: 
• Manufacturer 
• Device number 
• Serial number 
• Chiptype 
• Step (chip revision) 
• Romcode revision 
• Checksum (checksum of the device data) 
 

 The gray fields under Request Form, please fill out contain the 
ordering data read from the device: 

 
Figure 21: License Pane - Request Form, please fill out / Device Information 

 These ordering data read out from the device are displayed 
automatically from the device.  
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Data to manage the Order (License Information) 
For your order you must enter the following data to the License pane: 

1. License Type (User Single Device License). 

 
Figure 22: License Pane - Request Form, please fill out / License Type 

 Select the license type under Request Form, please fill out > Value, 
(for future application, currently only User Single Device License can be 
selected). 

2. Mandatory data to the order request (editable fields): 

• First Name 
• Surname 
• E Mail (address, to which the license download link shall be send.) 
• Telephone 
• Company 
• Address 
• Country 
• City, State, Zip 

 
Figure 23: License Pane - Request Form, please fill out / Mandatory data 

 Enter all mandatory fields under Request Form, please fill out > Value 
(marked with*). 

3. Additional order data, not mandatory (editable fields): 

• Fax 
• Customer Number 
• Order Number 
• Value added tax identification number 
 Under Request Form, please fill out > Value enter all fields for the 

additional data, which are not mandatory. 
 



NHST-T100-EN: Downloading Firmware to the Device with SYCON.net 43/160 

Configuration of LAN Controlled Master Devices | netHOST  
DOC130402OI05EN | Revision 5 | English | 2017-03 | Released | Public  © Hilscher 2013 - 2017 

6.3.2.7 Ordering the License 
Place your order in the License pane. Therefore: 

 
Figure 24: License Pane – Selecting the Subsidiary / Ordering / Contacts 

1. Select the Subsidiary  , to which the order shall be send. 

2. Place the order: 
 

  Refer to Section: Page 

• by E-Mail  , Ordering the License by E Mail 44 

• or by Fax   
or by Telephone , 

Ordering the License by Fax or 
by Telephone 

45 

• or in a File  . Exporting License Request to 
a File 

47 

 

 The Contact Data of the selected subsidiary are displayed under 
Position ,  and .  
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Ordering the License by E Mail 
You can place your order by e-mail. 

 
Figure 25: License Pane – placing the order by E-mail 

 Click E-mail…  . 
 The order E-mail License request opens:  

 
Figure 26: Example: Order E-Mail License request 

 The order e-mail License request contains: 

• the E-mail… of the selected subsidiary  , 

• the automatically generated XML file   EmailOrderRequest_-
[Devicenumber]_[Serialnumber].xml with a summary info of the order 
information, 

• the Order Address  ,  

• the License Information  ,  

• the License Type  ,  

• the Device Data  , 

• the ordered Licenses  . 
 

 Send the order e-mail License request. 
 The order process is complete. 
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Ordering the License by Fax or by Telephone 
You can place your order by Fax or by Telephone. 

                     
Figure 27: License Pane - placing the order by Fax or by Telephone 

 Click Print Fax Form  or Telephone… . 
 The summary of the ordering data PrintOrderRequest_[Devicenum-

ber]_[Serialnumber].html is opened in a browser window. 
 

 
Note: If your browser does not display the order data or the window Move 
Element or Copy Element are displayed, check the safety settings of 
your system. 

 
 

 
Figure 28: Example: Order Data Form PrintOrderRequest 
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 The order data form contains: 

 the Order Address ,  

 the License Information  ,  

 the License Type  ,  

 the Device Data  , 

 the ordered Licenses  . 
 

 Print the order data form, sign it and send it by Fax. 

 
Figure 29: License Pane – Fax Number of the selected Subsidiary 

 Use the Fax number  , which is displayed after the subsidiary was 
selected in the License pane. 

Or: 
 Keep ready the order data form and communicate the order data via 

telephone. 

 
Figure 30: License Pane – Telephone Number of the selected Subsidiary 

 Use the telephone number  , which is displayed after the subsidiary 
was selected in the License pane. 

 The order process is complete. 
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6.3.2.8 Exporting License Request to a File 
If you are working on a process computer without an e-mail client, you can 
export your order information to a file, save the file to a removable disk and 
place your order manually via e-mail from a different PC. 

 
Figure 31: License Pane - Ordering by exported File and E-Mail 

 Click Export License Request… . 
 The window Browse For Folder is displayed. 
 Choose for or create a new folder on a removable disk. 
 Save the automatically generated XML file EmailOrderRequest_-

[Devicenumber]_[Serialnumber].xml with a summary info of the order 
information to this folder. 

 Send this file from a PC with an e-mail client manually via e-mail. 
 Therefore use an e-mail address , which is displayed after the 

subsidiary was selected in the License pane (see Position  Figure 
License Pane on page 37). 

 The order process is complete. 
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6.3.2.9  How to get the License and transfer it to the Device 

 
Note: License files can only be delivered via e-mail. The e-mail contains a 
link to download the license file. 

 

According to the license you ordered, you will receive an e-mail containing 
a Link to download the License File. This leads to a server PC on which 
the license file is provided. Using the received link you will have to save the 
license file on your PC and then transfer the license to your device. If your 
e-mail client is on another PC as your device, you must save your license 
file e. g. to an USB stick. 

Steps how to proceed 
1. Save the license file to a PC or a disk. 

 Click to the Link to download the License File in the e-mail. 
 Save the license file *.nxl to a PC or a removable disk. 
 

2. Download the license file to the device. 

 Respectively connect the removable disk with the license file to the PC, 
which is connected to your device.  

 Click Download License  in the License pane in the configuration 
software. 

 
Figure 32: License Pane - Download License 

 

 The File selection window Open is displayed. 
 Therein select the license file netX License Files (*.nxl). 
 Click Open. 
 The license file is transferred to the device. 
 After this the license is present in the device and is activated with the 

next device reset. 
 

3. Activate Device Reset 
 

 
Hint: To activate the license in the first device, a device reset is required. 

 

 To check whether the license has been activated, follow the steps in 
section Which Licenses are present in the Device? on page 38. 
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7 Configuring the netHOST Step-By-Step  
7.1 Overview 

This chapter provides exemplary step-by-step instructions on how to 
configure a NHST-T100-DP/DPM netHOST as PROFIBUS DP master and 
how to configure a NHST-T100-EN/PNM as PROFINET IO Controller by 
using the SYCON.net configuration software provided by Hilscher. The 
configuration of the netHOST devices for DeviceNet, CANopen, EtherCAT 
and EtherNet/IP can, in principle, be carried out as described for the 
PROFIBUS DP and PROFINET IO examples in this chapter – except, of 
course, for the specific settings of the individual fieldbus/RTE protocols. 
 

 

Details of the parameters which have to be set for each individual fieldbus 
or RTE protocol can be found in the operating instruction manuals for the 
DTMs of the corresponding protocols. These DTM manuals are stored on 
the netHOST Solutions DVD in the directory 
Documentation\english\1.Software\SYCON.net 
Configuration Software\Master Configuration\[protocol]. 
During configuration in SYCON.net, you can also open a context-sensitive  
online help by clicking the Help button in the opened dialog window of the 
DTM, or by pressing the F1 key on your keyboard. 

 

7.2 Configuring netHOST for Fieldbus Systems with 
SYCON.net: NHST-T100-DP/DPM Example 

In this example for PROFIBUS DP, a pre-configured Hilscher CB-AB32-
DPS IO test board serves as Fieldbus slave device. 

7.2.1 Prerequisites 
• You have installed SYCON.net on your configuration PC. 
• You have the user right Maintenance, Planning Engineer or 

Administrator in SYCON.net. 
• The slave devices have been configured properly and you know the 

required configuration parameters of the slaves. In this example for 
PROFIBUS DP, you must know the number of bytes of the input/output 
modules. 

• If the slave devices you want to add to the Fieldbus are missing in the 
device catalog of SYCON.net, you first have to import the device 
description files of these devices into SYCON.net. Instructions for this 
can be found in the Importing Device Description Files into SYCON.net 
chapter on page 95. 

• You have assigned a suitable temporary IP address to the netHOST 
device (see section Assigning Temporary IP Address to netHOST 
Device on page 24). 

• The netHOST device is connected to a voltage supply. 
• The configuration PC and the netHOST device are connected to the 

same local TCP/IP (Ethernet LAN) network. 
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Note: Plug-in the Ethernet LAN cable into one of the two RJ45 sockets 
on the left side of the device (X2 interface).  

 

7.2.2 Step-By-Step Instructions  
7.2.2.1 Creating New netHOST Project in SYCON.net 

1. Start SYCON.net configuration software. 
 In the Windows Start menu, select All Programs > SYCON.net 

System Configurator > SYCON.net. 
 A login dialog appears: 
 

 
Figure 33: SYCON.net Login 

 Enter your password, then click OK. 
 SYCON.net opens with a new empty project: 
 

 
Figure 34: Empty Project in SYCON.net  
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2. Add netHOST device to the configuration project. 
 In the Vendor tab of the Device Catalog (right window), open folder 

Hilscher GmbH > Master. 
 Then select NHST-T100-DP/DPM device and drag & drop it onto the 

bus configuration line in the configuration window (middle window):  
 

 
Figure 35: Add netHOST Device in Configuration Project 

 

 The gateway device appears in the project: 
 

 
Figure 36: netHOST Device in Configuration Project 
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3. Save project. 
 In the menu, choose File > Save As to save the netHOST configuration 

project. 
 

7.2.2.2 Assigning Device to Driver and Configuring Driver 
1. Open the netHOST configuration window (i. e. the netHOST DTM). 
 Double-click the netHOST symbol in the bus configuration line or select 

the netHOST symbol and choose Configuration > Main Settings from 
the context menu (to open context menu, right-click on the netHOST 
symbol). 

 The netHOST DTM opens with the Device Assignment dialog window. 
SYCON.net automatically starts to search for connected devices. 

 

 
Figure 37: Scanning for Devices in SYCON.net 

 Because the netX Driver (which enables the Ethernet LAN connection 
to the netHOST device) is not yet acquainted with the IP address of the 
device, the netHOST is not found for the time being.  

 

2. Select driver. 
 In the Navigation Area, select Settings > Driver. 
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 The Driver dialog window opens. It lists all available drivers: 
 

 
Figure 38: Select Driver  

 

 Make sure the netX Driver is selected (check box must be activated). 
 

 
Note: In the netHOST DTM, the netX Driver usually is already selected 
by default. If this is not the case, activate the check box in front of the 
netX driver. 

 

 Click OK or Apply. 
 

3. Set IP address of netHOST in netX Driver. 
 In the Navigation Area, select Settings > Driver > netX Driver. 
 The netX Driver dialog window opens.  
 Select TCP Connection tab: 
 

 
Figure 39: Set IP Address in netX Driver  
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 Make sure the Enable TCP Connector option is selected (check box 
must be activated). 

 Click on  button next to the Select IP Range drop-down list. 
 In the IP Address field, enter the IP address which you have assigned 

to the netHOST device with the Ethernet Device Configuration Tool 
(see Assigning Temporary IP Address to netHOST Device section on 
page 24).  

 

 
Note: You will find a detailed description of this dialog in the netX Driver 
Dialog Window section on page 114. 

 

 Click Save. 
 

4. Assign netHOST device. 
 In the Navigation Area, select Settings > Device Assignment. 
 The Device Assignment dialog window opens.  
 In the Device selection drop-down list, choose suitable only entry. 
 Click Scan. 
 If all prerequisites are fulfilled (see Prerequisites section on page 49) 

and the IP address has been properly set in the netX Driver, the 
netHOST device will now be found and displayed in the list.  

 

 
Figure 40: Select Device  

 

 Activate the check box in front of the netHOST device. 
 Click Apply. 



Configuring the netHOST Step-By-Step 55/160 

Configuration of LAN Controlled Master Devices | netHOST  
DOC130402OI05EN | Revision 5 | English | 2017-03 | Released | Public  © Hilscher 2013 - 2017 

 

 
Note: You can create and edit a configuration project for the netHOST 
device without being actually connected to the device via Ethernet LAN. 
In this case, no netHOST device will be found in the Device Assignment 
dialog window. For downloading the configuration, however, you 
eventually need an Ethernet LAN connection to the netHOST device, and 
then you also need to assign the device in this dialog window. 

 

7.2.2.3 Configuring Ethernet Marshalling 
1. Open the configuration window for the Ethernet Marshalling. 
 Select the netHOST symbol, then choose Configuration > Ethernet 

Marshalling from the context menu (to open context menu, right-click 
on the netHOST symbol). 

 

 
Figure 41: Open Configuration Dialog for Primary Network 
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 The General dialog of the Ethernet Marshalling configuration opens: 
 

 
Figure 42: Setting IP Address (1) 

 

2. Set IP parameters. 
 In the Extras section, uncheck the DHCP option to deactivate the 

assignment of the IP address by DHCP server. This enables you to set 
the address parameters manually. 

 The Enable check boxes can now be selected. 
 Select Enable option for each of the address parameters that you want 

to configure here. 
 

 
Figure 43: Setting IP Address (2) 
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 Enter the IP address parameters. 
 

 
Note: The IP address which you configure here will be stored “non-
volatile” (i. e. permanently) in the netHOST device after download – 
unlike the temporary address which you before have assigned with the 
Ethernet Device Configuration Tool. If this new permanent address differs 
from the old temporary address, and if you later want to re-establish a 
connection between SYCON.net and the netHOST device after 
downloading the configuration, you need to enter this new permanent 
address (which now has become valid) in the netX Driver dialog window 
(see step 3: “Set IP address of netHOST in netX Driver” in the previous 
section), thus overwriting the obsolete old temporary IP address assigned 
by the Ethernet Device Configuration Tool. Otherwise you won’t be able 
to re-establish a connection between SYCON.net and the new IP address 
of the netHOST device. 
At least during testing, it is recommended to work with a fixed IP address. 
It is, however, possible to have the netHOST device receive its IP 
address from a BOOTP or DHCP server utility.   
If you choose the BootP or DHCP options in the dialog window by 
activating the corresponding check boxes, the manually entered address 
parameters stay (remain) in the dialog fields, but they are not 
authoritative any longer. Thus, if you later want to re-use the manually 
entered address parameters, just uncheck BootP or DHCP options and 
enable the address parameters. 

 
 Click OK to close the Ethernet Marshalling dialog window. 
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7.2.2.4 Adding and Configuring Slave Devices in Fieldbus 
 

 
Note: In this manual, the Hilscher CB-AB32-DPS IO test board serves as 
example of a slave device in the PROFIBUS DP network (secondary 
network). 
Should any other device that you might want to add and configure as 
slave in your Fieldbus not be listed in the Device Catalog of SYCON.net, 
you have to import the corresponding device description file into 
SYCON.net. Instructions for this can be found in the Importing Device 
Description Files into SYCON.net chapter on page 95.  

 
1. Add PROFIBUS DP slave. 
 In the Fieldbus tab of the device catalog (right window), open folder 

PROFIBUS DPV0 > Slave. 
 Select CB_AB32-DPS device, then drag it into the middle window and 

drop it onto the line symbolizing the secondary network (next to the 
netHOST symbol). 

 

 
Figure 44: Add Slave Device 

 The device is displayed as slave in the PROFIBUS (secondary network) 
line. 

 

2. Configure PROFIBUS DP slave. 
 To open the configuration dialog window, double-click the slave device 

on the secondary bus line, or select the device, then choose 
Configuration… from the context menu (to open context menu, right-
click on the slave symbol). 
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 The configuration dialog window of the PROFIBUS DP slave opens: 
 

 
Figure 45: Configure Slave Device 

 Configure the slave device. 
 

 
Detailed instructions on how to configure a slave device in the fieldbus 
network can be found in the operating instruction manual of the 
corresponding slave DTM. The slave DTM manuals are stored on the 
netHOST Solutions DVD in the directory 
Documentation\english\1.Software\SYCON.net 
Configuration Software\Master 
Configuration\[protocol]\Slave Configuration. 
For our PROFIBUS DP example, you need the operating instruction 
manual Generic Slave DTM for PROFIBUS DP Slave Devices, 
DOC031001OIxxEN.  
As an alternative, you can open the corresponding online help by clicking 
the Help button in the opened configuration dialog window of the slave 
DTM, or by pressing the F1 key on your keyboard. 

 
 Click OK to close the dialog window. 
 Repeat this process for each slave device in the Fieldbus. 
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7.2.2.5 Configuring Fieldbus Master 
1. Open the configuration dialog window of the PROFIBUS DP master. 
 Select the netHOST symbol, then choose Configuration > PROFIBUS 

DP Master from the context menu (to open context menu, right-click on 
the netHOST symbol). 

 The Bus Parameters dialog of the PROFIBUS DP Master 
configuration window opens: 

 

 
Figure 46: PROFIBUS DP Master – Bus Parameters  

 

2. Configure PROFIBUS DP bus parameters. 
 Set the bus parameters.  
 

 
Detailed instructions on how to configure the master device in the 
Fieldbus network can be found in the operating instruction manual of the 
corresponding master DTM. The master DTM manuals are stored on the 
netHOST Solutions DVD in the directory 
Documentation\english\1.Software\SYCON.net 
Configuration Software\Master 
Configuration\[protocol]. 
For our PROFIBUS DP example, you need the operating instruction 
manual DTM for Hilscher-PROFIBUS DP Master Devices, 
DOC070401OIxxEN. 
As an alternative, you can open the corresponding online help by 
clicking the Help button in the opened configuration dialog window of the 
slave DTM, or by pressing the F1 key on your keyboard. 

 
 Click Apply. 
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3. Define addresses of the stations. 
 In the Navigation Area, select Configuration > Station Table. 
 The Station Table dialog opens: 
 

 
Figure 47: PROFIBUS DP Slave Station Address 

 In the Station Address fields, enter an individual station address for 
each slave device. 

 Click OK to close the PROFIBUS DP Master configuration dialog. 
 You can now save the completed configuration project on your 

configuration PC, and then download the configuration to the netHOST 
device. 

 

4. Save project on configuration PC. 
 

 
Note: Save the project on your configuration PC after you have 
completed the configuration. Thus, you can later edit the project and 
reload it into the netHOST device or into a different (e. g. a substitute) 
device. Configuration projects stored only in a netHOST device can not 
be “read back” into SYCON.net. 

 

 In the menu, choose File > Save or Save as… to save the 
configuration project, or click  symbol. 
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7.2.2.6 Loading Configuration into netHOST Device 
1. Start SYCON.net. 
 In the Windows Start menu, select All Programs > SYCON.net 

System Configurator > SYCON.net. 
 

2. Open configuration project. 
 In the menu of SYCON.net, choose File > Open… to open the project. 
 

3. Download configuration to netHOST. 
 Select netHOST symbol, then choose Download from the context 

menu (to open context menu, right-click on the netHOST symbol). 
 

 
Figure 48: Download Configuration 

 
 

 
Hazard of device damage by disruption of voltage supply during 
configuration download! 
Do not interrupt the voltage supply while downloading the configuration to 
the netHOST. Power failure during a writing process in the file system can 
cause severe malfunctioning of the device. 

 
 Answer the security question with Yes. 
 The configuration file is downloaded to the netHOST. After the 

download has been completed, the netHOST device automatically 
resets itself. 



Configuring the netHOST Step-By-Step 63/160 

Configuration of LAN Controlled Master Devices | netHOST  
DOC130402OI05EN | Revision 5 | English | 2017-03 | Released | Public  © Hilscher 2013 - 2017 

 

 
Note: By default, the start of the bus communication is controlled by the 
application. In the Master Settings dialog window of the Fieldbus Master 
DTM you can configure whether the bus communication is to be started 
automatically by the device itself or whether it is to be started by the 
application. To open the Fieldbus Master DTM, right-click netHOST 
symbol, then choose Configuration -> [Fieldbus system] Master) from 
the context menu.   
How to start Fieldbus communication manually in the netHOST Device 
Test Application is described in section Testing Communication of 
netHOST for RTE Systems: NHST-T100-EN/PNM Example on page 86. 
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7.3 Configuring netHOST for RTE Systems with SYCON.net: 
NHST-T100-EN/PNM Example 

In this example for PROFINET IO, a pre-configured PC card CIFX 50-
RE/PNS serves as IO Device (slave device) in the RTE network. 

7.3.1 Prerequisites  
• You have installed SYCON.net on your configuration PC. 
• You have the user right Maintenance, Planning Engineer or 

Administrator in SYCON.net. 
• The slave devices have been configured properly and you know the 

required configuration parameters of the slaves. In this example for 
PROFINET IO, you must know the “name of station” of each IO Device 
and the number of bytes of the input/output modules. 

• If the slave devices you want to add to the RTE network are missing in 
the device catalog of SYCON.net, you first have to import the device 
description files of these devices into SYCON.net. Instructions for this 
can be found in the Importing Device Description Files into SYCON.net 
chapter on page 95. 

• You have assigned a suitable temporary IP address to the netHOST 
device (see section Assigning Temporary IP Address to netHOST 
Device on page 24). 

• The netHOST device is connected to a voltage supply. 
• The configuration PC and the netHOST device are connected to the 

same local TCP/IP (Ethernet LAN) network. 
 

 
Note: Plug-in the Ethernet LAN cable in the single RJ45 socket on the 
right side of the device (X3 interface). 

 

7.3.2 Step-By-Step Instructions  
7.3.2.1 Creating New netHOST Project in SYCON.net 

1. Start SYCON.net configuration software. 
 In the Windows Start menu, select All Programs > SYCON.net 

System Configurator > SYCON.net. 
 A login dialog appears: 
 

 
Figure 49: SYCON.net Login 

 Enter your password, then click OK. 
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 SYCON.net opens with a new empty project: 
 

 
Figure 50: Empty Project in SYCON.net  

 

2. Add netHOST device to the configuration project. 
 In the Vendor tab of the Device Catalog (right window), open folder 

Hilscher GmbH > Master. 
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 Then select NHST-T100-EN/PNM device and drag & drop it onto the 
bus configuration line in the SYCON.net configuration window (middle 
window):  

 

 
Figure 51: Add netHOST Device in Configuration Project 

 

 The netHOST device appears in the project: 
 

 
Figure 52: netHOST Device in Configuration Project 
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3. Save project. 
 In the menu, choose File > Save As to save the netHOST configuration 

project. 
 

7.3.2.2 Assigning Device to Driver and Configuring Driver 
1. Open the netHOST configuration window (i. e. the netHOST DTM). 
 Double-click the netHOST symbol in the bus configuration line or select 

the netHOST symbol and choose Configuration > Main Settings from 
the context menu (to open context menu, right-click on the netHOST 
symbol). 

 The netHOST DTM opens with the Device Assignment dialog window. 
SYCON.net automatically starts to search for connected devices. 

 

 
Figure 53: Scanning for Devices in SYCON.net 

 Because the netX Driver (which enables the Ethernet LAN connection 
to the netHOST device) is not yet acquainted with the IP address of the 
device, the netHOST is not found for the time being.  

 

2. Select driver. 
 In the Navigation Area, select Settings > Driver. 



Configuring the netHOST Step-By-Step 68/160 

Configuration of LAN Controlled Master Devices | netHOST  
DOC130402OI05EN | Revision 5 | English | 2017-03 | Released | Public  © Hilscher 2013 - 2017 

 

 The Driver dialog window opens. It lists all available drivers: 
 

 
Figure 54: Select Driver  

 Make sure the netX Driver is selected (check box must be activated). 
 

 
Note: In the netHOST DTM, the netX Driver usually is already selected 
by default. If this is not the case, activate the check box in front of the 
netX driver. 

 

 Click OK or Apply. 
 

3. Set IP address of netHOST in netX Driver. 
 In the Navigation Area, select Settings > Driver > netX Driver. 
 The netX Driver dialog window opens.  
 Select TCP Connection tab: 
 

 
Figure 55: Set IP Address in netX Driver  
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 Make sure the Enable TCP Connector option is selected (check box 
must be activated). 

 Click on  button next to the Select IP Range drop-down list. 
 In the IP Address field, enter the IP address which you have assigned 

to the netHOST device with the Ethernet Device Configuration Tool 
(see Assigning Temporary IP Address to netHOST Device section on 
page 24).  

 

 
Note: You will find a detailed description of this dialog in the netX Driver 
Dialog Window section on page 114. 

 
 Click Save. 
 

4. Assign netHOST device. 
 In the Navigation area, select Settings > Device Assignment. 
 The Device Assignment dialog window opens.  
 In the Device selection drop-down list, choose suitable only entry. 
 Click Scan. 
 If all prerequisites are fulfilled (see Prerequisites section on page 49) 

and the IP address has been properly set in the netX Driver, the 
netHOST device will now be found and displayed in the list.  

 

 
Figure 56: Select Device 
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 Activate the check box in front of the netHOST device. 
 Click Apply. 
 

 
Note: You can create and edit a configuration project for the netHOST 
device without being actually connected to the device via Ethernet LAN. 
In this case, no netHOST device will be found in the Device Assignment 
dialog window. For downloading the configuration, however, you 
eventually need an Ethernet connection to the netHOST device, and then 
you also need to assign the device in this dialog window. 

 

7.3.2.3 Configuring Ethernet Marshalling 
1. Open the configuration window for the Ethernet Marshalling. 
 Select the netHOST symbol, then choose Configuration > Ethernet 

Marshalling from the context menu (to open context menu, right-click 
on the netHOST symbol). 

 

 
Figure 57: Open Configuration Dialog for Ethernet Marshalling 
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 The General dialog of the Ethernet Marshalling configuration opens: 
 

 
Figure 58: Setting IP Address (1) 

 

2. Set IP parameters. 
 In the Extras section, uncheck the DHCP option to deactivate the 

assignment of the IP address by DHCP server. This enables you to set 
the address parameters manually. 

 The Enable check boxes can now be selected. 
 Select Enable option for each of the address parameters that you want 

to configure here. 
 

 
Figure 59: Setting IP Address (2) 



Configuring the netHOST Step-By-Step 72/160 

Configuration of LAN Controlled Master Devices | netHOST  
DOC130402OI05EN | Revision 5 | English | 2017-03 | Released | Public  © Hilscher 2013 - 2017 

 

 Enter the IP address parameters. 
 

 
Note: The IP address which you configure here will be stored “non-
volatile” (i. e. permanently) in the netHOST device after download – 
unlike the temporary address which you before have assigned with the 
Ethernet Device Configuration Tool. If this new permanent address differs 
from the old temporary address, and if you later want to re-establish a 
connection between SYCON.net and the netHOST device after 
downloading the configuration, you need to enter this new permanent 
address (which now has become valid) in the netX Driver dialog window 
(see step 3: “Set IP address of netHOST in netX Driver” in the previous 
section), thus overwriting the obsolete old temporary IP address assigned 
by the Ethernet Device Configuration Tool. Otherwise you won’t be able 
to re-establish a connection between SYCON.net and the new IP address 
of the netHOST device. 
At least during testing, it is recommended to work with a fixed IP address. 
It is, however, possible to have the netHOST device receive its IP 
address from a BOOTP or DHCP server utility.   
If you choose the BootP or DHCP options in the dialog window by 
activating the corresponding check boxes, the manually entered address 
parameters stay (remain) in the dialog fields, but they are not 
authoritative any longer. Thus, if you later want to re-use the manually 
entered address parameters, just uncheck BootP or DHCP options and 
enable the address parameters. 

 
 Click OK to close the dialog window. 
 

7.3.2.4 Adding and Configuring IO Devices (Slaves) in RTE Network 
 

 
Note: In this example for PROFINET IO, the Hilscher PC card cifX serves 
as example of a slave device in the RTE network. The PC card has 
already been loaded with firmware and a proper IO device configuration; 
therefore downloading firmware and configuration files to the cifX card 
are not described here. 
Should any other device which you might want to add and configure as 
slave in your RTE network not be listed in the Device Catalog of 
SYCON.net, you have to import the corresponding device description file 
into SYCON.net. Instructions for this can be found in the Importing Device 
Description Files into SYCON.net chapter on page 95.  

 
1. Add PROFINET IO Device. 
 In the Fieldbus tab of the device catalog (right window), open folder 

PROFINET IO > Slave. 
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 Select CIFX RE/PNS V3.4.19 – V3.4.x device, then drag it into the 
middle window and drop it onto the line symbolizing the RTE network 
(next to the netHOST symbol). 

 

 
Figure 60: Add IO Device to RTE Network 

 

 The PROFINET IO Device (i. e. the PC Card cifX) is displayed as slave 
in the RTE network line. 
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2. Configure PROFINET IO Device. 
 To open the configuration dialog window, double-click the slave device 

on the RTE bus line, or select the device, then choose Configuration… 
from the context menu (to open context menu, right-click on the device 
symbol). 

 The Modules configuration dialog window of the PROFINET IO Device 
opens: 

 

 
Figure 61: Configure IO Device (1) 

 

 Click Add Module button to add a module for input data.  
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 Click in the Module field of the newly added module, then select the 
number of input bytes of your IO Device from the drop-down list. In this 
example, the PC card cifX has 16 Bytes Input and 16 Bytes Output 
data. Therefore select 16 Bytes Input from the drop-down list. 

 

 
Figure 62: Configure IO Device (2) 

 

 Click Add Module button again to add a module for the output data.  
 Click in the Module field of the newly added module, then select 16 

Byte Output from the drop-down list. 
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Figure 63: Configure IO Device (3) 

 

 
Detailed information on how to configure a slave device in the Real-Time 
Ethernet network can be found in the operating instruction manual of the 
corresponding slave DTM. The slave DTM manuals are stored on the 
netHOST Solutions DVD in the directory 
Documentation\english\1.Software\SYCON.net 
Configuration Software\Master 
Configuration\[protocol]\[Slave Configuration]. 
For our PROFINET IO example, you need the operating instruction 
manual Generic DTM for PROFINET IO Devices, DOC060305OIxxEN.  
As an alternative, you can open the corresponding online help by clicking 
the Help button in the opened configuration dialog window of the slave 
DTM, or by pressing the F1 key on your keyboard. 

 
 Click OK to close the dialog window. 
 You have configured the I/O data of the PROFINET IO Device. 
 

Repeat this process for each slave device in the RTE network. 
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7.3.2.5 Configuring IO Controller (Master) of RTE Network 
 

 
Note: In this example you do not need to change the default settings of 
the IO Controller configuration. 

 
1. Open the configuration dialog window of the PROFINET IO Controller. 
 Select the netHOST symbol, then choose Configuration > PROFINET 

IO Controller from the context menu (to open context menu, right-click 
on the netHOST symbol). 

 The Controller Network Settings dialog of the PROFINET IO 
Controller configuration window opens: 

 

 
Figure 64: PROFINET IO Controller – Network Settings  

 

2. Check or change (if necessary) the IO Controller settings. 
 Navigate through the configuration dialog windows and check or 

change individual parameters, if necessary.  
 

 
Detailed information on how to configure the master device in the RTE 
network can be found in the operating instruction manual of the 
corresponding master DTM. The master DTM manuals are stored on the 
netHOST Solutions DVD in the directory 
Documentation\english\1.Software\SYCON.net 
Configuration Software\Master 
Configuration\[protocol]. 
For the PROFINET IO Controller, for instance, you need the operating 
instruction manual DTM for Hilscher-PROFINET IO-Controller Devices, 
DOC060302OIxxEN. 
As an alternative, you can open the corresponding online help by 
clicking the Help button in the opened configuration dialog window of the 
slave DTM, or by pressing the F1 key on your keyboard. 
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 After having finished the configuration, click Apply, respectively OK. 
 

3. Save project on configuration PC. 
 

 
Note: Save the project on your configuration PC after you have 
completed the configuration. Thus, you can later edit the project and 
reload it into the netHOST device or into a different (e. g. a substitute) 
device. Configuration projects stored only in a netHOST device can not 
be “read back” into SYCON.net. 

 

 In the menu, choose File > Save or Save as… to save the 
configuration project, or click  symbol. 

 

7.3.2.6 Loading Configuration into netHOST Device 
1. Start SYCON.net. 
 In the Windows Start menu, select All Programs > SYCON.net 

System Configurator > SYCON.net. 
 

2. Open configuration project. 
 In the menu of SYCON.net, choose File > Open… to open the project. 
 

3. Download configuration to netHOST. 
 Select netHOST symbol, then choose Download from the context 

menu (to open context menu, right-click on the netHOST symbol). 
 

 
Figure 65: Download Configuration 
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Hazard of device damage by disruption of voltage supply during 
configuration download! 
Do not interrupt the voltage supply while downloading the configuration to 
the netHOST. Power failure during a writing process in the file system can 
cause severe malfunctioning of the device. 

 
 Answer the security question with Yes. 
 The configuration file is downloaded to the netHOST. After the 

download has been completed, the netHOST device automatically 
resets itself. 

 

 
Note: By default, the start of the communication of the RTE systems 
PROFINET IO and EtherNet/IP is controlled by the application; EtherCAT 
communication on the other hand is started automatically by the device. 
In the Master Settings dialog window of the RTE Master DTM you can 
configure whether the bus communication is to be started automatically 
by the device itself or whether it is to be started by the application. To 
open the RTE Master DTM, right-click netHOST symbol, then choose 
Configuration -> [RTE system] Master) from the context menu.  
For PROFINET IO: open Controller Settings dialog window,   
for Ethernet/IP: open Scanner Settings dialog window  
for EtherCAT: open General dialog window,  
then set the start of the bus communication according to your needs.  
How to start RTE communication manually in the netHOST Device Test 
Application is described in section Testing Communication of netHOST 
for RTE Systems: NHST-T100-EN/PNM Example on page 86. 
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8 Testing Communication Step-By-Step 
8.1 Testing Communication of netHOST for Fieldbus: NHST-

T100-DP/DPM Example 
This chapter describes how to use the Hilscher netHOST Device Test 
Application to test the bus communication of the netHOST acting as 
master in a PROFIBUS DP network. 

8.1.1 Prerequisites 
• You have inserted the netHOST Solutions DVD (on which the netHOST 

Device Test Application is stored) into the DVD drive of your Windows 
PC/notebook. Alternatively, you can copy the netHOST Test folder 
(stored on the DVD in the Setups & Drivers directory) from the 
DVD to a local drive of your Windows PC/notebook. 

• The Windows PC/notebook and the netHOST device are connected to 
the same Ethernet LAN. 

• The netHOST device and the fieldbus slave devices are connected to 
the Fieldbus, are properly configured and supplied with voltage. 

8.1.2 Step-By-Step Instructions 
 

1. Start netHOST Device Test Application. 
 Insert the netHOST Solutions DVD into your local DVD ROM drive. 
 The netHOST Solutions start screen opens. 
 In the menu of the start screen, choose Run Windows Test 

Application. 
 

 
Note: As an alternative, you can also start the Test Application by double-
clicking the netHOST.exe file stored in the netHOST Test folder. 

 

 netHOST Device Test Application opens.  
 

 
Figure 66: Start netHOST Device Test Application 
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2. Check TCP/IP settings of the netX Driver. 
 In the menu, choose Device > Setup. 
 The Connector Configuration dialog opens.  
 Choose TCP Connection tab: 
 

 
Figure 67: TCP Connection netX Driver  

 

 Check whether the IP Address field displays the actual address of the 
netHOST. If not, enter the correct address. 

 

 
Note: The netHOST Device Test Application uses the same netX Driver 
parameters as SYCON.net. If you have already configured the right IP 
address in the netX Driver dialog window in SYCON.net, this address is 
also displayed and taken over by the netHOST Device Test Application. 

 

 Click OK. 
 The Connector Configuration dialog closes.  
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3. Open communication channel. 
 In the menu, choose Device > Open. 
 The Test Application establishes an Ethernet connection to the 

netHOST. This may take a few seconds. Afterwards, the Channel 
Selection dialog window opens: 

 

 
Figure 68: Channel Selection in netHOST Device Test Application  

 In the navigation tree on the left side, select Channel1 entry. This is the 
channel of the fieldbus master, in this case the PROFIBUS DP master. 

 

 
Important: Please note that in netHOST devices for Fieldbus (NHST-
T100-DP/DPM, NHST-T100-CO/COM and NHST-T100-DN/DNM),  
the communication stack of the Fieldbus master is always located in 
Channel 1. 
On the other hand, in netHOST devices for Real-Time Ethernet systems 
(NHST-T100-EN/PNM, NHST-T100-EN/ECM and NHST-T100-EN/EIM), 
the communication stack of the RTE master is always located in  
Channel 0. 

 
 In the right part of the dialog window, the device parameters of the 

connected netHOST are displayed. 
 

 
Note: You can check whether you are connected to the right device by 
comparing the number indicated in the Serial Number field with the serial 
number printed on the device label of the netHOST. 

 
 Click Open. 
 The Channel Selection dialog window closes. The opened channel 

afterwards is displayed in the header of the netHOST Device Test 
Application. 



Testing Communication Step-By-Step 83/160 

Configuration of LAN Controlled Master Devices | netHOST  
DOC130402OI05EN | Revision 5 | English | 2017-03 | Released | Public  © Hilscher 2013 - 2017 

 

4. Start bus communication. 
 In the menu, choose Device > Bus State. 
 The Bus State Test dialog window opens: 
 

 
Figure 69: Bus State Test in netHOST Device Test Application 

 In the New Bus State drop-down list, select Bus ON option. 
 Click Set Bus State. 
 The fieldbus communication is being started. 
 

5. Read and write I/O data. 
 In the menu, choose Data Transfer > I/O Data. 
 The Process Data I/O Image dialog window opens: 
 

 
Figure 70: I/O Data in netHOST Device Test Application 

 

 In the Length field of the Process Data Input Image area, enter the 
number of bytes to be displayed. 

 Then click into the Data field. 
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 Make sure that one or several slave devices belonging to the secondary 
network (i. e. slaves in the fieldbus) produce output signals, which then 
in turn will be displayed as incoming data in the Data field in the 
Process Data Input Image area of the Test Application. In our 
configuration example using the CB-AB32-DPS IO test board as 
fieldbus slave device, you can, for instance, press the S1 button on the 
test board. 

 The signal of the slave device is being displayed in the Data field. 
 

 
Figure 71: Displaying Input Data in the netHOST Device Test Application 

 In the Data field of the Process Data Output Image area, enter output 
data that can be sent to the slave device and trigger an event there. In 
our configuration example using the CB-AB32-DPS IO test board as 
fieldbus slave device for instance, you can enter the value 02 00. 

 Then click Update. 
 

 
Figure 72: Entering Output Data in the netHOST Device Test Application 

 At the slave device, the corresponding Bits are being received. (In our 
configuration example using the CB-AB32-DPS IO test board as 
fieldbus slave device for instance, the OUT LED at S2 lights up.) 



Testing Communication Step-By-Step 85/160 

Configuration of LAN Controlled Master Devices | netHOST  
DOC130402OI05EN | Revision 5 | English | 2017-03 | Released | Public  © Hilscher 2013 - 2017 

 

6. End testing. 
 In the menu, choose Device > Bus State. 
 The Bus State Test dialog window opens. 
 In the New Bus State drop-down list, select Bus OFF option, then click 

Set Bus State. 
 In the menu, choose Device > Close to close the communication 

channel. 
 In the menu, choose File > Quit to exit the netHOST Device Test 

Application. 
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8.2 Testing Communication of netHOST for RTE Systems: 
NHST-T100-EN/PNM Example 

This chapter describes how to use the Hilscher netHOST Device Test 
Application to test the bus communication of the netHOST acting as IO 
Controller in a PROFINET network. In this example a PC card CIFX 50-
RE/PNS is used as IO device and the cifX Test Application (which is part 
of the cifX driver installed on the PC hosting the cifX card) serves as slave 
application. 

8.2.1 Prerequisites 
• You have inserted the netHOST Solutions DVD (on which the netHOST 

Device Test Application is stored) into the DVD drive of your Windows 
PC/notebook. Alternatively, you can copy the netHOST Test folder 
(stored on the DVD in the Setups & Drivers directory) from the 
DVD to a local drive of your Windows PC/notebook. 

• The Windows PC/notebook and the netHOST device are connected to 
the same local Ethernet LAN. 

• The netHOST device and the slave devices are connected to the Real-
Time Ethernet network, are properly configured and supplied with 
voltage. 

• For this example you need a CIFX 50-RE/PNS serving as IO device and 
the cifX Test Application (which is part of the cifX driver installed on 
the PC hosting the cifX card). 

8.2.2 Step-By-Step Instructions 
1. Start netHOST Device Test Application. 
 Insert the netHOST Solutions DVD into your local DVD ROM drive. 
 The netHOST Solutions start screen opens. 
 In the menu of the start screen, choose Run Windows Test 

Application. 
 

 
Note: As an alternative, you can also start the Test Application by double-
clicking the netHOST.exe file stored in the netHOST Test folder. 

 

 netHOST Device Test Application opens.  
 

 
Figure 73: Start netHOST Device Test Application 
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2. Check TCP/IP settings of the netX Driver. 
 In the menu, choose Device > Setup. 
 The Connector Configuration dialog opens.  
 Choose TCP Connection tab: 
 

 
Figure 74: TCP Connection netX Driver  

 

 Check whether the IP Address field displays the actual address of the 
netHOST. If not, enter the correct address. 

 

 
Note: The netHOST Device Test Application uses the same netX Driver 
parameters as SYCON.net. If you have already configured the right IP 
address in the netX Driver dialog window in SYCON.net, this address is 
also displayed and taken over by the netHOST Device Test Application. 

 
 Click OK. 
 The Connector Configuration dialog closes.  
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3. Open communication channel. 
 In the menu, choose Device > Open. 
 The Test Application establishes an Ethernet connection to the 

netHOST. This may take a few seconds. Afterwards, the Channel 
Selection dialog window opens: 

 

 
Figure 75: Channel Selection in netHOST Device Test Application  

 In the navigation tree on the left side, select Channel0 entry. This is the 
channel of the RTE master, in this case the PROFINET IO Controller. 

 

 
Important: Please note that the communication stack of the RTE master 
in netHOST devices for Real-Time Ethernet systems (NHST-T100-
EN/PNM, NHST-T100-EN/ECM and NHST-T100-EN/EIM) is always 
located in Channel 0. 
On the other hand, in netHOST devices for Fieldbus (NHST-T100-
DP/DPM, NHST-T100-CO/COM and NHST-T100-DN/DNM), the Fieldbus 
master is always located in Channel 1. 

 
 In the right part of the dialog window, the device parameters of the 

connected netHOST are displayed. 
 

 
Note: You can check whether you are connected to the right device by 
comparing the number indicated in the Serial Number field with the serial 
number printed on the device label of the netHOST. 

 
 Click Open. 
 The Channel Selection dialog window closes. The opened channel 

afterwards is displayed in the header of the netHOST Device Test 
Application. 
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4. Start bus communication. 
 In the menu, choose Device > Bus State. 
 The Bus State Test dialog window opens: 
 

 
Figure 76: Bus State Test in netHOST Device Test Application 

 In the New Bus State drop-down list, select Bus ON option. 
 Click Set Bus State. 
 Communication of the RTE network is being started. 
 

5. Read and write I/O data. 
 In the menu, choose Data Transfer > I/O Data. 
 The Process Data I/O Image dialog window opens: 
 

 
Figure 77: I/O Data in netHOST Device Test Application 
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 In the Length field of the Process Data Input Image area, enter the 
number of bytes to be displayed. 

 Then click into the Data field. 
 

 
Note: Make sure that one or several slave devices belonging to the RTE 
network) produce output signals, which then in turn will be displayed as 
incoming data in the Data field in the Process Data Input Image area of 
the Test Application. Using the PC card CIFX 50-RE/PNS as IO Device, 
the following steps describe how to use the cifX Test Application (which 
is part of the cifX driver installed on the PC hosting the cifX card) for this.  

 
6. Open the cifX Test Application on your PC. 
 In the Windows Start menu of the PC hosting your PC card cifX, 

choose Control Panel > cifX Test. 
 The cifX Test Application opens:  
 

 
Figure 78: Start cifX Test Application 

 

7. Open connection to PC Card cifX in cifX Test Application. 
 In the menu, choose Device > Open. 
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 The cifX Test Application establishes a connection to the PC card via 
cifX driver and PCI interface. After a while, the Channel Selection 
dialog box opens: 

 

 
Figure 79: Channel Selection Dialog in cifX Test Application 

 

 In the left part of the dialog box, select Channel0. This is the channel of 
the PROFINET IO Device. 

 Click Open button.  
 The Channel Selection dialog box closes. The header of the cifX Test 

Application now displays the selected channel: 
 

 
Figure 80: cifX Test Application After Channel Selection 
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8. Send output data. 
 In the menu of the cifX Test Application, choose Data Transfer > I/O 

Data. 
 The Process Data I/O Image dialog window opens: 
 

 
Figure 81: I/O Data Dialog in cifX Test Application (1) 

 

 In the Data field of the Process Data Output Image area, enter output 
data that can be sent to the PROFINET IO Controller (i. e. the 
netHOST) in order to be displayed in the netHOST Device Test 
Application. 

 

 
Figure 82: I/O Data Dialog in cifX Test Application (2) 

 

 After having entered the output data, click Update. 
 The data is sent from the IO Device (i. e. the PC card cifX) to the IO 

Controller (i. e. the netHOST) via PROFINET network. 
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9. Read I/O data from IO Device in netHOST Device Test Application. 
 Change to the netHOST Device Test Application. 
 The incoming data from the IO Device is displayed in the Data field in 

the Process Data Input Image area: 
 

 
Figure 83: Displaying Incoming Data in netHOST Device Test Application 

 

10. Send Output data from IO Controller to IO Device. 
 In the Data field of the Process Data Output Image of the netHOST 

Device Test Application, enter output data that can be sent to the IO 
Device. 

 Click Update Button. 
 

 
Figure 84: Entering Output Data in netHOST Device Test Application 
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11. Display input data in cifX Test Application. 
 Change to the cifX Test Application. 
 In the Length field of the Process Data Input Image area, enter the 

number of bytes to be displayed. Then click into the Data field. 
 The incoming signals of the IO Controller are being displayed in the 

Data field: 
 

 
Figure 85: Displaying Input Data in cifX Test Application 

 

12. End testing. 
 In the menu of the netHOST Device Test Application, choose Device > 

Bus State. 
 The Bus State Test dialog window opens. 
 In the New Bus State drop-down list, select Bus OFF option, then click 

Set Bus State. 
 In the menu, choose Device > Close to close the communication 

channel. 
 In the menu, choose File > Quit to exit the netHOST Device Test 

Application. 
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9 Importing Device Description Files into SYCON.net 
This section is only relevant to you if the slave device, which you want to 
add to your netHOST configuration project in SYCON.net, is not listed in 
the device catalog of SYCON.net. In this case, you have to import the 
device description file of the slave device into SYCON.net. To do so, 
proceed as follows: 
 

 Open your netHOST configuration project in SYCON.net.  
 In the SYCON.net menu, choose Network > Import Device 

Descriptions… 
 The following dialog window opens: 
 

 
Figure 86: Import Device Description File (PROFIBUS GSD Example) 

 In the Files of type drop-down list, select the appropriate file type for 
the fieldbus/RTE system. 

 Then navigate to the directory where the device description file is 
stored. 

 All device description files fitting the chosen type of fieldbus/RTE 
system are displayed in the dialog window. 

 Select the appropriate file, then click Open. 
 Answer the security question, whether you want to reload the catalog, 

with Yes. 
 You have imported the device description file into SYCON.net, and you 

can now add the device to the secondary network in your configuration 
project. 
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10 Updating Firmware with SYCON.net 
10.1 Overview 

With the exception of the NHST-T100-EN device (order no.: 1890.800), all 
netHOST devices are shipped with their firmware already loaded.   
In case updating the firmware of the netHOST becomes necessary, this 
chapter describes how to use the SYCON.net configuration software to do 
so. The NHST-T100-DP/DPM serves as example device in this chapter. 
Note that any configuration file and IP address stored in the netHOST 
device will be erased by the firmware update. The device falls back to its 
default 0.0.0.0 IP address, therefore you have to re-assign an IP address 
to the netHOST device with the Ethernet Device Configuration Tool 
before you can download a new configuration with SYCON.net (see 
Assigning Temporary IP Address to netHOST Device section on page 24). 
 

 
Note: Updating firmware with SYCON.net as described in this chapter is 
only possible if a firmware is running in the netHOST device. If the 
firmware inside the device is defective or altogether missing, you have to 
perform a so-called “firmware recovery” by using an SD memory card or a 
USB connection. Instructions on this can be found in the user manual 
netHOST NHST-T100 – LAN controlled master devices for Fieldbus and 
Real-Time Ethernet networks in the Firmware recovery chapter.  

 

10.2 Prerequisites for Updating Firmware with SYCON.net 
• You have installed SYCON.net on your configuration PC. 
• You have inserted the netHOST Solutions DVD into your local DVD 

drive or have access to the firmware file intended for download (e. g. you 
have stored the file on your configuration PC). 

• The configuration PC and the netHOST device are connected to the 
same local Ethernet network. 

• The netHOST device is connected to a voltage supply. 
• You know the IP address of the netHOST device. 
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10.3 Step-By-Step Instructions for Updating Firmware with 
SYCON.net 

1. Start SYCON.net configuration software. 
 In the Windows Start menu, select All Programs > SYCON.net 

System Configurator > SYCON.net. 
 A login dialog appears: 
 

 
Figure 87: SYCON.net Login 

 

 Enter your password, then click OK. 
 SYCON.net opens with a new empty project: 
 

 
Figure 88: Empty Project in SYCON.net 
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2. Open existing netHOST project or create a new project. 
 

 
Note: To download the firmware to the netHOST, you can use your 
already existing configuration project. If you don’t have access to the old 
configuration project file, you can create a provisional new project, 
consisting only of the netHOST symbol, and use this makeshift project to 
establish an online connection and download the firmware file to the 
device.  

 

 In the menu, choose File > Open… to open an existing netHOST 
project. 

 

OR 
 

 In the Vendor tab of the Device Catalog (right window), open folder 
Hilscher GmbH > Master. Then select the netHOST device (in this 
example the NHST-T100-DP/DPM) and drag & drop it onto the bus 
configuration line in the middle window.  

 

3. Open the netHOST configuration window (i. e. the netHOST DTM). 
 Double-click the netHOST symbol in the bus configuration line, or select 

the netHOST symbol and choose Configuration > Main Settings from 
the context menu (to open context menu, right-click on the netHOST 
symbol). 

 If you are using an existing netHOST project (for which the 
configuration of the driver and the device assignment had already taken 
place) the netHOST DTM now opens with the Settings dialog window, 
which features the download function. In this case, you can directly 
proceed with step 4 and start downloading the firmware. 

 

OR 
 

 If you have just now created a new project, the netHOST DTM opens 
with the Device Assignment dialog window and automatically starts to 
search for connected devices.  
In this case, you first have to assign the device and configure the driver 
before you can proceed to download the firmware in the Settings dialog 
window. Information on how to assign the device and configure the 
driver can be found in the Assigning Device to Driver and Configuring 
Driver section on page 52. 
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4. Browse for firmware. 
 In the Navigation Area, select Configuration > Settings. 
 The Settings dialog window opens: 
 

 
Figure 89: Settings Dialog  

 Click Browse button next to the Available Firmware field, in order to 
search for the appropriate firmware file. 
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 The Select Firmware File dialog opens: 
 

 
Figure 90: Select Firmware File Dialog in SYCON.net 

 Navigate to the directory where the firmware file is stored. Firmware 
files are stored on the netHOST Solutions DVD in the 
Firmware\netHOST directory.  
The subsequent table indicates which file belongs to which device: 

 

netHOST device Protocol (Fieldbus or RTE) Firmware file 
NHST-T100-DP/DPM PROFIBUS DP Master FT20V010.NXF 

NHST-T100-CO/COM CANopen Master FT20V040.NXF 

NHST-T100-DN/DNM DeviceNet Master FT20V060.NXF 

NHST-T100-EN/PNM PROFINET IO Controller FT20C0V0.NXF 

NHST-T100-EN/ECM EtherCAT Master FT20E0V0.NXF 

NHST-T100-EN/EIM EtherNet/IP Scanner FT20G0V0.NXF 

Table 16: netHOST Firmware  

 Select the appropriate firmware file, then click Open. 
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 Back in the Settings dialog window, the selected firmware file is now 
displayed in the Available Firmware field: 

 

 
Figure 91: Firmware Download in SYCON.net  

 

5. Download firmware to netHOST device. 
 In the Available Firmware field, select the firmware file. 
 Class and version of the software are displayed. 
 Check whether you have selected the appropriate firmware file. 
 

  
Hazard of device damage by disruption of voltage supply during 
firmware update! 
Do not interrupt the voltage supply while updating the firmware of the 
netHOST. Power failure during a writing process in the file system can 
cause severe malfunctioning of the device. 

 
 If you have selected the appropriate firmware file, click Download, to 

start downloading the file to the netHOST device. 
 The firmware is downloaded to the netHOST. 
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Note: Any configuration file and IP address stored in the netHOST device 
will be erased by the firmware download. The device falls back to its 
default 0.0.0.0 IP address, therefore you have to re-assign an IP 
address to the netHOST device afterwards with the Ethernet Device 
Configuration Tool. Instructions for this can be found in the Assigning 
Temporary IP Address to netHOST Device section on page 24. 
 
 To close the netHOST DTM, click OK or Cancel. 
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11 Using SD Memory Card to Copy Configuration Data 
into Spare netHOST Devices 

11.1 Overview 
With the Memory Card Management function of the netHOST DTM in 
SYCON.net, you can copy an already downloaded configuration together 
with the firmware and the IP address from the internal load memory of the 
netHOST device onto an SD memory card, which has been inserted into 
the netHOST device. Thus, you can “backup” this data to an external 
storage medium. Afterwards, you can remove the SD memory card from 
the netHOST device, insert it into other devices and thus copy the data into 
their internal load memory.   
By this method, you can easily bring several devices to an identical state of 
configuration (i. e. “clone” a primary device) without having each time to 
establish an online connection between the configuration PC (respectively 
SYCON.net) and the individual devices.  
This can be useful, e. g., if you want to prepare an identical “spare” device. 
This chapter describes this procedure using the NHST-T100-DP/DPM as 
example device. 

11.2 Prerequisites 
• SD memory card, FAT16 formatted. 
 

 
Note: The SD memory card is not included in the delivery of the netHOST 
device, but can be obtained from Hilscher, part number 1719.003. 

 

• A configuration has been downloaded to the netHOST device. 
• The Windows PC/Notebook with SYCON.net and the netHOST device 

are connected to the same local Ethernet network.  
• The netHOST device is connected to a voltage supply. 

11.3 Step-By-Step Instructions 
1. Start SYCON.net configuration software. 
 In the Windows Start menu, select All Programs > SYCON.net 

System Configurator > SYCON.net. 
 A login dialog appears: 
 

 
Figure 92: SYCON.net Login 

 

 Enter your password, then click OK. 
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 SYCON.net opens with a new empty project: 
 

 
Figure 93: Empty Project in SYCON.net  

 

2. Open existing netHOST project or create a new project. 
 

 
Note: You can use your already existing configuration project to establish 
an online connection between SYCON.net and the netHOST device, and 
to open the Memory Card Management dialog. If you don’t have access 
to the old configuration project file, you can create a provisional new 
project, consisting only of the netHOST symbol, and use this makeshift 
project to establish the online connection. 

 

 In the menu, choose File > Open… to open an existing netHOST 
project. 

 

OR 
 

 In the Vendor tab of the Device Catalog (right window), open folder 
Hilscher GmbH > Master. Then select NHST-T100-DP/DPM device 
and drag & drop it onto the bus configuration line in the middle window.  

 

3. Open the netHOST configuration window (i. e. the netHOST DTM). 
 Double-click the netHOST symbol in the bus configuration line, or select 

the netHOST symbol and choose Configuration > Main Settings from 
the context menu (to open context menu, right-click on the netHOST 
symbol). 

 If you are using an existing netHOST project, for which the configuration 
of the driver and the device assignment had already taken place, the 
netHOST DTM now opens with the Settings dialog window. In this 
case, you can directly proceed with step 4. 
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OR 
 

 If you have just now created a new project, the netHOST DTM opens 
with the Device Assignment dialog window and automatically starts to 
search for connected devices.  
In this case, you first have to assign the device and configure the driver 
before you can use the Memory Card Management dialog window to 
access the SD memory card inserted in the netHOST device. 
Information on how to assign the device and configure the driver can be 
found in the Assigning Device to Driver and Configuring Driver section 
on page 52. 

 

4. Copy configuration data from netHOST device to SD memory card. 
 In the Navigation Area, select Configuration > Memory Card 

Management. 
 The Memory Card Management dialog window opens. If no SD 

memory card has been inserted into the netHOST device, the Folder 
field in the Directory area of the dialog window displays the file system 
of the internal load memory of the netHOST device. 

 

 
Figure 94: Memory Card Management of the netHOST DTM  

 Insert the SD memory card into the netHOST device. 
 In order to refresh the display, close the Memory Card Management 

dialog window, then open it again. 
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 After having inserted the SD memory card into the netHOST device, the 
Folder field in the Directory area of the dialog window displays the file 
system of the internal load memory of the netHOST device. Below that, 
the file system of the SD memory card is displayed. Furthermore, the 
Restore and Backup buttons are now active and can be used: 

 

 
Figure 95: Memory Card Management After Inserting SD Memory Card 

 Click Backup to copy the data stored in the internal load memory of the 
netHOST to the SD memory card. 

 The data is copied to the SD memory card and is then displayed below 
SDMMC:\Backup in the Folder field: 

 

 
Figure 96: Memory Card Management After Backup to SD Memory Card 
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 Click OK to close the netHOST DTM. 
 Exit SYCON.net. 
 

5. Copy data from SD memory card to spare netHOST device. 
 Remove the SD memory card from the original netHOST device. 
 Insert the SD memory card into the spare device. 
 Connect spare device to voltage supply or briefly disconnect voltage 

supply (in case the device had already been connected to voltage 
supply). 

 The spare netHOST device then loads the data from the SD memory 
card into its own internal load memory. While loading, the SYS LED 
quickly alternates between green and yellow for approximately eight 
seconds, then shows steady yellow for approximately ten seconds, then 
is switched off for a short while before it finally shows steady green 
light.  
The device automatically starts the loaded firmware and the 
configuration. 

 Remove the SD memory card from the netHOST device. 
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12 Description of the netHOST DTM 
12.1 Overview 

The SYCON.net configuration software consists of an FDT frame 
application (FDT = Field Device Tool) and individual DTMs (Device Type 
Managers). DTMs are software modules with a graphical user interface for 
configuring a certain device within the FDT frame application. The DTM 
contains the specific device and protocol parameters needed for 
configuration. 
This chapter describes the control elements and parameters of the 
netHOST DTM contained in SYCON.net. 
 

 
SYCON.net provides a context-sensitive online help for the DTM which 
can be called up in the opened DTM by clicking the Help button or by 
pressing the F1 key on your keyboard. 

 

12.2 Description of the GUI 
This section describes the structure of the graphical user interface (GUI) of 
the netHOST DTM. The GUI is divided into five areas: 
 

 
Figure 97: GUI of the netHOST DTM 

 General Device Information  
 

Parameter Meaning 
IO Device Name of the device 

Vendor Vendor name of the device 

Device ID Identification number of the device 

Vendor ID Identification number of the vendor 

Table 17: General Device Information 
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 Navigation Area 
In the navigation area, you can open individual dialog windows of the DTM 
by clicking on an entry in the navigation tree. The entries are grouped into 
different categories and folders.   
Note that the categories/folders displayed in this area depend on whether 
there is an active online connection between SYCON.net and the netHOST 
device. If the netHOST DTM in SYCON.net has an online connection to the 
netHOST device, only the dialog windows for Diagnosis will be offered in 
the navigation area. If there is no active online connection, only the dialog 
windows belonging to the Settings and Configuration categories will be 
displayed here. 
 

 

By clicking on the  button, you can hide 
the navigation area. By clicking the 

 control element on the 
bottom left side of the currently opened 
dialog window, you can re-open the 
navigation area. 
 

Figure 98: Navigation Area of the netHOST DTM 

 Dialog Pane (main area on the right side) 
The Dialog Pane displays the dialog windows which have been selected in 
the navigation area. If there is no active online connection, the dialog 
windows for Settings and Configuration can be chosen here: 
 

Dialog window Description 
Settings 

   Driver In the Driver dialog window, you can select a driver from the 
drivers list.  
For further information, refer to Driver Dialog Window section on 
page 113. 

       netX Driver In the netX Driver dialog window, you can configure the driver 
enabling communication between the DTM in SYCON.net and the 
netHOST device. For instance, you have to specify the IP 
address of the netHOST device here.  
For further information, refer to netX Driver Dialog Window 
section on page 114. 

   Device Assignment In the Device Assignment dialog window, you have to select the 
device which you want to configure, and assign it to the driver. 
For further information, refer to Device Assignment Dialog 
Window section on page 116. 

Configuration 

   Settings In the Settings dialog window, you can update the firmware of 
the netHOST, if necessary. You can also define a name for the 
configuration. 
For further information, refer to Settings Dialog Window section 
on page 119.  

   Memory Card  
   Management 

In the Memory Card Management dialog window, you can save 
the firmware and the configuration file from the netHOST to an 
SD memory card. You can also restore the saved files from 
memory card to netHOST device here. 
For further information, refer to Memory Card Management Dialog 
Window section on page 121. 
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   Licensing In the Licensing dialog window, you can check which license is 
present in the netHOST device. You can also order a license from 
Hilscher and download the license to the netHOST device. 
For further information, refer to Licensing Dialog Window section 
on page 123. 

Table 18: Dialog Windows in the Dialog Pane 

 

If there is an active online connection, the dialog windows for Diagnosis 
are displayed here instead of the Settings and Configuration dialog 
windows described above. For a description of the Diagnosis dialog 
windows, see Windows of the “Diagnosis“ Group section on page 124. 

 OK, Cancel, Apply and Help buttons 
 

 Meaning 
OK To confirm your latest settings, click OK. All changed values will be applied 

on the frame application database.  
The dialog then closes. 

Cancel To cancel your latest changes, click Cancel.  
Answer to the safety query Configuration data has been changed. Do 
you want to save the data? by Yes, No or Cancel. 
Yes: The changes are saved or the changed values are applied on the 
frame application database.  
The dialog then closes. 
No: The changes are not saved or the changed values are not applied on 
the frame application database.  
The dialog then closes. 
Cancel: Back to the DTM. 

Apply To confirm your latest settings, click Apply. All changed values will be 
applied on the frame application database.  
The dialog remains opened. 

Help To open the DTM online help, click Help. 

Table 19: Standard Command Buttons in the netHOST DTM 
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 Status Bar (Footer) 
The Status Bar displays information about the current state of the DTM. 
The current activity, e.g. download, is signaled graphically via icons in the 
status bar. 

 
Figure 99: Status Bar – Status Fields 1 to 6 

 

Status 
Field 

Icon / Meaning 

1 DTM Connection States 
 

 
Connected: Icon closed = Device is online 

 
 

Disconnected: Icon opened = Device is offline 

2 Data Source States 
 

 
Data set: The displayed data are read out from the instance data set 
(database). 

 
 

Device: The displayed data are read out from the device. 

3 States of the instance Date Set 
 

 
Valid Modified: Parameter is changed (not equal to data source). 

4 Changes directly made on the Device 
 

 
Load/configure diagnosis parameters: Diagnosis is activated. 

6 Device Diagnosis Status 

 
 

Save operation succeeded: The save operation has been successful. 

Further messages due to successful handling of device data. 
   Firmware Download: Firmware Download is running 

 
 

Save operation failed: The save operation has failed. 

Further fail operation messages due to incorrect communication due to 
malfunction in the field device or its peripherals. 

Table 20: Status Bar Icons [1] 

 

Offline State 
 

 
Save operation 
succeeded  

 
Firmware Download 

 
 

Firmware Download 
successful  

 
Online State and 
Diagnosis  

Figure 100: Status Bar Display Examples 
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Table lines 
In the DTM dialog pane table lines can be selected, inserted or deleted. 
 

 Meaning 

 
To select the first line of a table use First Line. 

 
To select the previous line of a table use Previous Line. 

 
To select the next line of a table use Next Line. 

 
To select the last line of a table use Last Line. 

 
Create a new Line inserts new lines into the table. 

 
Delete selected Line deletes the selected line from the table.  

Table 21: Selecting, inserting, deleting Table Line 

 

12.3 Dialog Windows of the “Settings” Group 
12.3.1 Overview 

This section describes the dialog windows belonging to the Settings 
category of the netHOST DTM. 
 

 
Note: You need the user right Maintenance, Planning Engineer or 
Administrator in order to be allowed to edit the dialog windows belonging 
to the Settings category. For information about user rights for the 
netHOST DTM, see User Rights for the netHOST DTM section on page 
155.  

 

 
Figure 101: Settings in netHOST DTM 
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12.3.2 Driver Dialog Window 
In the Driver dialog window, you can select the driver needed for 
establishing a connection between SYCON.net and the field device which 
is to be configured. For the netHOST, you need the netX Driver. The netX 
Driver is included in the SYCON.net installation and already pre-selected in 
the netHOST DTM.  
 To open the Driver dialog window, click Driver entry in the Settings 

folder in the Navigation Area of the opened netHOST DTM. 
 

 
Figure 102: Driver List 

 

 
Note: The Driver dialog window lists all Hilscher drivers installed on your 
system, which means that also drivers not relevant for the netHOST might 
be displayed here. 

 
Parameter Meaning 
Driver Name of the driver 

Version  Version of the driver 

ID ID of the driver (driver identification) 

Table 22: Driver Selection List Parameters 
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12.3.3 netX Driver Dialog Window 
The Driver folder in the Navigation Area lists all drivers that can be 
configured by a configuration dialog.  
The netX Driver dialog window allows you to configure the USB/RS232 
and the TCP connection of the netX Driver to the netHOST device.  
 

 
Figure 103: netX Driver 

 

 
Note: The USB/RS232 interface of the netX Driver is not needed for 
configuring the netHOST. 

 
 To configure the netX Driver, select Settings > Driver > netX Driver in 

the Navigation Area of the opened netHOST DTM. 
 The netX Driver dialog window opens.  
 Select TCP Connection tab: 
 

 
Figure 104: Configure TCP/IP Connection in netX Driver  

The subsequent table provides a description of the parameters: 
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Parameter Meaning Range of Value / 
Default Value 

Enable TCP Connector 
(Restart of ODM 
required) 

checked: The netX Driver can communicate via the TCP/IP 
interface. 
unchecked: The netX Driver can not communicate via the 
TCP/IP interface. 
If the check mark for Enable TCP Connector is set or 
removed, then the ODM server must be restarted1, to make 
the new setting valid. 
_______ 
1 Restart the ODM server via the ODMV3 Tray Application: 

-In the foot line click on  using the right mouse key.  
- In the context menu select Service > Start. 

checked,  
unchecked; 
Default: 
unchecked 

Select IP Range Via Select IP Range already created IP ranges can be 
selected. 

Via  an additional IP range can be added. 

Via  an IP range can be deleted. 

 

Scan Timeout [ms] With Scan Timeout can be set, how long to wait for a 
response while a connection is established. 

10 … 10000 [ms]; 
Default: 100 ms 

IP Range Configuration 
Disable IP Range checked: No connection. 

unchecked: The netX Driver tries to establish a connection 
using the configured TCP/IP interface. 

checked,  
unchecked (Default) 

IP Address (left) Enter the IP address of the device, (if Use IP Range is not 
checked). 
Enter the start address of the IP scanning range, (if Use IP 
Range is checked). 

valid IP address; 
Default: 192.168.1.1 

Use IP Range checked: An IP address range is used. 
unchecked: Only one IP address is used. 

checked,  
unchecked; 
Default: 
unchecked 

IP Address (right) Enter the ending address of the IP scanning range, (only if 
Use IP Range is checked). 

valid IP address; 
Default: 0.0.0.0 

Address Count Displays the scanning range address count, depending on 
the selected IP-start or IP-end address. (For this read the 
note given below.) 

recommended: 10  

TCP Port Identifies the endpoint of a logical connection or addresses a 
specific endpoint on the device or PC. 

0 - 65535; 
Default Hilscher device: 
50111 

Send Timeout [ms] Maximum time before the transfer of the transmission data is 
canceled, when the send process fails, for example, because 
of the transfer buffer is full.  

100 … 60.000 [ms]; 
Default (TCP/IP): 1000 
ms 

Reset Timeout [ms] Maximum time for a device reset, including the re-
initialization of the physical interface used for the 
communication. 

100 … 60.000 [ms]; 
Default (TCP/IP): 2000 
ms 

Keep Alive Timeout 
[ms] 

The "Keep Alive" mechanism is used to monitor whether the 
connection to the device is active. Connection errors are 
detected using a periodic heartbeat mechanism. The 
heartbeat mechanism will be initiated after the set time has 
elapsed if the communication has failed. 

100 … 60.000 [ms]; 
Default (TCP/IP): 2000 
ms 

Restore Resets all settings in the configuration dialog to the default 
values. 

 

Save Saving all settings made in the configuration dialog netX 
Driver > Save TCP/IP Connection, i. e. only for the selected 
connection type. 

 

Save All Saving all settings made in the configuration dialog netX 
Driver, i. e. for all connection types. 

 

Table 23: Parameters netX Driver > TCP Connection 
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Note: Do not use large IP ranges in combination with a low scan timeout.  
In Windows® XP SP2, Microsoft has introduced a limit for concurrent half-
open outbound TCP/IP connections (connection attempts) to slow the 
spread of virus and malware from system to system. This limit makes it 
impossible to have more than 10 concurrent half-open outbound 
connections. Every further connection attempt is put in a queue and 
forced to wait. Due to this limitation, a large IP range used in combination 
with a low scan timeout could prevent the connection establishment to a 
device. 

 

 

12.3.4 Device Assignment Dialog Window 
In order to establish an online connection between SYCON.net/the 
netHOST DTM and the netHOST device, you first need to assign the 
netHOST device to the netX Driver in the Device Assignment dialog 
window. 
 

 
Note: Before you can assign the netHOST device to the netX driver in the 
Device Assignment window, the driver has to be selected in the Driver 
dialog window. In the netHOST DTM, the appropriate driver for the 
netHOST – i. e. the netX driver – is already pre-selected by default. Note, 
however, that you still have to set the IP address of the netHOST in the 
netX Driver dialog window. 

 
 To assign the netHOST device to the driver, select Settings > Device 

Assignment in the Navigation Area of the opened netHOST DTM. 
 The Device Assignment dialog window opens and SYCON.net 

automatically starts scanning for connected devices: 
 

 
Figure 105: Scanning for Devices in SYCON.net 

 Afterwards, select the netHOST device which you want to assign to the 
netX driver. 
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Figure 106: Device Assignment in netHOST DTM  

The subsequent table provides a description of the parameters: 
Parameter Meaning Range of Value / 

Value 
Device selection Selecting suitable only or all devices. suitable only, all 

Device Device name.  

Hardware Port 0/1/2/3 Shows, which hardware is assigned to which communication interface.   

Slot number When using netHOST devices, the n/a entry means that no Slot-
Nummer (Karten-ID) exists. 
Note: When using cifX PC cards, this parameter indicates the Slot 
Number (Card ID) preset at the cifX card via the Rotary Switch Slot 
Number (Card ID). 

1 to 9, 
n/a 
 

Serial number Serial number of the device  

Driver Name of the driver  

Channel Protocol Shows, which firmware is loaded to which device channel. 
The data for the used channel consists of the protocol class and the 
communication class. 
a.) For devices without firmware: Undefined Undefined, 
b.) For devices with firmware: Protocol name according to the used 
Firmware 

 

Access path 
(under Device 
selection, last column 
on the right) 

Depending on the used driver, the column Access path shows various 
data concerning the access path. 
For the cifX Device Driver the following data is displayed:  
a.) For devices without firmware: …\cifX[0toN]_SYS, 
b.) For devices with firmware: …\cifX[0toN]_Ch[0to3]. 
cifX[0toN] = Board number 0 to N 
Ch[0to3] = Channel number 0 to 3 

Depending on the 
device and on the 
driver:  
board or channel 
number, IP address 
or COM interface 

Access path  
(at the lower side of 
the dialog pane) 

If under Device selection the check box for a device is checked, under 
Access path (at the lower side of the dialog pane) the driver 
identification or (depending on the used driver) additional data of the 
device is displayed. 
For the cifX Device Driver the following data are displayed:  
a.) For devices without firmware: …\cifX[0toN]_SYS, 
b.) For devices with firmware: …\cifX[0toN]_Ch[0to3]. 
cifX[0toN] = Board number 0 to N 
Ch[0to3] = Channel number 0 to 3 

driver identification 
(ID) 
depending on the 
device and on the 
driver:  
board or channel 
number, IP address 
or COM interface 

Table 24: Parameters of the Device Assignment 
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12.4 Dialog Windows of the “Configuration” Group 
12.4.1 Overview 

This section describes the dialog windows belonging to the Configuration 
category of the netHOST DTM. 
 

 
Note: You need the user right Maintenance, Planning Engineer or 
Administrator in order to be allowed to edit the dialog windows belonging 
to the Configuration category. For information about user rights for the 
netHOST DTM, see User Rights for the netHOST DTM section on page 
155.  

 

 
Figure 107: „Configuration“ in netHOST DTM 
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12.4.2 Settings Dialog Window 
In the Settings dialog window, you can download firmware into the 
netHOST device (firmware update) and define a name for the configuration. 
 

 To open the Settings dialog window, click Settings entry in the 
Configuration folder in the Navigation Area of the opened netHOST 
DTM. 

 

 
Figure 108: „Settings” Dialog Window in the netHOST DTM  

 

 
Note: In the Settings dialog window, only the Description field, the 
Available Firmware field and the Browse and Download buttons are 
active and can be used. All other fields or parameters are preset and can 
not be edited by the user.  
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Name Description 
General 
 Description Here you can enter a descriptive or symbolic name for the netHOST device. 

Afterwards, this name will be displayed in SYCON.net in front of the device.  
Protocol Combination 
 Primary network (Port X2) Displays the protocol of the network connected to port X2 of the netHOST 

device. 
 Secondary network (Port 

X3) 
Displays the protocol of the network connected to port X3 of the netHOST 
device. 

 Required gateway Displays the netHOST device type. 
 Required license Displays the number of master licenses required in the device if a netHOST 

with master functionality is being used. 
 Available Firmware Lists the firmware file selected for the device.  

Firmware files are stored on the netHOST Solutions DVD in the 
Firmware\netHOST directory. 

 Browse Opens a dialog to select a firmware file for download. The selected firmware file 
is shown in the Available Firmware field. 

 Download Transfers the firmware file which has been in the Available Firmware field into 
the netHOST device. 

 Software class Displays the Software class of the selected firmware file. 
 Software version Displays the version of the selected firmware file. 
Basic Settings 
 Mapping Cycle time Displays the cycle time for the device internal transfer of the input and output 

data from the buffer of port X2 to the buffer of X3 and visa versa (default = 1 
ms).  

 Mapping mode Always set to default. 
Network Address Switch 
 enable Not applicable for netHOST devices. 
 Used by Not applicable for netHOST devices. 

Table 25: Elements in the “Settings” Dialog Window 
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12.4.3 Memory Card Management Dialog Window 
In the Memory Card Management dialog window, you can:  
• copy the firmware file and the configuration data from the netHOST 

device to an inserted SD memory card (backup), 
• copy the firmware file and the configuration data from the inserted SD 

memory card to the netHOST device (restore). All old files stored in the 
netHOST device will thereby be overwritten. 

 

 
Note: For these functions, you need a FAT16-formatted SD memory card, 
which you insert into the netHOST device. You also need an active online 
connection between SYCON.net and the netHOST device.  
The SD memory card is not included in the delivery of the netHOST 
device and can be ordered from Hilscher, part number 1719.003. 

 

 To open the Memory Card Management dialog window, click Memory 
Card Management entry in the Configuration folder in the Navigation 
Area of the opened netHOST DTM. 

 

 
Figure 109: Memory Card Management of the netHOST DTM  
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Name Description 
Directory 
 Folder If no SD memory card has been inserted, the file system of the netHOST 

device is displayed here. 
If an SD memory card has been inserted into the netHOST device, the file 
system of the card is displayed here in addition to the file system of the 
netHOST. 
You can select a folder in order to display its contents in the adjacent File field. 

 File Displays the names of the files stored in the selected folder. 

 Size Displays the size of the files stored in the selected folder. 
Start-Up Options 
 Restore automatically Sets start-up options for booting from SD memory card. Selecting an option is 

currently not supported. 
At every start (preset): If an SD memory card is inserted in the netHOST 
device at the time of power return, the netHOST takes over the data from the 
SD card. 
If different: Data from the SD card is only taken over if it differs from the data 
stored in the internal load memory of the netHOST. 

Commands 
 Restore Copies the firmware and the configuration files stored on the SD memory card 

to the netHOST device. All old files stored in the netHOST device will thereby 
be overwritten. 
This button is only active if an SD memory card has been inserted into the 
netHOST device. If this is the case, the Folder field displays the directory of the 
memory card. The root directory of the card is „SDMMC“. 

 Backup Copies the firmware and the configuration files stored in the netHOST device to 
the SD memory card.  
This button is only active if an SD memory card has been inserted into the 
netHOST device. If this is the case, the Folder field displays the directory of the 
memory card. The root directory of the card is „SDMMC“. 

Table 26: Elements of the Memory Card Management 
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12.4.4 Licensing Dialog Window 
 

 
Note: Usually, all netHOST devices are already equipped with the 
necessary license on delivery. The individual control elements in this 
dialog window are therefore not described here. In case you want to 
belatedly order and download a license for the NHST-T100-EN device, 
see section Ordering and Downloading License to NHST-T100-EN with 
SYCON.net on page 36 for more information.  

 
In the Licensing dialog window, you can check which license is present in 
the netHOST device. 
 

 
Note: For these functions, you need an active online connection between 
SYCON.net and the netHOST device.  

 

 To open the Licensing dialog window, click Licensing entry in the 
Configuration folder in the Navigation Area of the opened netHOST 
DTM. 

 

 
Figure 110: Licensing Dialog Window of the netHOST DTM  
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12.5 Windows of the “Diagnosis“ Group 
12.5.1 Overview 

This section describes the dialog windows belonging to the Diagnosis 
category of the netHOST DTM. With the diagnosis functions, you can check 
the behavior of the device and detect communication errors.   
An active online connection between the netHOST DTM in SYCON.net and 
the netHOST device is needed for this. Double-clicking the netHOST 
symbol during an active online connection automatically opens the 
Diagnosis windows. (Without an active online connection, double-clicking 
the netHOST automatically opens the Settings and Configuration dialog 
windows.) Alternatively, you can open the diagnosis by selecting the 
netHOST symbol and then choosing Diagnosis > Main Settings from the 
context menu. 
The Extended Diagnosis helps to find communication and configuration 
errors if the functions of the general diagnosis do not suffice. 
 

 
Note: You need the user right maintenance, Planning Engineer or 
Administrator in order to be allowed to open the diagnosis windows. For 
information about user rights for the netHOST DTM, see User Rights for 
the netHOST DTM section on page 155.  

 

 
Figure 111: Diagnosis in netHOST DTM 

 



Description of the netHOST DTM 125/160 

Configuration of LAN Controlled Master Devices | netHOST  
DOC130402OI05EN | Revision 5 | English | 2017-03 | Released | Public  © Hilscher 2013 - 2017 

12.5.2 General Diagnosis Window 
The General Diagnosis window displays information about the current 
states of device, network and configuration.  
 To open the General Diagnosis window, click General Diagnosis 

entry in the Diagnosis folder in the Navigation Area of the opened 
netHOST DTM. 

 

 
Note: You need an active online connection between the netHOST DTM 
and the netHOST device for this.  

 

 
Figure 112: General Diagnosis in netHOST DTM 

 
Indication Meaning 
Device State 

  Communicating Shows that the netHOST firmware executes the network 
communication. 

  Run Shows that the netHOST firmware has been configured correctly.  

  Ready Shows that the netHOST firmware has been started correctly. The 
netHOST firmware waits for a configuration.  

  Error Shows that the netHOST firmware records a device status error. For 
further information about the error characteristics and the number of 
counted errors, please refer to the extended diagnosis. 
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Network State 

  Operate Shows that the netHOST firmware is in data exchange. 

  Idle Shows that the netHOST firmware is in idle mode. 

  Stop Shows that the netHOST firmware is in Stop state: There is no cyclic 
data exchange at the network. The netHOST firmware was stopped 
by the application program or it changed to the Stop state because of 
a bus error. 

  Offline The netHOST firmware is offline, it does not have a valid 
configuration. 

 
Configuration State 

  Configuration locked Shows that the netHOST firmware configuration is locked in order to 
avoid that the configuration data is being typed over. 

  New Configuration pending Shows that a new netHOST firmware configuration is available. 

  Reset required Shows that a firmware reset is required because a new netHOST 
firmware configuration has been loaded into the device.  

  Bus ON Shows whether the bus communication was started or stopped. I. e., 
whether the device is active on the bus or no bus communication to 
the device is possible and no response telegrams are sent. 

Table 27: Indications General Diagnosis 

 
Parameter Meaning 
Communication Error Shows the message text of the communication error. If the cause of 

the current error is resolved, „ – “ is displayed. 

Watchdog time Shows the watchdog time in ms. 

Error Count This field holds the total number of errors detected since power-up, 
respectively after reset. The protocol stack counts all sorts of errors 
in this field no matter if they were network related or caused 
internally. 

Table 28: Further Parameter General Diagnosis 
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12.5.3 Firmware Diagnosis Window 
The Firmware Diagnosis window displays information about the current 
tasks of the firmware.  
 To open the Firmware Diagnosis window, click Firmware Diagnosis 

entry in the Diagnosis folder in the Navigation Area of the opened 
netHOST DTM. 

 

 
Note: You need an active online connection between the netHOST DTM 
and the netHOST device for this.  

 

 
Figure 113: Firmware Diagnosis in netHOST DTM 

 
Column Meaning 
Task Task number  

Name of Task  Name of the task 

Version Version of the task 

Prio Priority of the task 

Description Description of the task 

State Status of the task 

Table 29: Parameters Task Information 
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12.6 Establishing Online Connection  
For some functions of the netHOST DTM – like diagnosis or downloading 
the configuration or firmware to the device – an active online connection 
between SYCON.net/netHOST DTM and the netHOST device is required. 

Prerequisites 
Prerequisites for an online connection are: 
• The configuration PC with SYCON.net/netHOST DTM and the netHOST 

device are connected to the same local Ethernet network. 
• The netHOST device is connected to a voltage supply. 
• You have assigned a suitable IP address to the netHOST device. 
• The netX Driver has been configured in the netX Driver dialog window 

(i. e. the IP address of the device has been set) and the netHOST 
Device has been assigned to the driver in the Device Assignment 
dialog window (see Assigning Device to Driver and Configuring Driver on 
page 52). 

Establish online connection 
Once you have opened certain dialog windows of the netHOST DTM, e. g. 
the Device Assignment dialog window, SYCON.net automatically 
establishes an online connection between the DTM and the device. 
If the netHOST Device is closed, you can manually establish an online 
connection in SYCON.net. For this: 
 

 Select the netHOST symbol in the configuration window, then choose 
Connect from the context menu (to open context menu, right-click on 
the netHOST symbol):  

 

 
Figure 114: Connect netHOST  
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OR 
 In the menu bar of SYCON.net, choose Device > Connect. 
 

 An active online connection is indicated in the configuration window by 
the green highlighted netHOST label: 

 

 
Figure 115: netHOST Connected 

 

 
Note: It is not possible to open the Settings and Configuration dialog 
windows of the netHOST DTM during an active online connection. If you 
double-click on the netHOST symbol while the device is online, the 
Diagnosis windows of the netHOST DTM open instead of the Settings 
and Configuration dialog windows. 

 

Close online connection 
You can close the online connection by  
 

 choosing Disconnect from the context menu of the netHOST symbol. 
OR 
 choosing Device > Disconnect in the menu bar of SYCON.net. 
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13 Brief Instructions for Configuring netHOST Master 
Devices 

13.1 netHOST as Master for Fieldbus Systems 
13.1.1 CANopen Master: NHST-T100-CO/COM 

The NHST-T100-CO/COM as CANopen Master device needs a 
configuration, i. e., for instance, information about how many CANopen 
Slave devices with how many input and output data are to be connected to 
the master. 
This section provides cursory instructions on how to configure the NHST-
T100-CO/COM netHOST device as CANopen Master in SYCON.net.  
More detailed instructions on how to configure a netHOST as Fieldbus 
master (on the basis of an example for PROFIBUS DP) can be found in 
section Configuring netHOST for Fieldbus Systems with SYCON.net: 
NHST-T100-DP/DPM Example on page 49. 
 

1. Add CANopen slave devices to configuration project. 
 Open device catalog and drag & drop as many CANopen slave(s) as 

needed onto the bus line of the CANopen master. 
 

2. Configure CANopen slave devices. 
 Open the configuration dialog for each CANopen slave device and 

configure the device. 
  

 
Detailed information on this can be found in the operating instruction 
manual Generic Slave DTM for CANopen Slave Devices, 
DOC060203OIxxEN. This manual is stored on the netHOST Solutions 
DVD in the directory 
Documentation\english\1.Software\SYCON.net 
Configuration Software\Master Configuration\CANopen 
Master\Slave Configuration. 
As an alternative, you can open the corresponding online help by clicking 
the Help button in the opened configuration dialog window of the slave 
DTM, or by pressing the F1 key on your keyboard. 

 
3. Configure CANopen master (NHST-T100-CO/COM). 
 Select the netHOST symbol, then choose Configuration > CANopen 

Master from the context menu (to open context menu, right-click on the 
netHOST symbol). 

 Configure the master device. 
 

 
Detailed information on this can be found in the operating instruction 
manual DTM for Hilscher-CANopen Master Devices, 
DOC070402OIxxEN. This manual is stored on the netHOST Solutions 
DVD in the directory 
Documentation\english\1.Software\SYCON.net 
Configuration Software\Master Configuration\CANopen 
Master. 
As an alternative, you can open the corresponding online help by clicking 
the Help button in the opened configuration dialog window of the DTM, or 
by pressing the F1 key on your keyboard. 
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13.1.2 DeviceNet Master: NHST-T100-DN/DNM 
The NHST-T100-DN/DNM as DeviceNet Master device needs a 
configuration, i. e., for instance, information about how many DeviceNet 
Slave devices with how many input and output data are to be connected to 
the master. 
This section provides cursory instructions on how to configure the NHST-
T100-DN/DNM netHOST device as DeviceNet Master in SYCON.net.  
More detailed instructions on how to configure a netHOST as Fieldbus 
master (on the basis of an example for PROFIBUS DP) can be found in 
section Configuring netHOST for Fieldbus Systems with SYCON.net: 
NHST-T100-DP/DPM Example on page 49. 
 

1. Add DeviceNet slave devices to configuration project. 
 Open device catalog and drag & drop as many DeviceNet slave(s) as 

needed onto the bus line of the DeviceNet master. 
 

2. Configure DeviceNet slave devices. 
 Open the configuration dialog for each DeviceNet slave device and 

configure the device. 
  

 
Detailed information on this can be found in the operating instruction 
manual Generic Slave DTM for DeviceNet Slave Devices, 
DOC041201OIxxEN. This manual is stored on the netHOST Solutions 
DVD in the directory 
Documentation\english\1.Software\SYCON.net 
Configuration Software\Master Configuration\DeviceNet 
Master\Slave Configuration. 
As an alternative, you can open the corresponding online help by clicking 
the Help button in the opened configuration dialog window of the slave 
DTM, or by pressing the F1 key on your keyboard. 

 
3. Configure DeviceNet master (NHST-T100-DN/DNM). 
 Select the netHOST symbol, then choose Configuration > DeviceNet 

Master from the context menu (to open context menu, right-click on the 
netHOST symbol). 

 Configure the master device. 
 

 
Detailed information on this can be found in the operating instruction 
manual DTM for Hilscher-DeviceNet Master Devices, 
DOC070403OIxxEN. This manual is stored on the netHOST Solutions 
DVD in the directory 
Documentation\english\1.Software\SYCON.net 
Configuration Software\Master Configuration\DeviceNet 
Master. 
As an alternative, you can open the corresponding online help by clicking 
the Help button in the opened configuration dialog window of the DTM, or 
by pressing the F1 key on your keyboard. 
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13.1.3 PROFIBUS DP Master: NHST-T100-DP/DPM 
The NHST-T100-DP/DPM as PROFIBUS DP Master device needs a 
configuration, i. e., for instance, information about how many PROFIBUS 
DP Slave devices with how many input and output data are to be 
connected to the master. 
This section provides only cursory instructions on how to configure the 
NHST-T100-DP/DPM netHOST device as PROFIBUS DP Master in 
SYCON.net. Detailed instructions can be found in section Configuring 
netHOST for Fieldbus Systems with SYCON.net: NHST-T100-DP/DPM 
Example on page 49. 
 

1. Add PROFIBUS DP slave devices to configuration project. 
 Open device catalog and drag & drop as many PROFIBUS DP slave(s) 

as needed onto the bus line of the PROFIBUS DP master. 
 

2. Configure PROFIBUS DP slave devices. 
 Open the configuration dialog for each PROFIBUS DP slave device and 

configure the device. 
  

 
Detailed information on this can be found in the operating instruction 
manual Generic Slave DTM for PROFIBUS DP Slave Devices, 
DOC031001OIxxEN. This manual is stored on the netHOST Solutions 
DVD in the directory 
Documentation\english\1.Software\SYCON.net 
Configuration Software\Master Configuration\PROFIBUS 
DP Master\Slave Configuration. 
As an alternative, you can open the corresponding online help by clicking 
the Help button in the opened configuration dialog window of the slave 
DTM, or by pressing the F1 key on your keyboard. 

 
3. Configure PROFIBUS DP master (NHST-T100-DP/DPM). 
 Select the netHOST symbol, then choose Configuration > PROFIBUS 

DP Master from the context menu (to open context menu, right-click on 
the netHOST symbol). 

 Configure the master device. 
 

 
Detailed information on this can be found in the operating instruction 
manual DTM for Hilscher-PROFIBUS DP Master Devices, 
DOC070401OIxxEN. This manual is stored on the netHOST Solutions 
DVD in the directory 
Documentation\english\1.Software\SYCON.net 
Configuration Software\Master Configuration\PROFIBUS 
DP Master. 
As an alternative, you can open the corresponding online help by clicking 
the Help button in the opened configuration dialog window of the DTM, or 
by pressing the F1 key on your keyboard. 
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13.2 netHOST as Master for Real-Time Ethernet Systems 
13.2.1 EtherCAT Master: NHST-T100-EN/ECM 

The NHST-T100-EN/ECM as EtherCAT Master device (respectively the 
NHST-T100-EN with loaded EtherCAT master firmware) needs a 
configuration, i. e., for instance, information about how many EtherCAT 
Slave devices with how many input and output data are to be connected to 
the master. 
This section provides cursory instructions on how to configure the NHST-
T100-EN/ECM netHOST device as EtherCAT Master in SYCON.net.  
More detailed instructions on how to configure a netHOST as master 
device in a Real-Time Ethernet network (on the basis of an example for 
PROFINET IO) can be found in section Configuring netHOST for RTE 
Systems with SYCON.net: NHST-T100-EN/PNM Example on page 64. 
 

1. Add EtherCAT slave devices to configuration project. 
 Open device catalog and drag & drop as many EtherCAT slave(s) as 

needed onto the bus line of the EtherCAT master. 
 

2. Configure EtherCAT slave devices. 
 Open the configuration dialog for each EtherCAT slave device and 

configure the device. 
  

 
Detailed information on this can be found in the operating instruction 
manual Generic Slave DTM for EtherCAT Slave Devices, 
DOC071202OIxxEN. This manual is stored on the netHOST Solutions 
DVD in the directory 
Documentation\english\1.Software\SYCON.net 
Configuration Software\Master Configuration\EtherCAT 
Master\Slave Configuration. 
As an alternative, you can open the corresponding online help by clicking 
the Help button in the opened configuration dialog window of the slave 
DTM, or by pressing the F1 key on your keyboard. 

 
3. Configure EtherCAT master (NHST-T100-EN/ECM). 
 Select the netHOST symbol, then choose Configuration > EtherCAT 

Master from the context menu (to open context menu, right-click on the 
netHOST symbol). 

 Configure the master device. 
 

 
Detailed information on this can be found in the operating instruction 
manual DTM for Hilscher EtherCAT Master Device, DOC080404OIxxEN. 
This manual is stored on the netHOST Solutions DVD in the directory 
Documentation\english\1.Software\SYCON.net 
Configuration Software\Master Configuration\EtherCAT 
Master. 
As an alternative, you can open the corresponding online help by clicking 
the Help button in the opened configuration dialog window of the DTM, or 
by pressing the F1 key on your keyboard. 
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13.2.2 EtherNet/IP Scanner: NHST-T100-EN/EIM 
The NHST-T100-EN/EIM as EtherNet/IP Scanner (respectively the NHST-
T100-EN with loaded EtherNet/IP Scanner firmware) needs a configuration, 
i. e., for instance, information about how many EtherNet/IP Adapter (slave 
devices) with how many input and output data are to be connected to the 
scanner. 
This section provides cursory instructions on how to configure the NHST-
T100-EN/EIM netHOST device as EtherNet/IP Scanner in SYCON.net.  
More detailed instructions on how to configure a netHOST as master 
device in a Real-Time Ethernet network (on the basis of an example for 
PROFINET IO) can be found in section Configuring netHOST for RTE 
Systems with SYCON.net: NHST-T100-EN/PNM Example on page 64. 
 

1. Add EtherNet/IP Adapters to configuration project. 
 Open device catalog and drag & drop as many EtherNet/IP slaves as 

needed onto the bus line of the EtherNet/IP Scanner. 
 

2. Configure EtherNet/IP Adapters. 
 Open the configuration dialog for each EtherNet/IP Adapter and 

configure the device. 
  

 
Detailed information on this can be found in the following operating 
instruction manuals:  
Generic, Modular Generic DTM from EDS File for non-modular and 
modular EtherNet/IP Adapter Devices, DOC100221OIxxEN 
and 
Generic DTM for EtherNet/IP Adapter Devices and Modular Generic DTM 
for modular EtherNet/IP Adapter Devices, DOC060305OIxxEN,  
both stored on the netHOST Solutions DVD in the directory 
Documentation\english\1.Software\SYCON.net 
Configuration Software\Master Configuration\EtherNetIP 
Scanner\Adapter Configuration. 
As an alternative, you can open the corresponding online help by clicking 
the Help button in the opened configuration dialog window of the slave 
DTM, or by pressing the F1 key on your keyboard. 

 
3. Configure EtherNet/IP Scanner (NHST-T100-EN/EIM). 
 Select the netHOST symbol, then choose Configuration > EtherNet/IP 

Scanner from the context menu (to open context menu, right-click on 
the netHOST symbol). 

 Configure the Scanner. 
 

 
Detailed information on this can be found in the operating instruction 
manual DTM for EtherNet/IP Scanner Devices, DOC061201OIxxEN.  
This manual is stored on the netHOST Solutions DVD in the directory 
Documentation\english\1.Software\SYCON.net 
Configuration Software\Master Configuration\EtherNetIP 
Scanner. 
As an alternative, you can open the corresponding online help by clicking 
the Help button in the opened configuration dialog window of the DTM, or 
by pressing the F1 key on your keyboard. 
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13.2.3 PROFINET IO Controller: NHST-T100-EN/PNM 
The NHST-T100-EN/PNM as PROFINET IO Controller (respectively the 
NHST-T100-EN with loaded PROFINET IO Controller firmware) needs a 
configuration, i. e., for instance, information about how many PROFINET IO 
Devices (slaves) with how many input and output data are to be connected 
to the Controller. 
This section provides only cursory instructions on how to configure the 
NHST-T100-EN/PNM netHOST device as PROFINET IO Controller in 
SYCON.net. Detailed instructions can be found in section Configuring 
netHOST for RTE Systems with SYCON.net: NHST-T100-EN/PNM 
Example on page 64. 
 

1. Add PROFINET IO Devices (slaves) to configuration project. 
 Open device catalog and drag & drop as many PROFINET IO Devices 

as needed onto the bus line of the PROFINET IO Controller. 
 

2. Configure PROFINET IO Devices. 
 Open the configuration dialog for each PROFINET IO Device and 

configure the device. 
  

 
Detailed information on this can be found in the operating instruction 
manual DTM for Hilscher-PROFINET IO-Controller Devices, 
DOC060302OIxxEN. This manual is stored on the netHOST Solutions 
DVD in the directory 
Documentation\english\1.Software\SYCON.net 
Configuration Software\Master Configuration\PROFINET 
IO Controller\IO Device Configuration. 
As an alternative, you can open the corresponding online help by clicking 
the Help button in the opened configuration dialog window of the slave 
DTM, or by pressing the F1 key on your keyboard. 

 
3. Configure PROFINET IO Controller. 
 Select the netHOST symbol, then choose Configuration > PROFINET 

IO Controller from the context menu (to open context menu, right-click 
on the netHOST symbol). 

 Configure the Controller. 
 

 
Detailed information on this can be found in the operating instruction 
manual DTM for Hilscher-PROFINET IO-Controller Devices, 
DOC060302OIxxEN. This manual is stored on the netHOST Solutions 
DVD in the directory 
Documentation\english\1.Software\SYCON.net 
Configuration Software\Master Configuration\PROFINET 
IO Controller. 
As an alternative, you can open the corresponding online help by clicking 
the Help button in the opened configuration dialog window of the DTM, or 
by pressing the F1 key on your keyboard. 
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14 Error Codes 
14.1 Error Code Definitions 

For COM based application, like the ODM Server and ODM drivers, a 
common error definition is used, similar to the Microsoft Windows® 
HRESULT definition. 
Error Code Structure: 
COM Errors are HRESULTs, which are 32 bit values using the following 
layout: 

 3 3 2 2 2 2 2 2 2 2 2 2 1 1 1 1 1 1 1 1 1 1 

 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0 9 8 7 6 5 4 3 2 1 0 

+---+-+-+-----------------------+-------------------------------+ 

|Sev|C|R|     Facility          |               Code            | 

+---+-+-+-----------------------+-------------------------------+ 

 

where 

Sev       - is the severity code: 

       00 - Success 

       01 - Informational 

       10 - Warning 

       11 - Error 

C         - is the Customer code flag 

R         - is a reserved bit 

Facility  - is the facility code 

Code      - is the facility's status code 

In this common error definition, several error code regions are already 
reserved by Windows® itself, the ODM and some other modules.  
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14.2 Overview Error Codes 
 

Overview Error Codes Range 

General Hardware Errors 
RCX Operating System 

RCX General Task Errors: 0xC02B0001 to 0xC02B4D52 

RCX Common Status & Errors Codes: 0x00000000 to 0xC002000C 

RCX Status & Error Codes: 0x00000000 to 0xC0000008 

ODM Server General ODM Error Codes: 0x8004C700 to 0x8004C761 

General ODM Driver Error Codes: 0x8004C7A0 to 0x8004C7C2 

ODM Drivers cifX Driver Specific ODM Error Codes: 0x8004C001 to 0x8004C0A4 

cifX Device Driver  
and netX Driver 

Generic Error Codes: 0x800A0001 to 0x800A0017 

Generic Driver Error Codes: 0x800B0001 to 0x800B0042 

Generic Device Error Codes: 0x800C0010 to 0x800C0041 

netX Driver CIFX API Transport Error Codes: 0x800D0001 to 0x800D0013 

CIFX API Transport Header State Error Codes: 0x800E0001 to 0x800E000B 

DBM ODM Error Codes DBM V4: 0xC004C810 to 0xC004C878 

Table 30: Overview Error Codes and Ranges 

 

 

The protocol-specific error codes are described in the Protocol API 
manuals of the corresponding communication protocols.  
These manuals are provided on the netHOST Solutions DVD in the  
Documentation\english\3.For 
Programmers\4.Communication Protocol specific APIs. 
directory. 
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14.3 General Hardware Error Codes 
14.3.1 RCX General Task Errors 

 

Error Code (Definition) Value Description 
RCX_E_QUE_UNKNOWN 0xC02B0001 Unknown Queue 
RCX_E_QUE_INDEX_UNKNOWN 0xC02B0002 Unknown Queue Index 
RCX_E_TASK_UNKNOWN 0xC02B0003 Unknown Task 
RCX_E_TASK_INDEX_UNKNOWN 0xC02B0004 Unknown Task Index 
RCX_E_TASK_HANDLE_INVALID 0xC02B0005 Invalid Task Handle 
RCX_E_TASK_INFO_IDX_UNKNOWN 0xC02B0006 Unknown Index 
RCX_E_FILE_XFR_TYPE_INVALID 0xC02B0007 Invalid Transfer Type 
RCX_E_FILE_REQUEST_INCORRECT 0xC02B0008 Invalid File Request  
RCX_E_TASK_INVALID 0xC02B000E Invalid Task 
RCX_E_SEC_FAILED 0xC02B001D Security EEPROM Access Failed 
RCX_E_EEPROM_DISABLED 0xC02B001E EEPROM Disabled 
RCX_E_INVALID_EXT 0xC02B001F Invalid Extension 
RCX_E_SIZE_OUT_OF_RANGE 0xC02B0020 Block Size Out Of Range 
RCX_E_INVALID_CHANNEL 0xC02B0021 Invalid Channel 
RCX_E_INVALID_FILE_LEN 0xC02B0022 Invalid File Length 
RCX_E_INVALID_CHAR_FOUND 0xC02B0023 Invalid Character Found 
RCX_E_PACKET_OUT_OF_SEQ 0xC02B0024 Packet Out Of Sequence 
RCX_E_SEC_NOT_ALLOWED 0xC02B0025 Not Allowed In Current State 
RCX_E_SEC_INVALID_ZONE 0xC02B0026 Security EEPROM Invalid Zone 
RCX_E_SEC_EEPROM_NOT_AVAIL 0xC02B0028 Security EEPROM Eeprom Not Available 
RCX_E_SEC_INVALID_CHECKSUM 0xC02B0029 Security EEPROM Invalid Checksum 
RCX_E_SEC_ZONE_NOT_WRITEABLE 0xC02B002A Security EEPROM Zone Not Writeable 
RCX_E_SEC_READ_FAILED 0xC02B002B Security EEPROM Read Failed 
RCX_E_SEC_WRITE_FAILED 0xC02B002C Security EEPROM Write Failed 
RCX_E_SEC_ACCESS_DENIED 0xC02B002D Security EEPROM Access Denied 
RCX_E_SEC_EEPROM_EMULATED 0xC02B002E Security EEPROM Emulated 
RCX_E_INVALID_BLOCK 0xC02B0038 Invalid Block 
RCX_E_INVALID_STRUCT_NUMBER 0xC02B0039 Invalid Structure Number 
RCX_E_INVALID_CHECKSUM 0xC02B4352 Invalid Checksum 
RCX_E_CONFIG_LOCKED 0xC02B4B54 Configuration Locked 
RCX_E_SEC_ZONE_NOT_READABLE 0xC02B4D52 Security EEPROM Zone Not Readable 

Table 31: RCX General Task Errors 
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14.3.2 RCX Common Status & Errors Codes 
 

Error Code (Definition) Value Description 
RCX_S_OK 0x00000000 Success, Status Okay 
RCX_E_FAIL 0xC0000001 Fail 
RCX_E_UNEXPECTED 0xC0000002 Unexpected 
RCX_E_OUTOFMEMORY 0xC0000003 Out Of Memory 
RCX_E_UNKNOWN_COMMAND 0xC0000004 Unknown Command 
RCX_E_UNKNOWN_DESTINATION 0xC0000005 Unknown Destination 
RCX_E_UNKNOWN_DESTINATION_ID 0xC0000006 Unknown Destination ID 
RCX_E_INVALID_PACKET_LEN 0xC0000007 Invalid Packet Length 
RCX_E_INVALID_EXTENSION 0xC0000008 Invalid Extension 
RCX_E_INVALID_PARAMETER 0xC0000009 Invalid Parameter 
RCX_E_WATCHDOG_TIMEOUT 0xC000000C Watchdog Timeout 
RCX_E_INVALID_LIST_TYPE 0xC000000D Invalid List Type 
RCX_E_UNKNOWN_HANDLE 0xC000000E Unknown Handle 
RCX_E_PACKET_OUT_OF_SEQ 0xC000000F Out Of Sequence 
RCX_E_PACKET_OUT_OF_MEMORY 0xC0000010 Out Of Memory 
RCX_E_QUE_PACKETDONE 0xC0000011 Queue Packet Done 
RCX_E_QUE_SENDPACKET 0xC0000012 Queue Send Packet 
RCX_E_POOL_PACKET_GET 0xC0000013 Pool Packet Get 
RCX_E_POOL_GET_LOAD 0xC0000015 Pool Get Load 
RCX_E_REQUEST_RUNNING 0xC000001A Request Already Running 
RCX_E_INIT_FAULT 0xC0000100 Initialization Fault 
RCX_E_DATABASE_ACCESS_FAILED 0xC0000101 Database Access Failed 
RCX_E_NOT_CONFIGURED 0xC0000119 Not Configured 
RCX_E_CONFIGURATION_FAULT 0xC0000120 Configuration Fault 
RCX_E_INCONSISTENT_DATA_SET 0xC0000121 Inconsistent Data Set 
RCX_E_DATA_SET_MISMATCH 0xC0000122 Data Set Mismatch 
RCX_E_INSUFFICIENT_LICENSE 0xC0000123 Insufficient License 
RCX_E_PARAMETER_ERROR 0xC0000124 Parameter Error 
RCX_E_INVALID_NETWORK_ADDRESS 0xC0000125 Invalid Network Address 
RCX_E_NO_SECURITY_MEMORY 0xC0000126 No Security Memory 
RCX_E_NETWORK_FAULT 0xC0000140 Network Fault 
RCX_E_CONNECTION_CLOSED 0xC0000141 Connection Closed 
RCX_E_CONNECTION_TIMEOUT 0xC0000142 Connection Timeout 
RCX_E_LONELY_NETWORK 0xC0000143 Lonely Network 
RCX_E_DUPLICATE_NODE 0xC0000144 Duplicate Node 
RCX_E_CABLE_DISCONNECT 0xC0000145 Cable Disconnected 
RCX_E_BUS_OFF 0xC0000180 Network Node Bus Off 
RCX_E_CONFIG_LOCKED 0xC0000181 Configuration Locked 
RCX_E_APPLICATION_NOT_READY 0xC0000182 Application Not Ready 
RCX_E_TIMER_APPL_PACKET_SENT 0xC002000C Timer App Packet Sent 

Table 32: RCX Common Status & Errors Codes 
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14.3.3 RCX Status & Error Codes 
 

Error Code (Definition) Value Description 
RCX_S_OK  0x00000000 SUCCESS, STATUS OKAY  
RCX_S_QUE_UNKNOWN  0xC02B0001 UNKNOWN QUEUE  
RCX_S_QUE_INDEX_UNKNOWN  0xC02B0002 UNKNOWN QUEUE INDEX 
RCX_S_TASK_UNKNOWN 0xC02B0003 UNKNOWN TASK  
RCX_S_TASK_INDEX_UNKNOWN 0xC02B0004 UNKNOWN TASK INDEX  
RCX_S_TASK_HANDLE_INVALID 0xC02B0005 INVALID TASK HANDLE  
RCX_S_TASK_INFO_IDX_UNKNOWN 0xC02B0006 UNKNOWN INDEX  
RCX_S_FILE_XFR_TYPE_INVALID 0xC02B0007 INVALID TRANSFER TYPE  
RCX_S_FILE_REQUEST_INCORRECT 0xC02B0008 INVALID FILE REQUEST  
RCX_S_UNKNOWN_DESTINATION 0xC0000005 UNKNOWN DESTINATION  
RCX_S_UNKNOWN_DESTINATION_ID 0xC0000006 UNKNOWN DESTINATION ID  
RCX_S_INVALID_LENGTH 0xC0000007 INVALID LENGTH  
RCX_S_UNKNOWN_COMMAND 0xC0000004 UNKNOWN COMMAND  
RCX_S_INVALID_EXTENSION 0xC0000008 INVALID EXTENSION  

Table 33: RCX Status & Error Codes 

 

14.3.3.1 RCX Status & Error Codes Slave State 
 

Error Code (Definition) Value Description 
RCX_SLAVE_STATE_UNDEFINED 0x00000000 UNDEFINED 
RCX_SLAVE_STATE_OK 0x00000001 OK 
RCX_SLAVE_STATE_FAILED 0x00000002 FAILED (at least one slave) 

Table 34: RCX Status & Error Codes Slave State 
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14.4 ODM Error Codes 
 

14.4.1 General ODM Error Codes 
 

Error Code (Definition) Value Description 

CODM3_E_INTERNALERROR 0x8004C700 Internal ODM Error 

ODM3_E_DESCRIPTION_NOTFOUND 0x8004C701 Description not found in ODM database 

CODM3_E_WRITEREGISTRY 0x8004C710 Error writing to the registry 

CODM3_E_BAD_REGULAR_EXPRESSION 0x8004C711 Invalid regular expression 

CODM3_E_COMCATEGORIE_MANAGER_ 
FAILED 

0x8004C712 Component Category Manager could not 
be instantiated 

CODM3_E_COMCATEGORIE_ENUMERATION_
FAILED 

0x8004C713 Driver could not be enumerated by the 
Category Manager 

CODM3_E_CREATE_LOCAL_BUFFER 0x8004C714 Error creating local buffers 

CODM3_E_UNKNOWNHANDLE 0x8004C715 Unknown handle 

CODM3_E_QUEUE_LIMIT_REACHED 0x8004C717 Queue size limit for connection reached 

CODM3_E_DATASIZE_ZERO 0x8004C718 Zero data length passed 

CODM3_E_INVALID_DATA 0x8004C719 Invalid data content 

CODM3_E_INVALID_MODE 0x8004C71A Invalid mode 

CODM3_E_DATABASE_READ 0x8004C71B Error reading database 

CODM3_E_CREATE_DEVICE_THREAD 0x8004C750 Error creating device thread 

CODM3_E_CREATE_DEVICE_THREAD_STOP_
EVENT 

0x8004C751 Error creating device thread stop event 

CODM3_E_CLIENT_NOT_REGISTERED 0x8004C752 Client is not registered at the ODM 

CODM3_E_NO_MORE_CLIENTS 0x8004C753 Maximum number of clients reached 

CODM3_E_MAX_CLIENT_CONNECTIONS_ 
REACHED 

0x8004C754 Maximum number of client connections 
reached 

CODM3_E_ENTRY_NOT_FOUND 0x8004C755 Driver/device not found 

CODM3_E_DRIVER_NOT_FOUND 0x8004C757 The requested driver is unknown to the 
ODM 

CODM3_E_DEVICE_ALREADY_LOCKED 0x8004C758 Device is locked by another process 

CODM3_E_DEVICE_UNLOCKED_FAILED 0x8004C759 Device could not be unlocked, lock was 
set by another process 

CODM3_E_DEVICE_LOCK_NECCESSARY 0x8004C75A Operation requires a device lock to be set 

CODM3_E_DEVICE_SUBSCRIPTIONLIMIT 0x8004C75B Maximum number of servers registered for 
this device reached 

CODM3_E_DEVICE_NOTSUBSCRIBED 0x8004C75C Process is not registered as a server on 
this device 

CODM3_E_DEVICE_NO_MESSAGE 0x8004C75D No message available 

CODM3_E_TRANSFERTIMEOUT 0x8004C760 Message transfer timeout 

CODM3_E_MESSAGE_INSERVICE 0x8004C761 Message in service 

Table 35: ODM Error Codes - General ODM Error Codes 
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14.4.2 General ODM Driver Error Codes 
 

Error Code (Definition) Value Description 
CODM3_E_DRV_OPEN_DEVICE 0x8004C7A0 Packet type unsupported by driver 
CODM3_E_DRV_INVALID_IDENTIFIER 0x8004C7A1 Invalid device identifier 
CODM3_E_DRV_DEVICE_PARAMETERS_ 
MISMATCH 

0x8004C7A3 Parameters differ from requested device 

CODM3_E_DRV_BROWSE_NO_DEVICES 0x8004C7A4 No devices found 
CODM3_E_DRV_CREATE_DEVICE_INST 0x8004C7A5 Device instance could not be created 
CODM3_E_DRV_DEVICE_NOMORE_TX 0x8004C7A6 Device connection limit reached 
CODM3_E_DRV_DEVICE_DUPLICATE_TX 0x8004C7A7 Duplicate transmitter ID 
CODM3_E_DRV_DEVICE_NOT_CONFIGURED 0x8004C7A8 Device is not configured 
CODM3_E_DRV_DEVICE_COMMUNICATION 0x8004C7A9 Device communication error 
CODM3_E_DRV_DEVICE_NO_MESSAGE 0x8004C7AA No message available 
CODM3_E_DRV_DEVICE_NOT_READY 0x8004C7AB Device not ready 
CODM3_E_DRV_INVALIDCONFIGURATION 0x8004C7AC Invalid driver configuration 
CODM3_E_DRV_DLINVALIDMODE 0x8004C7C0 Invalid download mode 
CODM3_E_DRV_DLINPROGRESS 0x8004C7C1 Download is active 
CODM3_E_DRV_ULINPROGRESS 0x8004C7C2 Upload is active 

Table 36: ODM Error Codes - General ODM Driver Error Codes 
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14.4.3 cifX Driver Specific ODM Error Codes 
 

 

cifX Driver Specific ODM Error Codes 
Error Code (Definition) Value Description 
DRV_E_BOARD_NOT_INITIALIZED 0x8004C001 DRIVER Board not initialized 
DRV_E_INIT_STATE_ERROR 0x8004C002 DRIVER Error in internal init state 
DRV_E_READ_STATE_ERROR 0x8004C003 DRIVER Error in internal read state 
DRV_E_CMD_ACTIVE 0x8004C004 DRIVER Command on this channel is 

active 
DRV_E_PARAMETER_UNKNOWN 0x8004C005 DRIVER Unknown parameter in function 
DRV_E_WRONG_DRIVER_VERSION 0x8004C006 DRIVER Version is incompatible with DLL 
DRV_E_PCI_SET_CONFIG_MODE 0x8004C007 DRIVER Error during PCI set configuration 

mode 

DRV_E_PCI_READ_DPM_LENGTH 0x8004C008 DRIVER Could not read PCI dual port 
memory length 

DRV_E_PCI_SET_RUN_MODE 0x8004C009 DRIVER Error during PCI set run mode 
DRV_E_DEV_DPM_ACCESS_ERROR 0x8004C00A DEVICE Dual port ram not 

accessable(board not found) 
DRV_E_DEV_NOT_READY 0x8004C00B DEVICE Not ready (ready flag failed) 
DRV_E_DEV_NOT_RUNNING 0x8004C00C DEVICE Not running (running flag failed) 
DRV_E_DEV_WATCHDOG_FAILED 0x8004C00D DEVICE Watchdog test failed 
DRV_E_DEV_OS_VERSION_ERROR 0x8004C00E DEVICE Signals wrong OS version 
DRV_E_DEV_SYSERR 0x8004C00F DEVICE Error in dual port flags 
DRV_E_DEV_MAILBOX_FULL 0x8004C010 DEVICE Send mailbox is full 
DRV_E_DEV_PUT_TIMEOUT 0x8004C011 DEVICE PutMessage timeout 
DRV_E_DEV_GET_TIMEOUT 0x8004C012 DEVICE GetMessage timeout 
DRV_E_DEV_GET_NO_MESSAGE 0x8004C013 DEVICE No message available 
DRV_E_DEV_RESET_TIMEOUT 0x8004C014 DEVICE RESET command timeout 
DRV_E_DEV_NO_COM_FLAG 0x8004C015 DEVICE COM-flag not set. Check if Bus is 

running 
DRV_E_DEV_EXCHANGE_FAILED 0x8004C016 DEVICE I/O data exchange failed 
DRV_E_DEV_EXCHANGE_TIMEOUT 0x8004C017 DEVICE I/O data exchange timeout 
DRV_E_DEV_COM_MODE_UNKNOWN 0x8004C018 DEVICE I/O data mode unknown 
DRV_E_DEV_FUNCTION_FAILED 0x8004C019 DEVICE Function call failed 
DRV_E_DEV_DPMSIZE_MISMATCH 0x8004C01A DEVICE DPM size differs from 

configuration 
DRV_E_DEV_STATE_MODE_UNKNOWN 0x8004C01B DEVICE State mode unknown 
DRV_E_DEV_HW_PORT_IS_USED 0x8004C01C DEVICE Output port already in use 
DRV_E_USR_OPEN_ERROR 0x8004C01E USER Driver not opened (device driver not 

loaded) 
DRV_E_USR_INIT_DRV_ERROR 0x8004C01F USER Can't connect to device 
DRV_E_USR_NOT_INITIALIZED 0x8004C020 USER Board not initialized (DevInitBoard 

not called) 
DRV_E_USR_COMM_ERR 0x8004C021 USER IOCTRL function failed 
DRV_E_USR_DEV_NUMBER_INVALID 0x8004C022 USER Parameter DeviceNumber invalid 
DRV_E_USR_INFO_AREA_INVALID 0x8004C023 USER Parameter InfoArea unknown 
DRV_E_USR_NUMBER_INVALID 0x8004C024 USER Parameter Number invalid 
DRV_E_USR_MODE_INVALID 0x8004C025 USER Parameter Mode invalid 
DRV_E_USR_MSG_BUF_NULL_PTR 0x8004C026 USER NULL pointer assignment 
DRV_E_USR_MSG_BUF_TOO_SHORT 0x8004C027 USER Message buffer too small 
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cifX Driver Specific ODM Error Codes 
Error Code (Definition) Value Description 
DRV_E_USR_SIZE_INVALID 0x8004C028 USER Parameter Size invalid 
DRV_E_USR_SIZE_ZERO 0x8004C02A USER Parameter Size with zero length 
DRV_E_USR_SIZE_TOO_LONG 0x8004C02B USER Parameter Size too long 
DRV_E_USR_DEV_PTR_NULL 0x8004C02C USER Device address null pointer 
DRV_E_USR_BUF_PTR_NULL 0x8004C02D USER Pointer to buffer is a null pointer 
DRV_E_USR_SENDSIZE_TOO_LONG 0x8004C02E USER Parameter SendSize too large 
DRV_E_USR_RECVSIZE_TOO_LONG 0x8004C02F USER Parameter ReceiveSize too large 
DRV_E_USR_SENDBUF_PTR_NULL 0x8004C030 USER Pointer to send buffer is a null 

pointer 
DRV_E_USR_RECVBUF_PTR_NULL 0x8004C031 USER Pointer to receive buffer is a null 

pointer 

DRV_E_DMA_INSUFF_MEM 0x8004C032 DMA Memory allocation error 
DRV_E_DMA_TIMEOUT_CH4 0x8004C033 DMA Read I/O timeout 
DRV_E_DMA_TIMEOUT_CH5 0x8004C034 DMA Write I/O timeout 
DRV_E_DMA_TIMEOUT_CH6 0x8004C035 DMA PCI transfer timeout 
DRV_E_DMA_TIMEOUT_CH7 0x8004C036 DMA Download timeout 
DRV_E_DMA_DB_DOWN_FAIL 0x8004C037 DMA Database download failed 
DRV_E_DMA_FW_DOWN_FAIL 0x8004C038 DMA Firmware download failed 
DRV_E_CLEAR_DB_FAIL 0x8004C039 DMA Clear database on the device failed 
DRV_E_DEV_NO_VIRTUAL_MEM 0x8004C03C DMA USER Virtual memory not available 
DRV_E_DEV_UNMAP_VIRTUAL_MEM 0x8004C03D DMA USER Unmap virtual memory failed 
DRV_E_GENERAL_ERROR 0x8004C046 DRIVER General error 
DRV_E_DMA_ERROR 0x8004C047 DRIVER General DMA error 
DRV_E_WDG_IO_ERROR 0x8004C048 DRIVER I/O WatchDog failed 
DRV_E_WDG_DEV_ERROR 0x8004C049 DRIVER Device Watchdog failed 
DRV_E_USR_DRIVER_UNKNOWN 0x8004C050 USER Driver unknown 
DRV_E_USR_DEVICE_NAME_INVALID 0x8004C051 USER Device name invalid 
DRV_E_USR_DEVICE_NAME_UKNOWN 0x8004C052 USER Device name unknown 

DRV_E_USR_DEVICE_FUNC_NOTIMPL 0x8004C053 USER Device function not implemented 

DRV_E_USR_FILE_OPEN_FAILED 0x8004C064 USER File could not be opened 

DRV_E_USR_FILE_SIZE_ZERO 0x8004C065 USER File size zero 

DRV_E_USR_FILE_NO_MEMORY 0x8004C066 USER Not enough memory to load file 

DRV_E_USR_FILE_READ_FAILED 0x8004C067 USER File read failed 

DRV_E_USR_INVALID_FILETYPE 0x8004C068 USER File type invalid 

DRV_E_USR_FILENAME_INVALID 0x8004C069 USER Invalid filename 

DRV_E_FW_FILE_OPEN_FAILED 0x8004C06E USER Firmware file could not be opened 

DRV_E_FW_FILE_SIZE_ZERO 0x8004C06F USER Not enough memory to load 
firmware file 

DRV_E_FW_FILE_NO_MEMORY 0x8004C070 USER Not enough memory to load 
firmware file 

DRV_E_FW_FILE_READ_FAILED 0x8004C071 USER Firmware file read failed 

DRV_E_FW_INVALID_FILETYPE 0x8004C072 USER Firmware file type invalid 

DRV_E_FW_FILENAME_INVALID 0x8004C073 USER Firmware file name not valid 

DRV_E_FW_DOWNLOAD_ERROR 0x8004C074 USER Firmware file download error 

DRV_E_FW_FILENAME_NOT_FOUND 0x8004C075 USER Firmware file not found in the 
internal table 

DRV_E_FW_BOOTLOADER_ACTIVE 0x8004C076 USER Firmware file BOOTLOADER active 
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cifX Driver Specific ODM Error Codes 
Error Code (Definition) Value Description 
DRV_E_FW_NO_FILE_PATH 0x8004C077 USER Firmware file no file path 

DRV_E_CF_FILE_OPEN_FAILED 0x8004C078 USER Configuration file could not be 
opend 

DRV_E_CF_FILE_SIZE_ZERO 0x8004C079 USER Configuration file size zero 

DRV_E_CF_FILE_NO_MEMORY 0x8004C07A USER Not enough memory to load 
configuration file 

DRV_E_CF_FILE_READ_FAILED 0x8004C07B USER Configuration file read failed 

DRV_E_CF_INVALID_FILETYPE 0x8004C07C USER Configuration file type invalid 

DRV_E_CF_FILENAME_INVALID 0x8004C07D USER Configuration file name not valid 

DRV_E_CF_DOWNLOAD_ERROR 0x8004C07E USER Configuration file download error 

DRV_E_CF_FILE_NO_SEGMENT 0x8004C07F USER No flash segment in the 
configuration file 

DRV_E_CF_DIFFERS_FROM_DBM 0x8004C080 USER Configuration file differs from 
database 

DRV_E_DBM_SIZE_ZERO 0x8004C083 USER Database size zero 

DRV_E_DBM_NO_MEMORY 0x8004C084 USER Not enough memory to upload 
database 

DRV_E_DBM_READ_FAILED 0x8004C085 USER Database read failed 

DRV_E_DBM_NO_FLASH_SEGMENT 0x8004C086 USER Database segment unknown 

DEV_E_CF_INVALID_DESCRIPT_VERSION 0x8004C096 CONFIG Version of the descript table 
invalid 

DEV_E_CF_INVALID_INPUT_OFFSET 0x8004C097 CONFIG Input offset is invalid 

DEV_E_CF_NO_INPUT_SIZE 0x8004C098 CONFIG Input size is 0 

DEV_E_CF_MISMATCH_INPUT_SIZE 0x8004C099 CONFIG Input size does not match 
configuration 

DEV_E_CF_INVALID_OUTPUT_OFFSET 0x8004C09A CONFIG Invalid output offset 

DEV_E_CF_NO_OUTPUT_SIZE 0x8004C09B CONFIG Output size is 0 

DEV_E_CF_MISMATCH_OUTPUT_SIZE 0x8004C09C CONFIG Output size does not match 
configuration 

DEV_E_CF_STN_NOT_CONFIGURED 0x8004C09D CONFIG Station not configured 

DEV_E_CF_CANNOT_GET_STN_CONFIG 0x8004C09E CONFIG Cannot get the Station 
configuration 

DEV_E_CF_MODULE_DEF_MISSING 0x8004C09F CONFIG Module definition is missing 

DEV_E_CF_MISMATCH_EMPTY_SLOT 0x8004C0A0 CONFIG Empty slot mismatch 

DEV_E_CF_MISMATCH_INPUT_OFFSET 0x8004C0A1 CONFIG Input offset mismatch 

DEV_E_CF_MISMATCH_OUTPUT_OFFSET 0x8004C0A2 CONFIG Output offset mismatch 

DEV_E_CF_MISMATCH_DATA_TYPE 0x8004C0A3 CONFIG Data type mismatch 

DEV_E_CF_MODULE_DEF_MISSING_NO_SI 0x8004C0A4 CONFIG Module definition is missing,(no 
Slot/Idx) 

Table 37: cifX Driver Specific ODM Error Codes 
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14.5 Error Codes cifX Device Driver and netX Driver 
14.5.1 Generic Error Codes 

 
 

Error Code (Definition) Value Description 
CIFX_INVALID_POINTER  0x800A0001 Invalid pointer (NULL) passed to driver 
CIFX_INVALID_BOARD  0x800A0002 No board with the given nameindex 

available 
CIFX_INVALID_CHANNEL  0x800A0003 No channel with the given index available 
CIFX_INVALID_HANDLE 0x800A0004 Invalid handle passed to driver 
CIFX_INVALID_PARAMETER  0x800A0005 Invalid parameter 
CIFX_INVALID_COMMAND 0x800A0006 Invalid command 
CIFX_INVALID_BUFFERSIZE  0x800A0007 Invalid buffer size 
CIFX_INVALID_ACCESS_SIZE 0x800A0008 Invalid access size 
CIFX_FUNCTION_FAILED  0x800A0009 Function failed 
CIFX_FILE_OPEN_FAILED  0x800A000A File could not be opened 
CIFX_FILE_SIZE_ZERO 0x800A000B File size is zero 
CIFX_FILE_LOAD_INSUFF_MEM  0x800A000C Insufficient memory to load file 
CIFX_FILE_CHECKSUM_ERROR  0x800A000D File checksum compare failed 
CIFX_FILE_READ_ERROR  0x800A000E Error reading from file 
CIFX_FILE_TYPE_INVALID  0x800A000F Invalid file type 
CIFX_FILE_NAME_INVALID 0x800A0010 Invalid file name 
CIFX_FUNCTION_NOT_AVAILABLE 0x800A0011 Driver function not available 
CIFX_BUFFER_TOO_SHORT 0x800A0012 Given buffer is too short 
CIFX_MEMORY_MAPPING_FAILED  0x800A0013 Failed to map the memory 
CIFX_NO_MORE_ENTRIES 0x800A0014 No more entries available 
CIFX_CALLBACK_MODE_UNKNOWN  0x800A0015 Unkown callback handling mode 
CIFX_CALLBACK_CREATE_EVENT_FAILED  0x800A0016 Failed to create callback events 
CIFX_CALLBACK_CREATE_RECV_BUFFER  0x800A0017 Failed to create callback receive buffer 

Table 38: Generic Error Codes 
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14.5.2 Generic Driver Error Codes 
 
Error Code 
(Definition) 

Value Description 

CIFX_DRV_NOT_INITIALIZED  0x800B0001 Driver not initialized 
CIFX_DRV_INIT_STATE_ERROR 0x800B0002 Driver init state error 
CIFX_DRV_READ_STATE_ERROR 0x800B0003 Driver read state error 
CIFX_DRV_CMD_ACTIVE 0x800B0004 Command is active on device 
CIFX_DRV_DOWNLOAD_FAILED  0x800B0005 General error during download 
CIFX_DRV_WRONG_DRIVER_VERSION 0x800B0006 Wrong driver version 
CIFX_DRV_DRIVER_NOT_LOADED  0x800B0030 CIFx driver is not running 
CIFX_DRV_INIT_ERROR 0x800B0031 Failed to initialize the device 
CIFX_DRV_CHANNEL_NOT_INITIALIZED  0x800B0032 Channel not initialized (xOpenChannel not 

called) 
CIFX_DRV_IO_CONTROL_FAILED  0x800B0033 IOControl call failed 
CIFX_DRV_NOT_OPENED( 0x800B0034 Driver was not opened 
CIFX_DRV_DOWNLOAD_STORAGE_UNKNOWN 0x800B0040 Unknown download storage type 

(RAMFLASH based) found 
CIFX_DRV_DOWNLOAD_FW_WRONG_CHANNE
L 

0x800B0041 Channel number for a firmware download 
not supported 

CIFX_DRV_DOWNLOAD_MODULE_NO_BASEOS  0x800B0042 Modules are not allowed without a Base 
OS firmware 

Table 39: Generic Driver Error Codes 
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14.5.3 Generic Device Error Codes 
 

Error Code (Definition) Value Description 
CIFX_DEV_DPM_ACCESS_ERROR 0x800C0010 Dual port memory not accessable (board 

not found) 
CIFX_DEV_NOT_READY  0x800C0011 Device not ready (ready flag failed) 
CIFX_DEV_NOT_RUNNING  0x800C0012 Device not running (running flag failed) 
CIFX_DEV_WATCHDOG_FAILED  0x800C0013 Watchdog test failed 
CIFX_DEV_SYSERR 0x800C0015 Error in handshake flags 
CIFX_DEV_MAILBOX_FULL 0x800C0016 Send mailbox is full 
CIFX_DEV_PUT_TIMEOUT  0x800C0017 Send packet timeout 
CIFX_DEV_GET_TIMEOUT  0x800C0018 Receive packet timeout 
CIFX_DEV_GET_NO_PACKET  0x800C0019 No packet available 
CIFX_DEV_MAILBOX_TOO_SHORT  0x800C001A Mailbox too short 
CIFX_DEV_RESET_TIMEOUT  0x800C0020 Reset command timeout 
CIFX_DEV_NO_COM_FLAG  0x800C0021 COM-flag not set 
CIFX_DEV_EXCHANGE_FAILED  0x800C0022 IO data exchange failed 
CIFX_DEV_EXCHANGE_TIMEOUT 0x800C0023 IO data exchange timeout 
CIFX_DEV_COM_MODE_UNKNOWN 0x800C0024 Unknown IO exchange mode 
CIFX_DEV_FUNCTION_FAILED  0x800C0025 Device function failed 
CIFX_DEV_DPMSIZE_MISMATCH 0x800C0026 DPM size differs from configuration 
CIFX_DEV_STATE_MODE_UNKNOWN 0x800C0027 Unknown state mode 
CIFX_DEV_HW_PORT_IS_USED  0x800C0028 Device is still accessed 
CIFX_DEV_CONFIG_LOCK_TIMEOUT  0x800C0029 Configuration locking timeout 
CIFX_DEV_CONFIG_UNLOCK_TIMEOUT  0x800C002A Configuration unlocking timeout 
CIFX_DEV_HOST_STATE_SET_TIMEOUT 0x800C002B Set HOST state timeout 
CIFX_DEV_HOST_STATE_CLEAR_TIMEOUT  0x800C002C Clear HOST state timeout 
CIFX_DEV_INITIALIZATION_TIMEOUT 0x800C002D Timeout during channel initialization 
CIFX_DEV_BUS_STATE_ON_TIMEOUT 0x800C002E Set Bus ON Timeout 
CIFX_DEV_BUS_STATE_OFF_TIMEOUT  0x800C002F Set Bus OFF Timeout 
CIFX_DEV_MODULE_ALREADY_RUNNING 0x800C0040 Module already running 
CIFX_DEV_MODULE_ALREADY_EXISTS  0x800C0041 Module already exists 

Table 40: Generic Device Error Codes 
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14.6 Error Codes netX Driver 
 

14.6.1 CIFX API Transport Error Codes 
 

Error Code (Definition) Value Description 
CIFX_TRANSPORT_SEND_TIMEOUT 0x800D0001 Time out while sending data 
CIFX_TRANSPORT_RECV_TIMEOUT 0x800D0002 Time out waiting for incoming data 
CIFX_TRANSPORT_CONNECT  0x800D0003 Unable to communicate to the deviceno 

answer 
CIFX_TRANSPORT_ABORTED  0x800D0004 Transfer has been aborted due to keep 

alive timeout or interface detachment 
CIFX_CONNECTOR_FUNCTIONS_READ_ERRO
R  

0x800D0010 Error reading the connector functions from 
the DLL 

CIFX_CONNECTOR_IDENTIFIER_TOO_LONG  0x800D0011 Connector delivers an identifier longer 
than 6 characters 

CIFX_CONNECTOR_IDENTIFIER_EMPTY 0x800D0012 Connector delivers an empty dentifier 
CIFX_CONNECTOR_DUPLICATE_IDENTIFIER  0x800D0013 Connector identifier already used 

Table 41: CIFX API Transport Error Codes 

 

 

14.6.2 CIFX API Transport Header State Error Codes 
 

Error Code (Definition) Value Description 
CIFX_TRANSPORT_ERROR_UNKNOWN  0x800E0001 Unknown error code in transport header 
CIFX_TRANSPORT_CHECKSUM_ERROR 0x800E0002 CRC16 checksum failed 
CIFX_TRANSPORT_LENGTH_INCOMPLETE  0x800E0003 Transaction with inclomplete length 

detected 
CIFX_TRANSPORT_DATA_TYPE_UNKOWN 0x800E0004 Device does not support requested data 

type 
CIFX_TRANSPORT_DEVICE_UNKNOWN 0x800E0005 Device not availableunknown 
CIFX_TRANSPORT_CHANNEL_UNKNOWN  0x800E0006 Channel not availableunknown 
CIFX_TRANSPORT_SEQUENCE 0x800E0007 Sequence error detected 
CIFX_TRANSPORT_BUFFEROVERFLOW 0x800E0008 Buffer overflow detected 
CIFX_TRANSPORT_RESOURCE 0x800E0009 Device signals out of resources 
CIFX_TRANSPORT_KEEPALIVE  0x800E000A Device connection monitoring error (Keep 

alive) 
CIFX_TRANSPORT_DATA_TOO_SHORT( 0x800E000B Received transaction data too short 

Table 42: CIFX API Transport Header State Error Codes 

 

 



Error Codes 150/160 

Configuration of LAN Controlled Master Devices | netHOST  
DOC130402OI05EN | Revision 5 | English | 2017-03 | Released | Public  © Hilscher 2013 - 2017 

14.7 ODM Error Codes DBM V4 
 

 

ODM Error Codes DBM V4 
Error Code (Definition) Value Description 
CDBM_E_MD5_INVALID 0XC004C810 Checksum invalid 
CDBM_E_INTERNALERROR 0XC004C811 Internal Error 
CDBM_W_WRITEREGISTRY 0X8004C812 Error writing to the registry 
CDBM_E_UNEXPECTED_VALUE_ 
IN_OLD_HEADER_FORMAT 

0XC004C813 Error in a file containing the old DBM 
Header format. 

CDBM_E_CHECKSUM_INVALID 0XC004C814 The Checksum of the old Header is invalid 
CDBM_E_DB_ALREADY_LOADED_ FORMAT 0XC004C815 A database is already loaded 
CDBM_E_NO_VALID_TRANSACTION 0XC004C816 No valid transaction handle given 
CDBM_E_STD_STRUCT_ERROR 0XC004C817 An error occurred during validation of data 
CDBM_E_UNSUPPORTED_ 
DATA_TYPE_FORMAT 

0XC004C818 Unsupported DataType 

CDBM_W_CLASS_DELETED_ FORMAT 0X8004C819 
(Warning) 

Using an Object which is marked as 
deleted 

CDBM_W_CLIENT_DISCONNECTED 0X8004C81A 
(Warning) 

A Client has already an outstanding 
connection to a Table. The connection is 
now destroyed. 

CDBM_E_STRUCTURE_DEFINITION_ INVALID 0XC004C81B A structure definition of an Element in a 
Table is invalid 

CDBM_E_NO_DATA_AVAILABLE 0XC004C81C No data available for this operation 
CDBM_E_NO_VALID_STRUCTURE 0XC004C81D No valid structure available for this 

operation 

CDBM_E_NO_TOGGLE_STRING_ FOUND 0XC004C81E No Toggle string found for this number 
CDBM_E_ELEMENT_OUT_OF_RANGE 0XC004C81F An element wasn’t found in the Record of 

a Table 
CDBM_E_ELEMENT_NOT_IN_ TABLE 0XC004C820 The element is not part of the Table 
CDBM_E_CANNOT_CONVERT_ 
INTO_CLIENT_TYPE 

0XC004C821 The data can't be converted into the Client 
type 

CDBM_E_TRANSACTION_ ALREADY_OPEN 0XC004C822 A transaction is already open. Please 
close this one first before opening a new 
one. 

CDBM_I_OLD_WITHOUT_HEADER 0X4004C823 
(Informational) 

Use of an old DBM file Format without 
Header 

CDBM_E_HR_FROM 0XC004C824 An HRESULT was received from a 
Subroutine 

CDBM_E_PARAMETER 0XC004C825 A Parameter is invalid 
CDBM_E_NOTIMPL 0XC004C826 Method is currently not implemented 
CDBM_E_OUTOFMEMORY 0XC004C827 Out of memory 
CDBM_E_NO_OPEN_TRANSACTION 0XC004C828 No transaction open 
CDBM_E_NO_CONTENTS 0XC004C829 No contents available 
CDBM_REC_NO_NOT_FOUND 0XC004C82A Record not found 
CDBM_STRUCTURE_ELEMENT_ NOT_FOUND 0XC004C82B Element of the Structure not found 
CDBM_E_NO_MORE_RECORDS_ IN_TABTYPE 0XC004C82C Table type 3 can contain only one record 
CDBM_E_WRITE 0XC004C82D The data in the VARIANT must be given in 

a SafeArray 
CDBM_E_WRITE_NO_PARRAY 0XC004C82E The VARIANT contains no valid [parray] 

element 
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ODM Error Codes DBM V4 
Error Code (Definition) Value Description 
CDBM_E_WRITE_CANT_ ACCESS_DATA 0XC004C82F Unable to access SafeArray Data in the 

VARIANT 
CDBM_E_WRITE_DATA 0XC004C830 To write the data of this Element it must be 

given as a BSTR, or as an Array of 
VT_UI1/VT_I1 

CDBM_E_WRITE_BSTR_E1 0XC004C831 The BSTR string must have an even 
length. 

CDBM_E_WRITE_BSTR_E2 0XC004C832 The BSTR string must contain only hex 
digits (0..9 and a/A..f/F). 

CDBM_E_WRITE_CANT_ INTERPRET_ARRAY 0XC004C833 Unable to interpret data in the SafeArray. 
CDBM_E_WRITE_VT_ERROR 0XC004C834 Data type in the SafeArray is not VT_UI1 

or VT_I1. 
CDBM_E_WRITE_LENGTH 0XC004C835 Data length is invalid for write operation of 

this type. 
CDBM_WRITE_ELEMENT 0XC004C836 Element not found in the Record of the 

Table 
CDBM_MIN_MAX_ERROR 0XC004C837 Can't write data because of min underflow 

or max overflow 
CDBM_TABLE_EXIST 0XC004C838 Table already exist in the database 
CDBM_MIN_MAX_INVALID 0XC004C839 The Min value is greater than the Max 

Value 
CDBM_DEF_MIN_MAX_INVALID 0XC004C83A The Default Value is not in the range 

between the Min value and the Max Value 
CDBM_CANT_CHANGE_STRUCTURE_ 
WHILE_RECORDS_EXIST 

0XC004C83B It's not allowed to change the structure 
while Records exist in the Table 

CDBM_NEW_STRUCT_NEEDS_TYPE 0XC004C83C In a newly added structure the data type 
must be set also 

CDBM_VALUE_ERROR 0XC004C83D Range error while validating a value 
CDBM_DATATYPE_ UNSUPPORTED_IN_RCS 0XC004C83E The data type is unsupported in the RCS 

file format 
CDBM_I_COUNT_OF_TABLES_ 
EXCEEDS_RCS_RANGE 

0X4004C83F 
(Informational) 

The count of Tables exceeds the RCS 
range of Tables. This can cause problems 
if the file is downloaded to RCS Systems 

CDBM_I_COUNT_OF_TABLES_ 
EXCEEDS_OLDDBM_RANGE 

0X4004C840 
(Informational) 

The count of Tables exceeds the 
DBM32.DLL range of Tables. This can 
cause problems if the file is used with older 
Tools using the DBM32.DLL 

CDBM_UNSUPPORTED_DATATYPE_ 
IN_RCS_MODE 

0XC004C841 The Data type is not compatible with the 
old database format 

CDBM_WRITE_UNSTRUCTURED_1 0XC004C842 The data of an unstructured record can 
only be written with the 'Write' Method not 
with 'WriteElement'. 

CDBM_READ_UNSTRUCTURED_1 0XC004C843 The data of an unstructured record can 
only be read with the 'Read' Method not 
with 'ReadElement' 

CDBM_WRITE_DATA_LENGTH_ INVALID 0XC004C844 The given data length doesn’t correspond 
with the expected data length. 

CDBM_UNKNOWN_VIEW_MODE 0XC004C845 The View Mode is unknown. 
CDBM_E_DIAG_TABLE 0XC004C846 It doesn’t make much sense to add or 

delete records from a diagnostic table 
because those changes are never saved. 
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ODM Error Codes DBM V4 
Error Code (Definition) Value Description 
CDBM_E_ADR_STRING_ERROR 0XC004C847 The given Address string doesn’t fit the 

required format of this type where all 
address bytes must be in the range 
between 0 and FF 

CDBM_ERROR_FROM_VAR_ CHANGE_TYPE 0XC004C848 Function VariantChangeType return an 
error when trying to convert the Parameter 

CDBM_E_MINERROR 0XC004C849 Error while comparing the Value with the 
lower range 

CDBM_E_MAXERROR 0XC004C84A Error while comparing the Value with the 
upper range 

CDBM_E_RANGE_ERROR 0XC004C84B Value out of Range 
CDBM_E_TABLE_TYPE1 0XC004C84C Table type 1 doesn’t have a unique record 

length over all records 
CDBM_E_TABLE_TYPE3_ ADDREC 0XC004C84D Table type 3 doesn’t allow to insert more 

than one Record 
CDBM_E_TABTYPE1 0XC004C84E It's not allowed to insert more Records 

than structure definitions in Table Type 1 
CDBM_E_TOGGLE_NOT_FOUND 0XC004C84F Could not find the string for this value in 

the list of valid toggle strings 
CDBM_E_TOGGLE_VALUE_IS_ EMPTY_STRING 0XC004C850 The toggle string for this value is empty. 
CDBM_VARIANT2BYTEARRAY_ ERROR 0XC004C851 Error during conversion of Variant to byte 

array 
CDBM_E_SET_ELEM_PROP_ DEPENDENCY 0XC004C852 The Toggle Type needs also the additional 

string and the additional number  entries in 
the Method 

CDBM_E_TABTYPE1_REC_ 
DOESNT_CORRESPOND_ WITH_ELEMENT 

0XC004C853 When reading the records of Table type 1 
elementwise the record number must 
correspond with the element number 

CDBM_TABTYPE1_NO_DATA_ 
FOUND_FOR_RECORD 

0XC004C854 When reading the records of Table type 1 
and structure definitions are present it's 
assumed that for each structure element a 
corresponding record must exist 

CDBM_E_TABTYPE1_WRITE_ 
ELEMENT_NE_RECORD 

0XC004C855 When writing the records of Table type 1 
elementwise and structure definitions are 
present it's only allowed to write the 
corresponding element number in each 
record 

CDBM_E_TABTYPE1_WRITE_ 
ELEMENT_NOT_FOUND 

0XC004C856 When writing the records of Table type 1 
with an array and structure definitions are 
present it's assumed that a corresponding 
element number of this record exist 

CDBM_I_TABLE_NAME_EXCEEDS_ 
RCS_RANGE 

0X4004C857 
(Informational) 

The Table name exceeds the maximum 
length of RCS compatible Table names 

CDBM_W_CUT_STRING 0X8004C858 
(Warning) 

The string exceeds the maximum length 
and will be limited to the maximum length 

CDBM_I_STRING_TOO_SHORT 0X4004C859 
(Informational) 

The string is below the minimum length. 
The minimum length will be reduced. 

CDBM_I_STRING_TOO_LONG 0X4004C85A 
(Informational) 

The string is exceeding the maximum. The 
maximum length will be extended. 

CDBM_E_STRING_TOO_SHORT 0XC004C85B 
(Error) 

The string is below the minimum length. 

CDBM_E_STRING_TOO_LONG 0XC004C85C 
(Error) 

The string is exceeding the maximum 
length 
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ODM Error Codes DBM V4 
Error Code (Definition) Value Description 
CDBM_E_WRONG_TYPE_ FOR_WRITE 0XC004C85D Writing on the Element type with the given 

Data type is not implemented 
CDBM_E_NO_APPEND_IN_ 
STRUCTURED_RECORDS 

0XC004C85E Method IDbmRecord::AppendData is not 
allowed for structured records 

CDBM_E_DATA_UNAVAILABLE 0XC004C85F No data available 
CDBM_E_CANT_CONVERT_ INTO 0XC004C860 Unable to convert the value into the 

Element type 
CDBM_E_DBM_FILE_OVERFLOW 0XC004C861 You try to write a RCS like database which 

needs too much bytes 
CDBM_E_PW_ERROR 0XC004C862 Password not correct 
CDBM_E_FILELENGTH_CORRUPT 0XC004C863 The file length doesn’t correspond to the 

length given in the Header. 
CDBM_E_STRUCT_TYPE 0XC004C864 Error in the file. 
CDBM_E_MD5SUM_INVALID 0XC004C865 MD5 sum invalid 
CDBM_E_STRUCT_LENGTH 0XC004C866 Error in the expected and given structure 

length at a specific offset in the file. 
CDBM_E_APPEND 0XC004C867 Append of data is only allowed if the 

Record contains only one data field and 
the field type will support this 

CDBM_APPEND_NOT_ SUPPORTED 0XC004C868 Append of Data not supported by this filed 
type 

CDBM_DATA_TYPE_APPEND_ ERROR 0XC004C869 Can't append Data of this type. 
CDBM_E_UNSTRUCTURED_TABLE_ 
DOESNT_SUPPORT_LENGTH 

0XC004C86A A Table without structure information 
doesn’t support a record length 

CDBM_E_DISABLED_WHILE_ 
TRANSACTION_IS_OPEN 

0XC004C86B The Method is disabled while a transaction 
is open. Please close this one first and call 
the Method again. 

CDBM_E_UNABLE_TO_CALL_ 
READ_ON_LINKED_LIST 

0XC004C86C The Method is disabled on a LinkedList 
type. Please use the IRecordCollection on 
this type. 

CDBM_E_ELEMENT_HAS_NO_ 
SUBSTRUCTURE 

0XC004C86D An Element from a Table has no 
substructure 

CDBM_STRUCT_ERROR_FROM_ 
VAR_CHANGE_TYPE 

0XC004C86E Error from calling VariantChangeType 

CDBM_E_FOREIGNKEY_DEF 0XC004C86F The definition of a FOREIGNKEY must 
contain the name of the related Table in 
the description and this Table must exist at 
this time 

CDBM_E_FOREIGNKEY_ REF_TAB 0XC004C870 The description of a FOREIGNKEY must 
refer to a Table of type 
'eDbmTableTypeLinkedList' 

CDBM_E_KEY 0XC004C871 To create a Record Collection with a KEY 
it's necessary to have the data type KEY at 
the first position in all Records of the 
searched Table 

CDBM_E_KEY_TABLE_TYPE 0XC004C872 This Method needs a Table of type 
'eDbmTableTypeLinkedList' 

CDBM_DATATYPE_NOT_ IMPLEMENTED 0XC004C873 This data type is currently not implemented 
CDBM_INSERT_POS_NOT_ FOUND 0XC004C874 The position of the Record where the new 

one should be inserted wasn’t found 
CDBM_E_INSERT_REC_QI 0XC004C875 Error during insertion of a Record 
CDBM_E_TAB_PROP 0XC004C876 Invalid Property in Table 
CDBM_E_KEY_NOT_FOUND 0XC004C877 The KEY wasn’t found in the Table 
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ODM Error Codes DBM V4 
Error Code (Definition) Value Description 
CDBM_E_KEY_INVALID 0XC004C878 The KEY is invalid for this operation 

Table 43: ODM Error Codes DBM V4 

 
 



Appendix 155/160 

Configuration of LAN Controlled Master Devices | netHOST  
DOC130402OI05EN | Revision 5 | English | 2017-03 | Released | Public  © Hilscher 2013 - 2017 

15 Appendix 
15.1 User Rights for the netHOST DTM 

The user rights for the netHOST DTM are set within the FDT-container, i. e. 
SYCON.net. Opening the dialog windows and reading the parameters do 
not require special user rights. Also, all users can choose between the 
decimal or hexadecimal display mode or sort table entries. 
Editing/configuring the parameters of the dialog windows belonging to the 
Settings and Configuration category, however, requires the user right of 
Maintenance, Planning Engineer or Administrator. 
The following tables give an overview of the existing user groups and their 
access rights regarding the netHOST DTM. 

User rights for the “Settings” dialog windows 
 

Dialog window / activity Observer Operator Maintenance Planning 
Engineer 

Adminis-
trator 

Driver Dialog Window D D X X X 

 Select driver - - X X X 

netX Driver Dialog Window D D X X X 

 Configure driver - - X X X 
Device Assignment Dialog 
Window 

D D X X X 

 Search device - - X X X 

 Select device - - X X X 

Table 44: Settings (D = Displaying, X = Editing, Configuring) 

 

User rights for the “Configuration” dialog windows 
 

Dialog window Observer Operator Maintenance Planning 
Engineer 

Adminis-
trator 

Settings Dialog Window D D X X X 

Memory Card Management 
Dialog Window 

D D X X X 

Licensing Dialog Window D D X X X 

Table 45: Configuration (D = Displaying, X = Editing, Configuring) 
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