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1 Introduction

1.1 About this manual
This manual provides information on how to set up EtherCAT Slave devices
described with XML DDF files. These devices can be configured with the
generic EtherCAT Slave DTM within an FDT Framework.

1.1.1 Online help
The generic EtherCAT Slave DTM contains an integrated online help.
Ø To open the online help, click on Help or press F1.

1.1.2 List of revisions
Index Date Version Component Changes
8 2023-02-06 1.1100

1.1100
EtherCATGenericSlaveDTM.dll
EtherCATGenericSlaveDTM.ocx

Document revised.

Table 1: List of revisions

1.2 Overview use cases
In the table below you find an overview of the applicable use cases.

Use case Description Chapter, section
Device start up · Creating project configuration Create project configuration
Configuring device
parameters

· Device behavior settings
· Set distributed clock parameters
· Set process data parameters

Behavior [} page 15]
Distributed clock [} page 19]
Process data [} page 24]

Descriptions · XML DDF viewer XML DDF viewer [} page 29]
User rights Definition of access rights User rights

Table 2: Overview use cases
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1.3 System requirements
· PC with 1 GHz processor or higher
· Windows® XP SP3,

Windows® Vista (32-Bit) SP2,
Windows® 7 (32-Bit and 64-Bit) SP1,
Windows® 8 (32-Bit and 64-Bit),
Windows® 8.1 (32-Bit and 64-Bit),
Windows® 10 (32-Bit and 64-Bit)

· Administrator privilege required for installation
· Internet Explorer 5.5 or higher
· RAM: min. 512 MByte, recommended 1024 MByte
· Graphic resolution: min. 1024 x 768 pixel
· Keyboard and Mouse
· Restriction: Touch screen is not supported.

Note:
If the project file is used on a further PC,
- this PC must also comply with the above system requirements,
- the device description files of the devices used in the project must
be imported into the configuration software SYCON.net on the new
PC,
- and the DTMs of the devices used in the project must also be
installed on that further PC.

1.4 About the generic EtherCAT Slave DTM
Using the generic EtherCAT Slave DTM you can:

· configure slave device within an FDT frame application whose settings
are defined via XML DDF files;

· store the information required for configuring the slave device in the
master and thus configure the master device.
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1.5 Requirements generic EtherCAT Slave DTM
The following requirements apply when working with a generic EtherCAT
Slave DTM:
· Installed FDT/DTM frame application (V1.2 compliant)
· Installed EtherCAT Master DTM
· XML DDF files of the devices to be configured
· The DTM must be loaded into the device catalog.
· Loading XML DDL files

To add devices to the netDevice device catalog, the XML DDL files of the
used devices must be imported via Network > Import device
descriptions .... into the folder C:\ProgramData\ SYCONnet\[protocol
name]\DDL and the device catalog must be reloaded.

1.6 DTM dialog structure
The graphical user interface of the DTM is composed of different areas and
elements listed hereafter:
1. A header area containing the General device information,
2. the Navigation area (area on the left side),
3. The Dialog pane (main area on the right side),
4. OK, Cancel, Apply, Help,
5. The Status line containing information e. g. the online-state of the

DTM.

Figure 1: Dialog structure of the Device Type Manager
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1.6.1 General device information
Parameter Description
IO device Device name
Vendor Vendor name of he device
Device ID Identification number of the device
Vendor ID Identification number of the vendor

Table 3: General device information

1.6.2 Navigation area
In the navigation area, you can select the individual dialog panes via the
folder structure of the DTM.

Figure 2: Navigation area

Ø Select the required folder and subfolder.
ð The corresponding dialog pane appears.
Ø Click , to hide or to open the navigation area.

1.6.3 Dialog pane
In the dialog pane area, the different windows of the DTM appear only with
displayed information or for required setting steps. You call up the
respective windows via the associated folder in the navigation area.
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1.6.4 OK, Cancel, Apply, Help,
In the configuration software SYCON.net the following is valid:

Description
OK To confirm your latest settings, click OK.

All changed values will be applied on the frame application database. The dialog then closes.
Cancel To cancel your latest changes, click Cancel.

Answer to the safety query "Configuration data has been changed. Do you want to save the data?" by
Yes, No or Cancel.
· Yes: The changes are saved or the changed values are applied on the frame application database.

The dialog then closes.
· No: The changes are not saved or the changed values are not applied on the frame application

database. The dialog then closes.

· Cancel: Back to the DTM.
Apply To confirm your latest settings, click Apply.

All changed values will be applied on the frame application database. The dialog remains opened.
Help To open the DTM online help, click Help.

Table 4: OK, Cancel, Apply, Help

1.6.5 Table lines
In the DTM dialog pane, you can select table lines.

Element Description
Click First line to select the first row of a table.

Click Previous line to select the previous row of a table.

Click Next line to select the next row in a table.

Click Last line to select the last row of a table.

Table 5: Select table line
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1.6.6 Status bar
In the status bar, graphical icons display the current DTM state (e. g.,
connection status, or other activities).

Figure 3: Status bar – status fields 1 to 6

Status 
field

Icon / description

1 DTM connection states
Connected: Icon closed = Device is online

Disconnected: Icon opened = Device is offline

2 Data source states
Data set: The displayed data is read out from the instance data set
(database).

Device: The displayed data is read out from the device.

3 States of the instance date set
Valid Modified: Parameter is changed (not equal to data source).

Table 6: Status bar icons [1]

Offline state

Online state

Table 7: Status bar, display examples
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2 Safety

2.1 General note
The documentation in the form of a user manual, an operating instruction
manual or other manual types, as well as the accompanying texts, have
been created for the use of the products by qualified personnel. When
using the products, all Safety Messages, Integrated Safety Messages,
Property Damage Messages and all valid legal regulations must be obeyed.
Technical knowledge is presumed. The user has to assure that all legal
regulations are obeyed.

2.2 Intended use
The generic EtherCAT Slave DTM serves for configuration of EtherCAT
Slave devices.

2.3 Personnel qualification
Personnel responsible for the application of the network system shall be
aware of the system behavior and shall be trained in using the system.

Generic EtherCAT Slave DTM | Configuration of EtherCAT Slave devices
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3 Device start up

3.1 Configuration steps
The following overview provides to you the step sequence on how to
configure an EtherCAT Slave device with a generic EtherCAT Slave DTM
as it is typical for many cases. It is assumed at this point that the installation
of the EtherCAT Master DTM has been completed.

Step Brief description Further information
Add EtherCAT Slave in the
device catalog

- Open configuration software SYCON.net.
- Network > Import device descriptions.
- Import the device description.

Section Create project
configuration [} page 12], or
operating instruction manual
“SYCON.net” and operating
instruction manual “netDevice
and netProject”

Load device catalog - Select Network > Device catalog,
- Reload catalog.

Create / open project - Select File > New or File > Open.
Insert the master device
and the slave device and
into configuration

- In the Device catalog, select the master device and
insert the device via drag & drop to the line in the
network view.
- In the Device catalog, select the slave device, and
insert it via drag and drop to the master bus line in the
network view.

Configure slave - Select Behavior.
- Set the device behavior parameters. 
- Select Distributed clock.
- Set the distributed clock parameters. 
- Select Process data.
- Set the process data parameters.
- Close the dialog via OK.

Behavior [} page 15]
Distributed clock [} page 19]
Process data [} page 24]

Configure master device Configure the master device via the EtherCAT Master
DTM netX.

Operating instruction manual of
the DTM

Save project - Select File > Save. Operating instruction manual
“SYCON.net”

Table 8: Getting started – Configuration steps
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3.2 Create project configuration
1. Complete the slave device in the device catalog.

Ø Select Network > Import device descriptions.
Ø Import the device description file.

2. Load device catalog
Ø Select Network > Device catalog.
Ø Select Reload catalog.

3. Create or open a project.
Ø Create new project / open existing project:
Ø Select File > New or File > Open.

4. Insert slave device to the configuration.
Ø In the device catalog, select the master device, and insert it via drag

and drop to the line in the network view.
Ø In the device catalog, under Slave, select the slave device.
Ø Insert the slave device via drag and drop to the master bus line.

Notes

Note:
In order to select the desired device in the device catalog, note the
details about the DTM and the device at the bottom of the device
catalog window. When sorting by fieldbus, several devices with the
same name from different vendors can be displayed.

For further information, see operating instruction manual
"SYCON.net" or "netDevice and netProject".

Generic EtherCAT Slave DTM | Configuration of EtherCAT Slave devices
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4 Configuration

4.1 Overview configure device parameters
Under "Configuration", you can configure your device.
· The General dialog pane shows general device data.
· In the General settings dialog pane, you can make device specific

settings.
· In the Signal configuration dialog, you can define the data structure of

the input and output data of your device and assign suitable data types,
names or signal names.

· In the Behavior pane, you can set or read parameters for the device
behavior (state machine time monitoring, device check, process data,
and watchdog timer).

· In the CoE Mailbox settings pane you can read the configured size of
the input or output mailbox for slave devices with CoE mailbox
functionality. CoE (CANopen over EtherCAT) is configured in the
master DTM.

Figure 4: Navigation area – configuration

Note:
To edit the dialog panes under Configuration, you need the user
rights for "Maintenance".

For further information about configuration, see the sections:
· General [} page 14],
· Behavior [} page 15],
· Distributed clock [} page 19],
· Process data [} page 24] and
· Mailbox [} page 28].
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4.2 General
The General dialog pane shows the general device data. The description
(editable) shows the current device designation. The station address (non-
editable) is set by the EtherCAT Master.
Ø Select Configuration > General in the navigation area.

Figure 5: Configuration > General

Parameter Description Editable
Description Symbolic Name of the EtherCAT Slave station Yes
Device type Device type as defined in the DDF No
Device name Device name as defined in the DDF No
Product revision Product revision as defined in the DDF or E²PROM No
Physics EtherCAT port configuration: Available ports and their types (see table below). No
Station Address Station Address denominates a logical address. 

The station address of a slave is set in the Master DTM.
No

Table 9: General dialog pane parameters

„Physics“ in the context of EtherCAT port configuration is described by two
characters indicating the physical interface of the connection. The coding is
as follows:
Physics Port type
K E-Bus
Y 100Base-TX
F 100Base-FX

Table 10: Coding of parameter “Physics”
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4.3 Behavior
At the “Behavior” pane, the parameters of
· the state machine timeout values,
· the device checkup,
· the process data,
· and the watchdog timer.

are set and displayed.

This pane is only available in case of a slave DTM at the Master busline.

Figure 6: Behavior
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4.3.1 State machine timeout
For various transitions between states of the EtherCAT slave state machine
the associated timeout values can be configured separately in the state
machine timeout section of the “Behavior” dialog:
· I2P

This value applies to the transition from Init state to Pre-Operational
state

· P2S, S2O
This value applies to the transition from Pre-Operational state to Safe-
Operational state and from Safe-Operational state to Operational state.

· Back to P, I 
This value applies to the transition from any higher state back to Pre-
Operational state or Init state.

· O2S
This value applies to the transition from Operational state to Safe-
Operational state.

Note:
These timeout values are specified in units of milliseconds.

Behavior > State Machine Timeout - Configuration

Generic EtherCAT Slave DTM | Configuration of EtherCAT Slave devices
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4.3.2 Device checkup
The “Device checkup” part of the Behavior dialog looks like:

Figure 7: Behavior > Device Check

The following table shows, which items identifying the EtherCAT Slave
device can optionally be verified during device check-up if marked in the
dialog accordingly.
Parameter Description
VendorID Device’s vendor ID (DDF or stored device-internally)
Product code Device’s product code (DDF or stored device-internally)
Revision Device’s revision (DDF or stored device-internally)

Table 11: Parameters Behavior > Device checkup

A verification of the serial number is not available here.

The values within the DDF file are verified against the corresponding
information stored in the device (for example, within an E²PROM circuit), if
the according check box is marked.

4.3.3 Process data
EtherCAT supplies different command sets for reading and writing:
· A combined read/write command (LRW),
· separate read and write commands (LRD/LWR).

This option allows choosing between these alternatives:

Figure 8: Behavior > Process data

Parameter Description
Use LRD/LWR
instead of
LRW

Logical read and write operation:
If marked, separate EtherCAT read (LRD) and write (LWR) commands will
be used.
Otherwise, a combined EtherCAT read and write (LRW) command will be
used.

Table 12: Parameters Behavior > Process data

For more information on EtherCAT read and write commands see the
EtherCAT Communication Specification, version 1.0, section 6.2 “EtherCAT
Services”, page 43.

Generic EtherCAT Slave DTM | Configuration of EtherCAT Slave devices
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4.3.4 Watchdog
Watchdog timers (separately) monitor both the entire PDI (Process Data
Interface) and all sync managers. The following rules apply for resetting the
watchdog timers:
· Each access from the application controller to the EtherCAT Slave

controller resets the watchdog timer of the Process Data Interface.
· Each write access to the associated memory area of a sync manager

resets the sync manager’s watchdog timer.

The watchdog timeout values can be calculated using the formula given
below from an individually configurable value and a common multiplier.

The “Watchdog” part of the “Behavior” dialog allows specifying the
multiplier and the individual values for PDI watchdog and sync manager
watchdogs.

Figure 9: Behavior > Watchdog

Parameter Description
Set multiplier Watchdog multiplier, content of the register 0x400
Set PDI watchdog PDI watchdog, see note below
Set SM watchdog SM watchdog, see note below

Table 13: Parameters Behavior > Watchdog

Note:
The PDI & SM watchdog timeout values are calculated as follows.
PDI watchdog timeout = ([value of register 0x400] + 2) * 40 * [value
of register 0x 410]
SM watchdog timeout = ([value of register 0x 400] + 2) * 40 * [value
of register 0x 420]

Generic EtherCAT Slave DTM | Configuration of EtherCAT Slave devices
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4.4 Distributed clock
At the “Distributed clock” pane you can activate the DC Sync mechanism,
Sync0 and Sync1, and you can make settings for the parameters:
· Sync 0 Cycle time,
· Sync 0 Shift time,
· Sync 1 Cycle time,
· Sync 1 Shift time.

Figure 10: Distributed Clock

Operation mode
Ø Select one of the three different operating modes for Distributed clock:
· DC unused,
· DC for synchronization oder
· User-defined Operation Mode.

Figure 11: Operation mode

Generic EtherCAT Slave DTM | Configuration of EtherCAT Slave devices
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Activate DC Sync

To set Sync 0 and Sync 1, “Activate DC Sync” must be checked. Only then
data entry is possible on this dialog pane, otherwise all fields and selection
elements are grayed out and disabled.
Ø Check Activate DC Sync if you want to configure Sync 0 or Sync 1.

Sync unit cycle

The displayed value for "Sync Unit Cycle" is set in the EtherCAT Master
DTM (free-running cycle time of the EtherCAT Master). In the generic
EtherCAT Slave DTM the field is therefore grayed out and disabled.

4.4.1 Sync 0

Activate Sync 0
Ø Activate Sync 0 by checking Activate Sync 0.
Ø Deactivate Sync 0 by unchecking Activate Sync 0.

4.4.1.1 Sync 0 Cycle Time

Note:
Whether this value can be adjusted by means of the generic
EtherCAT Slave DTM or not depends on the Device Description File
of the appropriate device.

Figure 12: Sync 0 Cycle Time

The Sync 0 Cycle Time can either be derived from the Sync Unit Cycle
Time adjusted at the EtherCAT Master (see above) by multiplying it with a
factor or it can be entered directly.
Ø For calculating the Sync 0 Cycle Time from the Sync Unit Cycle Time,

check Sync Unit Cycle.
Ê The Sync Unit Cycle Time is multiplied with (or divided by) an

adjustable factor.

The following factors are available within the selector list:

Generic EtherCAT Slave DTM | Configuration of EtherCAT Slave devices
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Figure 13: Sync Unit Cycle

Ø For specifying the Sync 0 Cycle Time directly, check User defined.

The value is specified in units of microseconds. The default value is 1000
microseconds. The allowed range of values is from 0 to 4,294,967.295
microseconds. If the specified value violates one of these limits, an error
message is issued.

4.4.1.2 Sync 0 Shift Time

Note:
Whether this value can be adjusted by means of the generic
EtherCAT Slave DTM or not depends on the Device Description File
of the appropriate device.

Figure 14: Sync 0 Shift Time

The Sync 0 Shift Time is calculated in the following way:

The Sync 0 Cycle Time is multiplied with (or divided by) an adjustable
factor, the Sync 0 Shift Time Modifier.

The following values are available within the selector list:
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Figure 15: Sync 0 Cycle Time

Note:
In contrast to the Sync 0 Cycle Time described above, here also the
factor 0 may be chosen!

The default value for this factor is
· 0: if the chosen operation mode (see above) is DC for synchronization
· 1: otherwise.

Then the value specified in the input field User defined is added to the
product. The allowed range of values extends from -2147483.648 to
+2147483.647. If a value outside of these limits is specified, an error
message will be issued.

The sum is displayed in the lower field having been grayed out. It is now
used as the Sync 0 Shift Time.
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4.4.2 Sync 1

Activate Sync 1
Ø Activate Sync 1 by checking Activate Sync 1.
Ø Deactivate Sync 1 by unchecking Activate Sync 1.

4.4.2.1 Sync 1 Cycle Time

Note:
Whether this value can be adjusted by means of the generic
EtherCAT Slave DTM or not depends on the Device Description File
of the appropriate device.

Figure 16: Sync 1 Cycle Time

The Sync 1 Cycle Time is calculated as the product of the Sync 0 Cycle
Time (see subsection Sync 0 Cycle Time [} page 20] above) with a positive
integer factor that is specified in the input field right of Sync 0 cycle time x.

The range of allowed factors extends from 1 to 1024. If a value violating
these limits is entered, an error message will be issued.

The product is then displayed in the grayed out field just below of the input
field.

4.4.2.2 Sync 1 Shift Time

Note:
Whether this value can be adjusted by means of the generic
EtherCAT Slave DTM or not depends on the Device Description File
of the appropriate device.

Figure 17: Sync 1 Shift Time

The value for the Sync 1 Shift Time is to be entered to the User defined
field.
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4.5 Process data
In EtherCAT, the process data objects (PDO) are assigned to sync
managers. A sync manager is used for synchronization of data
communication on a certain communication channel. This channel is
configured either for input or for output and either for cyclic or for acyclic
communication. (This is defined within the device description file.) Up to 16
sync manager can be configured. These are numbered from 0 up to 15.
The process data dialog only displays the sync manager which is for cyclic
communication. Possible sync managers for acyclic communication is
displayed in the CoE MailBox dialog.

The illustration below shows the process data dialog of the EtherCAT
Generic Slave DTM:

Figure 18: Configuration > process data

The process data dialog consists of three parts:
· Sync Manager area
· PDO Assignment area
· PDO Content area

4.5.1 Sync manager
Within the process data dialog only those PDOs can be shown
simultaneously, which are assigned to the same sync manager.

The left part of the process data dialog represents the Sync Manager area
which is used for choosing the sync manager to be used. It provides the
Sync Manager table for choosing the sync manager whose PDOs are to be
displayed, and additionally two checkboxes for PDO assignment and PDO
configuration which however are relevant in case of variable configuration
only.
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Figure 19: Configuration > Process data > Sync Manager

The table Sync Manager displays the configuration of the sync managers
for the device, as defined in its device description file (DDF). For each of
the 4 sync managers available at maximum in the table, the following
information is displayed:
Parameter Description
SM Sync Manager channel number (0-15)
Byte length Sync Manager length in bytes
Type Sync Manager type (Inputs/ Outputs)
Flags Sync Manager flags (Flag F = fixed contents)

Table 14: Parameters Process data > Sync Manager

In case this device supports acyclic communication based on mailboxes the
Sync Manager 0 is used for the mailbox output (master to slave) and the
Sync Manager 1 is used for the mailbox input (slave to master).

If the device does not support acyclic communication based on mailboxes,
Sync Manager 0 - 15 can be used for the Process data outputs and inputs
(also see Figure Configuration > process data [} page 24] > Sync
Manager).

The size of the Sync Managers is defined by the assigned PDO objects. In
this case, the PDO object is assigned to the Sync Manager 3 and because
the content of this object has the size 8 the Sync Manager is configured to
8 bytes.

The read-only checkboxes below show the download flags which are
defined in device description file. They have the following meaning:

Checkbox Description
PDO Assignment This flag indicates whether to download PDO assignment of Sync Manager.

If this flag is checked, this means that PDO assignment of the slave is writable and special CoE
Init-Commands should be generated by the EtherCAT Master DTM in the Configuration
Information File.
These CoE Init-commands include the indices of transmit/receive PDOs. Therefore the slave
knows how such PDOs are related to the Sync Manager.

PDO Configuration This flag indicates whether to download PDO mapping.
If this flag is set as checked, this means that PDO mapping of the slave is writable and special
CoE Init-Commands should be generated by the EtherCAT Master DTM in the Configuration
Information File.
These CoE Init-Commands include the indices of mapped process data objects. Therefore slave
knows how mapped PDOs are related to transmit /receive PDOs.

Table 15: Meaning of checkboxes
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4.5.2 PDO Assignment (Index 0x1C10- 0x1C1F)
The upper right part of the process data dialog represents the PDO
Assignment area for the sync manager chosen within the left part of the
window. It contains the transmit/receive PDOs.

Thus, the contents of this table depends on the choice of the sync manager
in the left part of the window. If a sync manager with type “Outputs” is
selected, all defined receive PDOs (Index 0x1600 -0x17FF) in the device
description file will be shown in this table.

Similarly, if a sync manager with type “Inputs” is selected, all defined
transmit PDOs (Index 0x1A00 -0x1BFF) will be shown in this table.

Figure 20: Process data > PDO Assignment

For the transmit/receive PDOs assigned to the chosen sync manager, the
following values are displayed:
Parameter Description
Name Name of the PDO
Activate Activation check box for assigned PDO of the selected Sync Manager
Index Object index of the PDO
Byte length Length of the PDO in bytes
Flags Flags assigned to the PDO
Description Description of the PDO

Table 16: Parameters process data > PDO Assignment

The PDO assignment is stored in a sync manager channel object within the
object dictionary of the EtherCAT slave. The index of such an object is
displayed in the headline of the PDO assignment area, and it has a
relationship with the sync manager channel number(n):

Index = 0x1C10 + n ( n = 0…15)

In the current example the information was taken from the object with the
index 0x1C12 indicating sync manager 2 had been chosen for display.

For slave devices with selectable PDO assignment, PDO/PDOs can be
selected from the given list of multiple fixed PDOs according to the rules
defined by the device description file.
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4.5.3 PDO Content (Index 0x1600-0x17FF, 0x1A00-0x1BFF)
The lower right part of the process data dialog represents the PDO Content
area. It contains the mapped process data objects of the transmit/receive
PDO, which has been selected in the upper right part of the window.

Figure 21: Process Data > PDO Content

For the mapped process data objects, the following values are displayed:
Parameter Description
Index Object index Subindex of the PDO
Sub index Sub index for the PDO
Byte length Size of the PDO entry in Byte
Offset Offset of the PDO entry (relative to 0x1600 for output and to 0x1A00 for

input PDOs)
Name Name of the PDO entry
Type Data type of the PDO entry

Table 17: Parameters Process Data > PDO Content

The PDO content is stored in a transmit/receive object within the object
dictionary of the EtherCAT slave. You can find the correct index of the
selected transmit/receive PDO in the headline of the PDO assignment area.

In the current example the information was taken from the object with index
0x1604.

For an explanation of the navigation buttons see section Table
lines [} page 8] of this document.
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4.6 Mailbox

4.6.1 CoE
For slave devices supporting the CoE MailBox, in addition the following
dialog pane appears:

Figure 22: Mailbox > CoE Mailbox settings

The dialog pane provides the following information:
· The channel number of the sync manager (for mailbox input and output)
· The configured mailbox size (this applies both for the input mailbox and

for the output)mailbox

The complete MailBox configuration for each slave with MailBox support is
done in the EtherCAT Master-DTM.
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5 Description

5.1 Overview description
In the navigation area under "Description“, you will find the "XML DDF
viewer", which displays the contents of the DDF file with the device
description.

Figure 23: Navigation area - Description

5.2 XML DDF viewer
The XML DDF Viewer displays the content of the DDF file of the device
which is stored in an XML format.

Under “Filename” the absolute file directory path and the file name of the
displayed DDF file is displayed. Find what offers a search feature to
search for text contents within the text of the DDF file.

In the DDF Viewer window on the left side, the line number is displayed for
simple overview, the further entries show the DDF file in text format.

Parameter Description
FIlename File directory path and the file name of the displayed DDF file.
Find what Search feature to search for text contents within the text of the DDF file.
Match case Search option
Match whole word Search option

Table 18: Device Description – GSDML Viewer

The “XML DDF Viewer” pane consists of the following elements:
· “File name” shows the absolute path of the DDF file.
· Find what offers searching for specific text within the DDF file.
· Using Find Next allows you to jump to the next occurrence of the text to

be searched for within the XML DDF file.
· Check Match case if you want to perform a case-sensitive search.
· Check Match whole word if only entire words should match and

fragments of words should be excluded from matching.

Note:
You can also access the search functionality of the XML DDF
Viewer by typing Ctrl-F on the keyboard.
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6 Appendix

6.1 References
[1] FDT Joint Interest Group (www.fdt-jig.org, FDT-JIG Working Group):
Device Type Manager (DTM) Style Guide, Version 1.0; FDT-JIG - Order
No. <0001-0008-000>, English, 2005.

[2] EtherCAT Technology Group: EtherCAT communication specification,
August 2007.

[3] Hilscher Gesellschaft für Systemautomation mbH: Protocol API,
EtherCAT Salve, V 5.3.0, Protocol API Manual, Revision 4,
DOC181005API04EN, English, 2021-09.

6.2 User rights
User-rights are set within the FDT-container. Depending on the level, the
configuration is accessible by the user or read-only.

To access the Settings, Configuration and Diagnosis panes of the
generic EtherCAT Slave DTM you do not need special user rights. Also all
users can select the decimal or hexadecimal Display mode or sort table
entries.

Note:
To edit, set or configure the parameters of the Settings and
Configuration panes, you need user rights for "Maintenance", for
"Planning Engineer" or for "Administrator".

The following tables give an overview of the user right groups and which
user rights you need to configure the single parameters.

6.2.1 Configuration
Observer Operator Maintenanc

e
Planning
engineer

Adminis-
trator

General [} page 14] D D X X X
General settings D D X X X
Signal configuration D D X X X
Behavior [} page 15] D D X X X
Mailbox [} page 28] D D X X X

Table 19: User rights configuration (D = displaying, X = editing, configuring)
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6.3 Conventions in this manual

Instructions
1. Operation purpose
2. Operation purpose

Ø Instruction

Results

 Intermediate result

 Final result

Signs

Sign Note
General note

Important note that must be followed to prevent malfunctions.

Reference to further information

Table 20: Signs
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6.4 Legal notes

Copyright

© Hilscher Gesellschaft für Systemautomation mbH

All rights reserved.

The images, photographs and texts in the accompanying materials (in the
form of a user's manual, operator's manual, Statement of Work document
and all other document types, support texts, documentation, etc.) are
protected by German and international copyright and by international trade
and protective provisions. Without the prior written consent, you do not
have permission to duplicate them either in full or in part using technical or
mechanical methods (print, photocopy or any other method), to edit them
using electronic systems or to transfer them. You are not permitted to make
changes to copyright notices, markings, trademarks or ownership
declarations. Illustrations are provided without taking the patent situation
into account. Any company names and product designations provided in
this document may be brands or trademarks by the corresponding owner
and may be protected under trademark, brand or patent law. Any form of
further use shall require the express consent from the relevant owner of the
rights.

Important notes

Utmost care was/is given in the preparation of the documentation at hand
consisting of a user's manual, operating manual and any other document
type and accompanying texts. However, errors cannot be ruled out.
Therefore, we cannot assume any guarantee or legal responsibility for
erroneous information or liability of any kind. You are hereby made aware
that descriptions found in the user's manual, the accompanying texts and
the documentation neither represent a guarantee nor any indication on
proper use as stipulated in the agreement or a promised attribute. It cannot
be ruled out that the user's manual, the accompanying texts and the
documentation do not completely match the described attributes, standards
or any other data for the delivered product. A warranty or guarantee with
respect to the correctness or accuracy of the information is not assumed.

We reserve the right to modify our products and the specifications for such
as well as the corresponding documentation in the form of a user's manual,
operating manual and/or any other document types and accompanying
texts at any time and without notice without being required to notify of said
modification. Changes shall be taken into account in future manuals and do
not represent an obligation of any kind, in particular there shall be no right
to have delivered documents revised. The manual delivered with the
product shall apply.

Under no circumstances shall Hilscher Gesellschaft für Systemautomation
mbH be liable for direct, indirect, ancillary or subsequent damage, or for
any loss of income, which may arise after use of the information contained
herein.
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Liability disclaimer

The hardware and/or software was created and tested by Hilscher
Gesellschaft für Systemautomation mbH with utmost care and is made
available as is. No warranty can be assumed for the performance or
flawlessness of the hardware and/or software under all application
conditions and scenarios and the work results achieved by the user when
using the hardware and/or software. Liability for any damage that may have
occurred as a result of using the hardware and/or software or the
corresponding documents shall be limited to an event involving willful intent
or a grossly negligent violation of a fundamental contractual obligation.
However, the right to assert damages due to a violation of a fundamental
contractual obligation shall be limited to contract-typical foreseeable
damage.

It is hereby expressly agreed upon in particular that any use or utilization of
the hardware and/or software in connection with
· Flight control systems in aviation and aerospace;
· Nuclear fission processes in nuclear power plants;
· Medical devices used for life support and
· Vehicle control systems used in passenger transport

shall be excluded. Use of the hardware and/or software in any of the
following areas is strictly prohibited:
· For military purposes or in weaponry;
· For designing, engineering, maintaining or operating nuclear systems;
· In flight safety systems, aviation and flight telecommunications systems;
· In life-support systems;
· In systems in which any malfunction in the hardware and/or software

may result in physical injuries or fatalities.

You are hereby made aware that the hardware and/or software was not
created for use in hazardous environments, which require fail-safe control
mechanisms. Use of the hardware and/or software in this kind of
environment shall be at your own risk; any liability for damage or loss due
to impermissible use shall be excluded.

Warranty

Hilscher Gesellschaft für Systemautomation mbH hereby guarantees that
the software shall run without errors in accordance with the requirements
listed in the specifications and that there were no defects on the date of
acceptance. The warranty period shall be 12 months commencing as of the
date of acceptance or purchase (with express declaration or implied, by
customer's conclusive behavior, e.g. putting into operation permanently).

The warranty obligation for equipment (hardware) we produce is 36
months, calculated as of the date of delivery ex works. The aforementioned
provisions shall not apply if longer warranty periods are mandatory by law
pursuant to Section 438 (1.2) BGB, Section 479 (1) BGB and Section 634a
(1) BGB [Bürgerliches Gesetzbuch; German Civil Code] If, despite of all
due care taken, the delivered product should have a defect, which already
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existed at the time of the transfer of risk, it shall be at our discretion to
either repair the product or to deliver a replacement product, subject to
timely notification of defect.

The warranty obligation shall not apply if the notification of defect is not
asserted promptly, if the purchaser or third party has tampered with the
products, if the defect is the result of natural wear, was caused by
unfavorable operating conditions or is due to violations against our
operating regulations or against rules of good electrical engineering
practice, or if our request to return the defective object is not promptly
complied with.

Costs of support, maintenance, customization and product care

Please be advised that any subsequent improvement shall only be free of
charge if a defect is found. Any form of technical support, maintenance and
customization is not a warranty service, but instead shall be charged extra.

Additional guarantees

Although the hardware and software was developed and tested in-depth
with greatest care, Hilscher Gesellschaft für Systemautomation mbH shall
not assume any guarantee for the suitability thereof for any purpose that
was not confirmed in writing. No guarantee can be granted whereby the
hardware and software satisfies your requirements, or the use of the
hardware and/or software is uninterruptable or the hardware and/or
software is fault-free.

It cannot be guaranteed that patents and/or ownership privileges have not
been infringed upon or violated or that the products are free from third-party
influence. No additional guarantees or promises shall be made as to
whether the product is market current, free from deficiency in title, or can be
integrated or is usable for specific purposes, unless such guarantees or
promises are required under existing law and cannot be restricted.

Confidentiality

The customer hereby expressly acknowledges that this document contains
trade secrets, information protected by copyright and other patent and
ownership privileges as well as any related rights of Hilscher Gesellschaft
für Systemautomation mbH. The customer agrees to treat as confidential all
of the information made available to customer by Hilscher Gesellschaft für
Systemautomation mbH and rights, which were disclosed by Hilscher
Gesellschaft für Systemautomation mbH and that were made accessible as
well as the terms and conditions of this agreement itself.

The parties hereby agree to one another that the information that each
party receives from the other party respectively is and shall remain the
intellectual property of said other party, unless provided for otherwise in a
contractual agreement.

The customer must not allow any third party to become knowledgeable of
this expertise and shall only provide knowledge thereof to authorized users
as appropriate and necessary. Companies associated with the customer
shall not be deemed third parties. The customer must obligate authorized
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users to confidentiality. The customer should only use the confidential
information in connection with the performances specified in this
agreement.

The customer must not use this confidential information to his own
advantage or for his own purposes or rather to the advantage or for the
purpose of a third party, nor must it be used for commercial purposes and
this confidential information must only be used to the extent provided for in
this agreement or otherwise to the extent as expressly authorized by the
disclosing party in written form. The customer has the right, subject to the
obligation to confidentiality, to disclose the terms and conditions of this
agreement directly to his legal and financial consultants as would be
required for the customer's normal business operation.

Export provisions

The delivered product (including technical data) is subject to the legal
export and/or import laws as well as any associated regulations of various
countries, especially such laws applicable in Germany and in the United
States. The products / hardware / software must not be exported into such
countries for which export is prohibited under US American export control
laws and its supplementary provisions. You hereby agree to strictly follow
the regulations and to yourself be responsible for observing them. You are
hereby made aware that you may be required to obtain governmental
approval to export, reexport or import the product.

6.5 Registered trademarks
Windows® XP, Windows® Vista, Windows® 7, Windows® 8, Windows® 8.1
and Windows® 10 are registered trademarks of the Microsoft Corporation.

EtherCAT® is a registered trademark and patented technology, licensed by
Beckhoff Automation GmbH, Germany.

All other brands mentioned are property of their respective owner of the
rights. Any company names and product designations provided in this
document may be brands (company names or trademarks) of the
corresponding owner and may be protected under trademark or patent law.
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Glossary
DDF Device Description File A file containing configuration information

about a device being a part of a network that can be read out by
masters for system configuration. Device Description Files use
various formats which depend on the communication system. Often
these formats are based on XML such as EDS_files or GSDML_files.
Contains configuration information

DDF Device Description File: A file containing configuration information
about a device being a part of a network that can be read out by
masters for system configuration. Device Description Files use
various formats which depend on the communication system. Often
these formats are based on XML such as EDS_files or GSDML_files.

DTM Device Type Manager: Software module with graphical user interface
for the configuration and/or for diagnosis of devices

EtherCAT Ethernet for Control Automation Technology: communication system
for Industrial Ethernet designed and developed by Beckhoff
Automation GmbH, Verl, Germany

EtherCAT Slave Device which is configured by the EtherCAT master, receives data
telegrams containing output data, executes commands issued by the
EtherCAT master and provides input and status data

FDT Field Device Tool: FDT specifies an interface, in order to be able to
use DTM (Device Type Manager) in different applications of different
manufacturers

netDevice FDT container of the Hilscher configuration software SYCON.net

Slave Type of device that is configured by the Master and which then
performs the communication

XML Extended Markup Language: symbolic language for structuring data
systematically which is maintained as a standard by the W3C (World-
wide web consortium). Device Description Files often use XML-based
formats for storing the device-related data appropriately.
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